16:16 <sil2100> #startmeeting Developer Membership Board
16:16 <meetingology> Meeting started at 16:16:28 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:16 <meetingology> Available commands: action, commands, idea, info, link, nick
16:17 <sil2100> One proposition I had: what would everyone think of moving the format a little bit, so that we handle applicants at the beginning of a meeting?
16:17 <sil2100> I suppose we should have a formal discussion/vote about that first, right?
16:17 <rbasak> I think that's fine, and you're the chair so you get to decide.
16:17 <sil2100> Since I'm always worried that the applicants have to wait until we're done with all the review items etc. unnecessarily
16:18 <rbasak> Maybe just ensure that there aren't any previous action items holding up applicants.
16:18 <sil2100> True
16:18 <rbasak> On the principle of giving applicants priority, strong +1 :)
16:18 <bdmurray> +1 from me too
16:18 <sil2100> Ok, I think we're good from this POV, let's try that then
16:18 <sil2100> #topic Ubuntu Core Developer Applications
16:19 <sil2100> #subtopic Simon Chopin
16:19 <sil2100> #link https://discourse.ubuntu.com/t/simon-chopin-core-dev-application/28291
16:19 <sil2100> schopin: o/
16:19 <schopin> o/
16:19 <sil2100> schopin: hello! Can you introduce yourself briefly?
16:20 <schopin> Hi! I am Simon Chopin, I'm a French software developer within the Foundations team of Canonical.
16:21 <sil2100> Questions?
16:21 <bdmurray> Could you elaborate on how you could do better with attention to detail?
16:23 <sil2100> schopin: ^ ?
16:24 <schopin> I oftentimes do small mistakes such as targetting the wrong series when uploading. Since I know this, it shouldn't happen, and yet...
16:25 <bdmurray> schopin: Do you have any plans for avoiding small mistakes in the future?
16:25 <rbasak> I'm not sure if you're done, but I have a couple of questions when you're ready.
16:26 <rbasak> Oh sorry, I'll wait
16:28 <schopin> bdmurray: besides looking into why dch -r targets my current series and not devel by default, I think I need to take the time to develop some "rituals"/checklists, and also some more wrappers.
16:29 <bdmurray> Okay, thanks. Go ahead rbask
16:29 <rbasak> Could you tell me about feature freeze please? How do you determine if a freeze is active? If feature freeze is active, then how do you decide if feature freeze would apply to a package for example for an upstream version moving from 1.2~rc2 to 1.2? And if you need an exception, how do you request one?
16:34 <schopin> After a few months of "open" development of the devel series, the archive enters Feature Freeze, during which autosync with Debian is disabled. To see when that happens I'd go to the release schedule on Discourse, or check the topic in #ubuntu-devel. We can upload to the archive if to fix bugs. New upstream releases are usually not uploaded, except if they are purely bugfix releases, which
16:34 <schopin> I'd expect in 1.2~rc2 to 1.2. If I need an exception, I'll open a FFe bug against the package, attaching the debdiff that I want to upload, and subscribe the release team.
16:36 <schopin> rbasak: ^
16:36 <rbasak> How would you decide if something is a purely bugfix release or not?
16:39 <schopin> I'll have a look at upstream's changelog and commit history. If they don't have the former and the latter is inexploitable, I'll probably err on the side of caution and not upload unless I know and trust upstream (which is unlikely if they don't have those two elements)
16:39 <schopin> It helps if they have an explicit release policy.
16:41 <schopin> Sometimes it's hard to decide if it's a bugfix or a feature, in which case I'll ask on #ubuntu-release
16:41 <rbasak> OK thanks. One more question from me please. How would you check if an upload will trigger a component mismatch?
16:43 <schopin> I'm making this one up so this might be wrong, but I guess I could somehow run germinate? Previously I did it manually but I missed the rustc/llvm-13/z3 chain, so...
16:45 <rbasak> OK thanks. I have no further questions
16:45 <sil2100> No questions from me
16:45 <sil2100> kanashiro: questions?
16:45 <kanashiro> schopin, let's suppose you uploaded a package to the development release and it caused a component mismatch, what are the possibilities to sort this out?
16:46 <schopin> MIR the component, or somehow fix the package relationship that caused the component mismatch, by e.g. drop a Recommends into a Suggests.
16:46 <kanashiro> schopin, thanks.
16:47 <kanashiro> no further questions
16:48 <sil2100> Okay, time for the vote
16:48 <sil2100> #startvote schopin to become core-developer
16:49 <sil2100> ...guess that's vote
16:49 <sil2100> #vote schopin to become core-developer
16:49 <meetingology> Please vote on: schopin to become core-developer
16:49 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:50 <rbasak> +1
16:50 <meetingology> +1 received from rbasak
16:50 <bdmurray> +1
16:50 <meetingology> +1 received from bdmurray
16:50 <kanashiro> +1
16:50 <meetingology> +1 received from kanashiro
16:51 <sil2100> +1
16:51 <meetingology> +1 received from sil2100
16:51 <sil2100> #endvote
16:51 <meetingology> Voting ended on: schopin to become core-developer
16:51 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
16:51 <meetingology> Motion carried
16:51 <sil2100> schopin: congratulations!
16:51 <schopin> Thanks :)
16:51 <sil2100> Who wants the action item of adding schopin to the core-dev's team?
16:51 <bdmurray> schopin: Congratulations!
16:52 <kanashiro> schopin, congrats! :)
16:52 <schopin> thanks all :)
16:52 <rbasak> I can do it
16:52 <sil2100> rbasak: thanks!
16:52 <sil2100> #action rbasak to add schopin to core-dev
16:52 * meetingology rbasak to add schopin to core-dev
16:53 <sil2100> #action rbasak to announce schopin's successful application
16:53 * meetingology rbasak to announce schopin's successful application
16:53 <sil2100> Ok, moving on, since we only have 7 minutes left
16:53 <sil2100> #topic Review of previous action items
16:53 <sil2100> kanashiro to update our wiki documentation with respect to our agreed packageset creation criteria <- kanashiro ?
16:54 <kanashiro> I started to work on that today, unfinished
16:54 <sil2100> Ok, let's carry over then!
16:54 <sil2100> #action kanashiro to update our wiki documentation with respect to our agreed packageset creation criteria (carried over)
16:54 * meetingology kanashiro to update our wiki documentation with respect to our agreed packageset creation criteria (carried over)
16:54 <sil2100> sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:54 <sil2100> I did one part of it (added it to the knowledge base), but need to update other places
16:54 <sil2100> So carry over for now
16:54 <sil2100> #action sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:54 * meetingology sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:54 <sil2100> teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:55 <sil2100> teward is absent (due to holidays), so carrying over
16:55 <sil2100> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:55 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:55 <sil2100> #topic Outstanding mailing list requests to assign
16:55 <sil2100> I don't think we have anything new
16:55 <sil2100> #topic Open TB bugs
16:55 <sil2100> ...none
16:55 <sil2100> #topic AOB
16:55 <sil2100> ...5 minutes left, any other business?
16:57 <kanashiro> none
16:57 <sil2100> Okay! Let's wrap it up then!
16:57 <sil2100> #endmeeting