19:09 <sil2100> #startmeeting Ubuntu Technical Board
19:09 <meetingology> Meeting started at 19:09:20 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:09 <meetingology> Available commands: action, commands, idea, info, link, nick
19:09 <sil2100> #topic Apologies
19:09 <sil2100> ...no apologies \o/
19:09 <cyphermox> I have a hard stop in an hour
19:09 <sil2100> #topic Action Review
19:09 * sil2100 (everyone) review the Ubuntu Backports Team Charter for ratification
19:10 <sil2100> I must say that I didn't look at it yet
19:10 <rbasak> My comments are in the thread
19:10 <rbasak> (summary: IMHO it's not ready for ratification as-is)
19:11 <sil2100> Then reminder to myself and others that didn't do this yet: let's all read and comment on the ML
19:11 <rbasak> But I would like to see some terms of reference defined and documented.
19:12 <sil2100> Let's move on for now
19:12 * sil2100 (everyone) formal ratification of third party seeded snap security policy (finalize wording on the Google Doc)
19:12 <rbasak> I have been working on the draft but we can discuss this in its own agenda item
19:13 <sil2100> Ok, so let's move for now
19:13 * sil2100 vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:13 <sil2100> vorlon: any progress here? ^
19:15 <sil2100> I think I saw the card on Jira, so I think the answer is 'not yet' - but it's on the backlog for vorlon
19:15 * sil2100 sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
19:16 <vorlon> sil2100: correct :/
19:16 <sil2100> So some good news and bad news. Good news is that I had a chat with Rex in Copenhagen about this, so I have a better understanding now. Bad news: nothing officially written besides scribbles
19:16 <sil2100> I blame it on the wiki
19:16 <sil2100> ...which apparently I was able to log onto now \o/
19:17 * sil2100 Review and leave feedback on the first version of the preamble and three first requirements https://pad.ubuntu.com/third-party-repository-requirements (all of the TB)
19:17 <sil2100> I think this one we need to remove
19:17 <sil2100> It's been moved to the google doc
19:17 <sil2100> Oh, hah!
19:17 * sil2100 rbasak to move the pad to Google Doc
19:17 <rbasak> done
19:17 <sil2100> This is done, so yeah, let me clear those out
19:17 <vorlon> should update the wiki to point to https://docs.google.com/document/d/1apUKR4gtOrfPGCWmtoebaQUhoy-fG8Cyo3VKJyhnpD0/edit ?
19:17 * sil2100 Discuss DMB inactivity expiration policy (all of the TB)
19:18 <sil2100> I think this is already done, right? Or do we still need to discuss something here?
19:18 <rbasak> I think we do need to discuss it, but haven't done yet.
19:18 <rbasak> It could do with tying up. I'd like for the TB to ratify what the DMB wanted, but while doing it clear up the ambiguous bits.
19:19 <rbasak> I don't mind drafting something, so you can carry it and assign to me for a concrete proposal if you'd like.
19:19 <rbasak> I won't get to it immediately since I'm prioritising some other TB/DMB things and it's no longer an urgent thing.
19:20 <sil2100> #action rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:20 * meetingology rbasak to draft a proposal of the DMB-proposed inactivity expiration policy for TB ratification
19:20 <sil2100> rbasak: feel free to reach out to me in case you won't find the time for that one
19:20 <rbasak> Thanks!
19:20 * sil2100 cyphermox to contact CC to trigger an election
19:20 <sil2100> This is marked done
19:21 <sil2100> I guess we had no candidates..?
19:21 <rbasak> Was there a call for nominations?
19:21 <sil2100> Yes, there was one for Marc's seat
19:21 <cyphermox> I remember marking it done, but now that I didn't see anything go by I wanted to circle back and check at what the status of things are
19:21 <rbasak> Oh yes. I remember now, sorry.
19:21 <sil2100> Even two, since one was really short-period, then one longer... but then it all died out
19:22 <sil2100> So I don't know what's the status of the actual nominations/election
19:22 <rbasak> Maybe we need to ask the CC to continue driving it
19:22 <sil2100> Should someone follow up?
19:22 <sil2100> cyphermox: could you do that?
19:22 <rbasak> Nominations aren't visible to us until after they've been shortlisted.
19:22 <cyphermox> yep, I will take care of it
19:23 <sil2100> #action cyphermox to follow up with the CC regarding the TB nominations and election
19:23 * meetingology cyphermox to follow up with the CC regarding the TB nominations and election
19:23 <sil2100> Thanks!
19:23 <sil2100> Ok, this is all for the action items
19:23 <sil2100> #topic Definition of our third party repository policy
19:23 <sil2100> #link Definition of our third party repository policy
19:24 <sil2100> Argh
19:24 <sil2100> #link https://docs.google.com/document/d/1apUKR4gtOrfPGCWmtoebaQUhoy-fG8Cyo3VKJyhnpD0/edit
19:24 <rbasak> I think I've incorporated all feedback into the draft, except for sil2100's suggest on some specifics for snaps which I think we agreed to put into an appendix.
19:24 <rbasak> Please could you review the draft text in full now? It should be complete now except for polish and any further requested amendments.
19:24 <rbasak> I'd like to run through the outstanding comments and suggestions and clean them up if you now if we have time for that.
19:24 <sil2100> Let's just check if we have anything else to take care of
19:24 <sil2100> No community bugs
19:24 <sil2100> I suppose also no ML entries?
19:25 <rbasak> There was the question of the DMB extension/election but I think that's settled now?
19:26 <rbasak> I don't see any other ML activity
19:26 <sil2100> Ok, so let's all take a look at the draft now
19:26 <sil2100> cyphermox, vorlon: ^
19:27 <vorlon> I'm going to beg off from this; I'm not feeling hot right now and don't think I'm going to be able to give a very good detailed review
19:27 <rbasak> OK
19:28 <vorlon> but I have reviewed it fairly recently (in terms of edit history) so hopefully won't have too much more to add
19:28 <sil2100> vorlon: o/
19:30 <sil2100> rbasak: ok, so I'm fine with the suggestions that you put on the document
19:31 <rbasak> Great, thanks! Also I added wording for all the requirements not just the first three.
19:31 <rbasak> (that's all the blue text
19:31 <rbasak> )
19:32 <sil2100> Ok, looking
19:32 <cyphermox> my only comment would be about not mentioning Flatpaks, etc.; otherwise it's all looking good to me
19:32 <rbasak> cyphermox: I added a comment on your comment just now
19:32 <cyphermox> oh, sure, yes
19:33 <cyphermox> basically, that's in line with what I mean, making it as general as possible
19:33 <cyphermox> I'm all good then
19:34 <sil2100> rbasak: this sounds very good. One really minor question (more of a formality) - should we use the 'TB' abbreviation in a formal document here, or better explicitly mention 'Technical Board'? As said, this is basically a minor question
19:35 <rbasak> OK so what I think I'll do next is remove the notes (they'll be retrievable if needed from version history), leaving only the draft text. I need to add an appendix for snaps as sil2100 suggested. And then I think it'll be ready for wider consultation. I'll need to audit the existing snaps that fall under scope to define an initial list of exceptions.
19:35 <rbasak> sil2100: agreed. I'll change that.
19:35 <rbasak> vorlon: shall I give you a few days to look first?
19:36 <sil2100> rbasak: +1 on that, I really like the overall sound of that
19:36 <sil2100> Thank you for driving this to completion
19:36 <rbasak> OK so that's on me to make progress again. Thank you for the feedback!
19:39 <sil2100> Ok, I guess that's it then
19:39 <sil2100> #topic AOB
19:39 <sil2100> Anything else we should discuss?
19:39 <sil2100> #topic Next chair
19:40 <sil2100> Ok, so alphabetically after me should be cyphermox , but I think he was chairing the last time
19:40 <cyphermox> hey, it's all good
19:40 <sil2100> cyphermox: ok o/ So cyphermox as the chair an rbasak as backup
19:40 <sil2100> Thanks!
19:41 <sil2100> Let me update the agenda
19:41 <sil2100> #endmeeting