16:30 <ddstreet> #startmeeting Ubuntu Backports Team
16:30 <meetingology> Meeting started at 16:30:26 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:30 <meetingology> Available commands: action, commands, idea, info, link, nick
16:30 <mapreri> I'll apologize in advance, last month I was kind of distracted, I basically forgot all of my tasks until.. today :(
16:30 <ddstreet> lol, no problem, i don't think i did much either :)
16:30 <ddstreet> #topic previous action items
16:31 <ddstreet> #subtopic ddstreet update tooling, requestbackport, backportpackage (carried over)
16:31 <ddstreet> did not get to this
16:31 <ddstreet> #action ddstreet update tooling, requestbackport, backportpackage (carried over)
16:31 * meetingology ddstreet update tooling, requestbackport, backportpackage (carried over)
16:31 <ddstreet> and of course if either of you get to this, feel free to update the tooling
16:31 <mapreri> ahah
16:31 <ddstreet> #subtopic mapreri upload (more of) all the tools (carried over, in progress)
16:32 <ddstreet> #action mapreri upload (more of) all the tools (carried over, in progress)
16:32 * meetingology mapreri upload (more of) all the tools (carried over, in progress)
16:32 <ddstreet> i assume carry over :)
16:32 <ddstreet> #subtopic mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:32 <ubottu> Debian bug 1001399 in lintian "lintian: adjust backports-upload-has-incorrect-version-number for ubuntu" [Normal, Open]
16:32 <ddstreet> carry over?
16:32 <mapreri> this is kind of stuck also because the lintian maintainer is in a... awkward situation rihgt now
16:32 <mapreri> -.-
16:32 <mapreri> but well
16:32 <mapreri> yes
16:32 <ddstreet> #action mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:32 * meetingology mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
16:33 <mapreri> I wonder if I should just include it in the ubuntu delta
16:33 <mapreri> one day
16:33 <ddstreet> that's certainly a possibility
16:33 <ddstreet> #subtopic mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
16:33 <mapreri> let's carry it over for now :(
16:34 <ddstreet> i think the wiki has actually been totally broken (for writes) for the last month, so i assume this hasn't been done ;-)
16:34 <ddstreet> #action mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
16:34 * meetingology mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
16:34 <ddstreet> #subtopic mapreri handle approval for backports of memtest86+ and freeipmi
16:34 <ddstreet> i think you commented on one of these? but still in progress?
16:34 <mapreri> yeah, I was complaining about this 2 days ago and again few minutes ago in a diferent channel…
16:34 <mapreri> I did really
16:34 <mapreri> mh
16:35 <ddstreet> do we need to keep the action or just let it get handled in the bugs?
16:35 <mapreri> indeed didn't write on the freeipmi but that's fine (We didn't nack that before)
16:35 <mapreri> drop the action, the bugs are enough
16:35 <ddstreet> ack
16:35 <mapreri> I'll follow the upload, since he hangs on in the italian channel
16:35 <ddstreet> #subtopic mapreri handle debhelper backport including revert dep on debugedit for focal-backports
16:35 <mapreri> although I think he also needs a sponsor :\
16:36 <mapreri> yeah, pending too, apologizes
16:36 <ddstreet> drop this action too, since there is still the bug open?
16:36 <mapreri> mhh, keep it pls
16:36 <ddstreet> ack
16:36 <ddstreet> #action mapreri handle debhelper backport including revert dep on debugedit for focal-backports
16:36 * meetingology mapreri handle debhelper backport including revert dep on debugedit for focal-backports
16:36 <mapreri> perhaps it'll keep my mind more on it, who knows
16:36 <ddstreet> :)
16:37 <ddstreet> #subtopic (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:37 <ddstreet> i assume we're carrying this and the other unassigned one
16:37 <ddstreet> #action (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:37 * meetingology (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
16:37 <ddstreet> #subtopic (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:37 <ddstreet> #action (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:37 * meetingology (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
16:37 <ddstreet> ok that's all the previous action items
16:38 <ddstreet> moving on to open ML threads
16:38 <ddstreet> #topic clarification on specific wording for no-bug-required backport exceptions
16:38 <ddstreet> well i guess that's the subtopic, ugh, i'm a bad chair
16:38 <ddstreet> #topic open ML threads
16:38 <mapreri> I think they are all stuck regardless :\
16:38 <ddstreet> #subtopic clarification on specific wording for no-bug-required backport exceptions
16:39 <ddstreet> yeah, let's all try to follow up on at least one of the ML threads before the next meeting :)
16:39 <mapreri> that's a great proposal \o/
16:39 <mapreri> I cheer to that!
16:39 <ddstreet> :)
16:39 <ddstreet> #action clarification on specific wording for no-bug-required backport exceptions
16:39 * meetingology clarification on specific wording for no-bug-required backport exceptions
16:39 <ddstreet> #subtopic TB ML thread for charter
16:40 <ddstreet> let's leave this for now...still basically waiting on feedback
16:40 <mapreri> I also have a whole week at the end of May in a debian event, so I'll likely also focus more on FOSS in general... let's be hopeful!
16:40 <ddstreet> i do think we should have some kind of 'end date' for when we just assume the charter is the rules we use for the team
16:40 <ddstreet> awesome!
16:40 <ddstreet> #action TB ML thread for charter
16:40 * meetingology TB ML thread for charter
16:41 <ddstreet> do we need to discuss either of those ML threads now or are there other ML threads we should discuss?
16:41 <mapreri> I don't think we need to
16:41 <ddstreet> perfect, next is open bugs
16:41 <ddstreet> #topic open bugs
16:42 <ddstreet> any in particular we should discuss?
16:42 <mapreri> nope
16:42 <mapreri> but I think there are too many open bugs already u.u
16:42 <ddstreet> lol well there are a few
16:43 <ddstreet> but i dont think there's any uploads that need reviewing, besides freeipmi/memtest86+, so it's not technically our responsibility to sponsor the open bugs
16:43 <mapreri> we should probably focus on screaming them out
16:43 <mapreri> right but
16:43 <mapreri> what should we do with things that are stuck in sponsorship?
16:43 <ddstreet> it's a good question
16:44 <mapreri> I'd propose to remove the subscription and tell them to re-subscribe the team once it's done
16:44 <mapreri> I think there is a precedent somewhere (i don't think it's sru thought)
16:44 <ddstreet> yep that's totally fine with me
16:44 <ddstreet> we should keep the 'bug reporter needs to find a sponsor' requirement, it'll be too much for us to sponsor everything
16:45 <teward> ddstreet: do we have a policy set where we close bugs that don't get sponsors after a certain period?
16:45 <teward> if we let these bugs pile up it'll lead to the problem that led to backports being defunct to begin with ;)
16:46 <mapreri> likely we should do that too
16:46 <mapreri> but those stuck in sponsorship should just get out of our view
16:46 <mapreri> teward: tbh, those bugs stuck at questions (like memtest, etc) would be set to "incomplete" and naturally expire in 60 days
16:46 <mapreri> I noticed it today that I had 4 more days before expiration
16:47 <mapreri> so I don't think we need that, just remember ourself to move to "incomplete" when things are stuck, maybe?
16:48 <ddstreet> since we expect bug reporters to 'own' the backport if it needs updates/fixes later, it's probably a good thing to use 'incomplete', since if the reporter can't be bothered to respond to questions they most likely won't follow up to 'own' the backport later, right?
16:49 <ddstreet> maybe we should put bugs without a sponsor in 'incomplete' too?
16:50 <mapreri> perhaps, yes
16:50 <mapreri> let's do that
16:50 <mapreri> but then maybe we should define a proper meaning for all bug status, we haven't done that yet
16:50 <mapreri> besides invalid/released, that's obvious.  but new/confirmed(triaged?)/incomplete is not well defined yet
16:51 <mapreri> should we do that now, or let's not?
16:51 <mapreri> or maybe, action somebody (me? :P) to send a mail with a proper proposal to add to the wiki a list of status and meanings?
16:51 <ddstreet> should we do it on the ML? whatever we decide should most likely write up the specifics on our policies wiki page
16:52 <ddstreet> or we could add it to the process page
16:52 <ddstreet> yeah let's move it to the list
16:52 <mapreri> do #action ?
16:53 <ddstreet> #action mapreri start thread on ML about how to use bug status to define meaing in process
16:53 * meetingology mapreri start thread on ML about how to use bug status to define meaing in process
16:53 <ddstreet> ok let's hope we find time for ML threads before the next mtg :)
16:54 <ddstreet> any other open bugs to discuss? or bug meta-discussion?
16:54 <mapreri> none for me
16:54 <ddstreet> ok let's move to aob
16:54 <ddstreet> #topic AOB
16:54 <ddstreet> any other business to discuss?
16:54 <mapreri> nope
16:55 <ddstreet> if not, i'll sched the next meeting in another month? or do we think we can go longer, 2 months?
16:55 <mapreri> 1m imho
16:55 <ddstreet> sounds good
16:55 <mapreri> we are already stalling, 2m would be worse
16:56 <ddstreet> yeah, if we are able to handle ML threads better, maybe we can increase the mtg interval then
16:56 <ddstreet> #action ddstreet schedule next meeting in 1 month
16:56 * meetingology ddstreet schedule next meeting in 1 month
16:56 <ddstreet> ok any last item before we close?
16:56 <mapreri> teward: anything? :)
16:56 <teward> nope
16:56 <ddstreet> #endmeeting