#ubuntu-meeting: Ubuntu Backports Team meeting

Meeting started by ddstreet at 16:33:09 UTC (full logs)

Meeting summary

  1. Previous Action Items (ddstreet, 16:34)
    1. ddstreet update tooling, requestbackport, backportpackage (carried over) (ddstreet, 16:34)
      1. ACTION: ddstreet update tooling, requestbackport, backportpackage (carried over) (ddstreet, 16:34)
      2. ddstreet update draft charter to point to team policies at single wiki page, create draft wiki page for team policies (ddstreet, 16:34)
      3. ddstreet send ML email after updating charter (ddstreet, 16:34)
      4. mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:34)
      5. ACTION: mapreri upload (more of) all the tools (carried over, in progress) (ddstreet, 16:35)
      6. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:35)
      7. ACTION: mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over) (ddstreet, 16:35)
      8. (unassigned) review delegation email on ML (ddstreet, 16:35)
      9. (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:36)
      10. ACTION: (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over) (ddstreet, 16:36)
      11. (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:36)
      12. ACTION: (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over) (ddstreet, 16:36)

  2. Open Mailing List Threads (ddstreet, 16:37)
    1. clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:37)
      1. clarification on specific wording for no-bug-required backport exceptions (ddstreet, 16:39)
      2. Ratifying a formal delegation (ddstreet, 16:40)
      3. suggestion to drop request for TB ratification and use simple team approval (ddstreet, 16:41)
      4. https://lists.ubuntu.com/archives/technical-board/2022-March/002620.html (ddstreet, 16:50)
      5. https://wiki.ubuntu.com/UbuntuBackports/Charter?action=recall&rev=5 (ddstreet, 16:51)
      6. https://lists.ubuntu.com/archives/technical-board/2022-March/002620.html (ddstreet, 16:51)

  3. open bugs (ddstreet, 16:52)
    1. update backportpackage and requestbackport scripts to behave according to new backport process (ddstreet, 16:52)
      1. ACTION: mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor (ddstreet, 17:02)
      2. VOTE: accept memtest86+ backport (Carried) (ddstreet, 17:07)
      3. VOTE: accept freeipmi backport (Carried) (ddstreet, 17:09)
      4. ACTION: mapreri handle approval for backports of memtest86+ and freeipmi (ddstreet, 17:10)
      5. https://bugs.launchpad.net/ubuntu/+source/debhelper/+bug/1965800 (ddstreet, 17:11)
      6. https://launchpad.net/~ddstreet/+archive/ubuntu/backport (ddstreet, 17:14)
      7. https://bugs.launchpad.net/ubuntu/+source/debhelper/+bug/1965800/comments/2 (ddstreet, 17:19)
      8. VOTE: adjust debhelper focal-backport to remove dep on debugedit (Carried) (ddstreet, 17:22)
      9. ACTION: mapreri handle debhelper backport including revert dep on debugedit for focal-backports (ddstreet, 17:25)

  4. AOB (ddstreet, 17:25)
    1. ACTION: ddstreet schedule next mtg for 1 month (ddstreet, 17:26)


Meeting ended at 17:27:04 UTC (full logs)

Action items

  1. ddstreet update tooling, requestbackport, backportpackage (carried over)
  2. mapreri upload (more of) all the tools (carried over, in progress)
  3. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
  4. (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
  5. (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)
  6. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
  7. mapreri handle approval for backports of memtest86+ and freeipmi
  8. mapreri handle debhelper backport including revert dep on debugedit for focal-backports
  9. ddstreet schedule next mtg for 1 month


Action items, by person

  1. ddstreet
    1. ddstreet update tooling, requestbackport, backportpackage (carried over)
    2. ddstreet schedule next mtg for 1 month
  2. mapreri
    1. mapreri upload (more of) all the tools (carried over, in progress)
    2. mapreri fix lintian to not complain about ~bpo suffix (https://bugs.debian.org/1001399) (carried over)
    3. mapreri review wiki page to see how we can highlight that backport requestors need to do the backport work and find a sponsor
    4. mapreri handle approval for backports of memtest86+ and freeipmi
    5. mapreri handle debhelper backport including revert dep on debugedit for focal-backports
  3. UNASSIGNED
    1. (unassigned) get DEB_VENDOR=ubuntu dch --bpo to DTRT pls (carried over)
    2. (unassigned) look at reviewer tooling such as 'queue' or other tools for reviewing/accepting/rejecting uploads, and closing the corresponding bugs (carried over)


People present (lines said)

  1. ddstreet (152)
  2. mapreri (97)
  3. meetingology (36)
  4. ubottu (4)
  5. rbasak (3)


Generated by MeetBot 0.4.0