16:07 <ddstreet> #startmeeting Ubuntu Developer Membership Board
16:07 <meetingology> Meeting started at 16:07:44 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:07 <meetingology> Available commands: action, commands, idea, info, link, nick
16:08 <ddstreet> hi all, so just for reference for the new memebers in case you didn't know the agenda is here https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda
16:08 <kanashiro> ack
16:08 <seb128> thx
16:09 <ddstreet> also before we start i guess it may be helpful for anyone watching to know there are new members, the current list is https://launchpad.net/~developer-membership-board/+members
16:09 <ddstreet> #topic Current Meeting Chair
16:10 <ddstreet> we don't normally discuss this one, but since there are new members, i guess i'll just mention if any of you would like to volunteer to take chairing shifts, the rotating list is opt-in
16:10 <ddstreet> so feel free to add yourself to the list on the agenda page
16:10 <seb128> 👍
16:10 <ddstreet> i'll skip the long-term action items, as we usually do
16:10 <ddstreet> #topic review of previous action items
16:11 <ddstreet> #subtopic sil2100 update DMB KB to clarify new contributing developers should only be added to ~ubuntu-developer-members, not to ~ubuntu-dev nor ~ubuntu-uploaders (done)
16:11 <ddstreet> looks like it's done
16:11 <ddstreet> i think right?
16:11 <ddstreet> i did not actually check
16:11 <ddstreet> i'll assume it is any move on :)
16:11 <sil2100> Yes, I think I did that!
16:11 <ddstreet> thanks!
16:11 <ddstreet> #subtopic sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:11 <ddstreet> carry over?
16:11 <sil2100> Carry over for now, it's a small item though
16:11 <ddstreet> #action sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:11 * meetingology sil2100 update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:12 <ddstreet> #subtopic sil2100 to finalize xypron's Ubuntu Contributing Developer membership (done)
16:12 <ddstreet> done also
16:12 <ddstreet> #subtopic sil2100 to announce xypron's Ubuntu Contributing Developer successfull application (done)
16:12 <ddstreet> and that looks done too
16:12 <ddstreet> #subtopic teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:12 <ddstreet> don't think teward is here today? i assume carry over for this one
16:12 <ddstreet> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:12 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:13 <ddstreet> next is the applications
16:13 <ddstreet> #topic fnordahl - per-package upload rights for the openvswitch and ovn packages
16:13 <ddstreet> i think this is done now via the ML
16:13 <ddstreet> so we just need an action to announce it and adjust ACL, any volunteers?
16:14 <ddstreet> ok well i guess i can
16:15 <ddstreet> #ddstreet announce fnordahl successful application
16:15 <ddstreet> oops
16:15 <ddstreet> #action ddstreet announce fnordahl successful application
16:15 * meetingology ddstreet announce fnordahl successful application
16:15 <sil2100> ddstreet: wait, so hm
16:15 <ddstreet> no?
16:15 <sil2100> ddstreet: regarding this - I don't think we actually need to decide first
16:15 <ddstreet> i thought it was 4 +1?
16:16 <sil2100> ddstreet: so this is basically a PPU for 2 packages, but question is: should this be a personal-PPU or should we create a openvswitch packageset?
16:16 <sil2100> Since I think it might be something more people would want to request PPU
16:16 <ddstreet> ah ok
16:16 <sil2100> And I  think we had this concept that we try to check if there's some common use-cases
16:17 <ddstreet> should this go to ML discussion or just decide now?
16:18 <kanashiro> seems sensible to me to create a new package set
16:18 <sil2100> If possible, we could discuss it here - since I think a packageset makes sense here. Anyone else agrees/disagrees?
16:18 <kanashiro> +1
16:18 <ddstreet> i had originally suggested to make them part of the openstack pkgset: https://people.canonical.com/~ubuntu-archive/packagesets/jammy/openstack
16:19 <ddstreet> however fnordahl clarified they are 'standalone' as far as being possible to use without o7k
16:19 <seb128> I don't feel like i know enough about the topic to have an opinion on whether it's likely to see more people applying for that specific 2 packages
16:19 <seb128> my personal approach would be to add the person and convert to a set if we ever get another person interested by the same packages
16:20 <seb128> but if sets are cheap I don't really an issue with creating one
16:20 <ddstreet> this might be a question better answered by people more familiar with the o7k and/or k8s areas?
16:20 <ddstreet> re: packagesets, they are intertwined with seeding/germination, so i'm not sure if it's cheap or easy
16:20 <ddstreet> or simple
16:21 <ddstreet> but i'm not actually sure
16:21 <rbasak_remote> Please not a packageset
16:21 <ddstreet> also i am pretty sure we (i.e. DMB) cannot create packagesets
16:22 <ddstreet> so probably this is a question for the TB since they are the only ones who can create packagesets i think?
16:22 <ddstreet> the rules of what we can do aren't always completely clear
16:22 <kanashiro> I like seb128's approach
16:22 <rbasak_remote> It's just a bunch of extra admin. Personal packages were created for a specific exceptional case only. It's documented.
16:23 <rbasak_remote> The DMB can decide for themselves on this one. It requires TB only because LP's ACLs aren't fine grained enough.
16:23 <ddstreet> should we take this to the ML or does everyone agree on one direction or another?
16:24 <rbasak_remote> But really there's no point making a packageset just for one reason and it's never traditionally been done that way. Better to just follow the existing pattern.
16:24 <rbasak_remote> Just for one person
16:25 <seb128> I'm +1 for just giving the ppu to fnordahl
16:25 <seb128> if we have disagreement we should probably move that to the list?
16:26 <sil2100> Ok, finally fully back
16:26 <ddstreet> i think we have seb128 and rbasak_remote suggesting to just use ppu
16:27 <rbasak_remote> I think everyone's happy with PPU? Looks like that's what was applied for and approved anyway?
16:27 <ddstreet> i think i'd concur with that
16:27 <ddstreet> kanashiro sil2100 you both ok with ppu approach?
16:27 <kanashiro> yep
16:27 <sil2100> Yeah, was reading backlog. I'm fine either way - if there's more people interested in getting the same PPU then I guess we can reconsider a packageset
16:27 <ddstreet> sounds good
16:28 <ddstreet> ok i added the action for announcing, i'll add action for adjusting acl
16:28 <sil2100> I was proposing a packageset as this is what we basically did for raspi for Dave
16:28 <ddstreet> #action ddstreet adjust fnordahl PPU acl
16:28 * meetingology ddstreet adjust fnordahl PPU acl
16:28 <sil2100> Dave (waveform) was applying for PPU for some raspi packages and we decided it made more sense to have it as a packageset as more people might want to have the same upload rights
16:29 <sil2100> So I thought this is our process - if a grouping makes sense -> turn into a packageset
16:29 <sil2100> The raspi packageset also has only one uploader
16:29 <sil2100> https://people.canonical.com/~ubuntu-archive/packagesets/jammy/raspi
16:29 <sil2100> But I agree, it's faster this way
16:29 <ddstreet> yeah, i don't really know what the specific process is, that probably would be a good thing to have a bigger discussion about and write down in official docs
16:29 <seb128> that sounds a discussion we should have, but not here today
16:29 <sil2100> +1
16:29 <ddstreet> to figure out exactly when we shoudl create packageset vs ppu
16:29 <ddstreet> yep
16:29 <seb128> +1
16:30 <ddstreet> should i put an action for that?
16:30 <seb128> yes
16:30 <sil2100> Can you assign it to me?
16:30 <ddstreet> sure
16:30 <sil2100> Thanks!
16:30 <ddstreet> #action sil2100 start discussion on process/rules for when to create packageset vs PPU
16:30 * meetingology sil2100 start discussion on process/rules for when to create packageset vs PPU
16:30 <ddstreet> thanks!
16:30 <ddstreet> ok lemme check agenda
16:31 <ddstreet> oh wow that took longer than i thought, we do actually have another applicant today
16:31 <athos> :)
16:31 <ddstreet> #topic Athos Ribeiro application for MOTU
16:31 <ddstreet> sorry for the delay athos :)
16:31 <sil2100> \o/
16:31 <ddstreet> athos can you introduce yourself?
16:31 <athos> sure!
16:31 <ddstreet> #link https://wiki.ubuntu.com/AthosRibeiro/MOTUDeveloperApplication
16:32 <athos> Hello everyone! I am Athos, I worf for the Canonical server team. Up until now, my main focus was to maintain our OCI images. For the kk cycle, I will be working on php and postgresql, the former being the main reason for requesting MOTU today :)
16:33 <rbasak_remote> Athos is a colleague on my team so as usual (for me in this situation) I intend to abstain unless everyone else is +3 and my +1 is need for quorum. So I might use this opportunity to drive home.  I'll be out ~20 minutes and then back to normal to vote if needed.
16:33 <kanashiro> same for me ^
16:34 <kanashiro> but I am not driving home :)
16:34 <ddstreet> let's open it for any questions then, though i assume you 2 on the same team know athos well enough not to have any questions :)
16:34 <sil2100> Sponsorship miner link: https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=Athos+Ribeiro&sponsoree_search=name
16:37 <sil2100> I still need a moment to browse through the application
16:37 <seb128> no question from me
16:40 <sil2100> athos: since you are applying for MOTU with driving transitions in mind, can you tell me what is a transition in the Ubuntu archive? How does one trigger a transition?
16:43 <athos> Interestingly, I haven't seen a formal definition of what a transition is around the docs :) My understanding if it is when you build a package that will have rebuilds for it's reverse dependencies depend on different binaries; or,
16:44 <athos> s/understanding if/understanding of it/
16:46 <sil2100> Can you give an example of how one could start a transition?
16:48 <athos> e.g., I am working on php-psr-log 3 right now, and it fails to migrate because civicrm in the archive depends on version 1 of that package; A simple rebuild of that package was tried in the past, but some metadata will need to change so the final binary package depends on the correct version of php-psr-log.
16:48 <athos> This transition started when php-psr-log 3 was built and pushed to proposed
16:49 <athos> as discussed recently, it is nice to send an email in the devel list boore starting it so everyone is in sync :)
16:49 <athos> s/boore/before/
16:50 * rbasak is back
16:51 <ddstreet> sil2100 any more q? just checking as we're approaching the hour
16:52 <seb128> (side note since I'm new and trying to figure out how things work around here, I will probably bring that up later/on the list/offband, but should we review the applications before the meeting? it feels suboptimal having a 10 min blank after the application summary for people to go read the reference)
16:52 <sil2100> hmm, I could ask some more questions about the transitions
16:52 <ddstreet> not trying to rush, and i personally am able to stay past the hour
16:52 <sil2100> seb128: we should! But it frequently happens that for instance I don't manage to do that in time, sadly!
16:53 <seb128> I need to wrap at the hour sorry
16:53 <sil2100> Ok, no questions then
16:53 <ddstreet> ok last call for q then before moving to the vote
16:54 <seb128> don't let me sidetrack the remaining of the meeting with my remark, I will raise that later in another way, it's also one meeting so I don't know how much that's a unlucky instance or if we a process issue to address
16:54 <seb128> still no question from me
16:54 <ddstreet> seb128 i completely agree, and there was some ML discussion last year around this you might be interested in reading for past context
16:55 <ddstreet> but definitely i agree we should continue the discussion about it
16:55 <ddstreet> ok let's vote
16:55 <ddstreet> #vote Grant Athos Ribeiro MOTU
16:55 <meetingology> Please vote on: Grant Athos Ribeiro MOTU
16:55 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:55 <seb128> +1
16:55 <meetingology> +1 received from seb128
16:55 <ddstreet> +1 as before with ubuntu-server team acl, happy with technical work and process understanding, no concerns for MOTU
16:55 <meetingology> +1 as before with ubuntu-server team acl, happy with technical work and process understanding, no concerns for MOTU received from ddstreet
16:56 <sil2100> +1 (although be sure to familiarize yourself on how library transitions are started, thinking about sonames there!)
16:56 <meetingology> +1 (although be sure to familiarize yourself on how library transitions are started, thinking about sonames there!) received from sil2100
16:56 <ddstreet> kanashiro rbasak around to vote?
16:56 <rbasak> Yes. Are we the only two left?
16:56 <rbasak> (who are here)
16:56 <rbasak> I think so?
16:56 <kanashiro> +1 to reach quorum
16:56 <meetingology> +1 to reach quorum received from kanashiro
16:56 <sil2100> I think we have a + 3 situation and 2 people remaining that are from the server team
16:56 <sil2100> \o/
16:56 <rbasak> OK
16:57 <rbasak> +1 to reach quorum (see abstention note above)
16:57 <meetingology> +1 to reach quorum (see abstention note above) received from rbasak
16:57 <ddstreet> #endvote
16:57 <meetingology> Voting ended on: Grant Athos Ribeiro MOTU
16:57 <meetingology> Votes for: 5, Votes against: 0, Abstentions: 0
16:57 <meetingology> Motion carried
16:57 <ddstreet> congrats athos!
16:57 <sil2100> athos: congratulations!
16:57 <sergiodj> congratulations, athos!
16:57 <schopin> athos: \o/
16:57 <kanashiro> congrats athos :)
16:57 <sil2100> DOes one of the newcomers want the action item of handling athos's application?
16:57 <ddstreet> kanashiro as athos is on your team, do you want to take the action to announce and adjust acl?
16:57 <seb128> congrats athos!
16:57 <kanashiro> ddstreet, sure, I can do that
16:57 <sil2100> Might be a good training opportunity!
16:58 <kanashiro> indeed
16:58 <ddstreet> #action kanashiro announce athos successful application
16:58 * meetingology kanashiro announce athos successful application
16:58 <rbasak> Details here: https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application
16:58 <ddstreet> #action kanashiro adjust athos ACL for MOTU
16:58 * meetingology kanashiro adjust athos ACL for MOTU
16:59 <ddstreet> ok moving on, there is a delegated team application (submitted by me) but scheduled for the next meeting, so i'll skip it today
16:59 <ddstreet> there are also AOB items added for discussion by me, but we're at the hour so
16:59 <ddstreet> does anyone want to continue discussion now or defer these to next meeting and/or ML?
17:00 <rbasak> Can we bump them to the next meeting for discussion please?
17:00 <rbasak> However I encourage ddstreet to raise them on the ML first.
17:00 <ddstreet> ok let's defer to next meeting, that's all then, thanks everyone!
17:00 <ddstreet> #endmeeting