20:02 <sil2100> #startmeeting Technical Board meeting
20:02 <meetingology> Meeting started at 20:02:26 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:02 <meetingology> Available commands: action, commands, idea, info, link, nick
20:02 <sil2100> #topic Apologies
20:02 <sil2100> I thin mdeslaur sent apologies for not being able to make it
20:03 <sil2100> #topic Action review
20:03 * sil2100 formal ratification of third party seeded snap security policy, depends on:
20:03 * sil2100 vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
20:03 <rbasak> I've been working on the pad, which is related.
20:03 <sil2100> vorlon: any progress here? ^
20:03 <vorlon> carry-over on that one, sorry
20:04 <sil2100> #action formal ratification of third party seeded snap security policy, depends on:
20:04 * meetingology formal ratification of third party seeded snap security policy, depends on:
20:04 <sil2100> #action vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance. (carry over)
20:04 * meetingology vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance. (carry over)
20:04 * sil2100 vorlon to reply to seeded snap upload permissions question on list
20:05 <vorlon> unless either of you think that's still important for me to do, I think we should just drop that one; likely to be superseded by the new policy regardless
20:05 <rbasak> Yeah I think it makes sense to collapse this all into the one effort.
20:05 <rbasak> (which is currently the pad)
20:05 <sil2100> +1
20:05 <sil2100> Moving on...
20:05 <rbasak> Just make sure that everything you want incorporated is actually included in the current pad please
20:06 * sil2100 sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step
20:06 <sil2100> Sadly this needs to be carried over. There has been progress but since last meeting not much, sadly
20:06 <sil2100> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step (carry over)
20:06 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which x-nox and TB will review, edit, and ratify before we move on to figuring out the next step (carry over)
20:06 * sil2100 all members to continue discussion at https://pad.ubuntu.com/third-party-repository-requirements
20:06 <vorlon> x-nox? /me glances at the wiki edit history and chuckles
20:07 <rbasak> I've been writing up wording on the pad.
20:07 <vorlon> rbasak: is that in a state now that you want us to review and give feedback on, or do you have further edits pending?
20:07 <rbasak> I'd like feedback on the preamble and my mostly v1 wording on the first three requirements please, to make sure I'm proceeding in a direction everyone agrees with.
20:07 <vorlon> ok
20:08 <sil2100> rbasak: thanks!
20:08 <vorlon> right now, or out of band?
20:08 <rbasak> What I'm proposing is that everything between BEGIN and END markers will end up in the final document (except for inline comments)
20:08 <rbasak> Out of band is probably best.
20:08 <vorlon> deadline? next TB meeting?
20:08 <rbasak> At least this time.
20:08 <rbasak> Yep
20:08 <rbasak> And then let's discuss in realtime next TB meeting please.
20:08 <rbasak> Also feel free to leave comments inline
20:08 <sil2100> Ok, let's create a differently worded action item then
20:09 <sil2100> #action Review and leave feedback on the first version of the preamble and three first requirements https://pad.ubuntu.com/third-party-repository-requirements (all of the TB)
20:09 * meetingology Review and leave feedback on the first version of the preamble and three first requirements https://pad.ubuntu.com/third-party-repository-requirements (all of the TB)
20:10 <sil2100> Thank you for working on this
20:10 <rbasak> yw! Glad to be doing something productive.
20:11 <sil2100> Ok, I think that's it from the explicit action items we have on the agenda
20:11 <sil2100> #topic ML topics
20:11 <rbasak> There is one private ML topic, and the DMB referred public one.
20:11 <sil2100> So we do seem to have the recent discourse regarding the DMB expiry
20:12 <rbasak> I don't see any other recent traffic.
20:12 <sil2100> vorlon's e-mail suggests that the authority to actually change DMB governance policy should be done by the TB - probably a good point that has been missed during the new policy discussion and ratification
20:13 <rbasak> I wonder if, to make progress, we could just vote to ratify the DMB's motion now. If the TB agrees, then that would make the (valid) point moot.
20:13 <sil2100> Should we discuss it here? Both me and rbasak are part of the DMB, but should we maybe request the DMB to submit an official proposal to the TB to review and/or ratify the new policy that wanted to be executed here?
20:13 <sil2100> *that was meant to
20:14 <rbasak> I think it's implied that the DMB wants the motion it passed ratified by the TB if ratification by the TB is required.
20:15 <sil2100> We could do that, although sooner or later I would like the policy to be reworded and include information about sending notices to members getting expired
20:15 <vorlon> I would kind of prefer to have more non-DMB members of the TB present for that particular discussion/vote
20:16 <sil2100> Agreed, maybe even, as someone outside of the team suggested, me and rbasak shouldn't actually have a vote on this?
20:16 <vorlon> no, you sohuld
20:16 <vorlon> should
20:16 <sil2100> I don't know what are the common-sense policies in such situations!
20:16 <rbasak> On sil2100's point, it would be nice to clear that up at the same time, if we're going to do it. Again, I don't think anybody on the DMB actually objects to that being in the long term policy?
20:16 <vorlon> there's no reason to recuse yourselves from such a decision
20:17 <sil2100> rbasak: yeah, I don't think so as well. I think it was something that was clearly missed, unfortunately, but at least I get the feeling that all DMB members would be fine with that - if included
20:17 <vorlon> in the meantime, if you've seen my second message on the list, I'm suggesting a path forward that doesn't depend on the TB ratification
20:17 <rbasak> I agree with not recusing myself for the reasons I stated in the ML thread. At least on this point. I think ddstreet is also questioning my conduct in one of his emails to the TB thread today, and wants a response from the TB on that too. I think I should stay out of that one.
20:17 <rbasak> But really they're two distinct questions I think.
20:17 * vorlon nods
20:18 <rbasak> "if the members of the DMB who are currently under discussion have personally voted to approve" -> that didn't happen - they were absent.
20:18 <rbasak> (IIRC)
20:18 <vorlon> ok
20:18 <sil2100> One thing for sure: I want us to have clear policies which have all requirements clearly stated
20:18 <vorlon> if someone wants to confirm whether they were or weren't present and follow up to the list to that effect, then, I would appreciate it
20:19 <rbasak> I should be able to look that up in a couple of minutes. Doing so...
20:19 <sil2100> ACK
20:20 <rbasak> According to https://lists.ubuntu.com/archives/devel-permissions/2021-November/001780.html the absent members did not vote.
20:20 <vorlon> If they WEREN'T present, then I definitely think the present members of the DMB, quorate or not, deciding a policy that allows them to remove members not present, and then removing those members, is improper.  So any resolution here is going to require the TB voting
20:21 <sil2100> vorlon: would you prefer to wait for input from other TB members? mdeslaur and cyphermox?
20:22 <rbasak> FTR, I voted -1 because I didn't think there was sufficient opportunity given to figure out the details by a forced email vote rather than waiting for a slot in a regular meeting (the meetings were full of applications around the time).
20:22 <vorlon> sil2100: for an actual policy that the TB votes on, yes, I want broader input than us 3
20:22 <sil2100> That of course makes sense
20:23 <sil2100> Let's maybe create an action item for this for the next meeting
20:23 <rbasak> FTR 2: I am however in favour in principle. Just that the details need figuring out properly, as I think the current mess demonstrates.
20:23 <vorlon> I will say that from my side I will attempt to make time for dealing with this on the mailing list in a timely manner, as I think having a functional DMB that can deal with applications promptly is very important to the health of the developer community
20:24 <sil2100> I also think that the base principle is good, especially that it's all for the good of a well-working DMB
20:24 <vorlon> (there was one suggestion on the list that we just let things wait until May for the next election of the DMB in general; I don't think that's a good idea)
20:25 <sil2100> No, I don't think so either. THe truth of the matter is that we have 2 inactive members which does cripple DMB operations. We didn't ahve a real problem yet but only because the remaining DMB members keep quite high attendance
20:26 <rbasak> It is at least functioning OK at the moment. I think most meetings that matter have made quorum recently. I'm fairly sure it's been much worse in the past.
20:26 <sil2100> But if we go down by 2 members, like it was mentioned on the ML, this will be problematic
20:26 <sil2100> Let me add an action item just in case for the next TB meeting
20:27 <rbasak> I would like to leave us time to handle the other private thread in realtime if possible please.
20:27 <sil2100> #action Discuss DMB inactivity expiration policy (all of the TB)
20:27 * meetingology Discuss DMB inactivity expiration policy (all of the TB)
20:27 <rbasak> That one has been dragging on for too long.
20:28 <vorlon> the proposal is that after adjourning the public meeting we meet in realtime via another medium to discuss the private matter
20:28 <vorlon> I have no objection to this
20:28 <sil2100> Yeah, let's do that please. Ok, in that case let's finalize the meeting here
20:28 <sil2100> #topic Community bugs
20:28 <sil2100> I see no open bugs
20:28 <sil2100> #topic Select chair
20:29 <sil2100> I have no idea how we actually do this, but I suppose let's try with cyphermox chairing and hmm, rbasak as backup? Would that make sense?
20:29 <rbasak> Sure
20:29 <sil2100> Thanks!
20:29 <sil2100> #endmeeting