16:03 <ddstreet> #startmeeting Ubuntu Developer Membership Board
16:03 <meetingology> Meeting started at 16:03:55 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:03 <meetingology> Available commands: action, commands, idea, info, link, nick
16:04 <ddstreet> i'll run thru previous actions first, as usual
16:04 <ddstreet> #topic Previous action items
16:04 <ddstreet> #subtopic ddstreet take vote to ML for Frank Heimes application for Ubuntu Contributing Developer
16:04 <ddstreet> done, he was approved via ML, and I sent out the results email already and added him to the team
16:05 <ddstreet> one note here, for contributing developer, the team to add the applicant to is https://launchpad.net/~ubuntu-developer-members
16:05 <ddstreet> however, our KB docs say to also add applicants to either ~ubuntu-dev or ~ubuntu-uploaders
16:06 <ddstreet> but i think specifically for contributing devs, that's not right?
16:06 <ddstreet> i only added him to ~ubuntu-developer-members, not ~ubuntu-dev nor ~ubuntu-uploaders
16:07 <ddstreet> teward sil2100 either of you know if that was the right action? or should he get added also to -dev or -uploaders?
16:07 <ddstreet> or rbasak if you're around ^
16:07 <teward> off the top of my head I'm not sure, but i don't think there's a problem necessarily with not putting them in the other groups.  and we know rbasak is alive
16:08 <ddstreet> ack, i'll assume i was right to only add him to ~ubuntu-develper-members; i'll add an action item to clarify our KB docs for that situation
16:08 <rbasak> I don't think that's intended for contributing developers
16:09 <ddstreet> #action ddstreet update DMB KB to clarify new contributing developers should only be added to ~ubuntu-developer-members, not to ~ubuntu-dev nor ~ubuntu-uploaders
16:09 * meetingology ddstreet update DMB KB to clarify new contributing developers should only be added to ~ubuntu-developer-members, not to ~ubuntu-dev nor ~ubuntu-uploaders
16:10 <ddstreet> #subtopic ddstreet update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves
16:10 <ddstreet> have not done this, i'll have to carry it over
16:10 <ddstreet> #action ddstreet update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:10 * meetingology ddstreet update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves (carried over)
16:10 <ddstreet> #subtopic teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access
16:11 <ddstreet> for reference:
16:11 <ddstreet> #link https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2022-January/019156.html
16:11 <ddstreet> teward carry this one over i assume?
16:11 <teward> yep carry over
16:11 <teward> been busy :P
16:11 <ddstreet> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:11 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access (carried over)
16:11 <teward> i have an informational item when you're done with the previous action items
16:11 <teward> 'cause it's relevant
16:12 <ddstreet> ok that's all the previous action items
16:12 <ddstreet> go for it teward
16:12 <ddstreet> #topic AOB
16:13 <teward> vorlon requested that DMB add coredev to ~unity7maintainers to adjust metapackages per dependencies, migrations, etc.
16:13 <teward> I executed that request but had to stab Simon Quigley multiple times to get him to approve it since i think all the admins on that team are otherwise dead
16:13 <teward> simon finalized that approval today after i managed to raise him via Telegram DMs
16:13 <rbasak> o/
16:13 <teward> that's it for me, but i think we have a few other things to stab at today?
16:13 <rbasak> "    At 2022-02-07 meeting, add action item to call for voting to replace 2 empty DMB chairs"
16:14 <rbasak> I'm not sure about this bit.
16:14 <rbasak> The other DMB seats aren't technically empty yet.
16:14 <rbasak> https://launchpad.net/~developer-membership-board/+members
16:14 <rbasak> I think they need to be emailed privately before being removed
16:14 <ddstreet> yep let's move to that topic
16:14 <teward> rbasak: i already told SImon he's at risk, but yes we should email them privately.
16:14 <ddstreet> #subtopic At 2022-02-07 meeting, add action item to call for voting to replace 2 empty DMB chairs
16:15 <ddstreet> rbasak teward according to the already approved rule of meeting attendance, their seats are now vacant
16:15 <ddstreet> there is no provision in the rule for needing to email anyone
16:16 <rbasak> In principle yes. But I think it'd be polite to give them personal notice before actually removing them. For all we know, their absence meant that they aren't even aware of that motion.
16:16 <teward> rbasak: ummmm
16:16 <teward> i have comments on this RE: Simon
16:16 <teward> but i can't share them here
16:16 <ddstreet> I'm happy to email them to let them know they have been removed from the DMB, but per the rule, we need to now hold a vote to fill the seats
16:16 <teward> they come from the many hats i wear
16:17 <teward> but i can affirm that Simon has been AWOL on other duties, and is *aware* the motion was passed
16:17 <teward> and still has not fulfilled any obligations
16:17 <rbasak> I don't agree.
16:17 <teward> so therefore with Simon in mind specifically, he has shown no effort despite multiple notices from me privately AND on phone calls to be fulfilling his role here
16:17 <teward> my 2 cents
16:17 <rbasak> Until they're actually removed from https://launchpad.net/~developer-membership-board/+members, then they're still on the board.
16:17 <ddstreet> unfortunately, the time for discussion on this point passed
16:17 <rbasak> We might have agreed that they will be removed, but we haven't actually removed them yet.
16:18 <ddstreet> rbasak the rule was passed; at the end of this meeting, i will remove them from the dmb team
16:18 <rbasak> You need a TB member I think.
16:18 <ddstreet> i'm not sure what your concern about removing them is, though?
16:18 <rbasak> I think it's rude and disrespectful to remove them without speaking to them first.
16:19 <rbasak> I don't think it's hard to speak to them first.
16:19 <rbasak> Ergo we should speak to them first.
16:19 <teward> rbasak: i wish you luck then to raise Simon
16:19 <ddstreet> rbasak no
16:19 <ddstreet> sorry
16:19 <teward> my talking to him this morning was the first time in 6 weeks I've been able to reach him
16:19 <ddstreet> rule was raised, discussed, and approved
16:19 <rbasak> Send the email. It's not hard.
16:19 <teward> may i suggest a middleground between you two while you take snipes at each other with opinions?
16:20 <ddstreet> rbasak i understand you feel like that's nice to do, but we need to move on and get participating members on the DMB
16:20 <ddstreet> go for it teward :)
16:21 <teward> email the members.  indicate they have a week to show that they have an intention to be on the DMB.  If they don't respond in that timeframe which is a reasonable timeframe, then they are not on the upcoming election and are removed from their seat.  IF they say they continue to have an intention and cannot attend next meeting for whatever reason, they are immediately invalidated.
16:21 <teward> this is a prerequisite however that they respond to the first email
16:21 <teward> this gives you both room to breathe:
16:21 <teward> (1) we'll have contacted them and
16:21 <teward> (2) we'll have the policy as enforced within 1 week
16:21 <rbasak> I don't follow.
16:22 <rbasak> That's not a compromise from my position. That is effectively restating my position.
16:22 <teward> rbasak: but with enforcement
16:22 <teward> rbasak: it's your point but it's with ddstreet's "the policy is already made" factored in
16:22 <teward> they forfeit their rights after that week basically for responding
16:22 <teward> and must be reelected to retain their positions
16:22 <rbasak> I'm not asking that they necessarily even get an option to stay. I'm saying that it's disrespectful to remove them without communicating with them first. That's all.
16:22 <teward> fyi i'm operating on 4 hours sleep
16:22 <ddstreet> well, let me suggest a slight alternative: we proceed with planning the election, and separately we email them to let them know they've been removed from the DMB, and let them know they are free and welcome to (re-)nominate themselves for their old positions during the upcoming election
16:23 <rbasak> They shouldn't be removed in any public way (eg. a call for nominations) without having received private communication first.
16:23 <ddstreet> rbasak we do everything publicly here - all discussion on this was public, this discussion right now is public
16:23 <rbasak> That's not the same.
16:24 <rbasak> We might have passed a motion saying that they will be removed. However we have not agreed the process for doing so.
16:24 <teward> rbasak: may i ask why you never brought this up as a concern?
16:24 <teward> until now.
16:24 <ddstreet> rbasak let's compromise on this - you reach out to them in whatever way you feel is best, and i'll put an action item on the agenda for me to schedule elections for their seats
16:24 <rbasak> It never came up.
16:24 <rbasak> I assumed people would be reasonable.
16:24 <rbasak> What you're saying is not reasonable.
16:25 <ddstreet> why isn't it reasonable?
16:25 <rbasak> An appropriate process would be: 1) Notify members that the criteria for their removal have been met; 2) Give them an opportunity to respond; 3) Remove them; 4) *Only then* begin the election process to replace their seats.
16:25 <ddstreet> that is your OPINION on a appropriate process; that isn't the process we actually voted on and approved
16:25 <ddstreet> again - why am i not being reasonable?
16:26 <rbasak> Because in general it's really inappropriate for negative stuff affecting someone personally to be published widely with making sure they have a heads-up first.
16:26 <rbasak> s/with/without/
16:26 <ddstreet> what do you mean? you think they don't have a heads-up on this?
16:26 <ddstreet> the rule was voted on 3 months ago
16:27 <rbasak> What I'm asking for is hardly onerous. I don't understand the resistance. I'm not asking the outcome be changed at all. I'm just asking that we be polite and respectful about doing it by actually communicating with the people affected.
16:27 <rbasak> They were, by definition, absent from that vote.
16:27 <ddstreet> the resistance is *we need to get new people in those seats*
16:27 <rbasak> Therefore they may not know. That's not a heads-up.
16:27 <teward> rbasak: i agree in principle except I personally told Simon about this three months ago
16:27 <ddstreet> clearly, there's a difference in our opinions that isn't going to get solved here
16:27 <teward> so with regards to ONE of the seats we can be sure they were informed
16:27 <rbasak> teward: OK, so if we know he knows, then I'm good there.
16:27 <teward> so at the VERY least we can move forward with that seat
16:27 <rbasak> What about the other seat?
16:28 <ddstreet> what about it?
16:28 <rbasak> ddstreet: I'm happy to agree to disagree.
16:28 <teward> am i going to have to be a tiebreaker here? :|
16:28 <rbasak> ddstreet: so propose a motion and I'll -1 it. That's the system.
16:29 <ddstreet> there is no motion - the rule is clear and the action is clear as well
16:29 <ddstreet> i'll add an action for rbasak to contact the members whose seats are now vacant
16:29 <rbasak> https://launchpad.net/~developer-membership-board/+members defines the current DMB membership. We have agreed to remove those members because the criteria have been met, but not agreed how to do it, and they're still there.
16:29 <rbasak> No thanks.
16:29 <ddstreet> i'll add an action for myself to begin planning the election for their seats
16:30 <ddstreet> rbasak you don't want to actually take this action yourself? why not?
16:30 <rbasak> You're driving this. Please don't pass the negative work on to me.
16:30 <ddstreet> you're trying to stop this
16:30 <teward> *sigh* lets stop arguing and do this
16:30 <rbasak> No, I'm asking that you communicate with them first, and then I'm in favour of continuing.
16:30 <ddstreet> would you prefer to continue with a  DMB with multiple missing members?
16:30 <teward> give ME an action item to contact the other seat
16:30 <ddstreet> rbasak i understand your ASK
16:30 <teward> give ME the action item to remove them from DMB if no reply by OEW
16:30 <teward> EOW*
16:30 <ddstreet> my answer is no
16:30 <rbasak> I'm asking you to stop being rude to the existing retiring members about this.
16:31 <ddstreet> #action teward communicate with absent DMB members
16:31 * meetingology teward communicate with absent DMB members
16:31 <ddstreet> #action ddstreet schedule new election for vacant DMB seats
16:31 * meetingology ddstreet schedule new election for vacant DMB seats
16:31 <rbasak> And, as long as that's your intention, I will have no further part of this.
16:31 <ddstreet> whew ok, are we done now?
16:31 <ddstreet> any last items?
16:31 <teward> ddstreet: your new election is prerequisite on my handling the communciation
16:31 <teward> that's just an FYI
16:31 <ddstreet> teward ack i'll send a call for nominations soon, thanks
16:32 <teward> this should settle both sides of the argument
16:32 <teward> i'll handle the reaching out
16:32 <rbasak> ddstreet: do you intend to wait for teward to contact the retiring members first?
16:32 <ddstreet> rbasak no
16:32 <teward> then you both leave me no choice on this
16:32 <ddstreet> but it'll probably be next week before i get to it, so teward should have the rest of this week
16:32 <teward> I vote we move this discussion to the ML
16:32 <teward> or escalate this to the next team up in the tier for decision
16:32 <rbasak> +1
16:33 <ddstreet> escalate it
16:33 <ddstreet> the DMB is broken and we need to fix it
16:33 <rbasak> Hardly
16:33 <ddstreet> #action teward escalate election to TB
16:33 * meetingology teward escalate election to TB
16:33 <ddstreet> ok, are we finally done now?
16:33 <rbasak> I'm still fine with the outcome you're seeking.
16:33 <ddstreet> #endmeeting