19:03 <ddstreet> #startmeeting Ubuntu Developer Membership Board
19:03 <meetingology> Meeting started at 19:03:10 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:03 <meetingology> Available commands: action, commands, idea, info, link, nick
19:03 <ddstreet> no preivous action items in the agenda
19:03 <ddstreet> going down the list, first topic is MOTU application
19:03 <ddstreet> #topic Ubuntu MOTU Developer application
19:04 <ddstreet> fheimes hello! can you introduce yourself?
19:04 <fheimes> hi, yes sure:
19:04 <ddstreet> #link https://wiki.ubuntu.com/FrankHeimes/MOTU
19:04 <fheimes> I'm Frank (Heimes), living in Germany, joined Canonical in '16 and I'm working in the SCE 'Server Commercial Engineering' (former 'hardware enablement' (former 'hyperscale')) team.
19:04 <teward> o/
19:04 <fheimes> The areas and topics I'm working on are mainly s390x (IBM Z) and ppc64el (IBM Power) projects.
19:05 <fheimes> There is quite some coordination work needed, but I want to stay in touch with technology and want to do development work, too.
19:05 <fheimes> Hence meanwhile I'm doing almost all the kernel SRU and Patch work in these projects, and try cover a bit more work in the packaging area, too.
19:05 <fheimes> I think looking at universe packages is a good start and I worked on several universe packages (but also on some from main - see MOTU-appl. wiki page) - I guess about half of them are s390x specific.
19:05 <fheimes> That's the reason I'm applying for the MOTU mebership (contributing developer) application - to be able to do more on the universe ones, w/o having to annoy others too much.
19:06 <fheimes> What else to say ... I also contributed a bit to the (old) installation-guide, the current Ubuntu Server guide and discourse and to the ubuntu-maintainers-handbook, again esp. in the area of installation.
19:07 <ddstreet> thanks! rbasak or teward go ahead with any q, i'm still reading the application
19:07 <fheimes> Well, I do not have a big Debian (distro) background, but I did some (internal) 'rough' Debian packaging in my previous job and maintained a few packages there. But I still had to learn (and still need to learn) more about Debian packaging and the Ubuntu processes (like SRU, versioning, transitions, etc.) on top.
19:07 <rbasak> fheimes: looks like you've got a great track record in getting bugfixes landed in Ubuntu. Thank you for your work!
19:07 <rbasak> fheimes: but have you done any package merge work in Ubuntu that demonstrates that you know how to do one correctly?
19:08 <fheimes> I recently worked on a version bump of openssl-ibmca, that got just today reviewed and uploaded by schopin
19:09 <fheimes> as well as for the (very specific) python3-zhmcclient package
19:09 <pleia2> I didn't know fheimes was coming in for his developer membership (I just have an s390x highlight, haha!), but I work with him a lot these days on Ubuntu w/ s390x stuff and he's always fantastic to collaborate with, including most recently with some new folks working on the Debian s390x port
19:09 <fheimes> I haven't done much LP PR merge work yet  ...
19:09 <rbasak> https://launchpad.net/ubuntu/+source/python3%2Dzhmcclient 404s?
19:10 <rbasak> No I mean a package merge - doesn't matter about the workflow. Something that catches up with Debian changes when an Ubuntu delta exists.
19:10 <teward> rbasak: src:zhmcclient
19:11 <rbasak> Thanks
19:11 <fheimes> https://launchpad.net/ubuntu/+source/zhmcclient
19:11 <rbasak> Yeah neither of those are merges :-/
19:11 <teward> rbasak: src:zhmcclient
19:11 <teward> blah laggg
19:11 <fheimes> not merges in the sense of sync from debian, no
19:13 <teward> fheimes: when rbasak and I speak of merges we mean merging newer Debian versions into the Ubuntu delta'd versions of a package and then handling the inclusion of the Ubuntu delta - i.e. an actual merge from Debian into Ubuntu
19:13 <teward> not a straight sync either.  for clarification
19:13 <rbasak> fheimes: looks like you have a current outstanding responsibility wrt. your previous sponsored upload of tigervnc. Could you explain what it is, please, and what you need to do?
19:13 <fheimes> yes - the packages I work on in Ubuntu are often more up to date than the Debian ones
19:13 <fheimes> but I try to get them back on a similar level
19:14 <fheimes> yes - I picked a patch from upstream that fixed a certain issue and patched/modified the Ubuntu tigervnc package
19:14 <fheimes> but that fix is not in Debian, hence I reached out to the Debian maintainer and suggested to get that also into Debian
19:15 <fheimes> I didn't got a response so far
19:15 <rbasak> Let's say you never get a response and don't expect to get one. What's the next required step that you must take in Ubuntu?
19:15 <fheimes> but if the patch will not land in Debian
19:15 <fheimes> it will be part of the next upstream tigervns version
19:15 <fheimes> and if that finally lands in Ubuntu, the patch that I incl. can be dropped again
19:16 <fheimes> I think I should discuss this with one of the Ubuntu fellows that is also a Debian mantainer
19:17 <fheimes> since I'm not a Debian maintainer I can't upload it myself
19:18 <fheimes> not sure if that is a perfect or exhausting answer though ...
19:19 <rbasak> It's good that you'd ask for help.
19:20 <fheimes> in case of my work on qtwebkit-opensource-src is worked surprisingly nice
19:20 <fheimes> the Debian maintainer is also an Ubuntu maintainer and was obvisouly subscribed to all qtwebkit-opensource-src bugs
19:20 <fheimes> hence he contacted me before I was ready and applied to to Debian right away (and sponsored my Ubunt upload afterwards )
19:20 <rbasak> But I'm not sure you really understand the workflow here, so I think I'd prefer for you to continue uploading under the supervision/mentorship of someone who understands the process already.
19:20 <rbasak> Let's move on from my questions - thanks.
19:21 <fheimes> well, I think a learned about a lot processes and workflows, but probably not all in detail ...
19:22 <teward> no questions here from me that rbasak hasnt brought up
19:23 <fheimes> in add. I could have opened a Debian bug and have attached it to the LP bug (in case you wanted to hear that ...)
19:23 <ddstreet> fheimes i dont have any technical q, as rbasak covered quite a lot, my question is just if motu is the most beneficial acl for you? from your upload list, it seems to be about 1/2 main, 1/2 universe
19:23 <fheimes> s/attached/referenced
19:24 <fheimes> well, I saw the MOTU application as a kind of a first step ...
19:24 <ddstreet> ok yeah, that is what it seemed liek
19:24 <ddstreet> it's possible that a PPU list of packages you commonly work with might be better, but it depends on what your future plans are, if you plan to apply later for coredev then motu definitely makes more sense
19:25 <ddstreet> for me, the bar to get PPU is somewhat lower than motu, even if some of the packages are in main
19:25 <fheimes> I thought about PPU as well (like also mentioned by slyon) - but didn't wanted to ask for both at the same time
19:26 <ddstreet> that's fine, we have sometimes allowed that and we just vote on the highest acl we think is ok
19:26 <ddstreet> but for PPU it would require a predefined list of packages
19:26 <rbasak> I don't think MOTU should be treated as a ramp to core dev. MOTU upload requires most of the same skills and understanding, missing only a few bits (eg. component mismatches) and my bar for both is thus approximately the same. Just because it's not in main and supported by Canoncial doesn't mean that it's less important and lower quality uploads are acceptable.
19:27 <rbasak> I'd be OK for PPU for packages that aren't expected to be in Debian ever.
19:27 <rbasak> For packages that are, I think it's important to demonstrate understanding of the package merge workflow.
19:28 <rbasak> Because you can't keep adding Ubuntu delta without knowing how to clean it up!
19:28 <fheimes> yeah - s390-tools would be an obvious choice ....
19:28 <fheimes> well, one never know what will ever land in Debian ...   ;-)
19:29 <ddstreet> i'm ready to vote, teward rbasak any further q or should we proceed?
19:29 <rbasak> I'm ready.
19:29 <fheimes> well, I mentioned some ways to clean this up again, but okay ...
19:29 <ddstreet> #vote Frank Heimes application for MOTU
19:29 <meetingology> Please vote on: Frank Heimes application for MOTU
19:29 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:29 <teward> robie's point still stands regardless - if you add to a delta and then dont know how to clean up and do the merge from Debian if Debian has newer its a critical workflow process thats missing there.
19:29 <rbasak> -1 I think it's essential that a MOTU understands package merge workflow
19:29 <meetingology> -1 I think it's essential that a MOTU understands package merge workflow received from rbasak
19:29 <rbasak> It's important to do merges stop universe becoming an unmaintainable mess. To receive +1 I'd have expected you to: 1) Have some sponsored package merges included in your MOTU application, with minimal required corrections from sponsors; 2) understand your responsibility to merge tigervnc since that's currently outstanding; and 3) be able to describe what a package merge is, rather than appear
19:30 <rbasak> oblivious of this process.
19:30 <teward> -1 MOTUs require knowledge of the merge workflows as well as other processes.  This alone is a critical requirement.
19:30 <meetingology> -1 MOTUs require knowledge of the merge workflows as well as other processes.  This alone is a critical requirement. received from teward
19:31 <teward> see rbasak's statements as well which echo mine.  (i'm on my phone or i'd write a larger dump of pretty much similar statements here)
19:33 <ddstreet> +0 I think your technical skill does appear to be good, but I also do agree on the point that MOTU should be aware of processes like merges; additionally the MOTU acl doesn't seem like the best fit for past work; if you only want PPU, I'd suggest getting some more uploads for a core set of packages; if you do want MOTU, I think you should get more uploads over a broad set of universe packages, including merges
19:33 <meetingology> +0 I think your technical skill does appear to be good, but I also do agree on the point that MOTU should be aware of processes like merges; additionally the MOTU acl doesn't seem like the best fit for past work; if you only want PPU, I'd suggest getting some more uploads for a core set of packages; if you do want MOTU, I think you should get more uploads over a broad set of universe packages, including merges received from ddstreet
19:33 <ddstreet> #endvote
19:33 <meetingology> Voting ended on: Frank Heimes application for MOTU
19:33 <meetingology> Votes for: 0, Votes against: 2, Abstentions: 1
19:33 <meetingology> Motion denied
19:34 <rbasak> fheimes: the good news is: you have an outstanding merge to do! Get some help from mentors on merging tightvnc and you'll have at least 1 unit of experience ready for your reapplication, which I hope to see soon!
19:34 <ddstreet> indeed, with some more work i think a reapplication would be welcome
19:34 <rbasak> And I hope that having done that you'll understand what we mean.
19:35 <rbasak> He did also apply for Contributing Developer.
19:35 <ddstreet> oh! ok i missed that
19:35 <ddstreet> fheimes would you like us to vote on contributing developer?
19:35 <fheimes> merging back tigervnc was and is still on my list, yes
19:35 <fheimes> thanks anyway ...
19:36 <fheimes> well, if possible, yes
19:36 <ddstreet> sure, is that ok with you rbasak teward?
19:36 <ddstreet> to vote for contrib devel
19:36 <rbasak> Yes please
19:36 <ddstreet> #vote Frank Heimes application for Ubuntu Contributing Developer
19:36 <meetingology> Please vote on: Frank Heimes application for Ubuntu Contributing Developer
19:36 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:37 <rbasak> +1
19:37 <meetingology> +1 received from rbasak
19:37 <teward> +1 for Ubuntu Contributing Developer
19:37 <meetingology> +1 for Ubuntu Contributing Developer received from teward
19:37 <rbasak> Lots of valuable contributions on your application page. Thank you for your work!
19:37 <ddstreet> +1 definitely sustained and broad work technically and non-technically, well deserved
19:37 <meetingology> +1 definitely sustained and broad work technically and non-technically, well deserved received from ddstreet
19:37 <ddstreet> #endvote
19:37 <meetingology> Voting ended on: Frank Heimes application for Ubuntu Contributing Developer
19:37 <meetingology> Votes for: 3, Votes against: 0, Abstentions: 0
19:37 <meetingology> Motion carried
19:38 <rbasak> I need to run now. Thanks all!
19:38 <fheimes> many thx
19:38 <ddstreet> thanks rbasak! o/
19:38 <teward> and I need another coffee run, or i'll crash hard.  o/
19:38 <ddstreet> technically, we need 4 +1 on any vote, but I'm certain we can get one more +1 for your contributing devel application
19:38 <ddstreet> thanks teward! o/
19:39 <ddstreet> so fheimes I'll take the vote to the ML to see if we can get one more DMB vote on it; if not, we can pass it next DMB meeting.
19:39 <ddstreet> and definitely think about reapplying when you feel you're ready
19:39 <ddstreet> #action ddstreet take vote to ML for Frank Heimes application for Ubuntu Contributing Developer
19:39 * meetingology ddstreet take vote to ML for Frank Heimes application for Ubuntu Contributing Developer
19:40 <fheimes> yepp, will keep that in mind
19:40 <ddstreet> well we've lost all our DMB members now except me, so I guess I'll defer the AOB section until next meeting.
19:41 <teward> *returns with glorious elixir*
19:41 <teward> is there anything in AOB tho?  :P
19:41 <ddstreet> teward ah well that was a fast coffee! :)
19:41 <teward> ddstreet: 30 ft. away is the Keurig :p
19:41 <ddstreet> since you're here let's go thru it
19:41 <ddstreet> #topic AOB
19:42 <ddstreet> #subtopic Should we check candidate signing of Ubuntu Code of Conduct?
19:42 <teward> subtopic send teward unlimited coffee funds
19:42 <ddstreet> i added this one; i dont remember where i was discussing it, but i realized we don't actually check this as part of the application process
19:42 <ddstreet> we probably should though?
19:42 <teward> ddstreet: my strong opinoin: yes.  it needs to be done
19:43 <teward> any contributions are governed by CoC, we brought this up during the chaos that involved CC involvement in certain people with rights (upload or otherwise) doing lots of CoC violations
19:43 <teward> resulting in hardcore booting from contributing in future
19:43 <teward> so we started to say membership routes need to validate that CoC is going to be abided by
19:43 <teward> whether we verify that the person has signed CoC on launchpad or we validate they agree to abide by it
19:43 <ddstreet> ok let's put an action item to add this to the docs, and we shoudl probably have some way to remind ourselves to check it each application too
19:44 <teward> at least, that's what we pushed to the Membership Boards anyways
19:44 <teward> yep
19:44 <ddstreet> you want to take the action? or i can
19:44 <ddstreet> since it's just me any you :)
19:44 <teward> you just volunteered :p
19:44 <ddstreet> or i could add it 'unassigned' ;-)
19:44 <ddstreet> lol
19:44 <ddstreet> yeah guess i did
19:45 <ddstreet> #action ddstreet update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves
19:45 * meetingology ddstreet update application docs and possibly DMB checklist, to make sure candidates have signed CoC before applying and before DMB approves
19:45 <ddstreet> ok last AOB for this week
19:45 <ddstreet> #subtopic Following up to this email from teward, should we update the application process wiki page to clarify the (possible) need to first apply to the ubuntu-wiki-editors team
19:46 <teward> ddstreet: i think that needs to be globally made known across all the boards and all the application processes
19:46 <ddstreet> so...i wasn't aware that most people can't create their own wiki page to use as an application page
19:46 <teward> not just DMB level membership stuff
19:46 <teward> yeah i knew about it but I kinda forgot since i've had edit privs since $Ever
19:46 <teward> :P
19:46 <ddstreet> yeah definitely - it should be clarified in all application processes
19:46 <ddstreet> lol
19:46 <ddstreet> you want to take this action item then? ;-P
19:46 <teward> agreed.  i'll forward that on to the standard membership boards as well with my CC hat on, but yes, we should probably make a note that it'll need to be done in the wiki pages.
19:47 <teward> ddstreet: all the pages are becoming blurs, but yes.
19:47 <teward> i'll take that one
19:47 <ddstreet> lol, awesome thanks!
19:47 <ddstreet> #action teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access
19:47 * meetingology teward follow up to get all application process wiki/docs to explain the process to be able to edit wiki pages, for applicants who don't yet have wiki edit access
19:47 <ddstreet> ok that's all the AOB
19:48 <ddstreet> teward any final items from you?
19:48 <teward> no there's one we haven't addressed.  send teward coffee.  :P  </joke>
19:48 <ddstreet> lol
19:48 <teward> (it's well known i'm a coffee addict so occasionally I joke to keep things light :P)
19:48 <ddstreet> that's an ongoing one ;-)
19:48 <teward> alls good
19:48 <ddstreet> ok let's wrap then, 10 minutes early
19:48 <sarnold> I'm afraid it's not a joke.. ;)
19:48 <ddstreet> #endmeeting