15:09 <sil2100> #startmeeting Developer Membership Board
15:09 <meetingology> Meeting started at 15:09:29 UTC. The chair is sil2100. Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:09 <meetingology> Available commands: action, commands, idea, info, link, nick
15:09 <sil2100> #topic Review of previous action items
15:10 <sil2100> We have the actions from ddstreet to announce and act on the successful+unsuccessful applications
15:10 <sil2100> ddstreet: is that done?
15:10 <ddstreet> yep, done
15:11 <sil2100> Next one: rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carried over)
15:11 <rafaeldtinoco> nope =(
15:11 <rafaeldtinoco> i had forgotten I had that
15:11 <sil2100> Let's carry that over then!
15:11 <rafaeldtinoco> please carry on and Ill try to solve it this week
15:11 <sil2100> #action rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carry over)
15:11 * meetingology rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carry over)
15:12 <sil2100> Ok, now let's move to applications, so that we don't waste time of our applicant
15:12 <sil2100> #topic Ubuntu MOTU Developer Applications
15:13 <sil2100> Today we have Simon Chopin (schopin) applying for MOTU
15:13 <sil2100> #link https://https//wiki.ubuntu.com/SimonChopin/MOTUDeveloperApplication
15:13 <schopin> o/
15:13 <sil2100> schopin: welcome! Please tell us about yourself o/
15:14 <schopin> (the link is corrupted, extra https. https://wiki.ubuntu.com/SimonChopin/MOTUDeveloperApplication )
15:14 <sil2100> Ah, looks like someone broke the link on the Agenda then
15:14 <sil2100> #link https://wiki.ubuntu.com/SimonChopin/MOTUDeveloperApplication
15:15 <schopin> Hi! As stated in my application, I'm a French software engineer, currently employed within the Foundations team at Canonical.
15:16 <rbasak> o/
15:16 <schopin> I've joined Canonical as I used to be an active Debian contributor when I was a student.
15:17 <rbasak> Is Stefano Rivera's endorsement purely based on contributions to Debian rather than Ubuntu?
15:17 <schopin> Sadly, yes. I sought his endorsement as a community member, as I don't have many longstanding relationships with community members outside of my team.
15:19 <teward> *points at vorlon and other Foundations team people* surprised that nobody I could tell from Foundations put their support in other than Lukas. just saying
15:19 <schopin> I didn't give them much time to do so :-)
15:20 <slyon> I do not have any DMB voting rights, but strongly support simon's application
15:20 <vorlon> I for one hadn't been asked
15:20 <sil2100> I couldn't endorse anyway as I was not a sponsor for Simon, at least yet o
15:20 <sil2100> o/
15:20 <schopin> vorlon: I think you were still asleep when I asked :)
15:21 <sil2100> Anyway, I suppose it's time for questions!
15:21 <teward> heh. at least we get a full story heh. sorry for the ping vorlon :P
15:22 <teward> schopin: i have a question but I'm here via my phone so i'll wait for others to ask questions before i voice mine (phone keyboard is slow typing)
15:22 <rafaeldtinoco> schopin: what is update excuses page used for ?
15:23 <schopin> It is generated by... britney? to explain why a given package hasn't migrated from -proposed to devel or -updates. Notably, this is were we'll find out that autopkgtests from rdepends have failed.
15:25 <rbasak> schopin: so like teward said, you have been sponsored by other people on your team but don't have endorsements from them. I'd really like to hear their opinion.
15:27 <ginggs> o/ I'm in schopin's team
15:28 <rbasak> OK, but there's also juliank, bdmurray, mwhudson
15:28 <schopin> rbasak: each time it has been a one-off. Gunnar Hjalmarsson updated a series of OpenSSL SRUs, laney uploaded my ppp merge, and leosilva sponsored a security patch.
15:28 <schopin> ALl of the others are in my team :-/
15:28 <rbasak> schopin: sure, but then they can speak to what little they have sponsored, and then we can consider them together as a whole
15:28 <teward> i'd still like to hear the opinions of other sponsors within your team
15:29 <juliank> what is with me?
15:29 <rbasak> juliank: you sponsored an upload for schopin?
15:29 <rbasak> https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=*chopin*&sponsoree_search=name
15:29 <slyon> ginggs: is part of Foundations, too and put his endorsement into the MOTU application wiki page
15:30 <juliank> rbasak: Ah yes, those all went swimmingly
15:30 <sil2100> schopin: I see in your application you mention being able to send e-mails to ubuntu-devel@ - is that still a problem for you, or did it get somehow sorted out out-of-process?
15:30 <juliank> I'm +1 on this application
15:30 <sil2100> I think there are some other teams that one can apply for to get this ability
15:30 <schopin> I've been white-listed.
15:30 <sil2100> Ah, ok!
15:30 <schopin> There are, and my application was initially for Contributing Developer.
15:31 <schopin> But slyon made the case that I should aim for MOTU
15:32 <ddstreet> schopin it looks like you only have a few (3-4) SRU uploads, is that right?
15:33 <schopin> It isn't, the tracker missed a few.
15:34 <rbasak> So you have endorsements that cover 14 out of 27 of your uploads I think.
15:34 <rbasak> From three sponsors
15:36 <juliank> I just forgot to write endorsements on the wiki page
15:36 <sil2100> schopin: another question from me - could you tell me what you think the main aims of the MOTU team are as a whole?
15:36 <schopin> ddstreet: I acknowledge that I could probably have more SRUs under my belt, especially from "normal" packages.
15:36 <rbasak> Five further sponsors haven't commented on your application
15:36 <rbasak> I'm counting juliank as having endorsed there
15:38 <schopin> sil2100: as I understand it, MOTU take care of the universe pocket, either directly or by sponsoring patches from the wider community.
15:38 <rbasak> A big set of your sponsorships are for packages in main that wouldn't be unblocked by MOTU
15:39 <juliank> a big set of upcoming ones for openssl transition will be in universe, fwiw
15:39 <sil2100> rbasak: I think schopin mentioned on his application that he wants to use the MOTU powers to help with the sponsoring queue and make more space for people from the team to sponsor his main uploads ;p
15:39 <sil2100> schopin: thanks o/
15:40 <sil2100> schopin: last question from me, slightly more packagey! What's the difference between universe and multiverse? ;)
15:40 <rbasak> sil2100: a long standing DMB principle has been to see evidence of the specific thing people expect to do with their powers, rather than backwards on a "I am going to do X" basis.
15:41 <schopin> sil2100: universe is FLOSS, whereas multiverse is software that has legal constraints.
15:41 <cjwatson> (yes, I added schopin to the allow-list for ubuntu-devel@, which is my general practice for people who are consistently posting on-topic content there - I think "posting moderated for people who are not Ubuntu developers" is a statement of the default behaviour rather than necessarily a hard requirement)
15:42 <ddstreet> schopin could you explain the difference, from a process/rules perspective, between uploading to the devel release and uploading to stable/SRU release?
15:42 <sil2100> rbasak: well, I think it varied per-DMB-cadence, we had many applicants applying for core-dev but not having enough experience and recommending (and accepting them) for MOTU as an intermediate step to help gaining the missing experience
15:44 <schopin> SRUs must be authorized by the SRU team, and after being in -proposed must be explicitly verified before being authorized to migrate.
15:45 <rbasak> sil2100: I can see that happening if (and only if) a MOTU application would have stood on its own merits
15:45 <schopin> devel has less constraints, although the process varies depending on the stages of release (freeze)
15:45 <sil2100> schopin: thanks o/
15:45 <sil2100> I have no other questions myself
15:46 <schopin> ddstreet: should I get into more details for devel?
15:47 <ddstreet> schopin from a uploader's perspective, is there any different process or requirements?
15:47 <ddstreet> comapring uploading to devel, vs uploading a sru?
15:49 <schopin> Assuming I'm uploading my own package, I'd need to be sure to mention the related bugs for the SRUs in the changelog, which should be filled with all details required.
15:50 <ddstreet> are there any different requirements for bug content or process, for devel vs stable?
15:50 <ddstreet> besides the changelog LP: reference
15:51 <schopin> The bug description must have repro steps and 'possible regressions' section, and must be tagged in a particular way.
15:51 <schopin> I'd need to look up the documentation for the tag, though.
15:51 <ddstreet> schopin let's use this bug for example: lp:1934988
15:52 <ubottu> Launchpad bug 1934988 in s390-tools (Ubuntu Impish) "Upgrade s390-tools to latest version (2.17.0)" [Undecided, Fix Released] https://launchpad.net/bugs/1934988
15:52 <ddstreet> could you upload that to a stable release? and if so (or assuming you could) what specifically should you change in the bug and/or in the package patch(es)?
15:53 <schopin> I think in the case of this package I could, because it is for hardware support, but I'd need to edit the description to make it clear.
15:54 <schopin> But I'd probably look into backporting specific patches, though, seeing the changelog.
15:54 <ddstreet> in quilt patches for packages, is there any specific information that you should include, when fixing a bug?
15:56 <schopin> The DEP-2 Origin: field seems rather appropriate.
15:56 <ddstreet> was any info missing from this patch: http://launchpadlibrarian.net/550441647/openssl_1.1.1f-1ubuntu2.4_1.1.1f-1ubuntu2.5.diff.gz
15:56 <schopin> s/2/3
15:57 <schopin> The info is there, but the formatting could be better. (last line of the patch log has a link to the upstream PR)
15:58 <ddstreet> ok no more q from me, thanks
16:02 <sil2100> Any other questions? rbasak, teward?
16:02 <rbasak> No further questions from me, thanks
16:02 <sil2100> rafaeldtinoco: ?
16:02 <schopin> teward mentioned having questions earlier.
16:04 <teward> was already answered by others asking. but it's spawned another question
16:04 <sil2100> Let's wait a few moments longer, but then I think it's time for votes as we're already over our allocated time-slot
16:04 <sil2100> Oh, ok!
16:04 <sil2100> Ask away then o/
16:05 <teward> schopin: you mentioned that your intention is to 'reduce the sponsoring queue so coredevs can look at your work' - why do you think that this will gain more attention to your work in favor of other sponsoring tasks in the queue? Because I watch the -sponsors email threads and a lot of them are in *various* packages with half the current sponsoring queue in main and half in Universe.
16:05 <teward> (related: http://reqorts.qa.ubuntu.com/reports/sponsoring/)
16:06 <teward> (many of these are SRUs which require different handling than a 'straight upload' too per processes)
16:08 <schopin> The topic of the sponsoring queue comes up regularly with my coworkers, and my experience in the few months I've been within the Foundations team is that for our non-core/MOTU members, patches added to the sponsorship queue remain there a rather long time, and at least in my case have been picked up by team members.
16:10 <schopin> This is true for both main and universe uploads.
16:11 <schopin> As anyone's time is finite, it stands to reason that my not adding to the universe queue, and being able to actually remove from it, frees up time for others.
16:12 <teward> I will point out just for future reference: the Foundations team has sponsors for that reason as their stuff tends to need special priority over some other tasks. Just a point of information.
16:12 <teward> i'm ready to vote.
16:13 <schopin> Agreed, but this happens also for our +1 work :)
16:14 <teward> oh, I know it does. :P (but that's the same topic just stated with slightly different scope)
16:14 <teward> sil2100: i'm ready to vote and then get lunch, i'm starving.
16:17 <sil2100> o/
16:17 <sil2100> Okay
16:18 <sil2100> #vote Grant Simon Chopin MOTU
16:18 <meetingology> Please vote on: Grant Simon Chopin MOTU
16:18 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:18 <rbasak> -1 I'd like to see more endorsements to cover your existing upload work (even with juliank's additional +1)
16:18 <meetingology> -1 I'd like to see more endorsements to cover your existing upload work (even with juliank's additional +1) received from rbasak
16:18 <rbasak> I have a strong aversion to missing endorsements from sponsors that I'd expect to have endorsed you. If your sponsors aren't willing to endorse you, then to me that's a very strong indication that you are not ready, and without the endorsements there I can't tell the difference. Two caveats: 1) if a sponsor doesn't feel that they've worked with you enough to give you a full endorsement, I'd still
16:18 <rbasak> like to see an "I can't speak for their work as a whole, but their work with me has been fine albeit limited" type endorsement; 2) I'm fine with a good sample of recent endorsements rather than expecting one from every single sponsor, but in this case I don't think you have a representative sample. Note that I haven't quizzed you on other aspects as I didn't want to draw out my questioning when it
16:18 <rbasak> wouldn't make a difference to my vote. I might want to do this if this motion doesn't succeed and you later reapply with a better sample of endorsements.
16:20 <teward> -1 While I agree that you *technically* have the ability to do the necessary tasks for MOTU rights, I think your intended purpose of 'making it easier for coredev sponsors to look at your stuff' is the wrong approach - the issue is less 'finite time' and more 'not enough sponsors not employed by Canonical'. Additionally, I want to see more endorsements from those who've worked with you - your application feels a bit rushed
16:20 <meetingology> -1 While I agree that you *technically* have the ability to do the necessary tasks for MOTU rights, I think your intended purpose of 'making it easier for coredev sponsors to look at your stuff' is the wrong approach - the issue is less 'finite time' and more 'not enough sponsors not employed by Canonical'. Additionally, I want to see more endorsements from those who've worked with you - your application feels a bit rushed received from teward
16:20 <teward> since many others who sponsored you on Foundations didn't even get to weigh in on your application.
16:20 <ddstreet> +0 : your endorsements are ok but less than great (i'd like to see one or two more written endorsements from more recent ubuntu sponsors), and your technical work appears good, but it doesn't seem like MOTU is a great fit for your typical work; additionally, while you do see to generally understand the process for stable releases, i don't quite see that reflected in the few SRUs you have done; I would like to see you reapply after a few
16:20 <meetingology> +0 : your endorsements are ok but less than great (i'd like to see one or two more written endorsements from more recent ubuntu sponsors), and your technical work appears good, but it doesn't seem like MOTU is a great fit for your typical work; additionally, while you do see to generally understand the process for stable releases, i don't quite see that reflected in the few SRUs you have done; I would like to see you reapply after a few received from ddstreet
16:20 <ddstreet> more universe uploads to devel, and a few more universe uploads to stable releases.
16:24 <teward> (my vote is not a barring from refiling your application, but please take the time to actually *get your endorsements* rather than force others to push into a rushed schedule)
16:25 <sil2100> +1 I on the other hand think we should be a bit less strict POV re: applicants for MOTU. The team needs help and we're looking for people passionate to partake in universe moderation. I don't have much contact with the work Simon is doing, but I see he has the right knowledge-set already, and I feel he would be a good addition to the team, regardless of being quite 'fresh'
16:25 <meetingology> +1 I on the other hand think we should be a bit less strict POV re: applicants for MOTU. The team needs help and we're looking for people passionate to partake in universe moderation. I don't have much contact with the work Simon is doing, but I see he has the right knowledge-set already, and I feel he would be a good addition to the team, regardless of being quite 'fresh' received from sil2100
16:27 <sil2100> It is good to have strong requirements for people that get upload rights, and I respect that - but here I, personally, don't feel any risk, not with the endorsements we have, not with the demonstrated knowledge, not with the visible drive to work on Ubuntu
16:28 <sil2100> So, even though probably controversial (even more so that Simon is part of my team, but as said, we don't work directly with eachother) I still stand with my vote here
16:28 <sil2100> rafaeldtinoco: are you around for the vote?
16:29 <teward> sil2100: as we're already way past the timeslot we may want to defer the rest of the vote to the internal lists or discussions
16:29 <sil2100> Yeah...
16:29 <slyon> ACK. I also think that simon demonstrated his need for MOTU powers in the big preparation of the openssl3 transition, that has mostly happened in a PPA so far, thus not visible in the archive. But with the JJ cycle starting this transition will soon hit the archive and then simon can land the work he prepared so far.
16:30 <sil2100> #endvote
16:30 <meetingology> Voting ended on: Grant Simon Chopin MOTU
16:30 <meetingology> Votes for: 1, Votes against: 2, Abstentions: 1
16:30 <meetingology> Motion denied
16:30 <sil2100> btw. this is not denied really ^
16:30 <teward> correct, this is not 'denied' more so 'deferred to the discussions for DMB to review'
16:30 <sil2100> With as the votes are right now, we basically need to defer this to either the next meeting or via ML
16:30 <teward> ^^ that
16:30 <sil2100> Yeah
16:31 <sil2100> schopin: please be patient, we will get back to you!
16:31 <sil2100> #action sil2100 to move the vote for schopin MOTU to the ML
16:31 * meetingology sil2100 to move the vote for schopin MOTU to the ML
16:31 <schopin> Yup, no worries :)
16:31 <sil2100> Okay, carrying on
16:31 <sil2100> #topic Outstanding mailing list requests to assign
16:31 <sil2100> So we still have the two proposals from Dan on the ML!
16:31 <teward> sil2100: action item for you or someone else to do: discuss changing the meeting time for 15:00 UTC to a different meeting time given Mondays are Hell.
16:31 <teward> just a suggestion to add to the list.
16:32 <sil2100> But seeing that we're past over the meeting time, I feel like we should defer that to the next meeting
16:32 <sil2100> Or continue on the ML
16:32 <sil2100> Since I already also am running out of time right now
16:32 <teward> i'd defer it
16:32 <teward> or continue on ML, either way we're way over time
16:32 <ddstreet> yep, i would love if members could please vote on the first proposal on the ML
16:32 <teward> and i'm starving as heck right now *nips out and **consumes all the food within a mile**
16:33 <sil2100> ddstreet: pinky promise that I'll get to it this week for sure!
16:33 <ddstreet> for the second proposal, i'd suggested we open a condorcet vote for it, which i'll do if there aren't objects
16:33 <ddstreet> objections
16:33 <sil2100> Okay, who wants the action item for moving the team meetings discussion?
16:33 <sil2100> ddstreet: +1
16:34 <ddstreet> ack, can you add action item for me to open condorcet vote for proposal #2?
16:34 <ddstreet> and i can take moving the meetings as well if nobody else wants it :)
16:34 <ddstreet> (well, starting a ML thread to find a new time)
16:34 <sil2100> #action ddstreet to open a condorcet vote for proposal for adjustment to quorum rule
16:34 * meetingology ddstreet to open a condorcet vote for proposal for adjustment to quorum rule
16:35 <sil2100> #action ddstreet to start a discussion about moving the meeting times for DMB meetings!
16:35 * meetingology ddstreet to start a discussion about moving the meeting times for DMB meetings!
16:35 <sil2100> phew, thank you ddstreet !
16:35 <sil2100> And teward for reminding about the last action item
16:35 <sil2100> Okay, I think this is it
16:35 <ddstreet> thank you for chairing!
16:35 <sil2100> #endmeeting