19:04 <rbasak> #startmeeting Technical Board
19:04 <meetingology> Meeting started at 19:04:53 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:04 <meetingology> Available commands: action, commands, idea, info, link, nick
19:05 <rbasak> #topic Apologies
19:05 <rbasak> #info mdeslaur sends his apologies
19:05 <rbasak> #info sil2100 may be unavailable due to the imminent Ubuntu release
19:05 <rbasak> #topic Action review
19:05 * rbasak rbasak to communicate the TB's MATE resolution to the MATE flavour leads.
19:06 <rbasak> I just did this, and Wimpy said to expect a response in a couple of weeks. Thanks Wimpy!
19:06 * rbasak formal ratification of third party seeded snap security policy, depends on:
19:06 * rbasak vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:06 <vorlon> carry-over
19:06 <rbasak> #action formal ratification of third party seeded snap security policy, depends on:
19:06 * meetingology formal ratification of third party seeded snap security policy, depends on:
19:06 <rbasak> #action vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:06 * meetingology vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:06 <rbasak> #action vorlon to reply to seeded snap upload permissions question on list
19:06 * meetingology vorlon to reply to seeded snap upload permissions question on list
19:07 <vorlon> carry-over
19:07 <rbasak> #action vorlon to reply to seeded snap upload permissions question on list
19:07 * meetingology vorlon to reply to seeded snap upload permissions question on list
19:07 <rbasak> FWIW, I'm not sure what that item is referring to exactly
19:07 * rbasak sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:08 <rbasak> I assume we will carry this as sil2100 isn't here.
19:08 <rbasak> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:08 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:08 * rbasak all TB members to "vote" or explain what they do not like of a proposal on https://pad.ubuntu.com/third-party-repository-requirements
19:09 <rbasak> Does everyone consider their input on this complete?
19:10 <vorlon> I see there's an ongoing discussion at the bottom of the document
19:10 <vorlon> I've given feedback on everything up to that point
19:10 <rbasak> I have an answer for the next related action item, so let's carry this I guess.
19:11 <rbasak> #action all members to continue discussion at https://pad.ubuntu.com/third-party-repository-requirements
19:11 * meetingology all members to continue discussion at https://pad.ubuntu.com/third-party-repository-requirements
19:11 * rbasak rbasak to draft refined rules for the proposed "stability" requirement for third-party software repositories
19:11 <sil2100> o/
19:11 <rbasak> I just drafted this
19:11 <rbasak> o/
19:11 <rbasak> Let me paste it into the pad
19:11 <sil2100> Sorry everyone, got distracted
19:12 * vorlon finds it, look for --BEGIN---
19:13 <vorlon> rbasak: thanks.  I think we should take some time to digest this rather than trying to decide on it this meeting (at least, I need time to digest :)
19:14 <rbasak> Sure.
19:15 <rbasak> I think the next agenda item will suffice to track the general goal of sorting this out.
19:15 <rbasak> #topic Erich Eickmeyer via the mailing list: DisplayCAL in the archive as a deb that pulls in a Flatpak, and its inclusion in Ubuntu Studio by default. See https://lists.ubuntu.com/archives/technical-board/2021-July/002562.html and https://pad.ubuntu.com/third-party-repository-requirements
19:15 <rbasak> Any specific next steps here? Is everyone happy to continue digesting/feedbacking?
19:17 <Eickmeyer> I don't want to crash the meeting, but can I say something about this (got a ping)?
19:18 <rbasak> Sure, please do
19:18 <Eickmeyer> Ok, well, considering the feedback I got from vorlon, I'm willing to drop this and have been working on a snap.
19:18 <Eickmeyer> Unfortunately, that has been quite the struggle, so I'm going to be enlisting some help on this.
19:19 <Eickmeyer> At the appropriate time, I hope to make it a seeded snap
19:19 <sil2100> \o/
19:20 <Eickmeyer> However, I agree that the technicality of being able to include a flatpak of *something* has merit, but I'm no longer pursuing it for this particular application.
19:20 <rbasak> OK. Thank you for the update!
19:20 <Eickmeyer> No problem. I hope that helps. :)
19:20 <rbasak> Where do we want to go from here then?
19:20 <sil2100> I think it's still good to work out an official policy for such cases
19:21 <cyphermox> +1
19:21 <rbasak> Should we archive the current discussion until/unless it's raised again by someone else with a similarly credible request? Or as sil2100 says, should we carry on anyway?
19:21 <cyphermox> well, aren't we with the third party repo requirements pad?
19:22 <vorlon> I think archiving it carries the risk of retread the next time it comes up :)
19:22 <rbasak> Personally I'm in favour of solidifying this anyway, as we are continuing with seeded snaps which would I think be expected to comply with these generic requirements anyway
19:22 <rbasak> OK, so I think we're agreed that we carry on?
19:22 <sil2100> My apologies for not finishing my comments for that one, but I think we should be continuuing, especially that I feel it's 'close' to being all properly defined
19:24 <rbasak> #agreed We will continue working on defining the third party repo requirements even though Eickmeyer has withdrawn his request for the DisplayCAL case, as we think it'd be useful to have anyway
19:24 <meetingology> AGREED: We will continue working on defining the third party repo requirements even though Eickmeyer has withdrawn his request for the DisplayCAL case, as we think it'd be useful to have anyway
19:25 <rbasak> So there remains an action item for everyone to continue working on the pad, so I'll leave that there, and I'll adjust the agenda item to make this request generic
19:25 <sil2100> +1
19:25 <rbasak> Anything else for this topic for now?
19:25 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:26 <rbasak> #info No recent communication on the public mailing list
19:26 <rbasak> However there was a private communication that needs a response I think, but should probably remain private for now.
19:26 <rbasak> Is there somewhere private the TB can go to discuss this now? Or do we need to use private email or something?
19:26 <vorlon> private email is pretty much it
19:27 <rbasak> OK. I'll start that thread after the meeting.
19:27 <rbasak> #topic Check up on community bugs (standing item)
19:27 <rbasak> #info No open community bugs
19:27 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:27 <sil2100> Me o/
19:28 <sil2100> Since I was supposed to be chairing today, right?
19:28 <rbasak> #info Next chair will be sil2100 with mdeslaur as backup
19:28 <rbasak> Yup, makes sense.
19:28 <rbasak> #endmeeting