14:29 <cpaelzer> #startmeeting Weekly Main Inclusion Requests status
14:29 <meetingology> Meeting started at 14:29:40 UTC.  The chair is cpaelzer.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
14:29 <sarnold> good morning
14:29 <meetingology> Available commands: action, commands, idea, info, link, nick
14:29 <cpaelzer> ping ddstreet, sarnold, didrocks, slyon, (doko) and jamespage for MIR team meeting
14:30 <didrocks> hey
14:30 <cpaelzer> Hello everyone o/
14:30 <slyon> o/
14:30 <cpaelzer> #topic Review of previous action items
14:31 <cpaelzer> I've seen we had a  few review upadtes but those (if needed) will come at later stages
14:31 <cpaelzer> the only independent activty is the update to the microlib testing that I was driving
14:31 <cpaelzer> latest state is here https://github.com/cpaelzer/ubuntu-mir/pull/1/files
14:31 <ubottu> Pull 1 in cpaelzer/ubuntu-mir "Rules for tests on the app-level" [Open]
14:31 <cpaelzer> I have two acks on the PR and a "ok" on the mail
14:31 <cpaelzer> no other feedback
14:31 <cpaelzer> therefore I'd think I can merge this after the meeting
14:31 <cpaelzer> please speak up if you think otherwise
14:32 <slyon> +1
14:32 <slyon> (for merging it)
14:32 <sarnold> +1 (I can't recall if I replied via email or elsewhere..)
14:32 <cpaelzer> Thanks, I'll somewhen in the next weeks then take the bigger task to unite rules and templates
14:32 <sarnold> good luck :)
14:32 <cpaelzer> Once I have something reviewable I'll again send a PR around to everyone
14:33 <cpaelzer> Going on with the agenda
14:33 <cpaelzer> #topic current component mismatches
14:33 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg
14:33 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches.svg
14:33 <sarnold> looks like nothing new
14:33 <cpaelzer> agreed
14:33 <cpaelzer> the latest news on fence-agents is that we have uploaded a fix to the one remaining blocker
14:33 <cpaelzer> it is currently held in impish-unapproved
14:34 <ddstreet> o/
14:34 <cpaelzer> once through there I'll ping for promotion to main
14:34 <ddstreet> hello sorry im late o/
14:34 <cpaelzer> np ddstreet
14:34 <cpaelzer> ok, nothing new here - going on ...
14:34 <cpaelzer> #topic New MIRs
14:34 <sarnold> cpaelzer: do we care about the amt_ws agent? https://github.com/ClusterLabs/fence-agents/issues/434 may or may not be important
14:34 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&assignee_option=none&field.assignee=&field.subscriber=ubuntu-mir
14:34 <ubottu> Issue 434 in ClusterLabs/fence-agents "misplaced python 'or' causes dead code" [Open]
14:35 <cpaelzer> here we have a first of a kind in https://bugs.launchpad.net/ubuntu/+source/egl-wayland/+bug/1935082
14:35 <ubottu> Launchpad bug 1935082 in egl-wayland (Ubuntu) "[MIR] egl-wayland" [Undecided, Confirmed]
14:35 <cpaelzer> this refers to the recently added rules about "testing with special HW"
14:35 <cpaelzer> I didn't want to  ake the call alone as interperting a very new rule might be interesting
14:35 <cpaelzer> so I wanted to ask if the statement at
14:35 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/egl-wayland/+bug/1935082/comments/20
14:36 <sarnold> I wish tseliot had been more detailed in his responses.. but as a first, it's not so bad.
14:36 <cpaelzer> Rule is
14:36 <cpaelzer> "If no build tests nor autopkgtests are included, and/or if the package requires specific hardware to perform testing, the subscribed team must provide a written test plan in a comment to the MIR bug, and commit to running that test either at each upload of the package or at least once each release cycle. In the comment to the MIR bug, please link to the codebase of these tests (scripts or doc of manual steps) and attach a full log of these
14:36 <cpaelzer> test runs. This is meant to assess their validity (e.g. not just superficial)"
14:36 <didrocks> I agree this fully apply to the testing with special HW rule
14:37 <cpaelzer> The "test plan" is a bit lighter than I'd have hoped
14:37 <didrocks> agreed
14:37 <sarnold> I don't know how to enable KMS, nor how to make sure it is enabled; I don't know what games would work -- what's glxgears on wayland? :) etc
14:37 <cpaelzer> the idea when writing the rule was "if we see an example plan and test log we can be more sure it is actually done"
14:37 <cpaelzer> but in this case not much logs exist as it is all UI
14:38 <cpaelzer> so my question to eventually vote on - is that statement enough or do we want/need to return that for something better (making a bad first case might invite others to be sloppy where it could be better)?
14:39 <slyon> I think we should ask for something better.
14:39 <sarnold> mm, good point
14:39 <slyon> Like some commands of how to check if KMS is enabled, which application to run, etc. (as sarnold suggested)
14:40 <cpaelzer> I'm tending to request something better as well
14:40 <cpaelzer> but I had expressed it in https://bugs.launchpad.net/ubuntu/+source/egl-wayland/+bug/1935082/comments/19 and that didn't help "enough"
14:40 <ubottu> Launchpad bug 1935082 in egl-wayland (Ubuntu) "[MIR] egl-wayland" [Undecided, Confirmed]
14:40 <cpaelzer> would anyone volunteer to help Alberto to add something better in this bug?
14:40 <sarnold> sure
14:41 <cpaelzer> is that the volunteering sarnold?
14:41 <sarnold> yup!
14:41 <cpaelzer> thank you a lot
14:41 <didrocks> I agree that we should have a better test case. As this is trusting the uploader that each upload is carefully tested, not wanting to write it up won’t help and make future uploads trustable IMHO
14:41 <cpaelzer> #action sarnold to contact alberto milone to make a better "special HW test statement" on bug 1935082
14:41 * meetingology sarnold to contact alberto milone to make a better "special HW test statement" on bug 1935082
14:42 <ubottu> Bug 1935082 in egl-wayland (Ubuntu) "[MIR] egl-wayland" [Undecided, Confirmed] https://launchpad.net/bugs/1935082
14:42 <cpaelzer> ok, going on then
14:42 <cpaelzer> #topic Incomplete bugs / questions
14:42 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.subscriber=ubuntu-mir
14:43 <cpaelzer> the recent bumps are fuse (Trevinho was so kind to help all upstremas by providing PRs)
14:43 <cpaelzer> and libportal which didrocks reviewed
14:43 <cpaelzer> nothing that needs immediate further activity AFAICS
14:43 <cpaelzer> #topic Any other business?
14:43 <cpaelzer> nothing from me
14:43 <slyon> nothing here
14:43 <didrocks> nothing either
14:44 <sarnold> nothing from me
14:44 <cpaelzer> ddstreet: I know you are busy, but do you have anything else or a comment ont he backlog?
14:44 <cpaelzer> ok I consider this a no and he also knows where to reach us
14:44 <cpaelzer> closing ...
14:44 <cpaelzer> thank you all!
14:44 <sarnold> thanks cpaelzer, all :)
14:45 <cpaelzer> #endmeeting