#ubuntu-meeting: Ubuntu Backporters meeting

Meeting started by ddstreet at 16:03:01 UTC (full logs)

Meeting summary

    1. ACTION: clarify how to accept/reject uploads to -backports queues (ddstreet, 16:06)
    2. AGREED: maintain a list of excluded packages, to be updated on ad-hoc basis and/or updated from mailing list discussion (ddstreet, 16:22)
    3. AGREED: ubuntu backporters team is not responsible for future security updates to packages, nor is the security team, the package requestor (and/or their sponsor) should expect to maintain it (ddstreet, 16:26)

  1. how the community requests backports (ddstreet, 16:27)
    1. https://lists.ubuntu.com/archives/ubuntu-backports/2021-July/021758.html (mapreri, 16:30)
    2. ACTION: update wiki/docs to reflect users can't just request a backport, and deprecate 'requestbackport' tool to print message and url indicating same (ddstreet, 16:33)
    3. ACTION: ddstreet reply to previous ML requests and open backport request bugs indicating change in process (ddstreet, 16:34)
    4. ACTION: teward update tooling, requestbackport (ddstreet, 16:38)
    5. ACTION: ddstreet update wiki docs with new process (ddstreet, 16:38)

  2. review of tooling, requestbackport and backportpackage (ddstreet, 16:39)
    1. ACTION: teward review backportpackage tool (ddstreet, 16:40)

  3. what releases are allowed/required to backport into (ddstreet, 16:41)
    1. AGREED: backports to interim releases are allowed on case-by-case basis, but not required (ddstreet, 16:43)
    2. ACTION: mapreri start ML discussion for list of dev tools to proactively put into -backports (ddstreet, 16:46)
    3. AGREED: LTS->LTS upgrades must be supported, and -backports should remain enabled/used (ddstreet, 17:12)
    4. AGREED: backported package versions must use suffix ~bpo along with target release version and .1, or as refined in ML discussion and stated in wiki docs (ddstreet, 17:17)

  4. security updates (ddstreet, 17:18)

  5. cleaning up wiki docs (ddstreet, 17:19)

  6. restrictions on eligible packages (ddstreet, 17:20)
    1. https://wiki.ubuntu.com/DocumentationTeam (ddstreet, 17:23)
    2. https://launchpad.net/~ubuntu-community-wiki-editors so these? (mapreri, 17:23)
    3. https://wiki.ubuntu.com/DocumentationTeam/Contact has the contact mechanisms right now to use (teward, 17:24)
    4. ACTION: ddstreet schedule mtg in 2 weeks (ddstreet, 17:27)
    5. ACTION: mapreri ask AA how to handle archive -backports approval/rejection (ddstreet, 17:28)
    6. ACTION: ddstreet update agenda page from today's meeting items (ddstreet, 17:28)


Meeting ended at 17:30:14 UTC (full logs)

Action items

  1. clarify how to accept/reject uploads to -backports queues
  2. update wiki/docs to reflect users can't just request a backport, and deprecate 'requestbackport' tool to print message and url indicating same
  3. ddstreet reply to previous ML requests and open backport request bugs indicating change in process
  4. teward update tooling, requestbackport
  5. ddstreet update wiki docs with new process
  6. teward review backportpackage tool
  7. mapreri start ML discussion for list of dev tools to proactively put into -backports
  8. ddstreet schedule mtg in 2 weeks
  9. mapreri ask AA how to handle archive -backports approval/rejection
  10. ddstreet update agenda page from today's meeting items


Action items, by person

  1. ddstreet
    1. ddstreet reply to previous ML requests and open backport request bugs indicating change in process
    2. ddstreet update wiki docs with new process
    3. ddstreet schedule mtg in 2 weeks
    4. ddstreet update agenda page from today's meeting items
  2. mapreri
    1. mapreri start ML discussion for list of dev tools to proactively put into -backports
    2. mapreri ask AA how to handle archive -backports approval/rejection
  3. teward
    1. teward update tooling, requestbackport
    2. teward review backportpackage tool
  4. UNASSIGNED
    1. clarify how to accept/reject uploads to -backports queues
    2. update wiki/docs to reflect users can't just request a backport, and deprecate 'requestbackport' tool to print message and url indicating same


People present (lines said)

  1. teward (183)
  2. ddstreet (125)
  3. mapreri (102)
  4. meetingology (17)


Generated by MeetBot 0.4.0