19:01 <rbasak> #startmeeting Technical Board
19:01 <meetingology> Meeting started at 19:01:04 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:01 <meetingology> Available commands: action, commands, idea, info, link, nick
19:01 <rbasak> #topic Action review
19:01 * rbasak Wimpress To follow-up on-list with design review to address MATE Boutique security/consent concerns.
19:02 <rbasak> Previous discussion here
19:03 <rbasak> Is there anything actually actionable by the TB any more here?
19:03 <mdeslaur> we need to figure out who's in charge of MATE I guess
19:03 <rbasak> I'd like for the TB to either drop this, or specify exactly what the TB needs to do :-/
19:03 * vorlon waves
19:03 <rbasak> o/
19:04 <mdeslaur> as I recall, the MATE boutique enables a PPA?
19:04 <vorlon> I don't remember if it's a ppa or an archive external to LP; but it's not under Ubuntu governance
19:04 <rbasak> Right, and I think it's agreed that this will be fixed, and how, but there's been no movement or ETA in many months/years AIUI.
19:05 <vorlon> right
19:06 <rbasak> I'm not sure if we want to actually do this, but the only way I can see to get this to move is for the TB to mandate a deadline after which MATE cannot ship as an official flavour unless/until this is fixed. Either that, or we drop the matter and let MATE continue as they wish.
19:06 <vorlon> well, I was going to say either a deadline for not being a flavor, or an upload to remove this behavior
19:06 <mdeslaur> I don't think we should let them continue
19:06 <vorlon> I agree
19:07 <mdeslaur> a deadline sounds appropriate
19:07 <rbasak> With Impish imminent, how about we set the requirement for J?
19:07 <sil2100> I would be +1 on removing the behavior, but I still hope we'll get some news back from Wimpy
19:07 <rbasak> So let Impish slide, but it's a hard requirement that this isn't a problem in J, otherwise it doesn't ship officially.
19:08 <mdeslaur> I agree to that
19:09 <rbasak> If flavour leads object, I'd be opening to them discussing alternatives with us. But setting the default position will help get some conclusion on this I think.
19:09 <rbasak> sil2100: opinion?
19:09 <rbasak> As in, are you +1 also?
19:09 <sil2100> I'm +1, just was trying to read some backlog to figure out - is this behavior with the boutique in impish right now?
19:10 <rbasak> That's the impression I have. If not, then there should be no problem :)
19:10 <vorlon> if it's changed, no one has told us
19:10 <vorlon> I think there was a vague sense that it might migrate to snaps but I haven't heard that this had happened
19:11 <rbasak> Yes that was discussed (very briefly) at https://irclogs.ubuntu.com/2021/05/28/%23ubuntu-desktop.html#t10:42
19:11 <sil2100> This is the problem when there's no active communication...
19:11 <rbasak> #agreed MATE is required to resolve the PPA situation by the J release. Otherwise, MATE will not be an official flavour in J.
19:11 <meetingology> AGREED: MATE is required to resolve the PPA situation by the J release. Otherwise, MATE will not be an official flavour in J.
19:12 <rbasak> #action rbasak to communicate the TB's MATE resolution to the MATE flavour leads.
19:12 * meetingology rbasak to communicate the TB's MATE resolution to the MATE flavour leads.
19:12 * rbasak formal ratification of third party seeded snap security policy, depends on:
19:12 * rbasak vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:12 <vorlon> fwiw I have more capacity this month than I have recently and think I will be able to make progress on this soon
19:13 <rbasak> Thanks - let's carry.
19:13 <rbasak> #action formal ratification of third party seeded snap security policy, depends on:
19:13 * meetingology formal ratification of third party seeded snap security policy, depends on:
19:13 <rbasak> #action vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:13 * meetingology vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
19:13 * rbasak vorlon to reply to seeded snap upload permissions question on list
19:13 <vorlon> likewise :)
19:13 <rbasak> #action vorlon to reply to seeded snap upload permissions question on list
19:13 * meetingology vorlon to reply to seeded snap upload permissions question on list
19:13 * rbasak sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:16 <sil2100> Yes, sadly that's still in progress, didn't progress much since the last meeting: https://wiki.ubuntu.com/OEMArchive <- the page is started, I have a few more drafted words but nothing much more
19:16 <rbasak> OK thanks. Carried then.
19:16 <rbasak> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:16 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
19:16 <rbasak> The next item wasn't updated on the agenda, but based on the logs from last time:
19:17 * rbasak mdeslaur to follow-up/respond for security team on advice for the flatpak TB request
19:17 <mdeslaur> I asked seth to file a bug: https://bugs.launchpad.net/ubuntu/+source/flatpak/+bug/1943480
19:17 <ubottu> Launchpad bug 1943480 in flatpak (Ubuntu) "flatpak installation permission requirements different from ubuntu software" [Undecided, New]
19:17 <rbasak> Thanks mdeslaur and sarnold!
19:17 <mdeslaur> though I now see that the bug doesn't specifically state the security team position on the matter, I'll make sure that is fixed
19:17 <rbasak> Is there anything further for the TB here?
19:18 <sarnold> mdeslaur: heh, yeah, I wasn't 100% sure we'd reached a consensus yet :(
19:18 <rbasak> OK how about I leave that action with mdeslaur for now? Or can you relay the security team position now for discussion?
19:19 <rbasak> I think the TB opinion is likely to follow the security team's opinion, and then the TB part could be concluded/closed and it'll just be a bug to implement.
19:19 <mdeslaur> I'm not sure there's anything more for the TB here
19:19 <mdeslaur> The TB deferred to the security team
19:20 <rbasak> OK thanks let's consider the TB part done then, and no further action for the TB.
19:20 <mdeslaur> It would just circle back is someone disagreed with the security team's decision
19:20 <mdeslaur> *if
19:20 * rbasak all TB members to "vote" or explain what they do not like of a proposal on https://pad.ubuntu.com/third-party-repository-requirements (cyphermox, 19:25)
19:20 <rbasak> I hope everyone did their homework?
19:20 <mdeslaur> I did spend some time on that page, but I still need to think about it some more
19:22 <mdeslaur> Can the others go through it before the next meeting, please?
19:22 * vorlon nods
19:22 <sil2100> Will do o/
19:22 <rbasak> Yep, thanks. And also that might mean that the rest of us need to circle round again to continue discussion / clarify any further questions.
19:23 <rbasak> So I'll leave the action for everyone. I certainly need to read mdeslaur's comments in detail.
19:23 <rbasak> #action all TB members to "vote" or explain what they do not like of a proposal on https://pad.ubuntu.com/third-party-repository-requirements
19:23 * meetingology all TB members to "vote" or explain what they do not like of a proposal on https://pad.ubuntu.com/third-party-repository-requirements
19:23 <rbasak> #topic Erich Eickmeyer via the mailing list: DisplayCAL in the archive as a deb that pulls in a Flatpak, and its inclusion in Ubuntu Studio by default. See https://lists.ubuntu.com/archives/technical-board/2021-July/002562.html and https://pad.ubuntu.com/third-party-repository-requirements
19:23 <rbasak> I think this is deferred for now, until the previous item is completed.
19:23 <rbasak> Any further discussion on this topic?
19:24 <mdeslaur> nope
19:24 <rbasak> #topic Scan the mailing list archive for anything we missed (standing item)
19:24 <rbasak> I screwed that up. Wrong magic symbol :-/
19:25 <rbasak> Anyway
19:25 <vorlon> :(
19:25 <vorlon> :)
19:25 <vorlon> (also wrong magic symbol)
19:25 <rbasak> I don't see anything on the ML.
19:25 <rbasak> #info Nothing spotted on the ML.
19:25 <rbasak> #topic Check up on community bugs (standing item)
19:26 <rbasak> #info No currently open community bugs
19:26 <rbasak> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
19:26 <rbasak> Next chair will be vorlon. Backup: sil2100
19:26 <rbasak> #topic AOB
19:26 <rbasak> AOB?
19:26 <mdeslaur> I've got none
19:26 <vorlon> nothing here
19:27 <rbasak> #endmeeting