16:05 <ddstreet> #startmeeting Ubuntu Backporters meeting
16:05 <meetingology> Meeting started at 16:05:06 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
16:05 <mapreri> what about laney ?
16:05 <meetingology> Available commands: action, commands, idea, info, link, nick
16:05 <ddstreet> i did ping him above
16:05 <ddstreet> he can catch up
16:05 <mapreri> alright
16:05 <ddstreet> so i created an agenda page, as rbasak linked above
16:05 <ddstreet> i'll relink for the record
16:06 <ddstreet> #link https://wiki.ubuntu.com/UbuntuBackports/Agenda
16:06 <ddstreet> hmm hope that worked
16:06 <mapreri> it did, #link is silent :)
16:06 <rbasak> I think it does stay silent for those.
16:06 <ddstreet> i'm happy to chair/guide this first mtg, but anyone please feel free to jump in at any time for anything
16:07 <mapreri> right behind you, thank you in advance for chairing
16:07 <ddstreet> on the agenda page, i put in some basic info and links
16:08 <ddstreet> the main stuff i think is in the discussion topics section, unless anyone has objections i think we can get through the first couple items fairly quickly, even if we just create action items to discuss them more later
16:08 <ddstreet> i think the bulk of the conversation will be around the process, at the end of the list
16:08 <mapreri> yes, agreed
16:08 <ddstreet> ok so first off, membership
16:08 <ddstreet> #topic membership
16:09 <ddstreet> the current list of members:
16:09 <ddstreet> #link https://launchpad.net/~ubuntu-backporters/+members
16:09 <rbasak> o/
16:09 <mapreri> I think we need to decide on whether to drop all of the old people in them?
16:10 <ddstreet> agreed, let's decide that first
16:10 <ddstreet> rbasak i think is typing
16:10 <rbasak> I was, but let's do that first.
16:10 <rbasak> My question was going to be about team leadership, which is in this section but can come last.
16:10 <mapreri> (and deactivate the techboard, it doesn't need to be an active member, being owner is enough for them)
16:10 <rbasak> deactivate the techboard> +1
16:10 <ddstreet> yep agreed here as well
16:11 <rbasak> I was going to JFDI before but I thought maybe better to wait for the meeting.
16:11 <ddstreet> well specifically, i think we should drop all the old members, and inactivate the TB
16:11 <rbasak> Anyone object to dropping all the old members?
16:11 <ddstreet> seems unanimous, which is good :)
16:11 <mapreri> very in favour of the matter, however I need to notice that
16:11 <ddstreet> i do wish laney was here though
16:11 <mapreri> scottk renewed his membership on oct 6th, which is weird
16:11 <ddstreet> as he's the only old member who participated so far
16:12 <mapreri> scottk never said anything in the mail threads right?
16:12 <rbasak> I wonder if he has a script that does that :)
16:12 <ddstreet> hmm maybe he just clicked on 'renew' without really thinking about it
16:12 <rbasak> I had been unable to reach him.
16:12 <mapreri> yeah, scottk has been quite unavailable as of late
16:12 <rbasak> When I asked him to transfer ownership to ~techboard - before I asked Launchpad to do it.
16:12 <mapreri> (as of late: last ~2 years, more or less)
16:13 <ddstreet> well since laney isn't around, i suggest we just reach consensus of who's here; i'm not sure if we even need an official vote, as i don't hear any objections from anyone
16:13 <rbasak> I propose that we proceed by removing everyone not present here today. Others can always be re-added later.
16:13 <mapreri> rbasak: including laney?
16:13 <ddstreet> +1 to that from me
16:13 <ddstreet> it's trivial to add him back if he wants to be added back
16:13 <mapreri> alright
16:14 <mapreri> +1 as well
16:14 <rbasak> mapreri: including laney because I think he specifically said in the ML thread that he wasn't able to participate in backport handling.
16:14 <mapreri> (you can use #agreed instead of formal vote for these matters :P)
16:14 <ddstreet> ah nice thanks :)
16:14 <ddstreet> ok so
16:14 <rbasak> Shall I do those things now then, to allow you to continue typing?
16:15 <ddstreet> sure thanks
16:15 <mapreri> please
16:15 <ddstreet> i suppose for the record we should do an agreed
16:15 <mapreri> please yes
16:15 <ddstreet> #agreed remove (inactivate) all old members who are not present in the current meeting
16:15 <meetingology> AGREED: remove (inactivate) all old members who are not present in the current meeting
16:15 <mapreri> then, I think reject all pending members as well imho.  let's start clean?
16:16 <ddstreet> yep i agree on that too
16:16 <ddstreet> probably most of them aren't interested anymore anyway
16:16 <ddstreet> no objections?
16:16 <mapreri> I wonder what that person who requested on 2006-09-09 to join would say if we approve now lol
16:16 <ddstreet> lol
16:16 <ddstreet> "sorry for the delay!"
16:16 <rbasak> There are also a bunch of pending members, but none of them have been a participant in the ML thread. Should I clean those up too?
16:16 <mapreri> rbasak: we just agreed on that :P
16:16 <ddstreet> yep i think we're agreed to reject all the pending members
16:17 <rbasak> OK
16:17 <ddstreet> #agreed reject all pending members
16:17 <meetingology> AGREED: reject all pending members
16:17 <mapreri> last, keep the current "moderated" team, or turn it to "restricted"?
16:17 <ddstreet> rbasak you might need to add yourself before disabling the TB
16:17 <mapreri> (I think we this we are over the "administrative" topics)
16:17 <mapreri> ddstreet: not needed, since techboard stays the owner)
16:17 <ddstreet> ah ok
16:18 <ddstreet> mapreri it shows as 'restricted' now for me, did it just get changed?
16:18 <mapreri> ah, it's already a "restricted" team now.  so probably those pending members were from before the change
16:19 <mapreri> ddstreet: not sure, didn't look at before.  just assumed it was "moderated" due to the pending members.
16:19 <rbasak> ddstreet: no we're good - team ownership gives me superpowers
16:19 <mapreri> https://launchpad.net/~ubuntu-backporters/+members is not super clean ♥
16:19 <rbasak> All agreed changes made I think
16:19 <ddstreet> as far as moderated vs restricted, i don't have a preference; i suspect there won't be a mass of people applying even if it's moderated :)
16:20 <mapreri> ime, moderated just lead to spam request more than anything *shrugs*
16:20 <rbasak> IMHO, allowing people to apply via Launchpad just confuses things.
16:20 <ddstreet> yeah i'm fine to stay restricted
16:20 <rbasak> Nobody knows how to deal with that.
16:20 <mapreri> instead, with restricted team, obviously the way to join is "go badger the team admin!" :P
16:21 <ddstreet> so for future membership, do we need to define a process now? i'm thinking not
16:21 <ddstreet> i don't expect many (or any) people to want to join anytime soon
16:21 <rbasak> I agree that can be deferred.
16:22 <mapreri> I think that is quite related to the actual backport process, but regardless I think we can defer for now, yes.  also we need to see how things go.
16:22 <mapreri> and, looking at how nobody was interested to join via mail, well…
16:22 <rbasak> What I'd like though is clarity on team leadership. Who can make decisions for the team? Specifically I mean administrative decisions, rather than individual review decisions. Making this clear would make it easier for the wider community to engage with you.
16:22 <ddstreet> #agreed defer discussion to define membership application process
16:22 <meetingology> AGREED: defer discussion to define membership application process
16:22 <ddstreet> yes that's a good point
16:23 <rbasak> I'm quite happy for that to just be ddstreet for now, FWIW.
16:23 <mapreri> since I'm usually very easy to reach, I'd prefer on a process that is: somebody ask the team to decide something, ddstreet texts me, we discuss very quickly, ddstreet reports back?
16:23 <rbasak> As he's the only one volunteering to do the driving anyway, I feel that he should have the authority to make decisions around the responsibility that he's taking.
16:23 <mapreri> (easy to reach, except for ubuntu-dev-tools reviews, sorry !)
16:23 <ddstreet> haha lol
16:24 <rbasak> I would expect ddstreet to work with mapreri of course, but I'd like to put ddstreet in the position that he has the authority to resolve a disagreement if there is one.
16:25 <mapreri> I'd say I'd be happy to place him on such place, I have enough disagreements to handle elsewhere anyway, and I trust him to be fair from the little I saw in the past.
16:25 <ddstreet> how about in between regular meetings, any administrative decisions can be handled by me, with an expectation (but not requirement) that i try to reach the rest of the team for opinions
16:25 <mapreri> having said this, I don't quite know what you might be referring to, rbasak.  what kind of situations are you imagining?
16:25 <rbasak> mapreri: I want to avoid indecisiveness, which is IMHO part of what killed the old team.
16:26 <mapreri> right.
16:26 <mapreri> I don't think that could happen here anytime soon with this new 2-person team though.
16:26 <rbasak> So things like "no I want to keep the status quo but I'm not going to help with delivering the team responsibilities under that status quo"
16:26 <rbasak> I don't want that to block the team.
16:26 <rbasak> Sure - hopefully that won't happen here.
16:26 <mapreri> it's more likely that we just both dwindle down in motivation in a few years
16:27 <ddstreet> ok so are we agreed to allow me (or current team admin/lead) to handle any administrative decisions?
16:27 <rbasak> +1
16:27 <mapreri> so yes, let me agree to give ddstreet ALL THE POWER
16:27 <rbasak> And no objections, so it's done :)
16:27 <mapreri> just try to get consensus if it's feasible, please.
16:28 <rbasak> Of course
16:28 <rbasak> The CoC mandates that
16:28 <ddstreet> to be clear, i don't want to decide anything unilaterally, but i suspect 1) there won't really be a lot of stuff needed between meetings and 2) i'll talk to the team member(s) about everything when possible
16:28 <mapreri> cool
16:29 <rbasak> ddstreet: that is exactly the position I'd like you to take, so we're good :)
16:29 <ddstreet> #agreed team lead/admin can make administrative decisions for the team, preferably with consultation with other team members
16:29 <meetingology> AGREED: team lead/admin can make administrative decisions for the team, preferably with consultation with other team members
16:29 <rbasak> Also #agreed ddstreet will, for now, be the sole team lead/admin
16:29 <ddstreet> yes i suppose we should define the members
16:30 <ddstreet> i'm the team lead, and the members are mapreri teward and, rbasak are you joining?
16:30 <ddstreet> and possibly laney, if he does want to stay on/rejoin
16:30 <rbasak> For now, I'm not joining, thanks. I'm just focused on trying to enable the people who _are_ volunteering.
16:30 <ddstreet> ok so just me mapreri and teward
16:31 <rbasak> And at that point I intend to step away.
16:31 <mapreri> yeah, I can do with being able to say "I'm not in a lead position in this team" \o/  (which is what happens way too often in debian when I join a team -.-)
16:31 <rbasak> :-)
16:31 <ddstreet> #agreed current team lead will be ddstreet, current team members will be mapreri teward
16:31 <meetingology> AGREED: current team lead will be ddstreet, current team members will be mapreri teward
16:31 <rbasak> With the team revitalized and with a team lead defined, I think my job is done :-P
16:31 <teward> this week's been chaotic so i mean :P
16:31 * mapreri notices that teward has been quite silent so fare in the meeting?
16:32 <ddstreet> and no objections to allowing laney to rejoin if he would like to (since we don't yet have a process to join defined)?
16:32 <mapreri> assuming he reads the minutes from the following discussion about the process, and he asks explicitly, yes, let's let him join.
16:33 <mapreri> but so, should ddstreet add teward to the lp team?
16:33 <ddstreet> #agreed to allow laney to rejoin the team if he requests to
16:33 <meetingology> AGREED: to allow laney to rejoin the team if he requests to
16:33 <rbasak> This is the point where I've stepped away. IMHO in a not voting away, it'd be useful if members committed to do whatever is defined that they should do, and otherwise they shouldn't be members. So maybe it doesn't really matter who is a member or not, for the time being, until that is defined or needs to be defined (eg. ACLs, or review roles, etc).
16:34 <rbasak> in a not voting *way*
16:34 <teward> mapreri: i've had nothing counter to any already stated items so far
16:34 <teward> also still on via phone so insanely hard to type indepth replied
16:34 <teward> replies*
16:34 <mapreri> ah, that explains! (the phone)
16:34 <teward> yup
16:34 <ddstreet> my only concern with teward is i know you're strected super thin, being on several boards and heavy workload
16:35 <teward> ddstreet: workload is getting a lot lighter at FT job.  Many large projects just finished and there's one rrmaining project on my radar of high importance
16:35 <ddstreet> but personally i have no problem with you joining even if it's just for occasional work on the backports
16:36 <teward> and the being on many teams and boards is why i stopped championing the redo of backports process
16:36 <teward> hence "member of backporters" not leader/officer
16:36 <ddstreet> ok
16:37 <ddstreet> sounds fine to me - i did put 'agreed' on the current team above, though if anyone wants to have a vote of the people currently here i'm fine with that as well
16:37 <ddstreet> otherwise i think we can let the new member list stand and continue
16:38 <ddstreet> ok let's move to the meetings
16:38 <ddstreet> #topic meeting schedule and location
16:38 <mapreri> I'm also fine we teward.  let's just say, please all of us be sincere and drop out if you realize you can't contribute :)
16:38 <mapreri> s/fine we/fine with/ (?)
16:38 <ddstreet> yes very much agreed with that ^
16:38 <teward> what mapreri said
16:39 <mapreri> do we need regular meetings?
16:39 <ddstreet> so for meetings, i assume we just hold them here?
16:39 <ddstreet> long term, probably not, but i think at first it might be good to have some regular meetings
16:39 <ddstreet> at least until we get going more smoothly
16:39 <mapreri> alright
16:40 <mapreri> (do we have a more in-topic irc channel?)
16:40 <rbasak> Would it be worthwhile agreeing a rule that members inactive for (say) 2 years get removed? I suggest this now because it's socially easier to set this now, rather than when the problem arises again.
16:40 <teward> we can probably get one made mapreri if needed
16:40 <ddstreet> yeah we probably should have a irc channel
16:40 <mapreri> teward: I'd ♥ to pls.  let's #ubuntu-backports @ libera?
16:40 <rbasak> I suggest just using #ubuntu-devel until it becomes a problem.
16:41 <rbasak> That helps with fostering involvement IMHO.
16:41 <teward> rbasak: agreed to the rule provided theres procedure in place to handle if the lead is the AWOL one
16:41 <mapreri> I'm fine as well.
16:41 <ddstreet> rbasak i do agree with the expiration rule, but suggest we defer the specific details to a future meeting
16:41 <rbasak> Sure
16:41 <teward> ^^ that
16:42 <mapreri> teward: procedure is: existing members vote and ask techboard to replace the lead.  easy.
16:42 <mapreri> I think this can be part of the next meeting together with the definition of how to join
16:43 <ddstreet> #action define details on handling members/leads who are no longer participating
16:43 * meetingology define details on handling members/leads who are no longer participating
16:43 <ddstreet> i think i forgot to add an action for defining the membership process?
16:44 <ddstreet> #action define process/procedure for adding new members
16:44 * meetingology define process/procedure for adding new members
16:45 <ddstreet> so re: irc, should we use ubuntu-devel or try to get ubuntu-backports?
16:45 <mapreri> let's keep with -devel for a while and see if we tend to have too many conversations (unlikely)
16:45 <teward> we could use either, but lets keep with -devel for now
16:45 <teward> unless we have a ton of things to discuss we should be OK with -devel
16:46 <teward> (finally back at my computer, geez...)
16:46 * mapreri is just biased in collecting as many channels as possible (not visible in me anymore since the freenode move when I cleaned up the list…)
16:46 <ddstreet> #agreed use #ubuntu-devel for normal team conversation
16:46 <meetingology> AGREED: use #ubuntu-devel for normal team conversation
16:46 <ddstreet> at least for now, can always change that later
16:47 <ddstreet> for a schedule of regular meetings, i think at first we should probably try for fortnightly meetings? weekly meetings probably would be too much, but i think we do have stuff to go thru
16:48 <ddstreet> i'm trying to get thru the administrative stuff, since we're not even at the real backports process yet and 45 minutes in :)
16:49 <mapreri> ftr, I already have other fortnight meetings in the other cycle
16:49 <mapreri> at the same time :P
16:49 <ddstreet> well this balances it out perfectly then doesn't it xD
16:49 <mapreri> so I'm good with fortnight, it'll just means I'll find myself a weekly cycle, one week in a channel, the other in another channel :3
16:50 <ddstreet> let's start with fortnightly and re-evaluate it each following meeting, i'm sure we will get to the point where we can drop it down to monthly, or less
16:50 <ddstreet> i'll schedule the next meeting in 2 weeks (after this one is over)
16:50 <teward> +1
16:51 <teward> ddstreet: send me an email reminder btw so i can add it in my schedule
16:51 <mapreri> cool
16:51 <ddstreet> #action schedule next meeting in 2 weeks, same location and time UTC
16:51 * meetingology schedule next meeting in 2 weeks, same location and time UTC
16:51 <mapreri> teward: are you in ubuntu-backports@luc right?  I guess ddstreet can call the meeting there.
16:51 <teward> my recurrings for the stuff got thrown into the abyss during the work migration to MS365 so i don't have my recurring meetings anymore
16:51 <teward> mapreri: probably not :p
16:51 <mapreri> you should if you are joining :P
16:51 <ddstreet> teward mapreri i'll create a google calendar event and include you both, if oyu use google calendar?
16:51 <teward> no idea who's on that list anymore
16:51 <ddstreet> well i mean you should get the invite even if you don't :)
16:51 <teward> mapreri: true, i'll drop in.
16:52 <mapreri> ddstreet: I use gcal yes  (and all my emails are associated to the google account, so it'll just come in whatever address you use)
16:52 <rbasak> FWIW I think we've (you've) made great progress so far, and if it takes another couple of weeks to sort out the process stuff, that's absolutely fine.
16:53 <rbasak> I think it's important to get the "constitutional" structure right, and that's done now, and I'm happy :)
16:53 <ddstreet> thanks!
16:53 <rbasak> I hope that this means that the previous problem won't recur.
16:54 <ddstreet> so re: ubuntu-backports@luc, i just joined that (or requested to)...not sure if we need to do something to manage that list?
16:54 <mapreri> for the ml mod, if that's needed, I'm happy to, since I already run `listadmin` regularly for another dozen MLs
16:54 <rbasak> FWIW, I moderate enough Ubuntu MLs already that adding another won't make any difference to me. So if you'd like a moderator I'm happy to do that.
16:54 <rbasak> Ah, snap :)
16:54 <mapreri> who is jdong again u.u
16:54 <ddstreet> i'll add an action to at least check if we need to take that list over
16:55 <ddstreet> yeah i saw that too, no idea
16:55 <ddstreet> #action take over ubuntu-backports@luc mailing list, or at least check if we need to manage it
16:55 * meetingology take over ubuntu-backports@luc mailing list, or at least check if we need to manage it
16:55 <mapreri> somebody who has been inactive long enough that all of their launchpad membership expired, apparently.
16:55 <rbasak> https://lists.ubuntu.com/mailman/listinfo/ubuntu-backports lists an old member
16:55 <rbasak> So I think you will need to take that over
16:56 <mapreri> rbasak: do you have contacts with the lists.u.c admins?
16:56 <mapreri> or is that canonical IS generically?
16:56 <rbasak> Canonical IS can swap it for us.
16:56 <rbasak> Right
16:56 <mapreri> if you'd like I can write a ticket
16:56 <rbasak> I expect ddstreet will be able to arrange it, but you have my TB hat support if you need it.
16:56 <mapreri> or let ddstreet ask for it, as you wish.
16:57 <ddstreet> mapreri if you are able to request the change then please do :)
16:57 <mapreri> alright
16:57 <ddstreet> #action mapreri request ownership change for ubuntu-backports@luc
16:57 * meetingology mapreri request ownership change for ubuntu-backports@luc
16:57 <mapreri> ta
16:58 <mapreri> (shall I ask them to just put my email in the list owner field?)
16:58 <mapreri> (more like, do you mind or should we do it differently?)
16:58 <ddstreet> ok so i *think* we are all thru the administrative part...there's only 3 minutes left in the hour though, i'm thinking we move the 'real' discussion of the process to the next meeting? 1 hour meetings are usually my max
16:58 <ddstreet> re: ml, i think it's fine to just put your email
16:59 <mapreri> I think I should have dinner in 30-60 minutes, so I'm fine going for a little longer.  but process is likely going to take more than that anyway, so…
16:59 <ddstreet> yeah, we could start but i dont think we would make it far
17:00 <ddstreet> i propose we adjourn this meeting and defer remaining discussion to the next one?
17:00 <ddstreet> i know we didn't really get the to good stuff yet
17:00 <ddstreet> but meetings tend to start falling apart after an hour-ish i think :)
17:01 <mapreri> incidentally, I was thinking of dumping my points of what the process should look like (or, what we need to discuss of them) in the agenda page, would you mind?  I suppose you could dump your ideas as well.
17:01 <ddstreet> ok sounds like no objections at least
17:01 <ddstreet> absolutely, please feel free to put it into the agenda, update it however you'd like
17:02 <mapreri> then we are good
17:02 <mapreri> [08 07:00:04 PM] <mapreri> ack.
17:02 <mapreri> I saw this fell out due to a network glitch on my side ↑
17:02 <mapreri> (I recovered your messages from my bouncer)
17:02 <ddstreet> i was also going to edit the agenda page with summary of today's meeting, and next mtg date, etc, but i'll make sure not to step on your edits
17:02 <mapreri> not going to do that now
17:03 <mapreri> if you give me a whole 2 weeks to prepare for the next meeting, be sure I won't write 2 weeks in advance :P
17:03 <ddstreet> ack, i'll try to have the page updated by my EOD
17:03 <ddstreet> lol
17:03 <ddstreet> yeah no need to hurry :)
17:03 <rbasak> I need to run now too. Thank you ddstreet both for chairing but more importantly driving this whole revitalisation!
17:03 <ddstreet> ok let's call this then, thanks for a great first mtg all!
17:04 <ddstreet> #endmeeting