15:28 <ddstreet> #startmeeting Developer Membership Board
15:28 <meetingology> Meeting started at 15:28:55 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:28 <meetingology> Available commands: action, commands, idea, info, link, nick
15:29 <sil2100> halves: hey, you still around I hope? ;)
15:29 <halves> sil2100 still around :)
15:29 <ddstreet> #topic Review of previous action items
15:30 <ddstreet> #subtopic ddstreet edubuntu seed <-> pkgset (carried over)
15:31 <ddstreet> i'll get to this eventually i suppose :(
15:31 <ddstreet> #action ddstreet edubuntu seed <-> pkgset (carried over)
15:31 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
15:31 <ddstreet> #subtopic rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carried over)
15:31 <rafaeldtinoco> nope, I did the similar requests that came through email but forgot to see there was a leftover
15:31 <rafaeldtinoco> carry this over please and I'll update later today
15:31 <ddstreet> #action rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carried over)
15:31 * meetingology rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carried over)
15:32 <ddstreet> #subtopic teward to add FourDollars to the Canonical OEM metapackage packageset
15:32 <ddstreet> don't think he is around today
15:33 <ddstreet> i think he did this though
15:34 <ddstreet> ah yes, found the team https://launchpad.net/~canonical-oem-metapackage-uploaders/+members
15:35 <ddstreet> he has been added
15:35 <ddstreet> #subtopic teward to announce FourDollars' successful application
15:35 <ddstreet> and announced https://lists.ubuntu.com/archives/devel-permissions/2021-June/001702.html
15:35 <ddstreet> #subtopic teward to apply Utkarsh's core dev permissions
15:36 <ddstreet> yep, he has been added to ~ubuntu-core-dev team
15:36 <sil2100> \o/
15:36 <teward> yep to 4dollars.  i literally JUST woke up because i had no sleep last night so apologies I am not here on time and am basically dead this meeting
15:36 <ddstreet> #subtopic teward to announce Utkarsh's successful application
15:36 <teward> (insomnia is a pain)
15:36 <ddstreet> ah hello o/
15:37 <teward> (i'm still not here fully)
15:37 <ddstreet> that is announced as well https://lists.ubuntu.com/archives/devel-permissions/2021-June/001701.html
15:37 <ddstreet> ok that's all the previous action items
15:37 <ddstreet> i think we can move directly to SRU developer application for halves
15:38 <ddstreet> #topic SRU Developer application
15:38 <ddstreet> halves welcome, can you introduce yourself please?
15:39 <ddstreet> halves i think you briefly dropped, i'd just asked if you could introduce yourself
15:39 <ddstreet> and also, welcome :)
15:40 <halves> ddstreet sorry, I was having some connection issues. seems stable now, hopefully there won't be problems
15:40 <halves> Hello, everyone! I'm Heitor, I work for Canonical in the Sustaining Engineering team. Most of my work is on bugs reported by Ubuntu Advantage customers, where I need to backport patches to the stable Ubuntu releases. I'd like to apply for the SRU developer role today. My wiki page has some examples of my work so far: https://wiki.ubuntu.com/halves/sru-developer
15:40 <ddstreet> #link https://wiki.ubuntu.com/halves/sru-developer
15:41 <ddstreet> thanks, i'll give some time for everyone to read and ask questions
15:42 <sil2100> halves: hello! Question: when working on an SRU and trying to fix multiple bugs, how would you decide whether you should cherry-pick single fixes or backport a whole new upstream release for the changes?
15:45 <halves> sil2100 hi!
15:46 <halves> sil2100 well, I think that would depend on the specific pkg. I'd start checking how much we'd have to change with individual cherry-picks, if it's simple changes that are mostly "self-contained", I'd probably lean towards that. if the patches are complex and have additional dependencies, I'd evaluate the feasibility of doing a new release
15:46 <sil2100> Thanks
15:46 <rbasak> halves: have you ever dealt with SRUs that aren't just cherry-picked bugfixes? Eg. feature changes, or new upstream releases?
15:47 <rafaeldtinoco> he created his own set of upstream changes for netplan at: https://github.com/canonical/netplan/pull/89/commits/8795c1f7e666fd53fbd965cabba30bc167784dbc
15:47 <ubottu> Pull 89 in canonical/netplan "Introduce support for networkd address options" [Merged]
15:47 <halves> rbasak yes, I've had to push upstream and Debian fixes before doing SRUs before
15:47 <halves> thanks rafaeldtinoco, Netplan is a good example :)
15:47 <rbasak> halves: I mean: have you managed an SRU where the upload to Ubuntu wasn't a cherry-pick?
15:47 <rafaeldtinoco> halves: what are migration excuses and why are they important for SRU proposals ?
15:49 <halves> rbasak yes, I've also had to do backports due to upstream patches diverging or not applying directly. there's a recent ZFS example in my wiki page, for https://bugs.launchpad.net/bugs/1875577
15:49 <ubottu> Launchpad bug 1875577 in zfs-linux (Ubuntu Focal) "Encrypted swap won't load on 20.04 with zfs root" [Medium, Fix Released]
15:51 <halves> rafaeldtinoco iirc migration excuses are important for moving SRUs "forward", out from the -proposed pocket into -releases. sometimes we can get autopkgtest failures or regressions that are not caused by the patch being introduced, and we might need to get the pkgs out of -proposed due to important fixes regardless of the autopkgtest results (such as security fixes or severe regressions)
15:52 <rafaeldtinoco> thanks, from your answers so far and your work showed in LP I already have my vote. I'll wait for others to continue.
15:53 <ddstreet> time check, no rush, but just pointing out our normal mtg end time is in ~7 minutes; i'm able to continue, if everyone else can
15:54 <ddstreet> sil2100 rbasak any further q or should we move to voting?
15:54 <rbasak> halves: let's say that a customer requests the addition of a new feature in a package in Focal, and asks you to land it as this application was successful. How would you determine if that would be permitted or not?
15:54 <ddstreet> since halves is on my team and i endorsed him, i'll hold my vote to the end
15:56 <halves> rbasak sorry, I'm not sure I understood the "this application was succesful" part. would this be something a customer has tested in-house and asked me to implement/backport into focal?
15:56 <rbasak> halves: sorry ignore that part, it's not important. Your second question is correct. If that's the situation, then how would you determine if the requested change is acceptable?
15:58 <halves> rbasak well, that one would be a bit hard to answer without more context, I think. if it's a package I'm familiar with, I'd evaluate the feature, see if it's implemented or has plans to be implemented upstream first. if it's something I'm not that much familiar with, I'd probably still consult upstream and evaluate how relevant it would be for an LTS release
15:59 <halves> I understand the SRU process is not strictly for implementing new features, so it would depend on how relevant the specific feature in question is (i.e. if it fixes existing issues, etc)
15:59 <rbasak> halves: who would make the final decision?
16:01 <halves> rbasak if it's just a matter of implementing a new feature "just because" then I'd simply explain to the requester that this is not how the SRU process works, but I'd likely consult more experienced core devs first
16:02 <rbasak> halves: I agree that's a good set of actions to take in this situation. But I want to know how well you understand how decision making happens in Ubuntu with respect to SRUs. Can you tell me who ultimately decides if a new feature is or isn't acceptable in an SRU in Ubuntu?
16:06 * rafaeldtinoco has a hard stop in ~10
16:07 <halves> rbasak I'm thinking that would be a core-dev, but I've never been in that situation before honestly. seems like this would be a good topic for me to study up on
16:08 <rbasak> OK, thanks
16:10 <ddstreet> rbasak any further q?
16:10 <rbasak> No further questions, thanks
16:11 <ddstreet> ok thanks let's get the vote in before rafaeldtinoco has to go
16:11 <ddstreet> #vote Grant Heitor Alves de Siqueira SRU Developer
16:11 <meetingology> Please vote on: Grant Heitor Alves de Siqueira SRU Developer
16:11 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
16:12 <ddstreet> as mentioned, i'll hold my vote to the end
16:12 * rbasak is typing
16:13 <rafaeldtinoco> +1. Despite Heitor not having so many SRUs, I have gone through his work, through the bugs he has worked on. He has a very good documentation on what he does. He gives enough information in the bugs so one can find how to reproduce the issue and how his actions are targetting the resolution. He has good upstream work with netplan showing development skills. He has good knowledge about internals considering his linux
16:13 <meetingology> +1. Despite Heitor not having so many SRUs, I have gone through his work, through the bugs he has worked on. He has a very good documentation on what he does. He gives enough information in the bugs so one can find how to reproduce the issue and how his actions are targetting the resolution. He has good upstream work with netplan showing development skills. He has good knowledge about internals considering his linux received from rafaeldtinoco
16:13 <rafaeldtinoco> kernel work. Therefore I will be very happy with him being part of the sru uploader team.
16:18 <rbasak> -1 but hopefully with a very straightforward path to changing my vote to a +1
16:18 <meetingology> -1 but hopefully with a very straightforward path to changing my vote to a +1 received from rbasak
16:18 <rbasak> Your SRU work looks good, and you have strong endorsements. So I'm confident that you can produce technicallhy good quality SRUs without supervision - when they are cherry-picks.
16:18 <rbasak> However I'm concerned that you don't fully follow the social aspect here: who is responsible for what, who can make final decisions, and so forth. When you can upload and others cannot, the social tendency is that you end up becoming the gatekeeper for unusual requests too. I don't expect you to be able to deal with these yourself, but I do think you ought to understand who to ask, and who can
16:18 <rbasak> decide.
16:18 <rbasak> I'm therefore -1 for now. I'd like you to go over this with one of your mentors. Once done, and your mentor confirms that they think you do have this straight in your mind, then I'd be happy to change my vote to +1 without need for a further meeting.
16:19 <rbasak> It's just the social side that I'm concerned about. I have no doubt in your technical skill here.
16:20 <ddstreet> sil2100 you still around to vote?
16:24 <ddstreet> te-ward indicated earlier he wasn't able to stay, and it looks like sil2100 had to leave as well, leaving us without quorum to finish voting (even with my vote)...i'll give a few more minutes before calling it
16:25 <halves> rbasak thank you for the feedback! I'm happy for the positive notes on the technical side, and will follow up on your other concerns for sure
16:29 <rafaeldtinoco> halves: and i would encourage you to follow core-dev application, its very obvious you have the skills to do so, maybe you can start helping in maintaining a package not getting too much attention
16:29 <ddstreet> ok looks like we won't make voting quorum today, so no need for me to vote
16:30 <ddstreet> #endvote
16:30 <meetingology> Voting ended on: Grant Heitor Alves de Siqueira SRU Developer
16:30 <meetingology> Votes for: 1, Votes against: 1, Abstentions: 0
16:30 <meetingology> Motion carried
16:30 <ddstreet> well, not actually carried
16:30 <ddstreet> sorry halves, but as discussed above I hope we'll see you reapply soon :)
16:31 <rafaeldtinoco> +1
16:31 <halves> ddstreet no worries! I definitely will :)
16:31 <halves> thank you all for reviewing my application today
16:31 <ddstreet> ok just a couple more items before wrapping the mtg
16:31 <ddstreet> #topic Outstanding mailing list requests to assign
16:32 <ddstreet> #subtopic https://lists.ubuntu.com/archives/devel-permissions/2021-August/001718.html
16:32 <ddstreet> rafaeldtinoco did you happen to handle that one?
16:32 <ddstreet> if you're still around
16:32 <rafaeldtinoco> that one is done, I think I replied to it
16:33 <ddstreet> great, thanks
16:33 <ddstreet> #subtopic https://lists.ubuntu.com/archives/devel-permissions/2021-August/001722.html
16:33 <rafaeldtinoco> the archives dont show multi-month thread replies i think =(
16:34 <ddstreet> anyone want to take this ml request?
16:34 <ddstreet> ok i can review it, looks easy
16:35 <ddstreet> #action ddstreet to review ml request https://lists.ubuntu.com/archives/devel-permissions/2021-August/001722.html
16:35 * meetingology ddstreet to review ml request https://lists.ubuntu.com/archives/devel-permissions/2021-August/001722.html
16:35 <ddstreet> unless i missed anything from the list, i think that's all the pending emails
16:35 <ddstreet> #topic Select a chair for the next meeting
16:35 <ddstreet> guess i'll move myself to the end :)
16:36 <ddstreet> rafaeldtinoco i'll just leave you as the next chair
16:36 <rafaeldtinoco> ddstreet: alright
16:36 <rafaeldtinoco> tku
16:36 <ddstreet> #topic Any other business
16:36 <ddstreet> long mtg today, anything else?
16:36 <ddstreet> ok let's wrap up then, thanks all o/
16:36 <ddstreet> #endmeeting