15:00 <rbasak> #startmeeting Developer Membership Board
15:00 <meetingology> Meeting started at 15:00:17 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:00 <meetingology> Available commands: action, commands, idea, info, link, nick
15:00 <teward> o/
15:00 * sil2100 has a conflicting meeting so he'll be only 75% here
15:00 <FourDollars> \o
15:00 <rbasak> Ditto
15:01 <teward> rbasak: we technically have 'quorate' for Utkarsh, but I think we're missing others, so give it a few to see who else shows up
15:01 <ddstreet> o/
15:01 <teward> if we aren't quorate for the meeting then... oh look ddstreet is here
15:01 <rbasak> #topic
15:01 <rbasak> #topic Long-term action items (do not need to be mentioned in regular meetings)
15:01 <rbasak> Oh.
15:01 <teward> rbasak: unassign the tsimonq2 task for now
15:01 <rbasak> #info rbasak didn't mention the items not to be mentioned
15:01 <rbasak> #topic Review of previous action items
15:01 <teward> i know a lot more than Simon is going to reveal here but he's otherwise too busy at the moment, so someone else will need to pick that up
15:01 <rbasak> OK
15:02 <teward> #NotMe
15:02 <rbasak> ddstreet edubuntu seed <-> pkgset (carried over)
15:02 <ddstreet> need to carry over
15:02 <rbasak> rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html (carried over)
15:02 <rbasak> rafaeldtinoco sends his apologies, so I'll carry that over
15:02 <rbasak> teward to add amurray to core-dev
15:03 <teward> ummmmmm
15:03 <teward> *checks*
15:03 <teward> yes that's done
15:03 <rbasak> teward to announce amurray's successful application
15:03 <teward> I *think* I did that?  I'll have to check the ML archives.
15:03 <teward> i'm a little discomboulated today :)
15:03 <rbasak> OK I'll leave that on for now
15:03 <teward> discombobulated*
15:03 <rbasak> #topic Package Set/Per Package Uploader Applications
15:03 <rbasak> #subtopic     [2021-06-28] Shih-Yuan Lee: https://wiki.ubuntu.com/ShihYuanLee/PPUApplication
15:03 <rbasak> FourDollars: o/
15:03 <rbasak> Would you like to introduce yourself?
15:03 <FourDollars> \o
15:03 <sil2100> o/
15:04 <FourDollars> Hi
15:04 <FourDollars> I am $4.
15:04 <FourDollars> I am a Canonical employee.
15:04 <FourDollars> I am a Debian developer.
15:05 <FourDollars> I am a Ubuntu Contributing Developer.
15:05 <FourDollars> I am a GNOME Emeritus Member.
15:05 * FourDollars copied from https://www.linkedin.com/in/fourdollars/.
15:06 <rbasak> Thanks!
15:06 <rbasak> Does anyone have any questions for FourDollars?
15:06 <teward> *is still reading, may have questions*
15:06 <FourDollars> I deeply involved the design of the implementaion of OEM metapackages.
15:07 <rbasak> I have a question
15:07 <FourDollars> Please.
15:07 <rbasak> I understand the OEM metapackages are limited in terms of what you're supposed to upload.
15:07 <rbasak> Can you describe those limitations, please?
15:08 <FourDollars> It can only contain the dependencies of the Debian packages from main.
15:09 <FourDollars> It can only contain the source list from Canonical OEM archive.
15:09 <rbasak> Thanks!
15:09 <rbasak> Are these documented anywhere please?
15:09 <FourDollars> Let me check.
15:09 <FourDollars> https://wiki.ubuntu.com/MIRTeam/Exceptions/OEM
15:10 <rbasak> Great, thanks!
15:11 <FourDollars> Cool~
15:11 <FourDollars> Any question else?
15:11 <ddstreet> just for clarification, you're applying to join this team, right? https://launchpad.net/~canonical-oem-metapackage-uploaders
15:11 <FourDollars> Yes.
15:11 <ddstreet> thanks, no other q from me
15:12 <teward> no q from me
15:12 <teward> *disappears for 30 seconds to obtain another coffee*
15:13 <rbasak> Does anyone else have any questions?
15:13 <rbasak> FourDollars: how do these packages relate to Ubuntu release cycle freezes?
15:13 <rbasak> Do you expect to be able to upload after feature freeze, and if so, will you be using any special process for that?
15:14 <FourDollars> rbasak: Basically OEM metapackages will on;y be related to LTS.
15:14 <FourDollars> s/on;t/only/ typo
15:14 <rbasak> During development of the LTS, or after?
15:15 <FourDollars> It depends on the OEM projects' schedules.
15:15 <rbasak> OK - so SRUs of new metapackages are a possibility?
15:15 <FourDollars> OEM metapckages will only be expected to appear in LTS' acrhive.
15:15 <rbasak> Do you have any expectation of changing existing metapackages in SRUs?
15:15 <FourDollars> No, we still need to do some SRU process for it.
15:16 <rbasak> OK, thanks.
15:16 <rbasak> I have no further questions.
15:16 <FourDollars> Sometimes the customer will add more platforms into the same OEM metapackage.
15:16 <rbasak> If nobody else has questions, let's move on to the vote.
15:16 <rbasak> #vote Grant FourDollars upload to the Canonical OEM metapackage packageset
15:16 <meetingology> Please vote on: Grant FourDollars upload to the Canonical OEM metapackage packageset
15:16 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
15:17 <teward> #voters teward rbasak ddstreet sil2100
15:17 <meetingology> Current voters: ddstreet, rbasak, sil2100, teward
15:17 <teward> *knows evil things about the IRC side :P)
15:17 <rbasak> lol
15:17 <teward> +1
15:17 <meetingology> +1 received from teward
15:17 <sil2100> I need a minute or two o/
15:17 <teward> yep yep
15:17 <teward> *sips caffeine*
15:18 <ddstreet> +1 happy with existing work setting up oem process and with endorsement, full confidence in excellent work on directly uploading oem metapkgs
15:18 <meetingology> +1 happy with existing work setting up oem process and with endorsement, full confidence in excellent work on directly uploading oem metapkgs received from ddstreet
15:19 <sil2100> +1
15:19 <meetingology> +1 received from sil2100
15:19 <rbasak> +1
15:19 <meetingology> +1 received from rbasak
15:19 <rbasak> #endvote
15:19 <meetingology> Voting ended on: Grant FourDollars upload to the Canonical OEM metapackage packageset
15:19 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
15:19 <meetingology> Motion carried
15:20 <rbasak> Congratulations!
15:20 <FourDollars> Cool~ Thanks a lot.
15:20 <teward> i'm going to be prodding permissions today anyways, so i'll take the "Assign user to group" and "Approval Notice" tasks
15:20 <rbasak> Any volunteers for taking the actions to put that live and send the announcement?
15:20 <rbasak> Thanks!
15:20 <teward> (permissions across things today anyways*)
15:20 <rbasak> #action teward to add FourDollars to the Canonical OEM metapackage packageset
15:20 * meetingology teward to add FourDollars to the Canonical OEM metapackage packageset
15:20 <rbasak> #action teward to announce FourDollars' successful application
15:20 * meetingology teward to announce FourDollars' successful application
15:21 <rbasak> #topic Ubuntu Core Developer Applications
15:21 <rbasak> #subtopic Utkarsh Gupta: https://wiki.ubuntu.com/UtkarshGupta/CoreDevApplication
15:21 <ddstreet> congratulations FourDollars!
15:21 <rbasak> utkarsh: hello!
15:21 <utkarsh> hello! o/
15:21 <rbasak> Would you like to introduce yourself please?
15:22 <utkarsh> I am Utkarsh, a 21 y/o. I've been a DD for about ~3 years and actively maintain packages (over ~700 uploads) & also an FTP trainee, reviewing the famous NEW queue (:D). I do a bunch of security related work in Debian as well.
15:22 <FourDollars> ddstreet: Thx.
15:22 <utkarsh> Since this February, I joined the Canonical's Server team and have been actively fixing & taking care of stuff. Besides day job, I also try to help and take care of the community side of things. I've written all of things down in my application. \o/
15:22 <rbasak> (since Utkarsh is a colleague on my team, I'm intend to mostly abstain from the discussion and vote)
15:22 <rbasak> Thanks!
15:22 <rbasak> Questions for utkarsh?
15:23 <teward> none from me
15:23 <ddstreet> still reading
15:24 <teward> utkarsh: might steal you for some PHP stuff if PHP 8 misbehaves during the transition with certain applications (and nginx fastcgi_pass stuff to FPM), but other than that, no questions for you :)
15:24 <utkarsh> teward: haha, absolutely! \o/
15:28 <sil2100> Ok, I think I have no questions (no capacity to ask any as well)
15:29 <ddstreet> utkarsh it looks like you have a lot of development-release experience from the last couple months, but not very much before that, and your first upload was feb this year, is that right? https://launchpad.net/~utkarsh/+uploaded-packages
15:30 <utkarsh> ddstreet: yep, that's correct! and is covered in my application (top part) and rbasak's and kanashiro's endorsement.
15:30 <ddstreet> so you've only done a couple sru uploads then, right?
15:30 <utkarsh> I've been fixing lots of Ubuntu-specific things (architecture related) in Debian so as to avoid delta and let them be in sync.
15:30 <utkarsh> since 2020, for Focal.
15:31 <utkarsh> that is, for ruby2.7 transition & some for Rails 6.0.
15:31 <ddstreet> can you explain how the sru process differs from development release process?
15:32 <utkarsh> Once an Ubuntu release has been completed and published, updates for it are only released under certain circumstances, and must follow a special procedure called a SRU. From the wiki: https://wiki.ubuntu.com/StableReleaseUpdates. I've done SRUs for 8 packages (bionic, focal, groovy, hirsute)
15:33 <utkarsh> 8 different packages, that is.
15:34 <sil2100> utkarsh: hm, actually, maybe one question: what's the difference between multiverse and universe?
15:34 <utkarsh> Once an SRU bug template is prepared, the upload is done to the desired release. A member from the SRU team then check everything & approves or asks for more information.
15:34 <utkarsh> should I continue describing this process?^
15:34 <utkarsh> or skip to sil2100's question?
15:34 <ddstreet> i'd like to hear more, but you can answer him first
15:35 <utkarsh> sil2100: hey, universe has community-maintained free and open-source software. OTOH, multiverse has s/w restricted by copyright or legal issues.
15:37 <utkarsh> ddstreet: okay, so once the SRU team acks an upload, it is accepted and available in -proposed. A verification is then requested by the bug submitter (preferably, which anyone can do) to ensure that the fix indeed works as intended.
15:37 <utkarsh> and we have a wait period for 7 days to ensure everything's fine. Post that, update is available in -updates.
15:38 <ddstreet> what do you need to include in quilt patches for srus, other than the change itself?
15:38 <utkarsh> DEP3 headers.
15:38 <utkarsh> to ensure others can easily track the origin, et al of the patch.
15:39 <utkarsh> I try my best to include all DEP3 headers in all my uploads, be it SRUs or uploads to the devel release.
15:39 <utkarsh> as a best practice :)
15:39 <sil2100> utkarsh: thanks for the answer o/
15:39 <utkarsh> \o/
15:40 <ddstreet> let's say you need to fix a bug in bionic; what's your process?
15:40 <ddstreet> assuming there is no open lp bug for the problem
15:40 <utkarsh> ah, alrighty.
15:42 <utkarsh> step 1: reproduce the problem. step 2: prepare the actual fix and the SRU bug template with all the necessary fields. step 3: indeed verify that the fix works fine (by maybe using a PPA or whatever's preferable - I use a PPA).
15:42 <utkarsh> step 4: upload the package & wait for SRU team to review.
15:42 <ddstreet> upload the pkg for bionic?
15:44 <utkarsh> step 5: if the team approves, do the verificaition (I try to let someone else do that so we have a second pair of eyes as well). step 6: also, check for any blockers (in case there's any).
15:45 <ddstreet> so after all that, do you then fix it for focal?
15:45 <utkarsh> I got sponsored for isc-dhcp/4.3.5-3ubuntu7.2 for bionic.
15:45 <utkarsh> oh yes, make sure the fix is for all the release.
15:45 <utkarsh> I mean, make sure it's fixed in -devel, first of all.
15:45 <ddstreet> what if it isn't?
15:46 <utkarsh> if not, prep a fix there and watch for regressions, etc. Let it migrate. Simulteanously, prep a fix for H/G/F/B if all of them are affected.
15:46 <ddstreet> do you need to fix anywhere else?
15:47 <utkarsh> in case the problem is in -devel release, I'd definitely forward the fix upstream or to Debian, whatever is appropriate.
15:47 <ddstreet> does debian need to apply the fix before we fix ubuntu?
15:48 <utkarsh> it's not necessary but is good to know that they've accepted the fix. For instance, Debian is in a freeze at the moment, so I send MRs and make sure they're accepted at least and so on.
15:48 <ddstreet> what if it's not fixed upstream, do you need to wait for upstream to patch before fixing ubuntu?
15:50 <utkarsh> I open PRs, et al upstream always (whenever possible) to make sure it's being tracked and will be subsequently fixed. Whilst it's ideal to be fixed upstream and then we cherry-pick from there but sometimes it so happens that we'd like to fix the bug immeditately, et al.
15:51 <ddstreet> so is it ok to just open a PR upstream and MR in debian with your fix and then immediately patch ubuntu releases?
15:52 <utkarsh> only if the fix is immediately needed or is a high-prio or something. Otherwise, it's always better for them to adapt the patch and then we cherry-pick that.
15:53 <ddstreet> ok thanks, we're coming up on the end of the hour, so no more q from me
15:53 <utkarsh> for example, I submitted a patch to Debian for them to accept and then did a sync here, when the upload wasn't high-prio.
15:53 <ddstreet> rbasak i think we're ready to vote unless anyone else has q
15:53 <sil2100> I might have one last question, more of a formality
15:53 <rbasak> OK thanks! Any more questions from anyone?
15:53 <rbasak> Oh sorry, go ahead sil2100
15:54 <sil2100> How does the upload story change after Final Freeze for an Ubuntu release?
15:55 <utkarsh> oh, of course. When the archive is frozen, fixes must be manually reviewed and accepted by the release team members.
15:55 <utkarsh> well documented here (https://wiki.ubuntu.com/FinalFreeze).
15:55 <sil2100> Can uploaders still upload things to the archive? If yes, what are appropriate uploads at this stage?
15:57 <sil2100> Ok, since there's not much time left, seeing that you know about the documentation bits - I guess that might be enough for me for now!
15:57 <utkarsh> the devs should upload to -proposed and the release team will cherry-pick if the circumstances allow. mostly RC bugs.
15:57 <sil2100> No further questions o/
15:57 <sil2100> Thanks o/
15:57 <utkarsh> I'd have added more but time constraints..
15:57 <utkarsh> thank you!
15:58 <rbasak> #vote Grant Utkarsh Gupta Ubuntu Core Developer
15:58 <meetingology> Please vote on: Grant Utkarsh Gupta Ubuntu Core Developer
15:58 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
15:59 <sil2100> +1 Solid endorsements, lots of activity and Ubuntu presence
15:59 <meetingology> +1 Solid endorsements, lots of activity and Ubuntu presence received from sil2100
15:59 <teward> +1 solid endorsements, lots of activity, I fully believe they meet all the requirements for core-dev
15:59 <meetingology> +1 solid endorsements, lots of activity, I fully believe they meet all the requirements for core-dev received from teward
15:59 <teward> sorry handling 3 things at once :)
16:02 <ddstreet> one sec, sorry
16:04 <ddstreet> I'm confident in experience/knowledge with the devel release process, but I am concerned about the lack of experience with sru process; for better or worse, the ubuntu process does have lots of special cases and while you do have a good theoretical knowledge of it, without some hands-on sru experience, knowledge of the process alone isn't always enough
16:04 <ddstreet> Certainly in the past, DMB members have rejected applications from people with more experience
16:05 <ddstreet> +1 however my opinion isn't that a core dev needs process expertise, as I believe knowledge of the process is secondary to good technical ability, and all your work so far shows excellent technical work, so even if you don't have as much experience as has been required in the past, I'm confident in the actual changes you'll make and also confident you'll handle any unexpected process issues right and ask for help when needed
16:05 <meetingology> +1 however my opinion isn't that a core dev needs process expertise, as I believe knowledge of the process is secondary to good technical ability, and all your work so far shows excellent technical work, so even if you don't have as much experience as has been required in the past, I'm confident in the actual changes you'll make and also confident you'll handle any unexpected process issues right and ask for help when needed received from ddstreet
16:07 <rbasak> +1 already endorsed; I would abstain, but voting to meet quorum as all other votes are unanimous
16:07 <meetingology> +1 already endorsed; I would abstain, but voting to meet quorum as all other votes are unanimous received from rbasak
16:07 <rbasak> #endvote
16:07 <meetingology> Voting ended on: Grant Utkarsh Gupta Ubuntu Core Developer
16:07 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
16:07 <meetingology> Motion carried
16:07 <rbasak> Congratulations utkarsh!
16:07 <utkarsh> thank you, everyone! \o/
16:08 <teward> i'll take the tasks
16:08 <utkarsh> ddstreet: duly noted, thank you! :D
16:08 <ddstreet> congratulations utkarsh!
16:08 <teward> again :p
16:08 <teward> rbasak: ^^
16:09 <rbasak> Thanks teward!
16:09 <rbasak> #action teward to apply Utkarsh's core dev permissions
16:09 * meetingology teward to apply Utkarsh's core dev permissions
16:09 <teward> might take a couple hours FourDollars, utkarsh, but i'll get to your perms at some point today or tomorrow.  Trying to put out a fire on FT job's exchange server
16:09 <rbasak> #action teward to announce Utkarsh's successful application
16:09 * meetingology teward to announce Utkarsh's successful application
16:09 <teward> (i hate that i know more about exchange than half the windows guys... >.<)
16:09 <utkarsh> teward: absolutely, no rush! \o/
16:10 <FourDollars> teward: Thx.
16:10 <rbasak> As we're over time, shall we skip the other standing agenda items for next time?
16:10 <teward> yep go go go
16:10 <teward> just for the record:
16:10 <teward> rbasak: i did that last item you left on agenda
16:10 <teward> had to dig in the May archives to find it but that was done for amurray's announce
16:10 <rbasak> Thanks!
16:10 <teward> *goes to beat his head on microsoft servers now for FT job*
16:11 <rbasak> #topic Next Chair
16:11 <rbasak> #info The next chair will be slashd
16:11 <rbasak> #topic AOB
16:11 <rbasak> Anything else that needs to be brought up today?
16:12 <rbasak> I guess not.
16:12 <rbasak> #endmeeting