14:01 <sil2100> #startmeeting DMB meeting
14:01 <meetingology> Meeting started at 14:01:55 UTC.  The chair is sil2100.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
14:01 <meetingology> Available commands: action, commands, idea, info, link, nick
14:02 <sil2100> #topic Review of previous action items
14:02 <sil2100> ddstreet edubuntu seed <-> pkgset (carried over)  <- ddstreet any progress on this?
14:02 <ddstreet> sorry no :(
14:02 <ddstreet> carry over again plz
14:02 <sil2100> #action ddstreet edubuntu seed <-> pkgset (carried over)
14:02 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
14:02 <sil2100> Ok, quick one
14:02 <sil2100> ddstreet add mhcerri to dkms packageset team <- I assume this is done?
14:02 <ddstreet> yep
14:03 <sil2100> Excellent
14:03 <teward> o/
14:03 <sil2100> Ah, just remembered we were supposed to first review the candidates today
14:03 <teward> here but was on a call.
14:03 <sil2100> So let's get back to this later, first doing the candidate review
14:03 <teward> sil2100: going through the current actions and checking off or continuing should be fine
14:03 <teward> unless we need to do the review first :)
14:03 <teward> (my morning cleared because of $ILLNESS in the other people so i have the whole hour)
14:03 <sil2100> We need to since some people only have 30 minutes, that was the request
14:03 <teward> 👍
14:04 <rafaeldtinoco> sil2100: yep, tku
14:04 <sil2100> #topic Ubuntu Core Developer Applications
14:04 <sil2100> #subtopic Alex Murray
14:04 <sil2100> amurray: o/
14:04 <sil2100> amurray: can you please introduce yourself?
14:05 <sil2100> #link https://wiki.ubuntu.com/AlexMurray/CoreDevApplication
14:05 <sil2100> #link https://udd.debian.org/cgi-bin/ubuntu-sponsorships.cgi?render=html&sponsor=&sponsor_search=name&sponsoree=alex.murray%40canonical.com&sponsoree_search=email
14:05 <amurray> hey - so I've been a member of the Ubuntu Security team for the past 3 years, working on security updates plus merges and other bits here and there
14:06 <amurray> (new versions of apparmor, SRUs of libseccomp etc as within the security teams purview)
14:06 <amurray> plus various features like the adduser/shadow changes for private home dirs in 21.04 etc
14:07 <sil2100> Ok, thanks! Let's move to questions
14:07 <teward> me first
14:08 <sil2100> We can always ask questions simultaneously, so everyone feel free to send your questions o/
14:09 <teward> amurray: I noticed a *large* portion of your contributions are targeted to -security (and -updates accordingly), which are processed through the Security team PPA and not direct uploads.  Comparatively, you have a *very* small number of uploads that needed sponsored otherwise.  I also see limited work on test hinting, unblocking proposed, seeds, lib transitions, etc. - all skills we expect CoreDev to know/understand.
14:10 <teward> Why do you specifically want Core Dev, in your own words, and how would it benefit you, as the vast majority of your contribs seem to pass via the Security PPA instead (which has different processes)?
14:10 <teward> Also, have you given any thought towards looking at the other items I mentioned (which cpaelzer has mentioned as well in one of the areas you should improve in)
14:10 <rafaeldtinoco> (Also considering you are applying because, in your words, you want to eliminate delays and reduce burden to sponsors)
14:10 <sil2100> amurray: can you give us an example of some proposed-migration work you have been doing with either your upload or an upload from someone else? What does 'proposed-migration' mean and what things there need attention?
14:11 <amurray> teward: sure, so for myself - as an example - when doing the recent libseccomp SRUs, these trigger a heap of other autopkgtests which are often flaky and either take a number of retriggers to get them to pass OR hints - so it was often quite time consuming to have to ask and chase up others just to retrigger these along the way
14:13 <amurray> also as part of the security team, for most updates via -security for the stable releases there is usually a corresponding update for devel - it would be quite beneficial to have someone else on our team who can sponsor these on behalf of others since at the moment there is only one of us who is coredev
14:15 <amurray> sil2100: proposed-migration is the process for packages to migrate from proposed to release/-updates depending on whether is devel or a stable release - my understanding is this involves resolving any failing autopkgtests for the package OR packages which depend on it and hence get triggered by it - and also any bugs which are tagged as blocking - so say for SRUs this would be doing testing and marking as ver
14:15 <amurray> attention to all these things (failing tests, blocker bugs)
14:15 <teward> amurray: message cutoff @ "so say for SRUs this would be doing testing and marking as ver..."
14:16 <teward> thanks for answering my question.
14:21 <sil2100> amurray: do you know if there's any other type of 'testing' that's performed on the packages when they're in -proposed for the devel series? Can a package be blocked in -proposed without any 'blocker' bugs and test failures?
14:22 <ddstreet> fyi all, amurray just pinged me to say his internet connection died, he's trying to reconnect with phone tethering
14:22 <sil2100> Oh crap
14:23 <amurray> sorry folks I just had an internet outage - sorry if I missed anything - I see a q from sil2100 re other types of testing for proposed
14:23 <sil2100> Yes, I don't think there was any other new questions so far
14:23 <sil2100> Can you answer that follow up question of mine?
14:23 <rafaeldtinoco> 11:21 AM <sil2100> amurray: do you know if there's any other type of 'testing' that's performed on the packages when they're in -proposed for the devel series? Can a package be blocked in -proposed without any 'blocker' bugs and test failures?
14:23 <rafaeldtinoco> if you lost it
14:24 <amurray> sil2100: hmm I know there's also component-mismatches so that if say a new dependency was needed for a package in main and the dependency was in universe that may block it
14:25 <sil2100> Yes, there's that as well for instance
14:25 <teward> amurray: you also had a message cutoff earlier
14:25 <teward> in your reply to sil: > and also any bugs which are tagged as blocking - so say for SRUs this would be doing testing and marking as ver...
14:25 <teward> so wasn't sure if you need to finish that statement :)
14:26 <amurray> so say for this would be doing testing and marking as verified etc - so need to pay attention to all these things (failing tests, blocker bugs)
14:27 <amurray> teward: did you get my response re hints-ubuntu and library transitions etc?
14:27 <teward> yep
14:27 <teward> um... wait.
14:27 <teward> *checks*
14:27 * sil2100 has no more questions
14:27 <teward> i got the one about the SRUs and autopkgtests and the note about only one on Security having coredev
14:27 <teward> but not the hints, transitions part.
14:27 <teward> think your net exploded right then ;)
14:28 <amurray> teward: sorry I realised I missed part of your question - so I have been trying to look at getting more exposure to these other parts, for example I more recently made my first contribution to hints-ubuntu
14:28 <amurray> I haven't done any library transitions though nor had the opportunity to have to get my hands dirty with seeds yet but I would not shy away from the challenges
14:28 * rafaeldtinoco starting parallel meeting in 2 min (but will be able to vote on highlight)
14:28 * rafaeldtinoco no questions from me
14:28 <teward> amurray: thanks for your response.
14:28 <teward> no more questions from me.
14:28 <amurray> (but if I had to dive into these things I would be sure to reach out to others to get guidance)
14:28 <sil2100> Any other questions from remaining members?
14:28 <ddstreet> no q from me
14:29 <sil2100> #vote Alex Murray for Core Developer membership
14:29 <meetingology> Please vote on: Alex Murray for Core Developer membership
14:29 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
14:30 <teward> +1 provided that Alex asks questions from other more experienced coredevs if he doesn't know the next thing to do
14:30 <meetingology> +1 provided that Alex asks questions from other more experienced coredevs if he doesn't know the next thing to do received from teward
14:30 <teward> rafaeldtinoco: ^^
14:31 <ddstreet> +1 good endorsements, and very good technical work from what i've seen
14:31 <meetingology> +1 good endorsements, and very good technical work from what i've seen received from ddstreet
14:31 <rafaeldtinoco> +1 with the concern of having more contributions from amurray in core parts of being a core dev (specially unblocking migrations). I like the approach of having more sponsors in security team and the test retries.
14:31 <meetingology> +1 with the concern of having more contributions from amurray in core parts of being a core dev (specially unblocking migrations). I like the approach of having more sponsors in security team and the test retries. received from rafaeldtinoco
14:31 <sil2100> +1 Alex's application also seems to make sense, as I see a real bottleneck that needs fixing right now
14:31 <meetingology> +1 Alex's application also seems to make sense, as I see a real bottleneck that needs fixing right now received from sil2100
14:32 <sil2100> #endvote
14:32 <meetingology> Voting ended on: Alex Murray for Core Developer membership
14:32 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
14:32 <meetingology> Motion carried
14:32 <ddstreet> congrats!
14:32 <sil2100> o/
14:32 <sil2100> amurray: congrats!
14:32 <rafaeldtinoco> amurray: congrats!
14:32 <amurray> wow, awesome - thanks everyone :)
14:32 <ogra> YAY !
14:33 <sil2100> So I'd appreciate someone taking the action item of adding amurray to the team and announcements
14:33 <teward> sil2100: consider that done by me
14:33 <teward> after my lunch meetings
14:33 <sil2100> Since I'm basically 'not here' today and tomorrow
14:33 <sil2100> teward: thanks!
14:33 <sil2100> #action teward to add amurray to core-dev
14:33 * meetingology teward to add amurray to core-dev
14:33 <sil2100> #action teward to announce amurray's successful application
14:33 * meetingology teward to announce amurray's successful application
14:33 <teward> it'll be sent out by EOD today, or tomorrow if I get swamped with crap at work today.  (email changes are pain >.<)
14:34 <sil2100> Ok, there was also one remaining action item from last time:
14:34 <sil2100> rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-April/001676.html and https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html
14:34 <rafaeldtinoco> I did one
14:34 <rafaeldtinoco> let me see
14:34 <rafaeldtinoco> the openstack
14:34 <rafaeldtinoco> missing https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html
14:34 <sil2100> Ok, I'll modify it so that only one is left!
14:34 <rafaeldtinoco> please carry that one
14:34 <sil2100> Thanks!
14:34 <rafaeldtinoco> sil2100: tku!
14:35 <sil2100> #topic AOB
14:35 <sil2100> ...any AOB?
14:35 <sil2100> Chair for next meeting should be rafaeldtinoco according to the agenda
14:35 <sil2100> o/
14:35 <sil2100> #endmeeting