19:06 <ddstreet> #startmeeting DMB Meeting - April 19, 2021
19:06 <meetingology> Meeting started at 19:06:45 UTC.  The chair is ddstreet.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
19:06 <meetingology> Available commands: action, commands, idea, info, link, nick
19:07 <ddstreet> #topic Previous Action Items Review
19:07 <ddstreet> oh
19:07 <ddstreet> hmm looks like meetingology's available command list is much shorter than it used to be
19:07 <ddstreet> anyway
19:08 <ddstreet> #subtopic ddstreet edubuntu seed <-> pkgset (carried over)
19:08 <ddstreet> carrying over still (i need to get to this, after i understand the seed tooling better)
19:08 <ddstreet> #action ddstreet edubuntu seed <-> pkgset (carried over)
19:08 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
19:09 <ddstreet> #subtopic ddstreet to reduce the scope of meeting scheduling mistakes
19:09 <ddstreet> pretty sure this was done last mtg, but definitely done now
19:09 <ddstreet> #subtopic rbasak to resolve Alex's request for an alternate meeting venue/time for his application
19:09 <ddstreet> was that already done last mtg?
19:10 <rbasak> Done
19:10 <rbasak> It's the next meeting
19:10 <ddstreet> ok
19:10 <ddstreet> #subtopic rbasak to handle GunnarHj core-dev rights, announcement, and post-coredev packageset/acl cleanups
19:10 <rbasak> Also done
19:10 <ddstreet> great thnx
19:11 <ddstreet> ok that moves us on to the PPU application from mhcerri
19:11 <mhcerri> o/
19:11 <ddstreet> #topic Marcelo Cerri DKMS upload rights application
19:11 <ddstreet> hi mhcerri can you introduce yourself?
19:11 <mhcerri> sure
19:12 <ddstreet> https://wiki.ubuntu.com/MarceloCerri/DkmsUploadApplication
19:12 <ddstreet> #link https://wiki.ubuntu.com/MarceloCerri/DkmsUploadApplication
19:12 <ddstreet> sorry go ahead
19:12 <mhcerri> hi, my name is Marcelo Cerri. I work on the kernel team for almost 5 years now. I'm currently working with our cloud kernels and with the stable team
19:13 <rbasak> mhcerri: hello! Do you have any recent sponsored DKMS fixing uploads?
19:15 <mhcerri> hi, rbasak. I don't think I have uploaded one this year.. we usually work on them when we have a new kernel, but I haven't worked on it in the last kernels we released
19:15 <sil2100> mhcerri: related to rbasak's question - why do you want to apply for DKMS upload rights? How does the lack of them affect you right now?
19:16 <ddstreet> for clarification/reference, here's the link to the kernel-dkms packageset current list of packages:
19:16 <ddstreet> #link https://people.canonical.com/~ubuntu-archive/packagesets/hirsute/kernel-dkms
19:17 <mhcerri> hi, sil2100. the lack of dkms upload rights, make it hard to me to help fixing those packages when we prepare new kernels. and that causes more overhead usually inside the kernel team because we need an additional person to review those uploads
19:17 <rbasak> I'm sure I've seen DKMS package fixes being uploaded recently. Do you know who has been sponsoring those?
19:18 <mhcerri> and just to make clear, that's not a work that we need to do only when a new ubuntu version is released, we also do the same kind of work for LTSs when we update our hwe and hwe-edge kernerls
19:19 <mhcerri> rbasak, do you mean for hirsute?
19:19 <rbasak> IIRC they were for stable releases, eg. Focal.
19:20 <sil2100> mhcerri: thanks o/
19:20 <mhcerri> rbasak, I don't know who has sponsored the latest uploads. but Timo and Alberto usually help with that. Tyler used to do that too in the past
19:21 <rbasak> OK
19:21 <rbasak> ...
19:21 <rbasak> The DMB doesn't normally grant permissions "pre-emptively", and expects to see an established track record in the specific area that an applicant wants to upload in, together with endorsements from sponsor(s) who have actually sponsored specific and recent work in this area.
19:22 <rbasak> So here I would expect to see:
19:23 <rbasak> 1) Recent sponsored uploads prepared by you for DKMS package updates; and 2) endorsements from your sponsors of that work affirming your readiness specifically for that work.
19:23 <ddstreet> it looks like the only upload for 2021 is dkms, sponsored by timo for https://bugs.launchpad.net/ubuntu/+source/dkms/+bug/1915051
19:23 <ubottu> Launchpad bug 1915051 in dkms (Ubuntu Hirsute) "dkms-autopkgtest: Also select binary packages that depends on dkms for testing" [High,Fix released]
19:23 <mhcerri> ddstreet, yes. I believe that's correct
19:23 <rbasak> See the final bullet point under "When to apply for team membership" at https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
19:24 <rbasak> You said above "that causes more overhead usually inside the kernel team because we need an additional person to review those uploads" - but IMHO that's the point - there should be someone experienced providing a code review.
19:25 <rbasak> What I suggest you do is be the person "on point" preparing all the DKMS package uploads for your team, and get sponsorship for them - maybe by finding a dedicated mentor who can upload these packages.
19:25 <rbasak> Once you have an established track record, and your mentor says you're ready, then I'd be happy to provide a +1.
19:25 <rbasak> In the meantime, IMHO it's entirely appropriate that you get code review prior to upload.
19:26 <rbasak> Other DMB member opinions may vary.
19:27 <ddstreet> mhcerri for that dkms bug 1915051, did you (or your sponsor) have to adjust anything in your debdiff(s) for the actual uploaded and released packages?
19:27 <ubottu> bug 1915051 in dkms (Ubuntu Hirsute) "dkms-autopkgtest: Also select binary packages that depends on dkms for testing" [High,Fix released] https://launchpad.net/bugs/1915051
19:27 <mhcerri> rbasak, so do you think I should apply again when I have more recent uploads? I don't think it will be possible for me to be the person preparing all the DKMS upload for the team due to the volume of work that it represents
19:28 <rafaeldtinoco> rbasak: I kind of agree with what you say based on the need (lack of recent uploads show no current bottleneck to have less uploaders/reviewers). At the same time what you are saying is somehow provided in his application.
19:28 <rbasak> mhcerri: I think so, yes. If there's more work then you can do then that's no problem. I was only suggesting that you do "all" so as to get an established track record as quickly as possible. It isn't a requirement.
19:29 <rafaeldtinoco> 12 sponsored dkms uploads in 2020
19:29 <rafaeldtinoco> is what he shows in his application
19:29 <rbasak> What I've suggested to teams before where there's been a bottleneck is to focus on one person at a time getting upload permission, just so that this one person gets the maxmium experience and that increases the number uploaders in the quickest way.
19:29 <mhcerri> ddstreet, I might be wrong, but as far as I remember no adjustments were necessary
19:30 <ddstreet> mhcerri the version numbers in particular; were your chosen version numbers correct for all releases?
19:30 <rbasak> rafaeldtinoco: I don't see those?
19:30 <rafaeldtinoco> rbasak: Examples of my work / Things I'm proud of in his application page ?
19:31 <rafaeldtinoco> I see a bunch of sponsored uploads sponsored by Tyler, Timo, Andy, etc
19:32 <rbasak> rafaeldtinoco: maybe I'm missing something but I don't see *any* DKMS package uploads in 2020. Do you have an example of one so I can figure out why our views differ here please?
19:33 <rafaeldtinoco> https://www.irccloud.com/pastebin/FM2aBZTc/
19:33 <mhcerri> ddstreet, I would have to check that. I don't remember any feedback regarding that (which doesn't mean it wasn't necessary)
19:33 <rafaeldtinoco> sorry, wasnt supposed to be a pastebin
19:34 <ddstreet> mhcerri the final version number for groovy was slightly changed, maybe by the sponsor, you appended ...ubuntu1 while for a stable release it should be ubuntu0.1 or ubuntu0.20.04.1
19:34 <rbasak> rafaeldtinoco: ah that is one, yes.
19:34 <rafaeldtinoco> rbasak: sysdig wireguard were uploaded in 2020 (beginning of)
19:35 <ddstreet> for focal the version technically should have been changed to ...ubuntu1.1 instead of ubuntu2, but that's ok
19:35 <ddstreet> version numbers are difficult minutae of the process
19:35 <mhcerri> ddstreet, you are right
19:35 <rbasak> Ah I didn't realise those two were DKMS.
19:35 <sil2100> They seem to be on the dkms packageset
19:36 <rafaeldtinoco> in that list, removing linux only uploads
19:36 <ddstreet> rbasak sil2100 i put a link to the packageset at the start of the topic
19:36 <rafaeldtinoco> we have sysdig, bcmwl, wireguard, etc
19:36 <rafaeldtinoco> it looks to me like a good set of examples
19:36 <rafaeldtinoco> of dkms uploads.. if we consider that packageset is small
19:36 <rafaeldtinoco> and uploads since xenial show experience
19:37 <rbasak> OK so with my apologies let me look again
19:37 <rafaeldtinoco> tku
19:38 <mhcerri> rbasak, I filtered some packages in the application page because it's hard to find them in udd because the majority of my uploads are kernels
19:39 <rbasak> mhcerri: thanks. I wanted to see a list of specifically *DKMS* package uploads, most recent first - and I saw linux-base and didn't realise wireguard and sysdig were DKMS.
19:41 <ddstreet> are we wrapped up on questions?
19:41 <rafaeldtinoco> mhcerri: why would I use ubuntu0~ or ubuntu0+ in versioning ? which is bigger ?
19:42 <mhcerri> rafaeldtinoco, + makes it bigger and ~ makes it smaller. so I would use ~ when I need to backport a package to an older ubuntu series
19:43 <ddstreet> any further q?
19:43 <rafaeldtinoco> im ok
19:44 <sil2100> All good here
19:44 <ddstreet> ok let's proceed to voting!
19:44 <ddstreet> #vote Marcelo Cerri DKMS upload rights application
19:44 <meetingology> Please vote on: Marcelo Cerri DKMS upload rights application
19:44 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
19:44 <ddstreet> #voters rbasak sil2100 rafaeldtinoco teward ddstreet
19:44 <meetingology> Current voters: ddstreet, rafaeldtinoco, rbasak, sil2100, teward
19:45 <rafaeldtinoco> +1
19:45 <meetingology> +1 received from rafaeldtinoco
19:46 <sil2100> +1
19:46 <meetingology> +1 received from sil2100
19:47 <rbasak> +1 I think you barely crossed the line in terms of regular DMB expectations for recent relevant experience and endorsements and need to unblock, but I think that given I'm on the fence, I'll accept your long previous track record. Please sync up with existing DKMS sponsors and uploaders before uploading.
19:47 <meetingology> +1 I think you barely crossed the line in terms of regular DMB expectations for recent relevant experience and endorsements and need to unblock, but I think that given I'm on the fence, I'll accept your long previous track record. Please sync up with existing DKMS sponsors and uploaders before uploading. received from rbasak
19:47 <ddstreet> +1 happy with endorsements and previous uploads, even if there is a months-long gap since the last significant number of uploads; the quality of actual code changes appears good which is the most important thing (to me); please do try to watch the small details of uploads though please
19:47 <meetingology> +1 happy with endorsements and previous uploads, even if there is a months-long gap since the last significant number of uploads; the quality of actual code changes appears good which is the most important thing (to me); please do try to watch the small details of uploads though please received from ddstreet
19:47 <mhcerri> rbasak, thanks!
19:47 <rafaeldtinoco> I like this approach also, doing a peer review before uploading.
19:48 <mhcerri> ddstreet, I will do. thank!
19:48 <ddstreet> #endvote
19:48 <meetingology> Voting ended on: Marcelo Cerri DKMS upload rights application
19:48 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
19:48 <meetingology> Motion carried
19:48 <ddstreet> congrats!
19:48 <rafaeldtinoco> mhcerri: congrats!
19:48 <rafaeldtinoco> and do peer reviews before uploads, its always good (we all do)
19:48 <mhcerri> thank you, everyone!
19:48 <mhcerri> rafaeldtinoco, I totally agree
19:49 <mhcerri> I will do for sure
19:49 <ddstreet> ok i have to step away in a minute, i think last thing we have is mailing list requests
19:49 <ddstreet> #topic Outstanding mailing list requests to assign
19:50 <mhcerri> let me know if you need any further action for me. and thanks again
19:50 <ddstreet> #subtopic https://lists.ubuntu.com/archives/devel-permissions/2021-April/001676.html
19:50 <ddstreet> mhcerri nope you're all good, thanks!
19:50 <ddstreet> rafaeldtinoco can you look at this one, i think it just needs pkgs added to openstack pkgset
19:50 <rafaeldtinoco> its mine!
19:50 <rafaeldtinoco> i did it before
19:50 <rafaeldtinoco> will do this one
19:50 <ddstreet> awesome
19:51 <ddstreet> #subtopic https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html
19:51 <ddstreet> rafaeldtinoco can you look at that also? i updated the pkgset in the stable releases, but i dont think it worked in hirsute
19:51 <rafaeldtinoco> ddstreet: ill check
19:52 <ddstreet> thanks
19:53 <ddstreet> ah i forgot to add action for someone to handle mhcerri addition to the pkgset team, anyone want that?
19:53 <rafaeldtinoco> i got my plate full with those 2
19:53 <rafaeldtinoco> :o)
19:53 <ddstreet> ack, i can take it
19:53 <rafaeldtinoco> tku
19:53 <ddstreet> #action ddstreet add mhcerri to dkms packageset team
19:53 * meetingology ddstreet add mhcerri to dkms packageset team
19:54 <ddstreet> #action rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-April/001676.html and https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html
19:54 * meetingology rafaeldtinoco look at https://lists.ubuntu.com/archives/devel-permissions/2021-April/001676.html and https://lists.ubuntu.com/archives/devel-permissions/2021-March/001635.html
19:54 <ddstreet> looks like next chair is sil2100 in 2 weeks
19:54 <ddstreet> #topic AOB
19:54 <ddstreet> anything else from anyone?
19:55 <rafaeldtinoco> tks for chairing ddstreet
19:55 <ddstreet> np!
19:55 <ddstreet> #endmeeting