15:00 <rbasak> #startmeeting Developer Membership Board
15:00 <meetingology> Meeting started at 15:00:04 UTC.  The chair is rbasak.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
15:00 <meetingology> Available commands: action, commands, idea, info, link, nick
15:00 <rbasak> #topic Review of previous action items
15:00 <rbasak> ddstreet edubuntu seed <-> pkgset (carried over)
15:01 <rbasak> rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:01 <rbasak> This one's done
15:01 <rbasak> rafaeldtinoco paperwork for paride permissions on serverdev and announce (done)
15:02 <rbasak> rafaeldtinoco paperwork for eickmeyer permissions on MOTU and announce (done)
15:02 <rbasak> So just need status from ddstreet please
15:02 <ddstreet> sorry need to carry that over please
15:03 <rbasak> #action ddstreet edubuntu seed <-> pkgset (carried over)
15:03 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
15:03 <rbasak> #topic Package Set/Per Package Uploader Applications
15:03 <rbasak> #subtopic Dave Jones -- raspi-common seed related PPU, 2021-03-08
15:03 <rbasak> Hello waveform!
15:03 <waveform> Greetings!
15:03 <sil2100> o/
15:03 <rbasak> #link https://wiki.ubuntu.com/DaveJones/PPUApplicationPi
15:03 <sil2100> I have something
15:04 <sil2100> So I see Dave applied for PPU, but I personally think he could try for core-dev as-is
15:04 <sil2100> Though hm, I see he's a bit low on endorsements
15:07 <waveform> I see you're trying to thwart my cunning plan for minimal responsibility?
15:07 <sil2100> But even with that, maybe it would make sense to consider him for core-dev and, if not getting enough votes, then re-vote for the PPU?
15:07 <sil2100> YES
15:07 <sil2100> ;)
15:08 <ddstreet> well waveform do you *want* to apply for core-dev?
15:08 <ddstreet> it's free to apply, and no penatly if we vote no :)
15:08 <rbasak> It will drag the meeting out longer though.
15:09 <ddstreet> but personally i do prefer applicants to at least request what level of access they actually want
15:09 <rbasak> (I don't mean to be negative; just laying it all out)
15:09 <waveform> ddstreet, it would make certain things easier but at the same time sil2100's absolutely going to drag me into +1 maintenance
15:09 <teward> (I'm here but late)
15:09 <rbasak> So it depends on if waveform wants to deal with core-dev applicant type questions today or not
15:10 <slashd> or we vote for the PPU and re-schedule him for coredev at next mtg (if interested) so it will give him time to get endorsement for the right application ?
15:10 <waveform> (not convinced I know what I'm doing on that side of things - not that that's stopped me in the past, but still I'm not going to go actively seeking things to go o.O at)
15:11 <rbasak> It sounds to me like you're not really prepared for a core dev application right now?
15:12 <rbasak> Wearing my chair hat for a moment, to make progress, we need to decide if we're going to consider a core dev application or not.
15:12 <waveform> slashd's proposal sounds good to me (I have little doubt after this sil2100 is going to whip me into gathering endorsements and re-submitting ;)
15:12 <rbasak> If waveform wants to positively affirm he'd like us to consider that, then we can, and then vote.
15:12 <rbasak> OK
15:12 <rbasak> So let's proceed with PPU only
15:13 <rbasak> Does anyone have questions for waveform for his PPU application?
15:14 * sil2100 has none for the PPU part
15:14 <rbasak> I should declare that I'm a personal friend of waveform's, so I intend to do my usual "abstain except to make quorum if everyone else is unanimous" thing.
15:15 <rbasak> If there are no questions, I guess we can move on to vote.
15:16 <slashd> no question here, I read the wiki page and I'm have everything I need to take a decision.
15:16 <rbasak> #vote Grant waveform PPU for  linux-firmware-raspi2, pi-bluetooth, rpi-eeprom, raspberrypi-userland (libraspberrypi0, libraspberrypi-bin), flash-kernel), and for u-boot
15:16 <meetingology> Please vote on: Grant waveform PPU for  linux-firmware-raspi2, pi-bluetooth, rpi-eeprom, raspberrypi-userland (libraspberrypi0, libraspberrypi-bin), flash-kernel), and for u-boot
15:16 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
15:16 <slashd> +1
15:16 <meetingology> +1 received from slashd
15:16 <sil2100> +1
15:16 <meetingology> +1 received from sil2100
15:16 <ddstreet> +1
15:16 <meetingology> +1 received from ddstreet
15:17 <rbasak> teward: ?
15:17 <teward> sorry cross-tasking today
15:17 <teward> +1
15:17 <meetingology> +1 received from teward
15:18 <teward> rbasak: sorry i'm half-pulled left and right for server stuff and work stuff
15:18 <rbasak> np, thanks
15:18 <rbasak> I think that's everyone here
15:18 <rbasak> #endvote
15:18 <meetingology> Voting ended on: Grant waveform PPU for  linux-firmware-raspi2, pi-bluetooth, rpi-eeprom, raspberrypi-userland (libraspberrypi0, libraspberrypi-bin), flash-kernel), and for u-boot
15:18 <meetingology> Votes for: 4, Votes against: 0, Abstentions: 0
15:18 <meetingology> Motion carried
15:18 <rbasak> Congrats waveform!
15:18 <slashd> Congrats waveform
15:18 <waveform> many thanks \o/
15:18 <sil2100> Congrats!
15:18 <rbasak> I can take the ACL and announcement actions - now that I can just do the TB end as well
15:18 <ddstreet> congrats!
15:19 <teward> https://en.wikipedia.org/wiki/HTTP_Strict_Transport_Security
15:19 <teward> oops sorry wrong window IGNORE
15:19 <teward> 50 windows here
15:19 <rbasak> #action rbasak to announce waveform's successful application
15:19 * meetingology rbasak to announce waveform's successful application
15:19 <waveform> sil2100, thanks - and yes, I'll start writing the next one... ;)
15:19 <rbasak> #action rbasak to add waveform's PPU ACL items
15:19 * meetingology rbasak to add waveform's PPU ACL items
15:19 <sil2100> YES PLEASE! ;)
15:19 <rbasak> #subtopic Rico Tzschichholz -- libreoffice PPU, 2021-03-08
15:20 <rbasak> ricotz: o/
15:20 <ricotz> hello :)
15:20 <ricotz> see https://wiki.ubuntu.com/ricotz/PPULibreofficeApplication :)
15:20 <rbasak> Thanks
15:20 <rbasak> #link https://wiki.ubuntu.com/ricotz/PPULibreofficeApplication
15:22 <rbasak> Does anyone have any questions for ricotz?
15:23 <ddstreet> none from me
15:23 <rbasak> I have a couple
15:23 <rbasak> On your application page you say "Canonical offered me to take over the official maintainer-ship of the LibreOffice package in Ubuntu, which will deepen my involvement even further". What's your understanding of "maintainership" as it applies to packages in Ubuntu, as an Ubuntu developer?
15:24 <sil2100> I have a 'standard' question
15:25 <ricotz> rbasak, it means I am packaging it and working together with the debian maintainer
15:25 <ricotz> rbasak, this is contract work for Canonical
15:26 <rbasak> ricotz: what would be your position if a non-Canonical Ubuntu developer made an upload to the libreoffice package in Ubuntu, or if they proposed some changes that you don't like?
15:28 <ricotz> rbasak, I would like to get some notification and maybe asked for reviewing the changes before an upload
15:28 <ricotz> there are usually no-change uploads for library transitions which would be of no concern
15:29 <sil2100> My 'standard' question: when uploading libreoffice to the devel series, what freezes should you take into consideration before performing the upload?
15:29 <rbasak> ricotz: what if you found yourselves at an impasse - a non-Canoncial but established Ubuntu developer wants to change something one way, and you want it changed a different way? How would you expect to resolve the conflict?
15:30 <ricotz> sil2100, I am working close together with the desktop team, and I am discussion new version uploads before doing so, same will apply for bug fixes
15:31 <ricotz> sil2100, so I am looking the development schedule, e.g beta, RC deadlines
15:32 <ricotz> rbasak, if the change proves to be equally efficient I would go with mine, but this seems to be a decision needs to be made case-by-case
15:33 <teward> ricotz: here's a hypothetical I want to pose for you, and it'll take a few messages to get it out so i would like everyone to hold off messages for a few moments while I write this out.
15:33 <ricotz> rbasak, I am usually following/proposing changes from/to debian
15:33 <rbasak> OK, thanks. I have no further questions.
15:34 <teward> I, an established Ubuntu Developer with core-dev privileges, am currently digging through the bug lists, and come across an unfixed High level bug that has patches prepped for it, and as a sponsor I sponsor the updates into the current dev release.  This affects a packate in your 'bailywick' currently.  It fixes a 'broken feature' and was fully pulled from upstream commits on the issue.
15:34 <teward> This is uploaded, accepted, and lands in the repository.
15:34 <teward> However, it was not reviewed/vetted by you.
15:34 <teward> How would you respond in this case?
15:34 <teward> assuming of course I"ve done reviews, testing, etc. that are normal for bug fixes to land.
15:35 <teward> (as I do with anything I sponsor)
15:36 <ricotz> teward, in my understand if a source package refers to a packaging git repository, such a change needs to be offered as merge request
15:37 <teward> ricotz: assume per the hypothetical that me or someone else has JFDI and done a direct-to-repos push and not a git merge request (because sometimes a major feature breaking is handled by the Sponsors and some of us who may not be privy to all the repos for packaging and such would potentially push-to-repos
15:37 <ricotz> so imho the core-dev didn't follow the usual advise
15:37 <teward> rather than push-to-git or merge request
15:37 <teward> ricotz: stay within the confines of the hypothetical please.  Assume in the case that ti's not me but anyone with upload privs who **are unaware of all the packages with git repos for packaging**
15:38 <teward> which, TO BE FAIR, happens often.
15:38 <slashd> ricotz, are you (or plan to) subscribe to all bugs in libreoffice in Ubuntu (launchpad) ?
15:38 <teward> (i stepped on Kubuntu's toes accidentally pushing an update for something that unbroke Lubuntu/Calamares that needed kpmcore, whoops, but they were watchful and poked me for the future)
15:39 <ricotz> teward, if I notice I will contact the uploader to discuss this
15:40 <ricotz> slashd, I am already subscribed for some time
15:42 <rbasak> Any more questions for ricotz?
15:43 <teward> not from me
15:43 <slashd> I'm good
15:44 <ddstreet> none from me
15:44 <sil2100> Good here
15:44 <rbasak> #vote Grant ricotz PPU for libreoffice
15:44 <meetingology> Please vote on: Grant ricotz PPU for libreoffice
15:44 <meetingology> Public votes can be registered by saying +1, -1 or +0 in channel (for private voting, private message me with 'vote +1|-1|+0 #channelname')
15:44 <rbasak> -1 reasons to follwo
15:44 <meetingology> -1 reasons to follwo received from rbasak
15:45 <slashd> +0
15:45 <meetingology> +0 received from slashd
15:46 <sil2100> +1
15:46 <meetingology> +1 received from sil2100
15:47 <teward> -1 reasons to follow as well, after rbasak posts theirs.
15:47 <meetingology> -1 reasons to follow as well, after rbasak posts theirs. received from teward
15:47 <ddstreet> +1 I'm happy with strong endorsements from existing desktop team members, and I have no reason to think future direct uploads would be any different from current sponsored uploads
15:47 <meetingology> +1 I'm happy with strong endorsements from existing desktop team members, and I have no reason to think future direct uploads would be any different from current sponsored uploads received from ddstreet
15:48 <ddstreet> so we're at a tie, of 0?
15:48 <rbasak> #endvote
15:48 <meetingology> Voting ended on: Grant ricotz PPU for libreoffice
15:48 <meetingology> Votes for: 2, Votes against: 2, Abstentions: 1
15:48 <meetingology> Motion carried
15:48 <teward> as it stands, the vote does not pass, unless we want to poll for rafaeldtinoco via mailing list for their vote.
15:49 <teward> i could poke tsimonq2 but he's... not available for another 12 hours.
15:49 <rbasak> Right - it depends on the others
15:49 <rbasak> Here's my reasoning for my -1 vote.
15:49 <rbasak> I think you're going to find yourself in a different position given the nature of your involvement with libreoffice, Canonical and Ubuntu. To navigate this well, I think you need to have a good understanding of how Ubuntu development teams interact and how authority in Ubuntu is delegated. I think your understanding of this is mistaken in a few places.
15:49 <rbasak> It's difficult for me to cover this in detail here without having a longer conversation. I think maybe we need to do that outside this meeting, and perhaps include the wider Ubuntu Desktop Team. I'd be happy to be involved, and I do appreciate your efforts in helping with libreoffice packaging in Ubuntu. Once this matter is resolved, I would welcome your reapplication.
15:50 <rbasak> FWIW, it might well be that some members of the Desktop team have misunderstood this too
15:50 <rbasak> But only your application was being considered here, so this might seem a bit unfair. Sorry about that.
15:50 <rbasak> Let's get it resolved :)
15:51 <rbasak> Which, FWIW, I think we should do anyway, regardless of the outcome of your application, which remains unresolved today as it needs an answer for the two other absent DMB members
15:51 <sil2100> Let's try to reach out to them this week
15:51 <ricotz> rbasak, I see, that is unfortunate for now, I am looking forward to a final decision
15:51 <rbasak> +1
15:52 <teward> My reasons, operating strictly on the DMB requirements for review of an application:
15:52 <teward> I do not feel the applicant has an understanding at large of how Ubuntu Packaging is *not* necessarily driven by Canonical tasks.  My current interpretation of their response to Robie's message is "I'm paid to do work on this package as contract work and need upload rights" which I further extend to "I'm paid to do this and that fact is more important than all because Canonical pays me for this".  The larger universe of **Ubuntu
15:52 <teward> Development** is NOT driven by the "Canonical Takes All" approach, as Canonical development alone does not drive Ubuntu package maintainership.
15:52 <teward> Further, their response to the hypothetical I posed is basically "well the core dev is supposed to make a merge request to the packaging git, which means that if coredev uploaded direct to repos they did it wrong".  This mindset of behavior is not conducive to working well in the Ubuntu Project at large because this happens regularly, because **packaging repositories are not readily documented in one central place for coredevs or
15:52 <teward> sponsors to look at for merge requests**.  Secondly, in the broader universe, there are packages with gits that sit *outside* Launchpad for packaging gits, and therefore cannot be 'merge requested' by developers.
15:52 <teward> Also, in support and echo of Robie's comments, I would strongly urge that the Desktop Team get in touch with Robie, as I believe that a different position will be found for you in this matter.  The Desktop Team and Canonical employment as well as contract work on a given issue does not supersede the general Ubuntu Development rules and mindset, which is different than the Canonical paid position mindsets and is handled independently of
15:52 <teward> Canonical contracts.
15:52 <teward> bah damned IRC splits.
15:52 <teward> that's my reasons.
15:53 <teward> ... aaaaaaand Exchange server is exploding at FT job.  *openly cusses out Exchange as a mail server platform, and splits attention 75%-25% job to DMB because he has to fix the broken evil*
15:53 <slashd> I took into consideration your strong endorsement, but I'm on the same page as rbasak's rationale above, hence why I +0
15:53 <rbasak> I think my summary would be: we can do this, but first we should make sure everyone clearly understands the division of roles, responsibilities and authority.
15:53 <teward> rbasak: sil2100: I suggest we reach out via internal lists to tsimonq2 and rafaeldtinoco and ask them to review and vote via the list.
15:54 <teward> for the current vote
15:54 <teward> and a discussion needs to happen with the teams, etc. on this matter
15:54 <rbasak> Yep
15:54 <rbasak> Anything else on this topic before we move on?
15:54 <ricotz> teward, hmm, I guess this I came accross the wrong way from my side, of course I am not making decisions on my own and am discussing them with other packagers
15:55 <teward> ricotz: my opinion stands.  I'm happy to reevaluate at a later date, but that requires the discussion rbasak has proposed to happen first
15:55 <rbasak> FWIW, I haven't taken that from this discussion today.
15:55 <ricotz> teward, I can see the burden it is to sponsor libreoffice caused by its size and complexity
15:55 <teward> and i agree with rbasak, I ahven't taken that from your statements today.
15:55 <rbasak> I have no reason to think that you wouldn't try and resolve things by reaching consensus first.
15:55 <rbasak> However I think it's important that you understand the fallback position from that, and I don't think you do.
15:55 <teward> i'm also going to put one additional echo into this:
15:55 <teward> what if the security team makes this mistake of not merge requesting
15:56 <teward> and simply pushes a security patch?
15:56 <teward> from THAT perspective you aren't going to argue with the Security Team, you're just going to merge the changes into yoru repos accordingly
15:56 <teward> because IIRC the SEcurity Team is one of the teams you don't really... argue much with... when a critical security patch goes out :P
15:57 <teward> just saying
15:57 <ricotz> correct, a CVE upload is another story for itself
15:57 <teward> ricotz: but carries the same weight/problem as if a core dev or someone uploaded something to -updates
15:57 <teward> wherein the point still stands: i think your thinking in the matter needs reviewed, because the way you responded to the initial hypothetical appeared argumentative overall
15:58 <teward> and not conducive for Ubuntu Development
15:58 <teward> as stated in my reasons (which stand and are not changing in this meeting at this time)
15:58 <teward> ... unrelated: i'm here 75% again.  job just needed Exchange kicked >.<
15:59 <rbasak> OK. Shall we move on? :)
15:59 <rbasak> #topic Outstanding mailing list requests to assign
15:59 <ricotz> thank you for your time
15:59 <rbasak> I only see the request from Alex Murray which is a thread in progress
16:00 <rbasak> I'll take the action to get a resolution on that (meeting venue/time agreed)
16:00 <rbasak> #action rbasak to resolve Alex's request for an alternate meeting venue/time for his application
16:00 * meetingology rbasak to resolve Alex's request for an alternate meeting venue/time for his application
16:00 <rbasak> #topic Open TB bugs
16:00 <rbasak> #info No open TB bugs
16:00 <rbasak> #topic Any other business
16:00 <ddstreet> o/
16:00 <rbasak> Does anyone have anything to raise?
16:01 <ddstreet> suggestion: maybe we should list the entire schedule of meeting times for each year instead of just the next 4 mtgs?
16:01 <ddstreet> in light of the time mix-up
16:01 <rbasak> Sure
16:01 <rbasak> Do I hear you volunteering? :)
16:01 <rbasak> There's also the fridge calendar
16:01 <ddstreet> ack, i can update it if there are no objects
16:01 <ddstreet> objections
16:02 <ddstreet> i'm not sure if i'm able to edit the fridge calendar, i can check
16:02 <rbasak> #action ddstreet to reduce the scope of meeting scheduling mistakes
16:02 * meetingology ddstreet to reduce the scope of meeting scheduling mistakes
16:02 <rbasak> (I'm deliberately leaving that open for you decide how to achieve that ;)
16:02 <ddstreet> thanks :)
16:02 <rbasak> Anything else?
16:03 <rbasak> #endmeeting