20:03 <vorlon> #startmeeting
20:03 <meetingology> Meeting started at 20:03:42 UTC.  The chair is vorlon.  Information about MeetBot at https://wiki.ubuntu.com/meetingology
20:03 <meetingology> Available commands: action, commands, idea, info, link, nick
20:03 <vorlon> #topic Apologies
20:04 <vorlon> I don't see any on the mailing list
20:04 <sil2100> I'd like to apologise for missing the last meeting
20:04 <vorlon> :)
20:04 <sil2100> Was uh, a weird week
20:04 <vorlon> #topic Action review
20:05 * vorlon Wimpress To follow-up on-list with design review to address MATE Boutique security/consent concerns.
20:05 <vorlon> Wimpress: ^^ is there anyone else from Ubuntu MATE who could take this up with us?
20:06 <vorlon> #action Wimpress To follow-up on-list with design review to address MATE Boutique security/consent concerns.
20:06 * meetingology Wimpress To follow-up on-list with design review to address MATE Boutique security/consent concerns.
20:06 * vorlon formal ratification of third party seeded snap security policy, depends on:
20:06 * vorlon vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
20:06 <vorlon> which is carry-over for me
20:06 <vorlon> #action vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
20:06 * meetingology vorlon to circle around with store, snapcraft, et all, and revise the snap source revision policy to be more clear with regards to rebuildability and GPL compliance.
20:06 * vorlon vorlon to reply to seeded snap upload permissions question on list
20:06 <vorlon> also carry-over
20:06 <vorlon> #action vorlon to reply to seeded snap upload permissions question on list
20:06 * meetingology vorlon to reply to seeded snap upload permissions question on list
20:06 * vorlon xnox to start a draft summarizing the OEM archive portion of the meeting which vorlon and mdeslaur will review, edit, and ratify before we move on to figuring out the next step ([2/3 subquorum required if one of us slacks, to avoid holding up the process])
20:07 <vorlon> xnox: ^^ we're still waiting on this from you, can you make some time for it please?
20:07 * vorlon sil2100 to follow up with xnox about OEM archive documentation
20:07 <vorlon> sil2100: have you? :)
20:07 <sil2100> Yes
20:07 <vorlon> cool - any update from xnox?
20:08 <sil2100> So I poked xnox about that and well, got what we currently have - but it's not in any discoverable place
20:08 <sil2100> Basically xnox pointed me at the ML posts:
20:08 <cyphermox> o/
20:08 <sil2100> https://lists.ubuntu.com/archives/technical-board/2020-January/002478.html
20:08 <sil2100> https://lists.ubuntu.com/archives/technical-board/2019-August/002456.html
20:08 <vorlon> right, a mailing list post is definitely not a draft, so...
20:09 <sil2100> Now the question is: do we want to make sure this is saved somewhere on a wiki? Maybe we should decide on where this should go?
20:09 <sil2100> Wiki, discourse?
20:09 <vorlon> given that this is supposed to be a policy, I think it belongs in the wiki (with all the othesr)
20:09 <sil2100> I can continue poking xnox or actually taking all that info there and nicely fitting it on a wiki
20:09 <sil2100> *take
20:09 <vorlon> sil2100: do you want to take the action of a first draft then?
20:10 <sil2100> vorlon: yeah, I can o/
20:10 <vorlon> sweet
20:10 <vorlon> #action sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
20:10 * meetingology sil2100 to start a draft summarizing the OEM archive portion of the meeting which xnox and TB will review, edit, and ratify before we move on to figuring out the next step
20:10 * vorlon mdeslaur to follow up on xnox's track clarification post to the list from 2020-08-12
20:10 <sil2100> I suppose we don't really have a wiki path for OEM stuff right now, right?
20:10 <vorlon> mdeslaur: ?
20:10 <vorlon> sil2100: no, but this is about Ubuntu technical policy, not about "OEM"
20:11 <mdeslaur> he said the track clarification was already added to the wiki, so it's completed
20:11 <vorlon> mdeslaur: thanks
20:11 <sil2100> vorlon: true that o/
20:11 <vorlon> #done mdeslaur to follow up on xnox's track clarification post to the list from 2020-08-12
20:12 * vorlon vorlon to update the list for Thunderbird update (https://irclogs.ubuntu.com/2021/01/26/%23ubuntu-meeting.html#t20:22)
20:12 <vorlon> carry-over, I'll get it done this week I swear
20:12 <vorlon> #action vorlon to update the list for Thunderbird update (https://irclogs.ubuntu.com/2021/01/26/%23ubuntu-meeting.html#t20:22)
20:12 * meetingology vorlon to update the list for Thunderbird update (https://irclogs.ubuntu.com/2021/01/26/%23ubuntu-meeting.html#t20:22)
20:12 * vorlon rbasak to write up proposal for how to do decision documentation for the future
20:12 <vorlon> rbasak: I think this might be done?
20:12 <rbasak> I posted that to the list.
20:12 * vorlon nods
20:12 <sil2100> I saw an e-mail sent out, yes
20:12 <vorlon> #done rbasak to write up proposal for how to do decision documentation for the future
20:12 <sil2100> rbasak: thanks o/
20:12 <vorlon> excellent
20:12 <rbasak> Any feedback or further action from that?
20:14 <vorlon> none from me
20:14 <vorlon> no new agenda items on https://wiki.ubuntu.com/TechnicalBoardAgenda, so
20:14 <vorlon> #topic Scan the mailing list archive for anything we missed (standing item)
20:14 * rbasak has one AOB item
20:15 <vorlon> we were cc:ed on a question from teward to sabdfl; but that's only to keep us in the loop and I don't see any action there https://lists.ubuntu.com/archives/technical-board/2021-February/002543.html
20:15 <rbasak> Agreed - I asked Thomas and he confirmed no action is expected from the TB at the moment.
20:16 <vorlon> and Laney asked about documentation of LTS status which sil2100 responded to
20:16 <vorlon> sil2100: do you think we *should* have a more specific place for documenting LTS status?
20:16 <vorlon> the release notes are kind of late to be gathering this info
20:17 <sil2100> hm, we do normally always reach out to flavors beforehand whenever an LTS is being worked on per policy
20:17 <vorlon> yes, but where does this get documented between the time you reach out to flavors, and the time the release notes start being created?
20:17 <sil2100> I don't think so, no
20:19 <sil2100> I'm looking at possible places where this could be actually documented better, I see we had an https://wiki.ubuntu.com/LTS wiki page with some LTS info
20:19 <sil2100> But anyway, maybe it's enough to just put that info in the release tracking thread whenever an LTS is worked on? Or hm, maybe better, on the release schedule thread?
20:20 <sil2100> Since on the release schedule threads we already have additional info like when transitions are planned and who is working on which milestone
20:20 <vorlon> what's the release tracking thread?
20:20 <sil2100> Like, you know, one of these: https://discourse.ubuntu.com/t/groovy-gorilla-20-10-release-status-tracking/18647
20:20 <sil2100> Since we're tracking release checklist items there, it's created relatively early
20:20 <sil2100> But I think maybe the release schedule would be actually a better idea
20:21 <vorlon> ah
20:21 <sil2100> Since it fits conceptually as well, since support status means when point releases might be prepared and for who
20:21 <vorlon> well I think I would leave it up to you whether you think there should be further action here
20:22 <sil2100> I'll bring it up with the release team and we'll figure something out, but I'm leaning towards the release schedule indeed
20:22 <sil2100> It's easily discoverable then
20:23 <vorlon> #action sil2100 to discuss with release team where to document decisions about LTS status of flavors (prior to release notes creation late in cycle)
20:23 * meetingology sil2100 to discuss with release team where to document decisions about LTS status of flavors (prior to release notes creation late in cycle)
20:23 <vorlon> #topic Check up on community bugs (standing item)
20:23 <vorlon> #link https://bugs.launchpad.net/ubuntu-community/+bugs?field.assignee=techboard
20:23 <vorlon> zaro boogs
20:23 <vorlon> #aob
20:23 <vorlon> rbasak: you had something?
20:23 <vorlon> #topic aob
20:24 <rbasak> I released the Thunderbird update today to Focal.
20:24 <rbasak> oSoMoN asked about doing the same for Bionic, but we hadn't discussed that previously.
20:24 <rbasak> I trust it'll be fine on the same basis as the Focal update, but I thought I'd check.
20:25 <mdeslaur> I think only one of the problematic packages was in bionic when I checked
20:25 <vorlon> seems ok, we didn't make any focal-specific decisions there so as long as the revdep situation is similar?
20:25 <mdeslaur> I believe it's fine for bionic also
20:25 <rbasak> I haven't checked the rdep situation
20:25 <vorlon> but I guess you would as part of SRU team due diligence?
20:25 <rbasak> Yes I'll check
20:26 <rbasak> How about we approve it on condition the SRU consider the situation effectively the same, and we'll consult the TB if we consider there to be any substantial difference?
20:26 <vorlon> ok then it seems alright to me; if you find any new wrinkles for bionic we can discuss on list, but otherwise I think it follows from the discussion we already had about focal?
20:26 <cyphermox> yes
20:26 <rbasak> +1
20:27 <rbasak> Thanks
20:27 <vorlon> excellent
20:27 <vorlon> #topic Select a chair for the next meeting (next from https://launchpad.net/~techboard/+members)
20:27 <vorlon> #info next chair will be sil2100, with mdeslaur as backup
20:27 <mdeslaur> ack
20:27 <sil2100> o/
20:27 <vorlon> straightforward :)
20:27 <vorlon> anything else?
20:27 <mdeslaur> nope
20:28 <sil2100> Nothing here
20:28 <vorlon> #endmeeting