15:03 <rafaeldtinoco> #startmeeting Ubuntu Developer Membership Board Meeting
15:03 <meetingology> Meeting started Mon Jan 11 15:03:14 2021 UTC.  The chair is rafaeldtinoco. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:03 <rafaeldtinoco> chair rafaeldtinoco
15:03 <rafaeldtinoco> #chair rafaeldtinoco
15:03 <meetingology> Current chairs: rafaeldtinoco
15:03 <rafaeldtinoco> #topic Review of previous action items
15:04 <rafaeldtinoco> ddstreet edubuntu seed <-> pkgset (carried over)
15:04 <ddstreet> carry over please
15:04 <rafaeldtinoco> #action ddstreet edubuntu seed <-> pkgset (carried over)
15:04 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
15:04 <rafaeldtinoco> ddstreet to update the KnowledgeBase with details regarding creation of new packagesets
15:05 <ddstreet> yep i believe that's done
15:05 <rafaeldtinoco> tku! ... next one
15:05 <rafaeldtinoco> ddstreet to add DKMS packages to the new kernel-dkms packageset
15:05 <ddstreet> yep that is done
15:05 <rafaeldtinoco> perfect! moving on..
15:05 <rafaeldtinoco> rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:06 <teward> derp
15:07 <teward> o/
15:07 <teward> (I am here!)
15:07 <rafaeldtinoco> teward: o/
15:07 <rbasak> Carry over please
15:07 <rbasak> I'll get to it very soon now I promise
15:07 <rafaeldtinoco> #action rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:07 * meetingology rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:07 <teward> sorry was communicating privately with rbasak on a few things (and stabbing someone because one of my employers service providers has an email breach)
15:07 <rafaeldtinoco> no worries, tku
15:08 <rafaeldtinoco> sil2100: yours are marked as done
15:08 <rafaeldtinoco> just referencing here for documentation
15:08 <rafaeldtinoco> sil2100 to add slyon to core-dev (done)
15:08 <rafaeldtinoco> sil2100 to announce slyon's successful application (done)
15:08 <rafaeldtinoco> that gives us next top
15:08 <rafaeldtinoco> topic
15:08 <rafaeldtinoco> #topic Package Set/Per Package Uploader Applications
15:08 <rafaeldtinoco> today we have 2 applicants
15:08 <rafaeldtinoco> paride: hello
15:09 <rafaeldtinoco> paride: would you mind introducing yourself to the group ?
15:09 <paride> hello Rafael! sure.
15:10 <teward> #link https://wiki.ubuntu.com/ParideLegovini/UbuntuServerDeveloperApplication
15:10 <paride> I'm Paride Legovini, longtime Linux (Debian/Ubuntu) user located in Italy. I'm currently part of the Ubuntu Server team where I work as the QA engineer.
15:10 <teward> #chair teward
15:10 <meetingology> Current chairs: rafaeldtinoco teward
15:10 <paride> My application page: https://wiki.ubuntu.com/ParideLegovini/UbuntuServerDeveloperApplication LP page: https://launchpad.net/~paride
15:10 <teward> (sorry bout that rafaeldtinoco just wanted to assist :P )
15:11 <rafaeldtinoco> teward: no reason to be sorry for
15:11 <rafaeldtinoco> alright, let's have some minutes for members to read your application (if not already) and ask you some questions
15:12 <paride> I've been involved with FLOSS development for several years now and began working with the Server Team in 2019. As part of my QA role I perform several different tasks, mostly maintaining automation of stuff, general quality checking, ISO testing and so on
15:12 <paride> I also participate in the triage process, bugfix work and merging of packages from Debian
15:13 <paride> I've also been involved in the Ubuntu Release process starting from 19.04, participating to the release "sprints" in person and lately remotely
15:14 <paride> My background before starting to work as Ubuntu fulltime is mostly in the academia (I studies physics and then geophysics), where I performed mostly IT related work for research groups
15:15 <paride> I am Debian Developer, which came handy from time to time for my Ubuntu work, and now I'm looking forward formally joining Ubuntu too :)
15:15 <rafaeldtinoco> thanks paride
15:15 <rbasak> I'm a colleague of Paride's, so I intend to step back and let others drive the interview.
15:15 <rafaeldtinoco> rbasak: tku. I'm in the same situation, so I'll open for questions of other DMB members
15:16 <rafaeldtinoco> sil2100: teward: ddstreet: go ahead whenever you're ready.
15:18 <teward> my attention on this is only 50% at the moment - active netsec issues @ workplace
15:18 <teward> but i have no questions at this time
15:18 <teward> sil2100: ddstreet: floor's yours
15:18 <ddstreet> paride most of your (listed) work so far has been on the devel release, have you done much sru work?
15:19 <sil2100> No questions here o/
15:20 <paride> ddstreet, I didn't do SRU uploads myself, however I've been involved in the cloud-init SRU process for the past few uploads, collecting test results to fill in cloud-init SRU bugs
15:22 <ddstreet> thanks, no more q from me
15:22 <paride> In general I did participate to sru *processes*, but without driving the process itself. Also as part of my triage process I did gave feedback on the possibility of SRUing a fix for the bug
15:22 <rafaeldtinoco> ddstreet: thank you
15:22 <rafaeldtinoco> are we ready to vote ?
15:23 <ddstreet> i'm ready
15:23 <rafaeldtinoco> #vote paride, Ubuntu Server Developer pkgset application
15:23 <meetingology> Please vote on: paride, Ubuntu Server Developer pkgset application
15:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:23 <rafaeldtinoco> #votesrequired 4
15:23 <meetingology> votes now need 4 to be passed
15:24 <ddstreet> +1 light on sru work, but i'm happy with endorsements and existing work
15:24 <meetingology> +1 light on sru work, but i'm happy with endorsements and existing work received from ddstreet
15:25 <teward> +1
15:25 <meetingology> +1 received from teward
15:25 <sil2100> +1 good endorsements + I have worked with Paride during release weeks for both devel and stable series and I was always happy with his work, so I'm confident that he'll do good with upload rights as well
15:25 <meetingology> +1 good endorsements + I have worked with Paride during release weeks for both devel and stable series and I was always happy with his work, so I'm confident that he'll do good with upload rights as well received from sil2100
15:26 <rbasak> Of everyone here, that's all the non-colleague DMB members voted I think?
15:26 <rafaeldtinoco> +1 (after all other votes). I would recommend more merges to paride so he can apply to coredev in a medium future
15:26 <meetingology> +1 (after all other votes). I would recommend more merges to paride so he can apply to coredev in a medium future received from rafaeldtinoco
15:26 <rbasak> So since they're all unanimous, I'll also provide a +1 to make quorum
15:26 <rbasak> +1
15:26 <meetingology> +1 received from rbasak
15:26 <rafaeldtinoco> perfect
15:26 <rafaeldtinoco> #endvote
15:26 <meetingology> Voting ended on: paride, Ubuntu Server Developer pkgset application
15:26 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:26 <meetingology> Motion carried
15:27 <rafaeldtinoco> paride: congrats !
15:27 <paride> yay!! thanks!
15:27 <ddstreet> congratulations!
15:27 <rafaeldtinoco> who can set him up ?
15:27 <rafaeldtinoco> me ?
15:27 <rafaeldtinoco> ok
15:27 <paride> also thanks for the feedback on the SRU/merges work
15:28 <rafaeldtinoco> #action rafaeldtinoco to add paride to serverdev and announce
15:28 * meetingology rafaeldtinoco to add paride to serverdev and announce
15:28 <rafaeldtinoco> ok, we still have another application
15:28 <rafaeldtinoco> Eickmeyer: ping
15:28 <Eickmeyer> o/
15:28 * Eickmeyer here, sleepy as it's early morning
15:28 <rafaeldtinoco> Eickmeyer: could you introduce your self to the crew ?
15:28 <rafaeldtinoco> #link https://wiki.ubuntu.com/Eickmeyer/MOTUApplication
15:29 <Eickmeyer> rafaeldtinoco: Sure.
15:30 <Eickmeyer> Hi everyone. I'm Erich Eickmeyer, leader of the Ubuntu Studio flavor, also member of the Ubuntu Community Council. I've been working with Ubuntu Studio since 2018 and became a council member in October, and was recently hired by MindShareManagement as their User Experience manager for the Kubuntu Focus line of laptops.
15:30 <Eickmeyer> My background prior to involvement in Ubuntu was in Audio/Video production and photography as well as customer service.
15:31 <Eickmeyer> My MOTU application is noted above, and my LP page is https://launchpad.net/~eeickmeyer
15:31 <rafaeldtinoco> thank you Eickmeyer !
15:31 <rafaeldtinoco> I'll give others some mins so they can read your application.
15:32 <rafaeldtinoco> DMB, please feel free to drop questions as needed.
15:33 <teward> I've worked a lot with Erich so i'm going to step back and let the rest of the DMB drive the interview.
15:33 <teward> (sorry i got a call from the CEO and had to take it - being the IT Security Guy at work is a... well, big thing xD)
15:34 <rafaeldtinoco> teward: alright, good luck =) stay close
15:34 <teward> yup
15:34 <teward> (I'm work from home - i ain't going anywhere xD)
15:37 <ddstreet> Eickmeyer it seems like most of your uploads are in the devel series, and not much SRU work, is that right?
15:37 <Eickmeyer> ddstreet: Not completely correct. There are several uploads I've done for SRU work, as sil2100 could probably tell you. :)
15:38 <Eickmeyer> With my UbuntuStudio packageset, I've even sponsored an SRU or two.
15:40 <rafaeldtinoco> Eickmeyer: could you point me out a diff of one of your most challenging uploads ? (one you feel proud about)
15:40 <Eickmeyer> rafaeldtinoco: Let me see what I can find.
15:43 <Eickmeyer> rafaeldtinoco: Having difficulty, but there's one for rapid-photo-downloader that basically required an interim upload even though the upstream developer, who filed the SRU, wanted the complete next version which had too many new features to qualify for an SRU.
15:43 <Eickmeyer> So we uploaded an interim version which fixed a crash in the application.
15:44 <Eickmeyer> rafaeldtinoco: Here's the diff: https://launchpad.net/ubuntu/+archive/primary/+files/rapid-photo-downloader_0.9.22-0ubuntu1_0.9.23a1-0ubuntu0.20.04.1.diff.gz
15:44 <rafaeldtinoco> Eickmeyer: thank you!
15:45 <rafaeldtinoco> https://bugs.launchpad.net/ubuntu/+source/rapid-photo-downloader/+bug/1873944
15:45 <ubottu> Launchpad bug 1873944 in rapid-photo-downloader (Ubuntu Groovy) "[SRU] Upgrade rapid-photo-downloader to version 0.9.23a1" [High,Fix released]
15:48 <sil2100> Eickmeyer: I see that your appliacation only has one endorsement - is there any reason for that?
15:48 <Eickmeyer> sil2100: Just lack of people available. I put the word out about two weeks ago.
15:49 <rafaeldtinoco> EOY is not a good time for endorsements =).. anyway I could add there that I have ran pkgset changes script many times because of Eickmeyer
15:50 <rafaeldtinoco> he has been adding packages to his seeds very actively lately
15:51 <ddstreet> Eickmeyer follow up q on that bug, i see it was rejected at first, and then reuploaded and then approved, was there discussion between you and any of the sru members before you reuploaded? i dont see any discussion in the bug comments
15:52 <Eickmeyer> ddstreet: Myself and bdmurray had some conversations in #ubuntu-release on how to proceed.
15:52 <ddstreet> ok excellent thanks
15:54 <Eickmeyer> I'll put this out there since it was only last week: I uploaded a fix to mate-optimus (a dgpu/igpu switching applet for all DEs) that had an incorrect call for KDE Plasma to logout which didn't allow for saving the current session. The fix was very easy.
15:54 <Eickmeyer> It's in the ubuntustudio packageset since graphics performance is something Studio users can benefit from.
15:55 <RikMills> sil2100: I would have done a full endorsement, but time was not my friend
15:56 <sil2100> RikMills: thanks!
15:56 * sil2100 has no other questions
15:56 <rbasak> Eickmeyer: have you had a package stuck in proposed before?
15:57 <Eickmeyer> rbasak: agordejo got stuck recently due to a FTBFS for itself due to a FTBFS for nuitka, which has since resolved with a new version of nuitka. I currently have ubuntustudio-meta stuck due to needing riscv64 builds removed from it, pinged #ubuntu-release to have that resolved, will ping again today.
16:00 <rafaeldtinoco> ddstreet: are you good with questions ?
16:00 <rafaeldtinoco> i know sil2100 is
16:00 <ddstreet> yep no more q from me
16:00 <rafaeldtinoco> ok
16:00 <rafaeldtinoco> no more questions from me either
16:00 <rafaeldtinoco> rbasak: let me know when you're good pls
16:00 <rafaeldtinoco> (no rush, take your time)
16:02 * ddstreet quick coffee refill
16:02 <teward> ddstreet: bring me some :P
16:02 * Eickmeyer notes that teward typically drinks coffee by the gallon
16:02 <teward> Eickmeyer: 10-gallon drum now.
16:02 <teward> (sorry for ot divergence)
16:03 <Eickmeyer> Yikes. XD
16:04 * ddstreet back
16:04 <rbasak> Eickmeyer: I see many -0ubuntu1 packages in Ubuntu
16:04 <rbasak> Do you have any plans to integrate with Debian?
16:05 <rbasak> What's the split between packages you maintain that are only in Ubuntu, and packages that have deltas against Debian?
16:05 <Eickmeyer> rbasak: Some of that has happened organically (lsp-plugins, for instance, was taken upstream early last year), and I do watch the Debian mulitmedia lists frequently as part of that team.
16:05 <rbasak> (I'm not saying that these are bad or good, just trying to understand)
16:06 <Eickmeyer> The packages that have deltas against Debian are typically quick fixes or patches past Feature Freeze. When possible, I try to sync from Debian.
16:07 <Eickmeyer> For example: for the mate-optimus delta, again, that was a quick fix that I've got an upstream PR in on, which will invalidate that patch I made for the Ubuntu version.
16:08 <Eickmeyer> And while it's a pre-FF fix, development on mate-optimus is slow.
16:09 <Eickmeyer> Most likely with Ross Gammon's help, I'll be able to do more with Debian.
16:10 <rbasak> OK thanks
16:10 <rbasak> I'm ready to vote
16:10 <rafaeldtinoco> alright
16:10 <rafaeldtinoco> thanks rbasak
16:11 <rafaeldtinoco> #vote Eickmeyer MOTU motion
16:11 <meetingology> Please vote on: Eickmeyer MOTU motion
16:11 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
16:11 <rafaeldtinoco> #votesrequired 4
16:11 <meetingology> votes now need 4 to be passed
16:13 <rbasak> +1
16:13 <meetingology> +1 received from rbasak
16:13 <rbasak> I'm mainly swayed by teward's endorsement, especially as he's your primary sponsor
16:14 <sil2100> hm
16:14 <rafaeldtinoco> +1 I know Eickmeyer from his requests and I feel his enthusiasm. My vote is to encourage him to keep pursuing the same with universe packages (specially helping guaranteeing quality in fixes).
16:14 <meetingology> +1 I know Eickmeyer from his requests and I feel his enthusiasm. My vote is to encourage him to keep pursuing the same with universe packages (specially helping guaranteeing quality in fixes). received from rafaeldtinoco
16:15 <rbasak> I would just ask please, Eickmeyer, that you continue to seek review if you're not sure about anything.
16:15 <Eickmeyer> rbasak: Of course. :)
16:15 <rbasak> That's partly from teward's endorsement too
16:15 <rbasak> :)
16:15 <rafaeldtinoco> yes! totally agree with what rbasak said
16:15 <sil2100> +1 seeing that you have teward's and RikMills's endorsments, are very responsive whenever reached out to on IRC + your answers to questions, I think you will do fine as a MOTU
16:15 <meetingology> +1 seeing that you have teward's and RikMills's endorsments, are very responsive whenever reached out to on IRC + your answers to questions, I think you will do fine as a MOTU received from sil2100
16:15 <Eickmeyer> teward and I have had that discussion. :)
16:15 <ddstreet> +1 the non-ubuntustudio uploads are a bit light and as teward said there are some small issues in them, but i'm leaning on teward's endorsement indicating that's getting better, and issues appearing to be minor; also I think his enthusiasm and cooperation is excellent, and non-packaging work seems to be good
16:15 <meetingology> +1 the non-ubuntustudio uploads are a bit light and as teward said there are some small issues in them, but i'm leaning on teward's endorsement indicating that's getting better, and issues appearing to be minor; also I think his enthusiasm and cooperation is excellent, and non-packaging work seems to be good received from ddstreet
16:16 <teward> +1 (my endorsement already covers this, my vote is in after we have reached quorum)
16:16 <meetingology> +1 (my endorsement already covers this, my vote is in after we have reached quorum) received from teward
16:16 <rafaeldtinoco> #endvote
16:16 <meetingology> Voting ended on: Eickmeyer MOTU motion
16:16 <meetingology> Votes for:5 Votes against:0 Abstentions:0
16:16 <meetingology> Motion carried
16:17 <rafaeldtinoco> Eickmeyer: congratulations!
16:17 <Eickmeyer> Thanks everyone!
16:17 <rafaeldtinoco> I'll do the paper work for him as well
16:17 <ddstreet> congratulations!
16:17 <rafaeldtinoco> #action paperwork for Eickmeyer's MOTU position
16:17 * meetingology paperwork for Eickmeyer's MOTU position
16:17 <rafaeldtinoco> #topic Select a chair for the next meeting
16:18 <rafaeldtinoco> #action Robie, Teward, Dan, Lukasz, Rafael
16:18 * meetingology Robie, Teward, Dan, Lukasz, Rafael
16:18 <RikMills> Eickmeyer: congratulations :)
16:18 <rafaeldtinoco> #topic Any other business
16:18 <Eickmeyer> Thanks, RikMills! Now I can help you with KDE stuff as well!
16:18 <rafaeldtinoco> anything else DMB ?
16:18 <rafaeldtinoco> 3
16:18 <rafaeldtinoco> 2
16:18 <rafaeldtinoco> 1
16:18 <rafaeldtinoco> #endmeeting