15:00 <sil2100> #startmeeting Developer Membership Board meeting
15:00 <meetingology> Meeting started Mon Dec 14 15:00:14 2020 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:00 <meetingology> 
15:00 <meetingology> Available commands: action commands idea info link nick
15:00 <teward> o/  (refilling coffee as well)
15:00 <sil2100> I think we have quorum, so let's start o/
15:00 <sil2100> Welcome everyone, let's start off with the previous items
15:00 <sil2100> #topic Review of previous action items
15:01 <teward> sil, ddstreet, rbasak, me.  that's 4 of 7 so we do have quorum :P
15:01 <sil2100> So we have a few items with Dan in the name
15:01 <sil2100> ddstreet edubuntu seed <-> pkgset (carried over)
15:01 <sil2100> ddstreet: once you're back, how's things with re ^ ?
15:02 <ddstreet> yes please carry over again, my goal is to get to that first thing next year
15:02 <sil2100> Ok, no problem
15:02 <sil2100> #action ddstreet edubuntu seed <-> pkgset (carried over)
15:02 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
15:02 <sil2100> ddstreet to ping TB to check on kernel-dkms packageset creation
15:03 <ddstreet> that is done, but there are 2 new action items i need to do for it, first i need to update our KB with the details for asking for a new packageset (specifically re: owner and who adds the packages)
15:03 <sil2100> Do we have the kernel-dkms packageset already?
15:03 <ddstreet> also i need to add the packages to the packageset
15:03 <ddstreet> but the TB has created the packageset for us already
15:03 <teward> so i'd say spin two new action items for that
15:04 <sil2100> Yeah, let's do that, can those be assigned to you then?
15:04 <ddstreet> i can take them both, should be quick
15:04 <ddstreet> yeah
15:04 <sil2100> #action ddstreet to update the KnowledgeBase with details regarding creation of new packagesets
15:04 * meetingology ddstreet to update the KnowledgeBase with details regarding creation of new packagesets
15:04 <sil2100> #action ddstreet to add DKMS packages to the new kernel-dkms packageset
15:04 * meetingology ddstreet to add DKMS packages to the new kernel-dkms packageset
15:04 <sil2100> Awesome
15:05 <sil2100> Ok, this one seems done: ddstreet discuss with slashd plans for DMB involvement or stepping down before next election
15:05 <ddstreet> yep done
15:05 <sil2100> Now a few from rbasak
15:05 <sil2100> rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:05 <rbasak> Carry over please. I've been away, but hope to hit this one up properly in January after the vacation period.
15:05 <sil2100> rbasak: I think I'm a bit detached from that one, any progress?
15:06 <sil2100> Ok!
15:06 <sil2100> Yeah, let's carry over then
15:06 <sil2100> #action rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:06 * meetingology rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:06 <sil2100> rbasak to handle private ML request
15:06 <rbasak> Done
15:06 <sil2100> \o/
15:06 <sil2100> Ok, that's all the previous action items
15:07 <sil2100> Let's move on to our applications for today
15:07 <sil2100> #topic Package Set/Per Package Uploader Applications
15:07 <sil2100> #subtopic nick black for notcurses/growlight PPU
15:07 <rbasak> See devel-permissions@ just now
15:07 <sil2100> So, I saw the follow up e-mail from Robie regarding this application
15:07 <rbasak> I believe he's deferring
15:08 <rbasak> Assuming everyone's happy with my reply?
15:08 <sil2100> Yeah, I think it made sense
15:08 <ddstreet> yep +1
15:08 <teward> yep
15:08 <sil2100> It would be hard for us to make a sensible decision about upload rights for someone that we can't judge the experience from the Ubuntu POV
15:09 <sil2100> #topic MOTU Applications
15:09 <sil2100> #subtopic Lukas 'slyon' Märdian, MOTU & netplan.io PPU
15:09 <teward> sil2100: actually, we can make that decision pretty easily, we've done it in the past (-1s exist for a reason)
15:09 <teward> just to finish that note ;)
15:09 <sil2100> #link https://wiki.ubuntu.com/slyon/MOTUApplication
15:10 <sil2100> teward: yeah, what I meant is that I wouldn't be able to judge if that person is safe to upload to Ubuntu or not
15:10 <teward> just a heads up: this is a dual part application - part MOTU and part PPU - i'd evaluate those as two separate votes.
15:10 <teward> my 2 cents.
15:10 <teward> (for sylon)
15:10 <slyon> As noted in the subtopic, this is a combined MOTU + netplan PPU application (if that is possible)
15:10 <sil2100> Since my -1 doesn't mean that person isn't capable of doing that, it would just mean I can't tell if that person can
15:10 <teward> slyon: NORMALLY we evaluate those independently
15:11 <teward> but I think we can just do two votes, one on MOTU and one on PPU
15:11 <slyon> teward: that would be great
15:11 <sil2100> Regarding slyon's application - his application is for MOTU and netplan.io PPU, but hm, do we have any means to maybe also try to look at it from the core-dev POV?
15:12 <teward> sil2100: my 2 cents is unless they applied for coredev we evaluate as is
15:12 <teward> since they applied for MOTU and specific PPU I was looking at it from that perspective
15:12 <sil2100> Since I know slyon is applying for MOTU as he felt that this would be a good starting point, but since slyon is part of Foundations, he's doing most work on main packages anyway
15:13 <slyon> I do lots of work in main as well, as part of my foundations role... Thought it would be wise to apply for MOTU first
15:13 <rbasak> IMHO, there's no harm in adding an additional vote for core dev. DMB members who are uncomfortable doing that can just -1 and request a reapplication with more notice or whatever
15:13 <teward> after evaluating i don't disagree with rbasak
15:13 <teward> so we should do the vote in this order then:
15:13 <teward> - Core Dev
15:13 <teward> - MOTU (if Core Dev doesn't get quorum)
15:13 <teward> - PPU (if Core Dev doesn't get quorum)
15:13 <sil2100> +1
15:13 <teward> and evaluate it from those perspective.
15:14 <ddstreet> so slyon, do you want us to consider you for coredev as well during this mtg? your desire is most important here i think
15:14 <rbasak> However we don't have endorsements for core dev
15:14 <sil2100> Three voting opportunities sound awesome ;)
15:14 <slyon> Absolutely, that would be great. I talked about this with sil2100 already a few days ago
15:14 <teward> rbasak: if sylon doesn't want to be considered for coredev then we can defer that to Some Future Time when they're ready.
15:14 <teward> but as per above... :P
15:14 <slyon> It improves the odds ;-)
15:14 <teward> ... bah need more coffee... back in a minute
15:15 <ddstreet> then the order of consideration from teward sounds right to me
15:15 <sil2100> Well, my application basically also says I think he's a solid core-dev candidate, but yeah, I do work with slyon quite closely ;)
15:15 <sil2100> I mean
15:15 <sil2100> s/application/endorsement/
15:15 <ddstreet> sil2100 well you're biased since you share the same first name, obviously ;-)
15:15 <teward> hah
15:15 <teward> ANYWAYS, sylon how about you introduce yourself while we review?
15:16 <sil2100> haha, indeed! You can't imagine how confusing on meetings it is right now
15:16 <ddstreet> lol
15:16 <slyon> I did not list my main work/packages in the application explicitly, but worked on the likes of: dnspython, python-httplib2, pexpect, sensible-utils, s390-tools[-signed], command-not-found, klibc, curl, ...
15:16 <slyon> teward: sure. So my Name is Lukas, I'm 30 years old, living in germany.
15:16 <slyon> I joined Canonical in early 2020 as part of the foundations team and netplan co-maintainer
15:17 <slyon> Have been a long time open source contributor since ~2009, working mainly on mobile/handheld based projects like the SHR operating system (OpenEmbedded/Yocto based) or the FreeSmartphone.org middleware
15:18 <slyon> I helped packaging some of this work for Debian as well.
15:18 <slyon> Also I did some device driver development for Letux/GTA04 devices, which partly landed in mainline
15:18 <slyon> (this was mostly battery, input and display driver work)
15:19 <rbasak> If xnox, rbalint or cpaelzer are around, would you be willing to extend your endorsement for slyon to core dev?
15:19 <slyon> I've been using Ubuntu since 2006, which made me stick to running Linux and open source software exclusively and I'm very happy to be in a position to contribute to Ubuntu now.
15:20 <rbasak> In other words, do you think he's ready for core dev now, or should he continue sponsored uploads for a while first?
15:20 <slyon> well.. I contributed a bit before as well, doing translations and themes. But as part of foundations I can improve the core stuff
15:21 <slyon> I guess that's about it... If there are any questions? Feel free to ask!
15:21 <rbasak> slyon: have you done any +1 maintenance work yet?
15:21 <sil2100> Ok, time for questions! (in the meantime)
15:22 <rbasak> Eg. any proposed migration issues?
15:22 <slyon> rbasak: Not yet, just volunteered for my first +1 shift this week, which will take place in Jan
15:22 <slyon> but I did work on proposed migration quite a lot
15:22 <slyon> as we do weekly proposed-migration rotations inside the foundations team
15:22 <slyon> s/rotations/assignments
15:23 <rbasak> Do you follow your uploads through until they migrate to the release pocket? And do you know where to go to work on getting things unstuck from proposed?
15:24 <slyon> rbasak: Yes. I always check my upload, to make sure they did not get stuck either during build or autopkgtests.
15:24 <slyon> I check the britney outputs and test logs if needed
15:24 <slyon> often times flaky tests make it fail/getting stuck, in which case I ask in #ubuntu-devel for somebody to retrigger the tests for me
15:25 <slyon> or I prepare MPs to file a hint and ask about it in #ubuntu-release
15:25 <rbasak> OK thanks!
15:27 <ddstreet> slyon i see you uploaded netplan for groovy on oct 14; was there any special consideration before uploading on that day? if you had uploaded a day later, oct 15, would there be any different considerations?
15:27 <teward> rbalint:
15:27 <rbalint> o/
15:27 <teward> <rbasak> If xnox, rbalint or cpaelzer are around, would you be willing to extend your endorsement for slyon to core dev?
15:27 <rbalint> teward, yes, absolutely
15:27 <rbalint> should i update the wiki?
15:28 <teward> rbalint: nah, your statement here is sufficient (they're being reviewed right now)
15:28 <slyon> ddstreet: yes. I sneeked that one in shortly before final freeze.
15:28 <teward> rbalint: thanks, and sorry to detract from your upcoming meeting prep time :)
15:28 <rbalint> teward, no prob, i'm happy to help :-)
15:28 <ddstreet> slyon yep :) and what would you have to do if it was after final freeze?
15:29 <slyon> I did prepare paperwork for a FeatureFreeze exception before that
15:29 <ddstreet> perfect, thanks.
15:29 * cpaelzer is reading backlog
15:30 <teward> cpaelzer: <rbasak> If ... cpaelzer are around, would you be willing to extend your endorsement for slyon to core dev?
15:30 <teward> sorry for all the pings rbasak xD
15:30 <ddstreet> slyon when adding patches, especially for SRUs but also for devel uploads, is there any specific information that you should include in the patch file(s)?
15:30 <cpaelzer> actually, yes I would be ok wit hthat - his work so far was rather flawless and most importantly where unsure he asked (instead of just doing things)
15:31 <cpaelzer> also I he lives so close that I can personally deliver punishment in case of misuse ...
15:31 <sil2100> hahaha
15:31 <rbasak> Thanks. I'll keep that in mind :-P
15:31 <cpaelzer> I guess for the decision at stake the former argument is more important
15:31 <teward> cpaelzer: hah.  thanks, cpaelzer, and sorry to have to call you in again on chaos :)
15:31 <cpaelzer> no problem at all teward
15:31 <teward> s/chaos/regular meeting stuff/
15:32 <slyon> ddstreet: IMO one important information to add to patches would be the upstreaming status, i.e. references the patches send to Debian or upstream (or not-needed, if that is the case), so that others can track the progress of that patch and drop it as soon as it is applied upstream
15:32 <slyon> cpaelzer: xD
15:33 <ddstreet> slyon is there any specific reference on what should get added to patches?
15:34 <slyon> ddstreet: oh you mean the LP bug number?
15:35 <slyon> i.e. LP: #xxxxxx so that the bug can be traced by launchpad
15:35 <ddstreet> does that go in the patch or somewhere else?
15:35 <slyon> that usually goes into debian/changelog but can also be part of the patch
15:35 <ddstreet> i was getting to if there is a reference or specification for what you should add to patches
15:36 <ddstreet> that lists the exact format of lines to add to patches...
15:37 <ddstreet> i was getting at DEP3, it makes me sad that not many people know about it, as it makes my (and my team's) job much easier :)
15:37 <ddstreet> so i like to ask about it
15:37 <ddstreet> but really it's not critical to the process
15:38 <ddstreet> i would suggest at least reviewing it and suggest using at least the Bug-Ubuntu and Origin fields
15:38 <slyon> ah hum.. yeah. usually those lines/templates are auto-generated by quilt so I was not sure about the reference, sorry about that
15:38 <ddstreet> yep, good enough :)
15:39 <slyon> I will!
15:39 <ddstreet> no more q from me
15:40 <rbasak> slyon: can you tell me what a seed is?
15:40 <rbasak> And where would you go for more information on them?
15:41 <xnox> teward:  sure.
15:41 <slyon> rbasak: a seed is a text file containing an "initial set of packages", which can be the starting point to build a new image for example, by pulling in all the seed's dependencies
15:41 <sil2100> slyon: could you tell us if you worked on any merges already? And what does such work involve?
15:41 <teward> xnox: nice, thanks for your response and extending your endorsement to cover core-dev as well for sylon.  sorry to ping you in many places :)
15:42 <slyon> seeds can be found here: https://people.canonical.com/~ubuntu-archive/seeds/i386.hirsute/ and are maintained by the release team
15:43 <slyon> sil2100: Yes I did some merges already. Starting point would be https://merges.ubuntu.com/main.html (or universe.html) to check for a suiteable package/merge.
15:43 <rbasak> OK thanks. And final question: when would you need a package transition, and what are the broad steps needed to complete one?
15:43 <rbasak> Sorry, finish with sil2100 first
15:44 <slyon> Then I would check the diffs manually and check if the current ubuntu delta is still needed or can be dropped (do a sync instead). Adopt the patches accordingly and open a tracking bug (if this is a longer standing issue, or sponsoring is needed, to note that I am working on that specific merge)
15:45 <slyon> The merge can be worked on with git-ubuntu or manually, preparing a debdiff for sponsors to review.
15:45 <sil2100> Awesome, thanks o/
15:47 <sil2100> Guess rbasak still has one open question ^
15:47 <slyon> rbasak: I did not work on transitions too much... AFAIU they are needed for "big packages" impacting lots of other packages, like toolchains. They should be timed to not be uploaded/tested at the same time as it could entangle lots of autopkgtests and make proposed migration pretty hard
15:48 <rbasak> Thanks
15:48 <rbasak> I'm ready to vote
15:49 <sil2100> Ok, any other questions?
15:49 <teward> none from me.
15:50 <sil2100> #vote Lukas 'slyon' Märdian for Ubuntu Core Developer membership
15:50 <meetingology> Please vote on: Lukas 'slyon' Märdian for Ubuntu Core Developer membership
15:50 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:51 <ddstreet> +1 very good endorsements, good amount of knowledge of process details, code quality appears good
15:51 <meetingology> +1 very good endorsements, good amount of knowledge of process details, code quality appears good received from ddstreet
15:51 <teward> +1 good endorsements, good knowledge of process details, but I strongly encourage asking for assistance if you encounter something 'odd' or which you're not familiar with (which is good advice in general)
15:51 <meetingology> +1 good endorsements, good knowledge of process details, but I strongly encourage asking for assistance if you encounter something 'odd' or which you're not familiar with (which is good advice in general) received from teward
15:52 <teward> (which echoes sil and xnox's endorsement notes)
15:52 <teward> also, more main package activity please :)
15:52 <teward> (not a blocker)
15:52 <rbasak> +1 strong endorsements, excellent track record of uploads and broad enough knowledge of Ubuntu development process.
15:52 <meetingology> +1 strong endorsements, excellent track record of uploads and broad enough knowledge of Ubuntu development process. received from rbasak
15:53 <sil2100> +1 (obviously as I have endorsed Lukas already, even though he is missing some experience, I am fully confident that he's capable of doing the right thing - and seeing his drive and passion regarding Ubuntu maintenance, he'll do just fine)
15:53 <meetingology> +1 (obviously as I have endorsed Lukas already, even though he is missing some experience, I am fully confident that he's capable of doing the right thing - and seeing his drive and passion regarding Ubuntu maintenance, he'll do just fine) received from sil2100
15:53 <rbasak> Caveat: I think you broadly understand seeds and package transitions, but I'm not sure your exactly on point in the details. Please confirm your understanding with your colleagues before you touch these areas unsupervised, and look out for accidentally starting a transition when you didn't intend it.
15:53 <slyon> Yes. I have a nice group of core-devs in my team, who I can (and will) ask questions
15:53 <rbasak> *you're
15:53 <teward> rbasak: sounds like the caveat the previous DMB gave me when I got core-dev.  :)
15:53 <slyon> rbasak: will do for sure!
15:53 <teward> (that's something everyone should get as advice though, imo)
15:53 <sil2100> Excellent!
15:53 <teward> well with that, i think we have quorum here.
15:53 <sil2100> #endvote
15:53 <meetingology> Voting ended on: Lukas 'slyon' Märdian for Ubuntu Core Developer membership
15:53 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:53 <meetingology> Motion carried
15:54 <sil2100> slyon: wow, congratulations!
15:54 <ddstreet> congratulations!
15:54 <rbalint> slyon, congratulations, welcome the the Core Dev Team, too! :-)
15:54 <slyon> \o/ awesome, thanks folks!
15:54 <teward> So: slyon: motu dismissed, PPU dismissed, coredev approved.  Welcome to the core dev team :)
15:54 <sil2100> Keep up the good work and don't hesitate to ask questions, we're all here to help!
15:54 <rbasak> Congratulations!
15:54 <slyon> wow this is really great
15:54 <teward> yep, we are.  never be afraid to ask where you're unsure
15:54 <teward> (best advice I've ever gotten - from rbasak xD)
15:54 <teward> xnox: rbalint: cpaelzer: thanks for your response to our pings, i know it is a minor interruption to your day, but it's appreciated :)
15:55 <sil2100> #topic AOB
15:55 <rbasak> Thanks :)
15:55 <slyon> Yes. I will absolutely continue to learn about all the details
15:55 <sil2100> Any other business?
15:55 <sil2100> Let me deal with the permissions and announcement
15:55 <sil2100> #action sil2100 to add slyon to core-dev
15:55 * meetingology sil2100 to add slyon to core-dev
15:55 <sil2100> #action sil2100 to announce slyon's successful application
15:55 * meetingology sil2100 to announce slyon's successful application
15:56 <teward> #subtopic Meeting FYI
15:56 <teward> Just an FYI: we have no DMB meetings until January thanks to the holidays.
15:56 <teward> next DMB meeting will be January 11
15:56 <sil2100> Oh, indeed!
15:56 <teward> (this has been the case since the November meetings where we agreed to skip the holiday timeperiod's chaos.)
15:56 <teward> (also, +o so meetingology lets me run special commands xD)
15:56 <sil2100> Have a nice EOY everyone!
15:57 <slyon> indeed, happy holidays everyone!
15:57 <sil2100> Let's wrap it up then
15:57 <teward> sil2100: same to you as well!
15:57 <sil2100> #endmeeting