15:29 <cpaelzer> #startmeeting Weekly Main Inclusion Requests status
15:29 <meetingology> Meeting started Tue Dec  8 15:29:44 2020 UTC.  The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:29 <meetingology> 
15:29 <meetingology> Available commands: action commands idea info link nick
15:30 <cpaelzer> ping jamespage ddstreet doko didrocks sarnold
15:30 <ddstreet> o/
15:30 <didrocks> o/
15:30 <cpaelzer> we can skip "Review of previous action items" since we had none and right away go to a rather crowded component mismatches ...
15:30 <cpaelzer> #topic current component mismatches
15:30 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg
15:30 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches.svg
15:31 <cpaelzer> first a few riscv related cases
15:31 <cpaelzer> we have seen them last week already
15:31 <cpaelzer> this is due to https://git.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/platform/commit/?id=6e2571375f95c01bc26f912b1de20909b8f2e547
15:31 <cpaelzer> on https://bugs.launchpad.net/ubuntu/+source/opensbi/+bug/1906668 I think this is dead-by-wrong-state
15:31 <ubottu> Launchpad bug 1906668 in opensbi (Ubuntu) "[MIR] opensbi" [Undecided,Confirmed]
15:31 <cpaelzer> xnox: this one is "confirmed" which makes it not appear int he MIR teams queue
15:31 <cpaelzer> xnox: can I assume you want this reviewed - in that case I'd set it back to new
15:32 <cpaelzer> doko: feel free to answer if you happen to know
15:32 <cpaelzer> Furthermore the same change triggered u-boot-menu which still lacks a MIR
15:32 <cpaelzer> you'd first think it is the same as all other u-boot-* which are already in main
15:32 <cpaelzer> but this is a different source
15:33 <cpaelzer> so we'd need a new MIR
15:33 <doko> I don't know. will ping him tomorrow
15:33 <cpaelzer> xnox: doko: would you mind to add that MIR (and keep it in "new" once ready)
15:33 <sarnold> good morning
15:33 <cpaelzer> doko: thanks for keeping that discussion ongoging with him then
15:33 <cpaelzer> the next is similar
15:33 <cpaelzer> a set of packages related to needrestart
15:33 <cpaelzer> due to https://git.launchpad.net/~ubuntu-core-dev/ubuntu-seeds/+git/ubuntu/commit/?id=ed7003d4c9a0be80e8a17699baa858b2bf1ce06b
15:34 <doko> that's server ...
15:34 <cpaelzer> it was added to the server seed
15:34 <cpaelzer> but so far I've not heard that the activity on this would have passed to us
15:35 <doko> unseed it?
15:35 <cpaelzer> unless that happened between xnox and ?? (maybe rharding) I'd expect MIRs requests on those
15:35 <cpaelzer> doko: how about me starting a mail thread with the relevant people requesting to clarify who has the current action items?
15:35 <cpaelzer> IIRC I have had some related discussions in my inbox, I can refer to those
15:36 <cpaelzer> #action - christian to ping xnox / rharding and others to clarify who is in the driver seed tor needrestart
15:36 * meetingology - christian to ping xnox / rharding and others to clarify who is in the driver seed tor needrestart
15:36 <cpaelzer> next in mismatches that isn't a usual suspect is rubygems
15:37 <cpaelzer> doko: I have spoken with kanashiro
15:37 <doko> cpaelzer: sounds good. please add mclemenceau
15:37 <cpaelzer> I will
15:37 <cpaelzer> doko: he is on cleanup duty now that he is back - part of that is rubygems
15:37 <cpaelzer> doko: it was in main as it was part of the same source
15:37 <doko> so wait some more days?
15:38 <cpaelzer> doko: it was shipped wit h the interpreter and then changed upstream
15:38 <cpaelzer> doko: we re-introduced the same we had before
15:38 <doko> so promote again?
15:38 <cpaelzer> but since it was removed in Debian/Ubuntu in between it now shows up as mismatch
15:38 <cpaelzer> doko: could I ask you to re-promote it on the base of the former promotion which was at https://bugs.launchpad.net/ubuntu/+source/gem2deb/+bug/894827/comments/10 ?
15:39 <ubottu> Launchpad bug 894827 in rubygems (Ubuntu) "[MIR] gem2deb" [Undecided,Fix released]
15:39 <doko> ok, doing. let's follow-up on this next week
15:39 <cpaelzer> thanks
15:40 <cpaelzer> kanashiro: ^^ could you prep a "where we are at with ruby - info" until next tuesday?
15:40 <cpaelzer> sizzle and rpi-eeprom I'd discuss in the incomplete bug section
15:40 <cpaelzer> anything else in mismatches to bring up ?
15:40 <cpaelzer> I consider this a no (or being asleep :-P )
15:40 <cpaelzer> #topic New MIRs
15:40 <cpaelzer> the list is empty
15:40 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=NEW&assignee_option=none&field.assignee=&field.subscriber=ubuntu-mir
15:41 <cpaelzer> but once xnox replies likely will contain opensbi
15:41 <cpaelzer> once set back from confirmed to new
15:41 <cpaelzer> if one has spare cycles and sees this in his inbox please feel free to grab
15:41 <cpaelzer> #topic Incomplete bugs / questions
15:41 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.subscriber=ubuntu-mir
15:41 <cpaelzer> on postgresql-13 things migrated and got promoted.
15:42 <cpaelzer> -12 is almost able to be rmeoved, hopefulyl we can do so before end of next week
15:42 <cpaelzer> sizzle is the next in incomplete
15:42 <cpaelzer> doko: did you hear anything about it ?
15:42 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/sizzle/+bug/1906514
15:42 <ubottu> Launchpad bug 1906514 in node-jquery (Ubuntu Hirsute) "sizzle needs a MIR, or node-jquery needs dropping the recommends" [High,Confirmed]
15:42 <cpaelzer> I see tag updates by mclemenceau and bdmurray - what do they tell us?
15:42 <doko> sorry, no
15:43 <doko> they are recorded in jira now
15:43 <cpaelzer> ok, could you carry that to the team meeting to get reolved mid-term?
15:43 <doko> ok
15:43 <cpaelzer> and finally https://bugs.launchpad.net/ubuntu/+source/rpi-eeprom/+bug/1895137
15:43 <ubottu> Launchpad bug 1895137 in rpi-eeprom (Ubuntu) "[MIR] rpi-eeprom; raspberrypi-userland" [Undecided,In progress]
15:43 <cpaelzer> waveform: ^^
15:43 <cpaelzer> doko has outlined todo's ~1 month ago on that bug
15:44 <cpaelzer> waveform: I wanted to know if this is incomplete as in "ack I'll do it at some point" or as in "we'll give u then"
15:44 <doko> Pi's are slow ;p
15:44 <cpaelzer> because depending on this it will have different cleanups to be done now :-)
15:44 <cpaelzer> waveform: if you only happen to read this later an update on the bug would be fine as well (even preferred)
15:44 <waveform> cpaelzer, that's basically done - I've just got to update the bug
15:44 <cpaelzer> ok, then do it :-)
15:44 <cpaelzer> that is all I wanted to bring up today
15:44 <cpaelzer> thanks team
15:44 <waveform> when I'm back from holiday :)
15:45 <cpaelzer> #topic Any other business?
15:45 <didrocks> nothing for me
15:45 <sarnold> nothing from me
15:45 <cpaelzer> FYI - for your time planning expect more effort being needed for MIR reviews in Jan/Feb
15:45 <cpaelzer> since as usual eveone has a late idea that needs to get in
15:46 <cpaelzer> waveform: FYI I updated the bug
15:46 <cpaelzer> ok that is it for today then ...
15:46 <cpaelzer> thank you everyone
15:47 <sarnold> thanks cpaelzer, all :)
15:47 <cpaelzer> #endmeeting