15:03 <teward> #startmeeting Developer Membership Board - Nov 16 2020 meeting
15:03 <meetingology> Meeting started Mon Nov 16 15:03:29 2020 UTC.  The chair is teward. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:03 <ddstreet> o/
15:03 <teward> #chairs rbasak sil2100 ddstreet teward
15:04 <teward> welcome to the November 16, 2020 meeting of the Developer Membership Board.
15:04 <teward> #topic Review of previous action items
15:04 <teward> #subtopic ddstreet edubuntu seed <-> pkgset (carried over)
15:04 <ddstreet> need to carry over still
15:05 <teward> #action ddstreet edubuntu seed <-> pkgset (carried over)
15:05 * meetingology ddstreet edubuntu seed <-> pkgset (carried over)
15:05 <teward> #subtopic rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:05 <rbasak> Carry over please
15:05 <teward> #action rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:05 * meetingology rbasak to reply to ML re: canonical-oem-metapackages packageset and owning team creation (carried over)
15:05 <teward> just for awareness, because these're done (thanks sil!)
15:06 <teward> #subtopic sil2100 to assign permissions and announce successful coredev application from Olivier Tilloy (done)
15:06 <teward> #subtopic sil2100 to assign permissions and announce successful coredev application from Sergio Durigan (done)
15:06 <sil2100> yw o/
15:06 <teward> #subtopic teward to email DMB ML regarding skipping of December 28th normally-scheduled meeting
15:06 <sil2100> That was done I suppose?
15:06 <teward> I emailed our list but got no rejection or negative response to the proposal
15:06 <sil2100> I'm generally +1
15:06 <teward> so I did email - if I don't hear back by next meeting I"m going to just assume nobody objects
15:06 <ddstreet> i'm still +1 on skipping that date
15:07 <teward> as am I, so that's 3 out of 7
15:07 <teward> and I don't think anyone will object :P
15:07 <teward> it's also already written in the agenda page we've tentatively agreed to skip :)
15:07 <rbasak> Yeah that's fine. We've done it before
15:07 <teward> good so that's +4.  I'll make the revision non-tentative on the agenda page later.
15:07 <teward> so onto actual business now...
15:08 <teward> #topic Package Set/Per Package Uploader Applications
15:08 <rbasak> I wrote up https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Scheduling when it last happened
15:08 <teward> rbasak: +1 thanks.
15:08 <teward> we have one applicant today
15:08 <teward> #subtopic Seth Forshee (2020-11-16 meeting)
15:08 <teward> #link https://wiki.ubuntu.com/SethForshee/DkmsUploadApplication
15:09 <teward> sforshee: say hello and introduce yourself while we review your application?
15:09 <sforshee> hi all, I'm Seth. I've been working on the kernel team at Canonical for 9+ years
15:09 <sforshee> I am applying to join the dkms package uploader team, which has been approved but (I think) not yet created
15:09 <sforshee> I'm part of the group who works on getting new upstream kernels ready for the development series, and part of that work is updating dkms modules to be compatible with these new kernels
15:09 <sforshee> we are often delayed due to needing sponsors for these dkms fixes, so I am seeking membership in order to sponsor these uploads and reduce such delays
15:09 <sforshee> I've been doing this work for years, so I am very familiar with dkms in general and I know which dkms packages in Ubuntu have active maintainers that we should coordinate these updates with
15:11 <rbasak> Have you done SRUs of DKMS packages, or only in the development release?
15:12 <sforshee> I have done SRU too, when we are backporting hwe kernels
15:12 <rbasak> Could you link an example please? The examples in your application aren't clickable and it isn't obvious to me which are SRUs
15:13 <sforshee> rbasak: ok, that may take a few minutes as I'm not sure off the top of my head which ones were SRU
15:13 <teward> we've got time :)
15:16 <ddstreet> sforshee is there currently a list of the existing dkms packages? i know the nvidia driver packages are dkms, but i'm not clear on what other dkms packages would be included in the new packageset
15:16 <sforshee> ddstreet: I think fginther provided one when requesting the new team, if not I can provide one
15:17 <ddstreet> ah indeed he did https://lists.ubuntu.com/archives/devel-permissions/2020-July/001539.html
15:17 <sil2100> Yeah, Francis had a list in the original e-mail
15:18 <sforshee> rbasak: I haven't been able to find an SRU example yet ... tbh I think that list is incomplete, but those were all I was able to find
15:18 <teward> there's a couple things missing there that're DKMS i think ddstreet
15:18 <teward> such as the nvidia 450 drivers too
15:18 <teward> (which I know exist)
15:18 <sforshee> likely those are new since the list was made
15:19 <teward> mhm
15:19 <sforshee> a lot of new nvidia drivers have been intorduced lately
15:19 <ddstreet> yeah, i assume the packageset will need to be updated with each new nvidia package name, since it includes the version info in the name for whatever reason
15:20 <teward> guess we need to poke the kernel team today then for the updated set of things to put into the packageset.
15:20 <rbasak> sforshee: I don't see any DKMS uploads in 2020. Is this because they tend to come in batches, or is there some other reason?
15:21 <sforshee> rbasak: this year others have been doing the dkms updates while I had some other tasks to focus on
15:24 <sforshee> rbasak: yeah I don't think any in that list are SRU. It may be in those cases that I only supplied the patches and someone else prepared the uploads
15:25 <sforshee> rbasak: I do have a lot of SRU experience with other packages, kernel and linux-firmware in particular
15:26 <ddstreet> sforshee when performing an sru to add a patch, do you need to add anything to the patch file?
15:26 <sforshee> if you'd like an example of those I can easily supply one
15:26 * rbasak continues to look at some details
15:27 <sforshee> ddstreet: the patch file is added in the debian dir and is added to a dkms conf file listing the patches to be applied
15:28 <ddstreet> and do you use the patch file generated from git format-patch as-is, or does it need any sru-specific changes (besides normal backporting code changes)?
15:29 <sforshee> just backporting in my experience
15:30 <rbasak> sforshee: I just looked at one of your linux-firmware SRUs so I accept your point - thanks.
15:30 <ddstreet> i was hinting at the dep3 header info, which isn't used in kernel-land, but is very useful for other packages
15:31 <sforshee> ddstreet: ah, okay. I was never asked by a sponsor to include those headers
15:32 <ddstreet> e.g. https://bugs.launchpad.net/ubuntu/+source/sysdig/+bug/1773367/comments/3
15:32 <ubottu> Launchpad bug 1773367 in sysdig (Ubuntu) "sysdig 0.21.0-1 ADT test failure with linux 4.17.0-1.2+signed1" [Medium,Fix released]
15:32 <sforshee> got it, I will definitely keep that in mind in the future
15:33 <ddstreet> it's not critical since the info can be found eventually, but really helps speed up debugging previous sru'ed patches
15:35 <ddstreet> no more q from me (getting quick coffee)
15:39 <teward> i've got no questions (you all asked them).
15:39 <teward> any more questions for sforshee?
15:40 <sil2100> None from me
15:40 <teward> rbasak: ?
15:40 <rbasak> I'm ready to vote, thanks.
15:41 <teward> #voters ddstreet teward rbasak sil2100
15:41 <meetingology> Current voters: ddstreet rbasak sil2100 teward
15:41 <rbasak> I'd prefer to have seen: 1) a more recent track record of sponsored uploads to the requested packages; 2) more direct examples of DKMS SRUs performed. However I think that in Seth's case, he has been immersed in Ubuntu development long enough, with a long track record of uploads, that he knows what is expected and his uploads won't cause problems for other developers, and I don't want to block
15:41 <teward> #vote Seth Forshee for DKMS Packageset upload rights
15:41 <rbasak> progress in getting the DKMS packageset started. I consider this the exception though - for most applicants to the DKMS packageset, I would expect my two points directly fulfilled so this exception shouldn't be considered to be setting a standard.
15:41 <meetingology> Please vote on: Seth Forshee for DKMS Packageset upload rights
15:41 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:41 <rbasak> +1
15:41 <meetingology> +1 received from rbasak
15:41 <rbasak> +1
15:41 <meetingology> +1 received from rbasak
15:41 <teward> +1
15:41 <meetingology> +1 received from teward
15:41 <ddstreet> +1 happy with endorsements, long history of kernel/dkms experience, and quality seems good (but please remember the dep3 headers :)
15:41 <meetingology> +1 happy with endorsements, long history of kernel/dkms experience, and quality seems good (but please remember the dep3 headers :) received from ddstreet
15:42 <sil2100> +1
15:42 <meetingology> +1 received from sil2100
15:42 <teward> #endvote
15:42 <meetingology> Voting ended on: Seth Forshee for DKMS Packageset upload rights
15:42 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:42 <meetingology> Motion carried
15:42 <sil2100> Congratulations!
15:42 <ddstreet> congratulations!
15:42 <teward> sforshee: congratulations on a successful application for DKMS packageset upload rights!
15:42 <sforshee> thanks all!
15:42 <teward> who wants to handle the announcement and assignment of permissions?
15:43 <teward> (I'm not going to be able to do that today0
15:43 <ddstreet> i can volunteer but i may not be able to until later this week
15:43 <teward> sil2100: i know i keep giving you those tasks every meeting... xD
15:43 <teward> ddstreet: cool i don't think there's an immediate rush to do that today unless sforshee needs these rights sooner
15:44 <teward> #action ddstreet to announce Seth FOrshee's successful packageset application and apply permissions
15:44 * meetingology ddstreet to announce Seth FOrshee's successful packageset application and apply permissions
15:44 <teward> and I can't type to save my life apparently.
15:44 <sforshee> later this week is great
15:45 <sil2100> ddstreet: in case you don't find the time, give me a poke o/
15:45 <ddstreet> ack
15:45 <teward> perfect.
15:45 <teward> #topic Any Other Business
15:45 <sil2100> We'll need to get the packageset and teams created
15:45 <sil2100> Via the TB I suppose
15:45 <ddstreet> yep
15:45 <teward> ddstreet: i assume you'll poke the TB for that?
15:46 <ddstreet> i will yeah
15:46 <teward> #action ddstreet to contact TB for packageset and teams creation for DKMS packageset
15:46 * meetingology ddstreet to contact TB for packageset and teams creation for DKMS packageset
15:46 <teward> perfect.  There's nothing left on the agenda that I can see, any other business for us to handle in this meeting today?
15:47 <teward> Guess not, so I'll end the meeting.  Thanks everyone!
15:48 <sil2100> Thanks o/
15:48 <teward> #endmeeting