14:30 <cpaelzer> #startmeeting Weekly Main Inclusion Requests status
14:30 <meetingology> Meeting started Tue Aug 11 14:30:50 2020 UTC. The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:30 <meetingology>
14:30 <meetingology> Available commands: action commands idea info link nick
14:30 <cpaelzer> hi jamespage: ddstreet: sarnold:
14:31 <cpaelzer> we are a reduced team again with doko and didrocks being out this week
14:31 <cpaelzer> gladly I could convince seb128 to attend in case we need AA actions (and my precheck indicates we will)
14:31 <cpaelzer> welcome him
14:32 <cpaelzer> #topic Review of previous action items
14:32 <cpaelzer> we had one action to check if probert-network still doesn't show up in component mismatches
14:33 <cpaelzer> it does still seem wrong (is in universe, but is depended from main, not showing)
14:33 <cpaelzer> I have asked Odd_Bloke to file a bug and get in touch wit hthe archive admins about that oddity
14:33 <seb128> :-)
14:33 <cpaelzer> seems nothing we could do a lot about
14:33 <sarnold> good morning
14:33 <cpaelzer> #topic current component mismatches
14:33 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg
14:33 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches.svg
14:33 <cpaelzer> we have a bunch ready to promote today
14:33 <cpaelzer> and a puzzle :-)
14:34 <cpaelzer> let us go one by one
14:34 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/python-requests-toolbelt/+bug/1751093
14:34 <ubottu> Launchpad bug 1751093 in python-requests-toolbelt (Ubuntu) "[MIR] python-requests-toolbelt" [Undecided,Fix released]
14:34 <cpaelzer> that is ready (from past review)
14:34 <cpaelzer> and now depended on again
14:34 <cpaelzer> openstack is still subscribed
14:34 <cpaelzer> so I gues we'd just want that to be re-promoted in groovy
14:34 <cpaelzer> jamespage: any objections to do that?
14:35 <cpaelzer> arr
14:35 <cpaelzer> just found out jamespage is out this week as well
14:36 <cpaelzer> but the case is rather clear
14:36 <cpaelzer> anyone else to object re-promoting that=
14:36 <cpaelzer> ?
14:36 <sarnold> wfm
14:36 <cpaelzer> seb128: would you take this to promote it to groovy-main?
14:36 <seb128> sure
14:36 <cpaelzer> thanks
14:37 <cpaelzer> next case is actually a double
14:37 <cpaelzer> hwloc depends on https://bugs.launchpad.net/ubuntu/+source/s390-dasd/+bug/1522003
14:37 <ubottu> Launchpad bug 1522003 in s390-dasd (Ubuntu) "[MIR] s390-dasd" [Undecided,Fix released]
14:37 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/s390-sysconfig-writer/+bug/1522002
14:37 <ubottu> Launchpad bug 1522002 in s390-sysconfig-writer (Ubuntu) "[MIR] s390-sysconfig-writer" [Undecided,Fix released]
14:37 <cpaelzer> both were in main before
14:37 <cpaelzer> they are ready to be promoted
14:37 <cpaelzer> TBH I don't see why they even demoted in the first place
14:37 <cpaelzer> IMHO those should also be (re-)promoted
14:37 <cpaelzer> any objection to that?
14:38 <cpaelzer> I take that as a now and the case is rather clear again
14:39 <sarnold> wfm
14:39 <cpaelzer> seb128: those would be the next to for you - ok with that ?
14:39 <seb128> k
14:39 <cpaelzer> last item out of this category is https://bugs.launchpad.net/ubuntu/+source/khronos-opencl-clhpp/+bug/1636728
14:39 <ubottu> Launchpad bug 1636728 in khronos-opencl-clhpp (Ubuntu) "[MIR] khronos-opencl-clhpp" [Undecided,Fix released]
14:39 <cpaelzer> here we need the desktop Team anyway - the package was in main , the MIR is ready - but the subscriber was unclear
14:39 <cpaelzer> "ubuntu-x" is subscribed
14:40 <cpaelzer> we were wondering if that is still an active team from canonicals POV (to provide support in main)
14:40 <cpaelzer> seb128: do you happen to know since "ubuntu-x" sounds so Desktop'ish?
14:40 <cpaelzer> this one https://launchpad.net/~ubuntu-x-swat
14:41 <seb128> I don't think it's in the official list no
14:41 <cpaelzer> seb128: thanks
14:41 <cpaelzer> seb128: cuold you carry https://bugs.launchpad.net/ubuntu/+source/khronos-opencl-clhpp/+bug/1636728 to the Desktop Team meeting then to sort out who should subsceribe now?
14:41 <ubottu> Launchpad bug 1636728 in khronos-opencl-clhpp (Ubuntu) "[MIR] khronos-opencl-clhpp" [Undecided,Fix released]
14:41 <cpaelzer> "subscribe"
14:42 <seb128> ack
14:42 <cpaelzer> the next in component mismatches is a massive tree of golang things
14:42 <cpaelzer> but not listing the root of the dependency
14:43 <cpaelzer> further to the right there is "gcc-compute-image-packages" which sounds suspicious to be related
14:43 <cpaelzer> does anyone know or has worked on that?
14:43 <seb128> the khronos package seems to be pulled in by ocl-icd which is owned by kernel so I would suggest kernel should look at that one
14:43 <cpaelzer> since doko isn't here let me ping xnox - as maybe is is around and knows about it ^^
14:44 <cpaelzer> seb128: agreed (we said and have seen the same last week) - but since the old owner was ubuntu-x it would be Dekstop to punt it over to kernel
14:44 <cpaelzer> maybe just get your and their manager connected
14:44 <cpaelzer> or do you prefer me to do the mailing
14:44 <cpaelzer> I can do it if you like
14:44 <seb128> k
14:45 <seb128> I can handle it
14:45 <cpaelzer> ok, thanks
14:45 <seb128> np!
14:45 <xnox> cpaelzer: sorry, what are you asking me?
14:45 <cpaelzer> xnox: hi
14:45 <cpaelzer> xnox do you know about all the google/golang things in https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg ?
14:45 <cpaelzer> we were wondering if that is any foundation driven effort?
14:46 <xnox> cpaelzer: i think it's on rbalint to file all the MIRs and subscribe either foundations or cpc/cloudware.
14:46 <cpaelzer> I beg your pardon - since doko isn't here to speak for foundations I asked you
14:46 <cpaelzer> thank you - that makes sense then
14:46 <cpaelzer> all other things in there are known cases and actively handled one or the other way
14:47 <cpaelzer> I'll take an action to sort with vorlon how to handle the subscription problem that doko brought up for the fonts package
14:47 <cpaelzer> #action - cpaelzer to ask Steve how to fastpath font packages without subscriptions
14:47 * meetingology - cpaelzer to ask Steve how to fastpath font packages without subscriptions
14:47 <cpaelzer> #topic New MIRs
14:47 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=NEW&assignee_option=none&field.assignee=&field.subscriber=ubuntu-mir
14:47 <cpaelzer> up until a few minutes ago there was https://bugs.launchpad.net/ubuntu/+source/python-jwcrypto/+bug/1869215
14:47 <ubottu> Launchpad bug 1869215 in python-jwcrypto (Ubuntu) "[MIR] python-jwcrypto" [High,In progress]
14:48 <cpaelzer> but that will work out once jamespage is back
14:48 <cpaelzer> really new is https://bugs.launchpad.net/ubuntu/+source/ipp-usb/+bug/1891157
14:48 <ubottu> Launchpad bug 1891157 in ipp-usb (Ubuntu) "[MIR] ipp-usb" [High,New]
14:48 <cpaelzer> and that looks for a reviewer
14:48 <cpaelzer> I have to admit I didn't even get to process my assignments of last week :-/
14:48 <cpaelzer> does anyone have the breathing room to look at this (two packages actually)
14:48 <cpaelzer> sarnold: ddstreet: ^^ ?
14:49 <ddstreet> i haven't got to the one i took last week either
14:49 <sarnold> I've still not finished the previous pcakage I've accepted :( I should say no on this one
14:49 <cpaelzer> ok so we are all in the sma eboat
14:49 <cpaelzer> same boat
14:49 <cpaelzer> we will let it open for this week
14:50 <cpaelzer> butnext week we need to asign someone as the target is 20.10
14:50 <cpaelzer> maybe I can take a few hours off my +1 duty without being slapped too hard
14:50 <cpaelzer> we will see
14:50 <cpaelzer> #topic Incomplete bugs / questions
14:50 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.subscriber=ubuntu-mir
14:50 <cpaelzer> nothing new here
14:51 <cpaelzer> #topic Any other business?
14:51 <cpaelzer> ok, that is it then
14:51 <cpaelzer> thanks everyone that isn't on PTO :-)
14:51 <cpaelzer> we see the expected end-of-cycle ramp up of activity here
14:51 <cpaelzer> see you all next week
14:52 <cpaelzer> #endmeeting