19:01 <sil2100> #startmeeting DMB meeting
19:01 <meetingology> Meeting started Mon Aug 10 19:01:50 2020 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:01 <meetingology> 
19:01 <meetingology> Available commands: action commands idea info link nick
19:02 <sil2100> #topic Review of previous action items
19:02 <sil2100> #subtopic rafaeldtinoco to check edubuntu seed <-> pkgset relationship (generation) and if edubuntu pkgsets can be dropped (carried over)
19:02 <rafaeldtinoco> I think this is duplicated
19:02 <rafaeldtinoco> ddstreet: ^ did you have this also ?
19:02 <rafaeldtinoco> (last item)
19:03 <sil2100> Ah, indeed
19:03 <ddstreet> rafaeldtinoco yeah i think that's a new one on my action list
19:03 <sil2100> ddstreet: any progress? Or should we carry over?
19:03 <ddstreet> new from last mtg
19:03 <ddstreet> no progress sorry, plz carry over
19:04 <sil2100> Ok then
19:04 <sil2100> #subtopic rafaeldtinoco to create, for now, a small "what-to-do" for pkgset changes in -devel (document exceptions inclusion for DMB team) (carried over)
19:04 <rafaeldtinoco> https://wiki.ubuntu.com/UbuntuDevelopers/SeedsAndAutomatedPkgsets
19:04 <rafaeldtinoco> and its a Makefile now
19:04 <rafaeldtinoco> this is the "quick what to do"
19:04 <rafaeldtinoco> it will get better (as the long standing item)
19:05 <rafaeldtinoco> for now you can consider done
19:05 <sil2100> Ok, thanks! I'll have to read that up - today I quickly wanted to use it but it errored out when I tried running `make fetch`
19:05 <rafaeldtinoco> just ping me
19:05 <sil2100> But I didn't look into the details, need to try again
19:05 <rafaeldtinoco> sure thing
19:05 <sil2100> I was too busy with pointy-release stuff
19:06 <sil2100> #subtopic rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
19:06 <rbasak> rafaeldtinoco: nicely done - thanks!
19:06 <rbasak> Is that linked to from anywhere?
19:06 <rafaeldtinoco> that is this item ^
19:06 <rafaeldtinoco> and no, where should I like it ?
19:06 <rafaeldtinoco> (it will get bigger and more detailed)
19:06 <rbasak> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase is the general starting point for DMB-internal docs
19:06 <rafaeldtinoco> ok
19:06 <rbasak> (internal as in not relevant to anyone but active DMB members, but public of course)
19:07 <rafaeldtinoco> sil2100: mark this as carried over then., it will be done next meeting
19:07 <rafaeldtinoco> rbasak: tku
19:07 <sil2100> Sure o/
19:07 <ItzSwirlz> o/
19:07 <sil2100> #subtopic DMB to vote at next mtg(s) on controlling the membership access for the OEM enablement metapackages
19:08 <rbasak> I was distracted during the previous meeting, sorry.
19:08 <rbasak> But AIUI, there's nothing being done here yet, except to define a packageset?
19:08 <sil2100> Yeah, so I'm reading the previous meeting logs now
19:09 <sil2100> I think we agreed that we would just be creating a packageset and delegating the management of those permissions to ubuntu-archive, correct?
19:09 <rafaeldtinoco> As a first step towards making this self service for that team, I'd like
19:09 <rafaeldtinoco> to ask the DMB to consider making a packageset for this purpose.
19:09 <rafaeldtinoco> Initially it'll have no uploaders apart from ~ubuntu-core-dev, so we're
19:09 <rafaeldtinoco> considering the set itself only right now.
19:09 <sil2100> Is this something we should vote on?
19:09 <rafaeldtinoco> this is the core part for now
19:10 <rafaeldtinoco> we will have people applying for upload rights later
19:10 <rafaeldtinoco> iirc
19:10 <sil2100> Ok, so only voting on creating the packageset for now with core-dev as members, without team delegation?
19:10 <rafaeldtinoco> i would set the team ready
19:10 <rafaeldtinoco> just so we dont need AA later
19:11 <rafaeldtinoco> this way we can manage permissions as they apply
19:11 <rbasak> Create a team maybe, and add only ~ubuntu-core-dev to it initially
19:11 <rafaeldtinoco> yep
19:11 <rafaeldtinoco> then we are good to go for applications
19:12 <sil2100> Do we want to define the initial packageset contents formally?
19:12 <rbasak> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Personal_packagesets_and_glob_expansions is prior art for "glob-based" packagesets
19:12 <rbasak> There, the formal packageset contents was defined in the packageset description using the glob pattern
19:12 <rafaeldtinoco> yep
19:13 <rafaeldtinoco> m tells me
19:13 <rafaeldtinoco> that packageset permissions can be added if a source package exists
19:13 <rafaeldtinoco> *anywhere* (i.e. in a PPA), not just in Ubuntu. So there would be a
19:13 <rafaeldtinoco> script which enumerates a staging PPA and adds packages found there
19:13 <rafaeldtinoco> which match the glob 'oem-*-meta' to the packageset.
19:13 <sil2100> Yeah, so the glob here would be oem-*-meta
19:13 <rafaeldtinoco> they want source packages to come automatically from a staging ppa
19:13 <sil2100> Ok, so let me formulate the vote then
19:13 <rbasak> rafaeldtinoco: I would prefer to require the glob to be driven from the archive, not from a PPA
19:14 <rbasak> I'm not sure a packageset containing a package not in the archive would work anyway
19:14 <rafaeldtinoco> rbasak: what are the cons ?
19:14 <rafaeldtinoco> ah i see
19:14 <ddstreet> that was a concern for me also rbasak, driving the packageset from a ppa is essentially opening a backdoor into the archive
19:14 <rbasak> It's confusing, because the DMB's remit relates to the archive only
19:14 <rafaeldtinoco> you mean an upload for a source that we dont have
19:14 <rafaeldtinoco> yep
19:14 <rbasak> And also what ddstreet says
19:14 <rbasak> The process would be:
19:15 <rbasak> Get a core dev or MOTU sponsored upload into the archive
19:15 <rbasak> Get an AA to do the NEW review
19:15 <rbasak> Ask the DMB to run the script to update the packageset using the glob pattern
19:15 <rbasak> In that order
19:15 <sil2100> Are we ready to vote on the base part?
19:16 <rafaeldtinoco> what is the NEW review ?
19:16 <rafaeldtinoco> rbasak: ^
19:16 <ddstreet> sil2100 is there specific wording that we're voting on now?
19:16 <rafaeldtinoco> sil2100: I think we are all +1 on this, currently discussing the implementation
19:17 <sil2100> #vote Creation of a new canonical-oem-metapackages packageset and owning team for the glob expansion of oem-*-meta, initially having ~ubuntu-core-dev as the only member
19:17 <meetingology> Please vote on: Creation of a new canonical-oem-metapackages packageset and owning team for the glob expansion of oem-*-meta, initially having ~ubuntu-core-dev as the only member
19:17 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:17 <sil2100> (we need a formal vote)
19:17 <sil2100> Did I  get this right?
19:18 <rbasak> +1 assuming that the glob expansion will be performed from archive packages only
19:18 <meetingology> +1 assuming that the glob expansion will be performed from archive packages only received from rbasak
19:18 <ddstreet> +1 for pkgset and team creation
19:18 <meetingology> +1 for pkgset and team creation received from ddstreet
19:18 <sil2100> +1
19:18 <meetingology> +1 received from sil2100
19:18 <rafaeldtinoco> +1 for both
19:18 <meetingology> +1 for both received from rafaeldtinoco
19:18 <sil2100> #endvote
19:18 <meetingology> Voting ended on: Creation of a new canonical-oem-metapackages packageset and owning team for the glob expansion of oem-*-meta, initially having ~ubuntu-core-dev as the only member
19:18 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:18 <meetingology> Motion carried
19:18 <sil2100> Ok, motion carried, yes, we can proceed with implementation details
19:18 <sil2100> ;)
19:19 <rafaeldtinoco> sorry, had in my head this was already voted previously
19:19 <rafaeldtinoco> thanks
19:19 <ddstreet> i think at the last mtg we said it would be better to defer the specific pkgset operation to ubuntu-archive or ubuntu-sru team, is that right? and dmb would only manage team membership?
19:19 <sil2100> I don't think it was, as the action item was to vote on it now
19:20 <rafaeldtinoco> ddstreet: we did say that
19:20 <rafaeldtinoco> but never agreed
19:20 <sil2100> Yeah
19:20 <rafaeldtinoco> im thinking if that would be easier for them
19:20 <ddstreet> i do agree with rbasak on the concerns around the implementation, but maybe that's best for a different team to work out?
19:21 <rbasak> AIUI then, we'd define the glob expansion (ie. define the script that does the glob expansion) but ~ubuntu-archive or ~ubuntu-sru would actually run it?
19:21 <rbasak> If that's considered useful, then sure
19:21 <rafaeldtinoco> im ok with that
19:21 <ddstreet> i'm ok either way
19:21 <rafaeldtinoco> rbasak: would that be a burden for the sru team ?
19:21 <rafaeldtinoco> thinking on what would be best for all (SRU team and this new team)
19:22 <sil2100> Same here, I don't think it's that much of a deal to actually need to be delegated though
19:22 <rafaeldtinoco> if its just running a script
19:22 <rafaeldtinoco> i can do it with the weekly pkgset
19:22 <rbasak> The SRU team aren't used to managing packagesets or running recognising weird edge cases to run appropriate scripts
19:22 <rafaeldtinoco> pkgset <-> seed sync
19:22 <rafaeldtinoco> i can run both together
19:23 <rafaeldtinoco> do we have a "production"  place
19:23 <rafaeldtinoco> to land those things ?
19:23 <rbasak> I'm not refusing to do it on behalf of the SRU team or anything, but I'm not sure it's going to be helpful. In practice it'll end up getting missed I think
19:23 <sil2100> I'd say let's leave it under our control for now
19:23 <ddstreet> sounds like rafaeldtinoco is taking an action item to add it to the tooling then? :)
19:23 <rafaeldtinoco> rbasak: that is understood
19:23 <rafaeldtinoco> ddstreet: its ok for me.. i was just wondering
19:23 <rafaeldtinoco> is my home the best place to run cron jobs ?
19:23 <rbasak> I'm with sil2100. Let's leave it under our control for now.
19:23 <rafaeldtinoco> should I deploy it somewhere ?
19:23 <rbasak> We don't have a good place to cron it from
19:24 <rafaeldtinoco> ok, it will continue here then
19:24 <rbasak> We could start by just responding to a ping from an uploader who is stuck
19:24 <rbasak> And then go from there
19:24 <sil2100> Ok, let's put some action items
19:24 <sil2100> Who wants to take the actual team and packageset creation?
19:24 <rbasak> I'll take it
19:24 <rafaeldtinoco> cool. i can do the scripting
19:24 <rafaeldtinoco> and crontabing
19:25 <rafaeldtinoco> if needed (or should we wait applicants first ?)
19:25 <sil2100> #action rbasak to take care of the canonical-oem-metapackages packageset and owning team creation
19:25 * meetingology rbasak to take care of the canonical-oem-metapackages packageset and owning team creation
19:25 <sil2100> rbasak: guess it needs the TB, right?
19:25 <sil2100> (I always forget)
19:25 <rbasak> rafaeldtinoco: personally I'd wait until managing it manually becomes painful
19:25 <rbasak> But I have no objection if you want to run ahead with it
19:25 <rafaeldtinoco> manually it is
19:25 <rbasak> Yes - packageset creation will need the TB. We have a process for requesting that
19:25 <rafaeldtinoco> so we can all get used to it
19:25 <sil2100> I think we all have enough on our plates that it's best not to put additional scripting work ;)
19:25 <rafaeldtinoco> sil2100: yes!
19:26 <sil2100> Ok, I think we have this sorted out then
19:26 <sil2100> #subtopic slashd to add Yaru to the desktop set for focal
19:26 <sil2100> I don't think slashd is here with us today?
19:26 <sil2100> Does anyone know if that is done?
19:27 <ddstreet> looks like it's not done yet
19:27 <ddstreet> and slashd is out today
19:27 <sil2100> Ok, let's carry that one over then
19:28 <sil2100> Last action item is a duplicate, and we discussed it already
19:28 <sil2100> We have no applicants today, so let's move to AOB
19:28 <sil2100> #topic AOB
19:28 <sil2100> Anything to discuss otherwise?
19:29 <sil2100> I take that as a no!
19:30 <sil2100> Ok, I guess we can finish
19:30 <sil2100> #topic Select a chair for the next meeting
19:30 <sil2100> That would be Teward, but I guess he's not here today
19:30 <sil2100> #endmeeting