14:31 <cpaelzer> #startmeeting Weekly Main Inclusion Requests status
14:31 <meetingology> Meeting started Tue Aug  4 14:31:14 2020 UTC.  The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
14:31 <meetingology> 
14:31 <meetingology> Available commands: action commands idea info link nick
14:31 <cpaelzer> ping for doko didrocks sarnold ddstreet jamespage
14:32 <cpaelzer> #topic Review of previous action items
14:32 <cpaelzer> we had no open action items
14:32 <cpaelzer> more interesting for when peopel show up will be the bug lists and component mismatches
14:32 <cpaelzer> so let me link the latter and wait until MIR members respond here
14:32 <cpaelzer> #topic current component mismatches
14:32 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches-proposed.svg
14:32 <cpaelzer> #link https://people.canonical.com/~ubuntu-archive/component-mismatches.svg
14:33 <cpaelzer> what do we see excluding the usual suspects and known cases
14:33 <sarnold> python-invoke? is that new?
14:34 <sarnold> same with lzip?
14:34 <cpaelzer> yes I think so
14:34 <ddstreet> o/
14:34 <cpaelzer> lintian "things" usually where with foundations the last few times - doko is that still the case?
14:35 <doko> yes
14:35 <cpaelzer> ok
14:35 <cpaelzer> then let us check paramiko and what has put it in main
14:36 <doko> but every lintian upload seems to include new dependencies these days :-(
14:36 <cpaelzer> jamespage: I think that is for openstack - I see ironic, manila, cinder and such
14:36 <cpaelzer> jamespage: do you add this to your already long list to take a look if you want to MIR or modify it?
14:36 <doko> python-invoke, openstack
14:37 <cpaelzer> yep I found the same (see above) just wanted jamespage to ack looking for it
14:38 <cpaelzer> doko: opencl is that something you know about fromt he toolchain POV
14:38 <cpaelzer> as we wondered about ocl-icd -> khronis-... last week
14:38 <cpaelzer> I mean the latter has an approved MIR from the past
14:39 <cpaelzer> the question is re-promote it or do we want to not do this for soem reason?
14:39 <cpaelzer> lad MIR is https://bugs.launchpad.net/ubuntu/+source/khronos-opencl-clhpp/+bug/1636728
14:39 <ubottu> Launchpad bug 1636728 in khronos-opencl-clhpp (Ubuntu) "[MIR] khronos-opencl-clhpp" [Undecided,Fix released]
14:41 <doko> stayed out a long time outside main, doesn't have a package provider anymore
14:41 <sarnold> what's a package provider?
14:41 <doko> kernel team? or tjaltoonen for the X stack?
14:42 <cpaelzer> sarnold: I guess doko meant a subscriber who takes care for it
14:43 <doko> oops, yes
14:44 <cpaelzer> doko: let me state that it needs a subscriber again on the bug (lter) and go on here
14:44 <cpaelzer> doko: I have checked fonts-material-design-icons-iconfont
14:44 <cpaelzer> it really is one of those font cases which don't need the full MIR process
14:44 <sarnold> cpaelzer: aha, thanks :)
14:45 <cpaelzer> doko: could you later on just promote it under the terms of https://wiki.ubuntu.com/MainInclusionProcess?action=show&redirect=MIRTeam#Font_Packages ?
14:46 <cpaelzer> you'll let me know later doko - as well as jamed page about paramiko - going on with the topics
14:46 <cpaelzer> #topic New MIRs
14:46 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=NEW&assignee_option=none&field.assignee=&field.subscriber=ubuntu-mir
14:46 <cpaelzer> there is some movement here
14:46 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/tlp/+bug/1888656
14:47 <ubottu> Launchpad bug 1888656 in OEM Priority Project "[MIR] tlp" [Critical,New]
14:47 <cpaelzer> was set to NEW and is supposed to be reviewed, I think I haven't taken one in a while and will take this one
14:47 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/nvme-cli/+bug/1889688
14:47 <ubottu> Launchpad bug 1889688 in nvme-cli (Ubuntu) "[MIR] nvme-cli" [Undecided,New]
14:47 <ddstreet> i can take the nvme-cli one
14:47 <cpaelzer> this is a foundations case it seems, waits for xnox to comment as asked by vorlon
14:48 <cpaelzer> ddstreet: thanks, but if it is complex you might hold back until xnox/vorlon have settled if they really want it supported
14:48 <ddstreet> sure i'll let them settle before i start the review
14:48 <cpaelzer> thanks, I've assigned you
14:48 <cpaelzer> the next is a tripled for mdevctl
14:48 <cpaelzer> https://bugs.launchpad.net/ubuntu/+source/libonig/+bug/1889248
14:48 <ubottu> Launchpad bug 1889248 in mdevctl (Ubuntu) "[MIR] mdevctl, jq, libonig" [Undecided,New]
14:49 <cpaelzer> this is driven by me and I can take jq and libonig
14:49 <cpaelzer> but mdevctl I'm the Debian and Ubuntu Maintainer as well as the MIR requester - it seems wrong to check that myself
14:49 <cpaelzer> needs another pair of eyes
14:49 <cpaelzer> anyone up to mdevtl MIR review?
14:51 <doko> cpaelzer: promote without a subscriber?
14:52 <cpaelzer> doko: the fonts package you mean
14:52 <cpaelzer> ?
14:52 <doko> yes
14:52 <doko> I'll look at mdevctl
14:53 <cpaelzer> thanks for mdevctl
14:53 <cpaelzer> I'll assign you so we know
14:53 <cpaelzer> well when steve told us that fonts packages should not require the full process that did not come up yet
14:53 <cpaelzer> but you are right someone has to look after it
14:53 <cpaelzer> :-/
14:54 <cpaelzer> I guess we need to ping whoever owns the package depending on it
14:54 <cpaelzer> that would be foundations
14:54 <cpaelzer> https://launchpad.net/ubuntu/+source/freetype
14:54 <cpaelzer> has https://launchpad.net/~foundations-bugs subscribed
14:55 <cpaelzer> doko: can you add that subscription and promote - would that work for you?
14:55 <doko> ok
14:56 <cpaelzer> and about https://launchpad.net/ubuntu/+source/khronos-opencl-clhpp once more
14:56 <cpaelzer> in the past https://bugs.launchpad.net/ubuntu/+source/khronos-opencl-clhpp/+bug/1636728/comments/5
14:56 <ubottu> Launchpad bug 1636728 in khronos-opencl-clhpp (Ubuntu) "[MIR] khronos-opencl-clhpp" [Undecided,Fix released]
14:56 <cpaelzer> it was said that "ubuntu-x subscribed to bugs now"
14:57 <cpaelzer> they still are subscribed according to the package overview
14:57 <cpaelzer> I'm wondering if that is enough thou
14:57 <sarnold> is there still an 'ubuntu-x'? that feels a bit like something from before my time
14:57 <cpaelzer> well it is an old team with a lot of old names in it
14:58 <cpaelzer> https://launchpad.net/~ubuntu-x-swat/+members#active
14:58 <cpaelzer> RBH we should wait until didrocks is back to speak for desktop who would be the natural successor
14:58 <cpaelzer> that or kernel (given the bug history)
14:58 <cpaelzer> not resolving that today and going on
14:59 <cpaelzer> #topic Incomplete bugs / questions
14:59 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-date_last_updated&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&field.subscriber=ubuntu-mir
14:59 <cpaelzer> nothing new on this list
14:59 <cpaelzer> \o/
14:59 <cpaelzer> #topic Any other business?
14:59 <ddstreet> i have a q
14:59 <ddstreet> something i noticed last week, it's the probert package, https://bugs.launchpad.net/ubuntu/+source/probert/+bug/1830347
15:00 <ubottu> Launchpad bug 1830347 in probert (Ubuntu) "[MIR] probert as dependency of curtin" [Undecided,Fix released]
15:00 <ddstreet> it seems that the 'probert-network' binary pkg didn't correctly get promoted to main, so now (in f and g) we have 'probert' in main, and it depends on 'probert-network', but probert-netowrk is in universe
15:01 <ddstreet> i was surprised the mismatches svg didn't show it
15:02 <doko> doesn't show up in the text mismatches either
15:02 <cpaelzer> Odd_Bloke: ^^ I think we have talked about this did we ?
15:02 <ddstreet> it seems to just be an oversight, promoting version 0.17 back in eoan did appear to promote all binaries, but starting in focal at 0.17build1 it seems probert-network stayed in universe
15:02 <cpaelzer> ddstreet: there is also "probert-storage" which is in main
15:02 <ddstreet> yep just the -network seems wrong
15:02 <cpaelzer> $ reverse-depends --release=groovy probert-network
15:02 <cpaelzer> Reverse-Depends
15:02 <cpaelzer> * probert
15:02 <cpaelzer> * subiquitycore
15:02 <cpaelzer> it definetly should be in main
15:03 <ddstreet> is there something wrong with the mismatch generation code that it should have caught it?
15:03 <ddstreet> not a big deal, just was surprising to me
15:03 <Odd_Bloke> cpaelzer: I don't recall a specific discussion about -network, but I'm vaguely aware of the background of the probert split.
15:04 <cpaelzer> Odd_Bloke: was there any intention to not have probert-network in main as well?
15:04 <Odd_Bloke> I can't speak with authority on that, but I agree that I can't see why it wouldn't.  I'll ping Ryan in #curtin.
15:05 <cpaelzer> ddstreet: doko: also the text version of component mismatches doesn't mention it https://people.canonical.com/~ubuntu-archive/component-mismatches.html
15:05 <cpaelzer> I guess we have two things from here
15:05 <cpaelzer> a) promote it as it should be in and revisit if it is auto-demoted (it shouldn#t but who knows)
15:05 <cpaelzer> b) wonder and probably debug why the component mismatch script doesn't list it
15:06 <cpaelzer> I have no cycles left to do the debug anytime soon :-/
15:06 <cpaelzer> doko could you do (a) for us?
15:06 <cpaelzer> so we at least can do that part?
15:06 <cpaelzer> #action - recheck if probert was promoted and not auto-demoted again
15:06 * meetingology - recheck if probert was promoted and not auto-demoted again
15:08 <cpaelzer> while waiting for doko to tell us if this is ok to be promoted (groovy + focal)
15:08 <cpaelzer> I wanted to give a heads up that soon https://bugs.launchpad.net/ubuntu/+source/ceph-iscsi/+bug/1854362 will be ready as well
15:08 <ubottu> Launchpad bug 1854362 in urwid (Ubuntu) "[MIR] ceph-iscsi, tcmu, python-configshell-fb, python-rtslib-fb, urwid, targetcli-fb" [Undecided,In progress]
15:08 <cpaelzer> it only misses the seed change to pull it in
15:08 <cpaelzer> ceph-iscsi itself wiats for seucrity still
15:08 <cpaelzer> @sarnold I ahve pinged the trello card you have
15:08 <cpaelzer> but everything els eis ready and a valid use-case withotu ceph-iscsi
15:09 <cpaelzer> so I expect next week this will show up in component misatches and needs promotions
15:09 <sarnold> cpaelzer: aha, nice, with all the grub2 issues and fde work I was worried chrisc_coulson might not get back to this for a while... hooray for progress :)
15:09 <doko> looks like I end up with all action items this week ;p
15:10 <doko> we can't promote it, if it's in the release pocket. that would need new uploads for -proposed
15:10 <cpaelzer> nope only the promotions as you are the only AA today, 3 MIR reviews where distributed to others
15:10 <cpaelzer> doko: can we at least promote it in groovy then?
15:11 <doko> yes. ddstreet, are you doing the uploads then, if you want to see it promoted?
15:12 <ddstreet> doko for probert? i can do a no-change rebuild if needed
15:12 <doko> yes
15:12 <ddstreet> for f and g, or just g?
15:13 <ddstreet> since it's in the release pocket for both of them currently
15:13 <doko> just f
15:13 <ddstreet> ah ok yep will do, thanks
15:17 <doko> anything else?
15:18 <cpaelzer> no I think we are good for today
15:18 <cpaelzer> thank all of you!
15:18 <cpaelzer> #endmeeting