15:06 <slashd> #startmeeting DMB meeting
15:06 <meetingology> Meeting started Mon Jul 27 15:06:05 2020 UTC.  The chair is slashd. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:06 <meetingology> 
15:06 <meetingology> Available commands: action commands idea info link nick
15:06 <slashd> #topic Review of previous action items
15:06 <slashd> #subtopic rafaeldtinoco pkgset tooling full documentation (being worked, carried until mentioned)
15:06 <rafaeldtinoco> these are the long term action items
15:06 <slashd> still at the same state ?
15:06 <slashd> right
15:06 <rafaeldtinoco> yep, just mention those
15:06 <rafaeldtinoco> and move on
15:07 <slashd> #subtopic rafaeldtinoco to check edubuntu seed <-> pkgset relationship (generation) and if edubuntu pkgsets can be dropped (carried over)
15:08 <slashd> #subtopic rafaeldtinoco to create, for now, a small "what-to-do" for pkgset changes in -devel (document exceptions inclusion for DMB team) (carried over)
15:08 <rafaeldtinoco> git.launchpad.net/~developer-membership-board/+git/packageset
15:08 <rafaeldtinoco> i still need to finish
15:09 <slashd> #subtopic rafaeldtinoco link team delegation from dmb kb page when reading ddstreet updates (carried over)
15:10 <slashd> rafaeldtinoco Any updates on those items ? or all good for now ?
15:11 <rafaeldtinoco> sorry
15:11 <rafaeldtinoco> my time in the meeting to talk
15:11 <rafaeldtinoco> nope, only the documentation
15:12 <rafaeldtinoco> item is almost finish
15:12 <rafaeldtinoco> but I still have to create the wiki page
15:12 <rafaeldtinoco> and link to the dmb wiki pages
15:12 <slashd> thanks rafaeldtinoco anything we can do to help ?
15:13 <rafaeldtinoco> yes. please
15:13 <sil2100> How can we help?
15:13 <rafaeldtinoco> id like help from someone in the edubuntu seed <-> pkgset relationship
15:13 <rafaeldtinoco> you can get the packageset tool from the git repo I pasted
15:13 <rafaeldtinoco> and follow the README file and check
15:13 <ddstreet> i can take that action item
15:13 <rafaeldtinoco> edubuntu seed <-> pkgset (from germinate)
15:14 <rafaeldtinoco> and check if we should add something to exceptions, or any bigger change there
15:14 <ddstreet> slashd can you give me action item for that
15:14 <rafaeldtinoco> thanks a lot @ddstreet
15:14 <rafaeldtinoco> busy weeks I had
15:14 <rafaeldtinoco> well you too
15:14 <rafaeldtinoco> thanks for sharing the burden lol
15:14 <ddstreet> yep np, i've wanted to understand the seed/pkgset tooling better so this is a good excuse :)
15:15 <rafaeldtinoco> nice, its all in Makefile now
15:15 <rafaeldtinoco> and feel free to push things to the repo
15:15 <slashd> #action edubuntu seed <-> pkgset (ddstreet)
15:15 * meetingology edubuntu seed <-> pkgset (ddstreet)
15:15 <rafaeldtinoco> or MR for me to review
15:16 <slashd> We have no applicant today. Is there anything else we need to discuss or something I missed ?
15:16 <ddstreet> are you going thru the mailing list items in the agenda?
15:17 * slashd looking
15:17 <slashd> #subtopic Request for delagate team for DKMS modules (Francis Ginther)
15:18 <slashd> seems like the vote went on the ML ^
15:18 <ddstreet> do we want to just vote on it now?
15:18 <ddstreet> or keep it on ML?
15:18 <sil2100> Yeah, I think the people that didn't vote could vote now
15:19 <sil2100> We could follow up on the thread for consistency
15:19 <ddstreet> i'm fine voting now if we want to queue up a vote for it
15:20 <slashd> I'm fine with both (ML or proceed with a vote now)
15:20 <slashd> I think we have quorum today anyway
15:20 <ddstreet> let's just vote now, yeah
15:20 <ddstreet> i think there are 2 motions https://lists.ubuntu.com/archives/devel-permissions/2020-July/001540.html
15:21 <slashd> #vote Please vote on: Request for delegate team for DKMS modules
15:21 <meetingology> Please vote on: Please vote on: Request for delegate team for DKMS modules
15:21 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:21 <ddstreet> slashd shouldn't we vote on the 2 motions separately?
15:21 <ddstreet> i mean maybe we'll all vote the same for both, but probably should allow for voting separately?
15:22 <sil2100> I guess this is for the first motion I assume?
15:22 <slashd> #endvote
15:22 <meetingology> Voting ended on: Please vote on: Request for delegate team for DKMS modules
15:22 <meetingology> Votes for:0 Votes against:0 Abstentions:0
15:22 <meetingology> Deadlock, casting vote may be used
15:22 <ddstreet> sounds good yep, this roudn is for motion #1, Create a DKMS packageset defined as "Packages that ship DKMS
15:22 <ddstreet> modules that need updating to support new kernel versions"
15:23 <slashd> #vote Please vote on: Motion 1: Create a DKMS packageset defined as "Packages that ship DKMS
15:23 <slashd> modules that need updating to support new kernel versions" once we have
15:23 <slashd> further agreed upon at least one uploader to be able to upload to this
15:23 <slashd> packageset.
15:23 <meetingology> Please vote on: Please vote on: Motion 1: Create a DKMS packageset defined as "Packages that ship DKMS
15:23 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:23 <sil2100> +1
15:23 <meetingology> +1 received from sil2100
15:24 <ddstreet> +1 sounds reasonable to me
15:24 <meetingology> +1 sounds reasonable to me received from ddstreet
15:24 <slashd> +1
15:24 <meetingology> +1 received from slashd
15:24 <rafaeldtinoco> +1
15:24 <meetingology> +1 received from rafaeldtinoco
15:24 <slashd> #voterequired 4
15:26 <slashd> rbasak also +1'd in the ML
15:26 <slashd> #endvote
15:26 <meetingology> Voting ended on: Please vote on: Motion 1: Create a DKMS packageset defined as "Packages that ship DKMS
15:26 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:26 <meetingology> Motion carried
15:27 <slashd> #vote Please vote on: Motion 2: Create a DKMS packageset uploading team once we have further
15:27 <meetingology> Please vote on: Please vote on: Motion 2: Create a DKMS packageset uploading team once we have further
15:27 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:27 <slashd> agreed upon at least one uploader to be added to this team.
15:27 <slashd> #voterequired 4
15:28 <sil2100> +1 on this one as well
15:28 <meetingology> +1 on this one as well received from sil2100
15:29 <ddstreet> +1 the stated restrictions appear to limit this team to just the dkms modules, which i believe is the intention/goal of the original request, so seems reasonable and appropriate
15:29 <meetingology> +1 the stated restrictions appear to limit this team to just the dkms modules, which i believe is the intention/goal of the original request, so seems reasonable and appropriate received from ddstreet
15:29 <slashd> +1
15:29 <meetingology> +1 received from slashd
15:29 <ddstreet> slashd is the directive '#votesrequired' (with an s, not r)?
15:30 <ddstreet> oh actually just missing the s, maybe
15:30 <slashd> #votesrequired 4
15:30 <meetingology> votes now need 4 to be passed
15:31 <rafaeldtinoco> is this the same motion ?
15:31 <slashd> motion 2
15:31 <rbasak> Same as the one I emailed?
15:31 <rafaeldtinoco> ah ok
15:31 <rafaeldtinoco> +1
15:31 <meetingology> +1 received from rafaeldtinoco
15:31 <rafaeldtinoco> yes
15:31 <rafaeldtinoco> i was going to say that
15:31 <rbasak> +1
15:31 <meetingology> +1 received from rbasak
15:31 <slashd> #endvote
15:31 <meetingology> Voting ended on: Please vote on: Motion 2: Create a DKMS packageset uploading team once we have further
15:31 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:31 <meetingology> Motion carried
15:32 <slashd> Who wants to take action on these 2 motions ?
15:32 <rbasak> There are no actions yet
15:32 <rafaeldtinoco> we got nothing from them yet
15:32 <rbasak> Until we have an uploader approved
15:32 <slashd> all good then
15:33 <slashd> next topic....
15:33 <slashd> #subtopic Adding Yaru to the desktop set for focal (Marco Trevisan)
15:34 <slashd> do we need to vote for that ?
15:35 <ddstreet> probably not, it seems simple enough, it's already in g, i can take action item for it unless anyone else wants it
15:35 <slashd> ddstreet: I'll take care of it if no one has it yet
15:36 <ddstreet> sounds good, thnx
15:36 <slashd> #action Adding Yaru to the desktop set for focal (slashd)
15:36 * meetingology Adding Yaru to the desktop set for focal (slashd)
15:36 <slashd> #subtopic RFC: auto-generated packageset for Canonical OEM enablement metapackages (Iain Lane)
15:37 <slashd> Something to mention here ?
15:37 <ddstreet> not sure if Laney is around?
15:38 <ddstreet> this request seemed, to me, very reasonable, but i think i would prefer to have the mentioned script already created before voting on the new packageset
15:39 <ddstreet> also it wasn't clear to me who would be running the script, and if there would be any human review of its updates (e.g. if it's run on a crontab)
15:39 <slashd> maybe preferable to then addresse those point to the ML and vote when we have all the infos in next DMB mtg(s)
15:39 <Laney> i'm here
15:39 <Laney> what up
15:40 <ddstreet> re: oem packageset
15:40 <Laney> I mean the script is like
15:40 <Laney> for pkg in all_packages:
15:40 <Laney> if fnmatch.fnmatch(pkg, 'oem-*'meta'):
15:40 <Laney> packageset.add(pkg)
15:41 <ddstreet> i assume it would need to be run regularly by a DMB member? or via cron somewhere?
15:41 <Laney> ya something like that, or the oem team can poke you to run it
15:42 <rafaeldtinoco> can be integrated in the packageset repo
15:42 <Laney> or I guess one option would be to make the set owned by another team
15:42 <rafaeldtinoco> and run in crontab or manually
15:42 <Laney> like ~ubuntu-archive or ~ubuntu-sru
15:42 <Laney> then they can run it themseves
15:43 <slashd> sil2100 ^ Any thoughts on that ? since you are in both group
15:43 <Laney> probably -archive since we're talking about uploading to NEW here
15:44 <Laney> then the dmb's role will be handling applications for new uploaders, but not managing the actual packages in the set
15:44 <rbasak> I'm going to have to disappear, sorry. Back in about an hour.
15:45 <slashd> Laney: I guess we will need to make sure ~archive is agree with that, I don't think dmb has authority on that
15:46 <Laney> sure
15:46 <ddstreet> i would also want to make sure the ppa is access-controlled too, since it essentially opens a self-service hole to upload new packages
15:47 <ddstreet> but as long as the packageset team owns the ppa that should be enough
15:47 <Laney> but maybe you can agree that you are ok in principle with it being ubuntu-archive (i.e. not the dmb)
15:47 <Laney> nod
15:47 <ddstreet> yes i'm fine with the dmb only managing membership in the team
15:47 <slashd> same here
15:48 <ddstreet> not sure if we have enough detail to vote on this right now? and probably would need agreement from -sru and/or -archive teams also; should we take it back to the list to continue?
15:49 <sil2100> Sorry, I have a standup now, let me read the backlog
15:49 <slashd> sil2100: take your time I think your input will be valuable here
15:49 <Laney> can come back to it next meeting if you want, I don't think anyone is ready for the rights yet anyway
15:49 <Laney> just want to have it all in place for when they are
15:49 <rafaeldtinoco> i think a reply to the email
15:49 <rafaeldtinoco> with the proposal we have right now
15:50 <rafaeldtinoco> would be better for voting next meeting
15:50 <sil2100> Yeah, I think this should be safe and doable, since the OEM meta package generation is very strictly defined and controlled
15:50 <rafaeldtinoco> if needed, im +1 on the change (to only control the membership of the team)
15:52 <slashd> should we open a vote ? rbasak just left the meeting, maybe we should reconvene next DMB about this topic
15:52 <ddstreet> just to clarify, we'd need a specific action item to vote on right?
15:52 <ddstreet> which i assume for the dmb would only be 'create packageset and owning team' right?
15:53 <rafaeldtinoco> the motion would be either we manage the packageset OR we manage permissions of who could change the packageset (by adding or removing people to a team)
15:53 <rafaeldtinoco> yep
15:54 <slashd> #action vote at next mtg(s) on controlling the membership access for the OEM enablement metapackages.
15:54 * meetingology vote at next mtg(s) on controlling the membership access for the OEM enablement metapackages.
15:54 <slashd> anything else on this topic ?
15:55 <sil2100> I don't have preferences, but I think it would make sense for ubuntu-archive to be able to control this
15:56 <slashd> thanks sil2100
15:56 <slashd> #subtopic Verify ubuntu-budgie packages, possibly remove fossfreedom personal packageset if no longer needed (Open TB bugs)
15:57 <ddstreet> i added this item as i noticed the still-open tb bug
15:57 <slashd> ack so all good then
15:57 <ddstreet> added this comment to the bug for clarification https://bugs.launchpad.net/ubuntu-community/+bug/1716770/comments/9
15:57 <ubottu> Launchpad bug 1716770 in ubuntu-community "[TB/DMB] New packageset ~personal-fossfreedom in Artful" [Undecided,New]
15:57 <ddstreet> i haven't seen any reply from fossfreedom, so we could just close this out
15:58 <slashd> ack
15:58 <slashd> I think that cover everything in the agenda. Anything else before we call it a day ?
16:00 <slashd> I guess we are done then.
16:00 <slashd> #endmeeting