18:59 <rafaeldtinoco> #startmeeting Developer Membership Board Meeting
18:59 <meetingology> Meeting started Mon Jun 15 18:59:58 2020 UTC.  The chair is rafaeldtinoco. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
18:59 <meetingology> 
18:59 <meetingology> Available commands: action commands idea info link nick
19:00 <ddstreet> o/
19:00 <rafaeldtinoco> #chair rafaeldtinoco
19:00 <meetingology> Current chairs: rafaeldtinoco
19:00 <rafaeldtinoco> #topic Review of previous action items
19:00 <rafaeldtinoco> ddstreet: should i start with your items ?
19:01 <ddstreet> sure, i think most are done
19:01 <rafaeldtinoco> alright
19:01 <rafaeldtinoco> ddstreet follow up on packageset owning team for ubuntu-mate (carried over)
19:01 <ddstreet> done, team's created and pkgset is moved over to using it
19:02 <rafaeldtinoco> I have a question regarding the team creations to the end
19:02 <rafaeldtinoco> moving on
19:02 <rafaeldtinoco> ddstreet to handle PPU rights of tux{math,paint,type},x11vnc for alkisg ahead of edubuntu packageset removal in the future
19:02 <ddstreet> done
19:02 <rafaeldtinoco> ddstreet send out announcement for oSoMoN addition to mozilla packageset (rolled over)
19:02 <ddstreet> yep sent, done
19:02 <rafaeldtinoco> ok.. now my stuff
19:02 <ddstreet> one addition first
19:02 <rafaeldtinoco> sure
19:02 <ddstreet> briefly
19:03 <ddstreet> as alkisg should now have all the upload rights needed from the edubuntu pkgset, we should add a action item to remove it, unless there is any other reason for keeping it
19:04 <rafaeldtinoco> what happened to the seeds, do u know ?
19:04 <rafaeldtinoco> i can add filters to pkgset scripts, but they are basically creating the sets coming from existing seeds
19:04 <ddstreet> no, i haven't looked at it other than adding alkisg's upload pkgs
19:04 <rafaeldtinoco> ok.. let me add an action to myself here
19:05 <rbasak> The packageset scripts have a list of autogenerated packagesets, don't they?
19:05 <rafaeldtinoco> rbasak: yep, I can simply filter out edubuntu
19:05 <rafaeldtinoco> im wondering about the seeds existance
19:05 <rafaeldtinoco> should we care ?
19:05 <rbasak> I thought was an inclusion list rather than an exclusion list?
19:06 <rafaeldtinoco> its a shell script with an array currently
19:06 <rbasak> But yeah, we could be good citizens and remove the seed too
19:06 <rafaeldtinoco> and then germinate runs through all generated files
19:06 <rafaeldtinoco> ok, for the seed removal we will need an aa
19:06 <rafaeldtinoco> #action rafaeldtinoco to check edubuntu seed <-> pkgset relationship (generation) and if edubuntu pkgsets can be dropped
19:06 * meetingology rafaeldtinoco to check edubuntu seed <-> pkgset relationship (generation) and if edubuntu pkgsets can be dropped
19:06 <ddstreet> and we should probably manually remove edubuntu from groovy, right?  but leave it untouched from focal and earlier?
19:06 <rbasak> That might be more of a release team or AA thing, yeah
19:06 <rafaeldtinoco> if you all agree ^
19:07 <rbasak> Presumably the image generation machinery needs disconnecting if it isn't already
19:07 <rbasak> +1
19:07 <rafaeldtinoco> hum. true
19:07 <ddstreet> +1
19:07 <rafaeldtinoco> it will be a good exercise to understand in deep the correlation
19:07 <rbasak> Yes - I'd love to learn from you when you're done figuring it out :)
19:07 <rafaeldtinoco> ddstreet: yes (for the groovy removal part)
19:08 <rafaeldtinoco> yep the pkgsets changes emails are about the re-start once im done
19:08 <rafaeldtinoco> let me move to my items
19:08 <rafaeldtinoco> and we can catch up after
19:08 <rafaeldtinoco> rafaeldtinoco to follow up with TB / packageset tooling on ubuntu-studio-uploaders being added to ubuntustudio packageset for upload rights
19:08 <rafaeldtinoco> >  Archive Upload Rights for ubuntu-studio-uploaders: archive 'primary', package set 'ubuntustudio' in groovy
19:08 <rafaeldtinoco> done
19:08 <rafaeldtinoco> rafaeldtinoco to handle request "Adding lubuntu-update-notifier to the Lubuntu package set" (carried over)
19:08 <rafaeldtinoco> > Archive Upload Rights for lubuntu-dev: archive 'primary', package set 'lubuntu' in groovy
19:08 <rafaeldtinoco> done
19:09 <rafaeldtinoco> rafaeldtinoco to complete documentation on existing packageset tooling, and discuss the current (large) delta in the packagesets that need adjusted (rolled over)
19:09 <rafaeldtinoco> > Work in progress, move to long term please.
19:09 <rafaeldtinoco> #action rafaeldtinoco to move pkgset tooling documentation to long term
19:09 * meetingology rafaeldtinoco to move pkgset tooling documentation to long term
19:09 <rafaeldtinoco> rafaeldtinoco to handle getting gnome-shell into ubuntu desktop exceptions list
19:09 <rafaeldtinoco> > Archive Upload Rights for ubuntu-desktop: archive 'primary', package set 'ubuntu-desktop' in groovy
19:09 <rafaeldtinoco> done
19:09 <rafaeldtinoco> rafaeldtinoco to handle "Refresh the packagesets" mailing list item (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001486.html)
19:09 <rafaeldtinoco> done ^
19:09 <rafaeldtinoco> @ddstreet lets talk about this one after I finish my items
19:09 <rafaeldtinoco> per your previous email
19:10 <ddstreet> ack
19:10 <rafaeldtinoco> rafaeldtinoco to look into mailing list item "Including yaru-theme in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001487.html)
19:10 <rafaeldtinoco> > Archive Upload Rights for ubuntu-desktop: archive 'primary', package set 'ubuntu-desktop' in groovy
19:10 <rafaeldtinoco> done
19:10 <rafaeldtinoco> rafaeldtinoco to look into mailing list item "Include fprint packages in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001488.html)
19:10 <rafaeldtinoco> >    Add libfprint to exceptions for ubuntu-desktop pkgset
19:10 <rafaeldtinoco> committed
19:10 <rafaeldtinoco> > $ edit-acl add -S {groovy,focal,eoan,bionic} -s libfprint -P ubuntu-desktop -t upload
19:10 <rafaeldtinoco> done
19:10 <rafaeldtinoco> rafaeldtinoco to handle "Packages to Remove from ubuntustudio packageset" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001497.html)
19:10 <rafaeldtinoco> > Done with the pkgset tool re-run for Groovy.
19:10 <rafaeldtinoco> rafaeldtinoco to handle "Applying packageset exceptions transitively" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001501.html)
19:11 <rafaeldtinoco> > Work in progress, move to long term please.
19:11 <rafaeldtinoco> #action rafaeldtinoco to document exceptions inclusion for DMB team
19:11 * meetingology rafaeldtinoco to document exceptions inclusion for DMB team
19:11 <rafaeldtinoco> ok
19:11 <rafaeldtinoco> we have no applications today
19:11 <rafaeldtinoco> should we discuss anything here
19:11 <rafaeldtinoco> or at the end ?
19:12 <ddstreet> i guess just the mailing list items?
19:12 <rafaeldtinoco> #topic Outstanding mailing list requests to assign
19:12 <rafaeldtinoco> jackd2 for ubuntustudio packageset (Erich Eickmeyer)
19:12 <rafaeldtinoco> ddstreet: ^
19:13 <ddstreet> rafaeldtinoco so, i don't really understand your email reply, but i think that's because i don't understand the tooling yet
19:14 <rafaeldtinoco> let me clarify for you then
19:14 <rafaeldtinoco> in single terms
19:14 <rafaeldtinoco> simple
19:14 <rafaeldtinoco> all pkgset inclusion/exclusion is done by the tooling.. for -devel only
19:14 <rafaeldtinoco> based on the existing seeds for the -devel version.
19:15 <rafaeldtinoco> if there is a pkg that is in the wrong pkgset (server instead of ubuntustudio, lets say)
19:15 <rafaeldtinoco> we have one file to be updated to mark it as an exception
19:15 <rafaeldtinoco> the tooling will be ran 2 or 3 times a week and send an email with the changes
19:16 <rafaeldtinoco> if no complains, the changes will be applied (to devel, based on seed, again)
19:16 <ddstreet> so, packages can only be in a single packageset?
19:16 <rafaeldtinoco> good question
19:17 <rafaeldtinoco> there are seeds that extend other seeds
19:17 <rbasak> AIUI, there are various edge cases that are handled poorly or have surprising results
19:17 <rafaeldtinoco> rbasak: +1 on what you said
19:17 <rafaeldtinoco> the logic is a big python batch with lots of edge cases
19:17 <rbasak> When we've tried to clean these up in the past, different DMB members have had different opinions on what the answer should be
19:17 <rafaeldtinoco> that part is the one I still have to work on
19:18 <ddstreet> so with this example, was it wrong for me to add jackd2 to ubuntustudio packageset?
19:18 <ddstreet> because that would break some other packageset?
19:18 <rafaeldtinoco> so with that example
19:18 <rbasak> I think for now we have to just keep adding exceptions case-by-case, and longer term it'd be nice to specify what the behaviour should be and then start adjusting the tooling to head towards that goal.
19:18 <rafaeldtinoco> for all previous versions .. doing by hand was correct (because we are not automatically updating those).
19:18 <rafaeldtinoco> for groovy .. the correct thing was to put it as an exception.. so instead of "server" it would be "ubuntustudio" in the next automatic generation changes
19:19 <rafaeldtinoco> an email would be sent to us saying that it was about to add the source package (jackd2) to ubuntustudio
19:19 <rafaeldtinoco> we would not complain and the changes would be committed
19:19 <rafaeldtinoco> rbasak: yes
19:19 <rafaeldtinoco> i want to put what we have "in production"
19:19 <rafaeldtinoco> and read the batch better
19:19 <rafaeldtinoco> and document what it does (with germinate output)
19:19 <rafaeldtinoco> and we can maybe discuss
19:19 <ddstreet> so our packageset list doesn't include 'hidden' packagesets like 'server'? https://people.canonical.com/~ubuntu-archive/packagesets/groovy/
19:20 <ddstreet> or do you mean 'ubuntu-server'
19:20 <rbasak> ddstreet: a consequence of manually adjusting an automatic packageset is that the next time the tooling is run, it might try to undo what you did, and then the person running it has to either go with it or code up an exception. Sometimes that's hard to do. The alternatives are to fix the tooling before making the adjustment, or to leave the uploader stuck without the packageset change. None of
19:20 <rbasak> these options are good :-/
19:20 <rafaeldtinoco> ddstreet: https://paste.ubuntu.com/p/H4GBJFYpNK/
19:20 <ddstreet> right, i was clear that my addition of jackd2 might be undone later, which is why i added the follow-up in the agenda to see if the seed update was all that's needed
19:21 <rafaeldtinoco> the jackd2 case I'll re-check
19:21 <rafaeldtinoco> actually
19:21 <rafaeldtinoco> I replied to you on that already
19:21 <rafaeldtinoco> right ?
19:21 <rafaeldtinoco> (just checking)
19:21 <rbasak> ddstreet: yeah and to be clear I'm fine with your approach.
19:21 <ddstreet> ok, maybe it's just me who doesn't see the link between the seeds and packagesets, i'm hoping to get a clearer picture once the tooling is documented...
19:22 <ddstreet> maybe i should just read the existing tooling now
19:22 <ddstreet> well, not *now*, but i mean before refactoring
19:22 <rafaeldtinoco> #action rafaeldtinoco add jackd2 as an exception (from ubuntu-server to audio-plugins perhaps)
19:22 * meetingology rafaeldtinoco add jackd2 as an exception (from ubuntu-server to audio-plugins perhaps)
19:22 <rbasak> In the case that a package is only seeded from one place, it'll end up in the corresponding automatic packageset if there is one.
19:22 <rbasak> If it's seeded from more than one place, then the tooling has various logic to try and resolve it.
19:22 <rbasak> That's the extent of my knowledge :)
19:23 <rafaeldtinoco> yes
19:23 <rafaeldtinoco> rbasak: said correctly
19:23 <rbasak> (and when I say seed, I probably mean germinate - it doesn't matter whether the package is directly or indirectly seeded)
19:23 <rafaeldtinoco> there are some decisions made to see where the package will stay (and now it even reads the pkg dependencies)
19:23 <rafaeldtinoco> this part was made by iain in last change
19:24 <rafaeldtinoco> im about to enter that batch code now =)
19:24 <rafaeldtinoco> ddstreet: let me document something "quick" for the next meeting
19:24 <rafaeldtinoco> "what to do instead of edit-acl for -devel"
19:24 <rafaeldtinoco> - guaranteeing seed is good
19:25 <rafaeldtinoco> - editing exceptions file and commiting
19:25 <rafaeldtinoco> - waiting pkgset auto re-generation
19:25 <rafaeldtinoco> type of thing
19:25 <ddstreet> +1 would definitely help me
19:25 <rafaeldtinoco> #action rafaeldtinoco to create, for now, a small "what-to-do" for pkgset changes in -devel
19:25 * meetingology rafaeldtinoco to create, for now, a small "what-to-do" for pkgset changes in -devel
19:25 <rafaeldtinoco> #action rafaeldtinoco to put pkgset tooling to automatically update pkgsets (crontab)
19:25 * meetingology rafaeldtinoco to put pkgset tooling to automatically update pkgsets (crontab)
19:25 <rafaeldtinoco> ok
19:26 <rafaeldtinoco> that was it on my side for this #)
19:26 <Laney> YEAHHHHH
19:26 <rafaeldtinoco> =)
19:26 <rafaeldtinoco> ddstreet: should I move on to TB bugs ?
19:26 <ddstreet> sure
19:26 <rafaeldtinoco> #topic Open TB bugs
19:26 <Laney> The idea is that flavour developers get to maintain their own stuff, btw, and 'their own stuff' is defined as the things in their flavour, i.e. what they seed
19:27 * Laney runs
19:27 <rafaeldtinoco> Laney: +1 and dont go to far
19:27 <rafaeldtinoco> Packageset modification for ~ubuntu-mate-uploaders
19:27 <rafaeldtinoco> @ddstreet fix released ^
19:27 <ddstreet> yep
19:27 <ddstreet> though
19:28 <rafaeldtinoco> I have a question about this
19:28 <ddstreet> just for my own info, should the devel release have been done differently?
19:28 <ddstreet> (or any of it)
19:28 <rafaeldtinoco> devel should be done automatically (through seed updates -> pkgset changes OR by exceptions file being changed)
19:29 <rafaeldtinoco> ah for this change
19:29 <rafaeldtinoco> no
19:29 <rafaeldtinoco> sorry, this is just a permission change
19:29 <rafaeldtinoco> right ? from person to the team
19:29 <ddstreet> i think just uploader change is totally separate from the tooling, right?
19:29 <ddstreet> yep
19:29 <rafaeldtinoco> that is the exact question I have
19:29 <rafaeldtinoco> who defined we would start creating the teams ?
19:29 <rafaeldtinoco> i mean, is there anything we should follow ?
19:30 <rafaeldtinoco> (start creating dev groups with dmb permissions)
19:30 <ddstreet> there's some docs in the kb
19:30 <ddstreet> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase
19:30 <rafaeldtinoco> because this change gives DMB the power to add/remove people from pkgsets
19:31 <ddstreet> yep
19:31 <rafaeldtinoco> should we do this ad-hoc like you're doing ?
19:31 <rafaeldtinoco> or try to guarantee all pkgsets have their respective devel group ?
19:32 * rbasak doesn't follow
19:32 <rafaeldtinoco> rbasak: last changes coming from ddstreet
19:32 <rafaeldtinoco> like this
19:32 <rafaeldtinoco> https://bugs.launchpad.net/ubuntu-community/+bug/1881666
19:32 <ubottu> Launchpad bug 1881666 in ubuntu-community "[TB/DMB] Packageset modification for ~ubuntu-mate-uploaders" [Undecided,Fix released]
19:32 <ddstreet> changing the ubuntu-mate packageset uploader from an individual to a team
19:33 <ddstreet> note that this was the last 'flavor packageset' that *was not* set to team-uploader
19:33 <ddstreet> so now, all the flavor packagesets have team uploaders
19:33 <rafaeldtinoco> ah was it ?
19:33 <rbasak> The main thing is that we own the team, and nobody else apart from the DMB can change its membership
19:33 <rafaeldtinoco> ok.. so my question is dead
19:33 <rbasak> That seems correct
19:33 <ddstreet> rbasak so team members can't add other members?
19:33 <rbasak> There's also the stuff about ~ubuntu-dev vs. ~ubuntu-upladers which is covered in the docs I think?
19:33 <rbasak> Correct
19:34 <rbasak> That can be done with a delegation, but the team must explicitly have that
19:34 <ddstreet> we should make sure not to add anyone to an uploader team as 'administrator' though, right?
19:34 <rbasak> Right
19:34 <ddstreet> unless they have a delegation
19:34 <ddstreet> ack
19:34 <rafaeldtinoco> hum.
19:34 <rafaeldtinoco> that is new to me, will have to read
19:35 <ddstreet> rbasak rafaeldtinoco note that i did update the dmb kb with some clarification steps
19:35 <rafaeldtinoco> ddstreet: tku, ill read it carefully
19:35 <ddstreet> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase?action=diff&rev2=33&rev1=27
19:35 <ddstreet> or just check the 'info' tab to select diffs
19:35 <rafaeldtinoco> cool
19:35 <ddstreet> i think everything i added is correct, but please do correct anything as needed
19:35 <rbasak> Delegations documented here: https://wiki.ubuntu.com/UbuntuDevelopers/TeamDelegation
19:36 <rafaeldtinoco> alright, got homework on this
19:36 <rafaeldtinoco> anything else on this discussion ?
19:36 <ddstreet> we should link the teamdelegation from our kb page
19:36 <ddstreet> if it isn't already
19:37 <rafaeldtinoco> #action rafaeldtinoco link teamdelegation from dmb kb page when reading ddstreet updates
19:37 * meetingology rafaeldtinoco link teamdelegation from dmb kb page when reading ddstreet updates
19:37 <rafaeldtinoco> ill do it since I'll read it again
19:37 <ddstreet> thanks
19:37 <rafaeldtinoco> #topic PPU addition for ~alkisg
19:37 <rafaeldtinoco> https://bugs.launchpad.net/ubuntu-community/+bug/1881653
19:37 <ubottu> Launchpad bug 1881653 in ubuntu-community "[TB/DMB] PPU addition for ~alkisg" [Undecided,Fix released]
19:37 <rafaeldtinoco> fix released also ^
19:38 <ddstreet> yep
19:38 <rafaeldtinoco> do I have to check groovy for this one ?
19:38 <rafaeldtinoco> ah it was permission only
19:38 <rafaeldtinoco> nm
19:38 <rafaeldtinoco> ppu, ok moving on
19:39 <ddstreet> right, and next one is ppu also i think
19:39 <rafaeldtinoco> #topic PPU addition for ~rcj
19:39 <rafaeldtinoco> https://bugs.launchpad.net/ubuntu-community/+bug/1866679
19:39 <ubottu> Launchpad bug 1866679 in ubuntu-community "[TB/DMB] PPU addition for ~rcj" [Undecided,Fix released]
19:39 <rafaeldtinoco> fix released also
19:39 <ddstreet> yep, and while the tb bug doesn't list groovy, i am pretty sure he already had ppu for groovy
19:39 <rafaeldtinoco> cool
19:40 <rafaeldtinoco> #topic Select a chair for the next meeting
19:40 <rafaeldtinoco> rbasak: can u chair the next one ?
19:40 <rafaeldtinoco> you're the next on the list
19:41 <rafaeldtinoco> I can change it later if you can't
19:41 <rafaeldtinoco> #topic Any other business
19:41 <rafaeldtinoco> ok..
19:41 <rafaeldtinoco> any other stuff to be discussed ?
19:42 <ddstreet> nothing else from me
19:42 <rbasak> rafaeldtinoco: sure
19:42 <rafaeldtinoco> rbasak: tku
19:42 <rafaeldtinoco> ok.. im calling it in ... 5
19:42 <rafaeldtinoco> 4
19:42 <rafaeldtinoco> 3
19:42 <slashd> Just as an fyi ... I'll need to catch up on the current todo, but I'm back after a few weeks of absence.
19:43 <rafaeldtinoco> slashd: welcome back =)
19:43 <rafaeldtinoco> slashd: you will be chairing after rbasak
19:43 <ddstreet> glad to have you back slashd :)
19:43 <rafaeldtinoco> fyio
19:43 <rafaeldtinoco> 3
19:43 <slashd> rafaeldtinoco: no problem for the chairing order
19:43 <rafaeldtinoco> 2
19:43 <rafaeldtinoco> 1
19:43 <rafaeldtinoco> #endmeeting