15:08 <ddstreet> #startmeeting DMB meeting
15:08 <meetingology> Meeting started Mon Jun  1 15:08:08 2020 UTC.  The chair is ddstreet. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:08 <meetingology> 
15:08 <meetingology> Available commands: action commands idea info link nick
15:08 <ddstreet> #chair ddstreet
15:08 <meetingology> Current chairs: ddstreet
15:09 <ddstreet> #topic Review of previous action items
15:09 <ddstreet> tsimonq2 to better document what we expect applicants to know (carried over)
15:09 <rbasak> teward: around?
15:09 <ddstreet> i assume this continues to be carried over?  we could change it to (will be carried until mentioned) if so
15:10 <teward> hey headbashing atm
15:10 <teward> here but i am playing catchup on 2 things
15:10 <teward> :)
15:11 <ddstreet> tsimonq2 should we carry that item over until mentioned in a future mtg?
15:12 <tsimonq2> ddstreet: Sure.
15:12 <ddstreet> ack thnx
15:12 <tsimonq2> Before that happens...
15:12 <ddstreet> #action tsimonq2 to better document what we expect applicants to know (will be carried until mentioned)
15:12 * meetingology tsimonq2 to better document what we expect applicants to know (will be carried until mentioned)
15:12 <tsimonq2> I'd like to mention I have something started.
15:12 <ddstreet> ah ok sorry
15:12 <tsimonq2> There are some Lubuntuisms in there, but it's the base for what I'm going to write.
15:12 <tsimonq2> It's all good, it's not fully done yet.
15:13 <tsimonq2> https://phab.lubuntu.me/w/lubuntu-dev/
15:13 <tsimonq2> That's actually based off of the Kubuntu Developers page.
15:14 <tsimonq2> Anyway, I thought I'd mention it. We can move on from her.e
15:15 <ddstreet> thanks, looks good!
15:15 <ddstreet> ok next item
15:15 <ddstreet> teward follow up on packageset owning team for ubuntu-mate (carried over)
15:15 <teward> still haven't had a chance to, anyone else on the DMB want to take it?
15:16 <teward> (one of the billion things that I think I handed to ddstreet I thought)
15:16 <ddstreet> yep i can take this, unless anyone else wants to grab it
15:16 <ddstreet> #action ddstreet follow up on packageset owning team for ubuntu-mate (carried over)
15:16 * meetingology ddstreet follow up on packageset owning team for ubuntu-mate (carried over)
15:16 <teward> (FWIW: lots of IT Security issues in my main job so that has hampered my efforts on things)
15:17 <ddstreet> rafaeldtinoco i'm going to defer your items until the end of the list if that's ok with you, try to keep actions grouped by owner
15:17 <rafaeldtinoco> es
15:17 <rafaeldtinoco> its a good practice
15:17 <ddstreet> teward to handle PPU rights of tux{math,paint,type},x11vnc for alkisg ahead of edubuntu packageset removal in the future
15:17 <ddstreet> teward i looked at this a bit, i don't think it's done yet right?
15:18 <sil2100> If someone has any action items that they'd like to pass to someone else, feel free to assign me then
15:18 <teward> no it's not, I think we need to JFDI.
15:18 <ddstreet> my main q was if we are dropping edubuntu just for groovy and later, or for focal and earlier too?
15:18 <teward> ddstreet: i think that was a separate discussion
15:18 <teward> because that task was specifically getting the PPU rights applied
15:18 <teward> we have yet to have a full discussion over the edubuntu packageset removal
15:18 <ddstreet> ok so just to be safe we should ask for PPU rights for all releases for him then
15:18 <teward> correct.
15:18 <ddstreet> ack, i can do this, i was already looking at it earlier today
15:19 <ddstreet> #action ddstreet to handle PPU rights of tux{math,paint,type},x11vnc for alkisg ahead of edubuntu packageset removal in the future
15:19 * meetingology ddstreet to handle PPU rights of tux{math,paint,type},x11vnc for alkisg ahead of edubuntu packageset removal in the future
15:19 <ddstreet> teward to apply permissions changes for oSoMoN to mozilla packageset and send out announcement (rolled over)
15:19 <ddstreet> teward this is done, just needs the announcement sent out; i can do that
15:19 <teward> yep
15:20 <ddstreet> #action ddstreet send out announcement for oSoMoN addition to mozilla packageset (rolled over)
15:20 * meetingology ddstreet send out announcement for oSoMoN addition to mozilla packageset (rolled over)
15:20 <ddstreet> teward to handle Erich Eickmeyer permissions changes for access to Ubuntu Studio packageset and send out announcement (half-done, rolled over)
15:20 <ddstreet> this is done
15:20 <ddstreet> sil2100 to add kanashiro coredev permissions and send announcement
15:20 <ddstreet> i think you did that right sil2100?
15:20 <sil2100> Yes, this is done
15:21 <ddstreet> ok we're on to rafaeldtinoco items :)
15:21 <ddstreet> rafaeldtinoco to follow up with TB / packageset tooling on ubuntu-studio-uploaders being added to ubuntustudio packageset for upload rights (carried over)
15:21 <tsimonq2> I did process some minor packageset additions for Erich over the past few weeks.
15:21 <tsimonq2> calamares-settings-ubuntu comes to mind. ;)
15:21 <rafaeldtinoco> ddstreet: Ill have PTO on wednesday and will work all my items during my PTO basically.
15:21 <rafaeldtinoco> so the gnome-shell item was discussed broadly
15:22 <rafaeldtinoco> in https://lists.ubuntu.com/archives/devel-permissions/2020-May/001501.html
15:22 <rafaeldtinoco> and Im considering to be together with "refresh packagesets"
15:23 <rafaeldtinoco> and, like tsimonq2 said, we are doing all packageset changes additions/removals by hand here and ther
15:23 <rafaeldtinoco> but we still need the full refresh
15:23 <ddstreet> so should we carry over all items for you then?
15:23 <rafaeldtinoco> nope
15:23 <ddstreet> or are some already done, by hand
15:23 <rafaeldtinoco> there were 2 you did
15:23 <ddstreet> i did? ;-)
15:23 <rafaeldtinoco> yaru-theme
15:23 <rafaeldtinoco> and fprintf
15:23 <rafaeldtinoco> for ubuntu-desktop
15:23 <rafaeldtinoco> didnt u ?
15:24 <rafaeldtinoco> i mean, like gnome-shell, they are connected as well
15:24 <rafaeldtinoco> from Laney "I know this isn't finalised yet. It works for the yaru-theme case, but
15:24 <rafaeldtinoco> there are also some others which are IMO still incorrect, like mozjs68."
15:24 <ddstreet> i dont think i did, but let me put the action on me to check that, maybe i did
15:24 <rafaeldtinoco> nope you replied to the thread
15:24 <rafaeldtinoco> and there is some work from Iain
15:25 <rafaeldtinoco> ddstreet: carry all my items over please
15:25 <ddstreet> right i replied basically saying i don't understand what the desktop packageset split is intended to do
15:25 <rafaeldtinoco> i think they will all be sorted
15:25 <ddstreet> ok
15:25 <rafaeldtinoco> with me catching up with what Iain did
15:25 <rafaeldtinoco> and updating all packagesets
15:25 <rafaeldtinoco> this will be done by next meeting
15:25 <ddstreet> #action rafaeldtinoco to follow up with TB / packageset tooling on ubuntu-studio-uploaders being added to ubuntustudio packageset for upload rights (carried over)
15:25 * meetingology rafaeldtinoco to follow up with TB / packageset tooling on ubuntu-studio-uploaders being added to ubuntustudio packageset for upload rights (carried over)
15:25 <ddstreet> #action rafaeldtinoco to handle request "Adding lubuntu-update-notifier to the Lubuntu package set" (carried over)
15:25 * meetingology rafaeldtinoco to handle request "Adding lubuntu-update-notifier to the Lubuntu package set" (carried over)
15:25 <ddstreet> #action rafaeldtinoco to complete documentation on existing packageset tooling, and discuss the current (large) delta in the packagesets that need adjusted (rolled over)
15:25 * meetingology rafaeldtinoco to complete documentation on existing packageset tooling, and discuss the current (large) delta in the packagesets that need adjusted (rolled over)
15:26 <ddstreet> #action rafaeldtinoco to handle getting gnome-shell into ubuntu desktop exceptions list
15:26 * meetingology rafaeldtinoco to handle getting gnome-shell into ubuntu desktop exceptions list
15:26 <ddstreet> #action rafaeldtinoco to handle "Refresh the packagesets" mailing list item (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001486.html)
15:26 * meetingology rafaeldtinoco to handle "Refresh the packagesets" mailing list item (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001486.html)
15:26 <ddstreet> #action rafaeldtinoco to look into mailing list item "Including yaru-theme in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001487.html)
15:26 * meetingology rafaeldtinoco to look into mailing list item "Including yaru-theme in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001487.html)
15:26 <ddstreet> #action rafaeldtinoco to look into mailing list item "Include fprint packages in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001488.html)
15:26 * meetingology rafaeldtinoco to look into mailing list item "Include fprint packages in the ubuntu-desktop set" (https://lists.ubuntu.com/archives/devel-permissions/2020-April/001488.html)
15:26 <ddstreet> ok and rafaeldtinoco if i can help with anything do let me know
15:26 <sil2100> Same
15:26 <rafaeldtinoco> tks
15:27 <rafaeldtinoco> i think Ill got it all cleared up
15:27 <rafaeldtinoco> PTO is for that, isnt it ?
15:27 <ddstreet> lol only if you're doing it at the beach :)
15:27 <rafaeldtinoco> sgtm
15:27 <ddstreet> ok that's all the previous action items, no applications on the agenda for today
15:28 <ddstreet> 2 mailing list items i think
15:28 <ddstreet> Packages to Remove from ubuntustudio packageset (Erich Eickmeyer) https://lists.ubuntu.com/archives/devel-permissions/2020-May/001497.html
15:28 <rafaeldtinoco> they are related
15:28 <rafaeldtinoco> to all my actions
15:28 <ddstreet> yep unfortunately i think you're getting this one too :)
15:28 <rafaeldtinoco> cleaning up for ubuntustudio
15:28 <ddstreet> but it should come 'for free' with the tooling updates
15:29 <rafaeldtinoco> and packageset exceptions <- this feature is *needed* to make sure we can cover it all
15:29 <ddstreet> #action rafaeldtinoco to handle "Packages to Remove from ubuntustudio packageset" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001497.html)
15:29 * meetingology rafaeldtinoco to handle "Packages to Remove from ubuntustudio packageset" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001497.html)
15:29 <rafaeldtinoco> #)
15:29 <ddstreet> rafaeldtinoco unfortunately i think the next one is yours too, iain's email
15:30 <ddstreet> Applying packageset exceptions transitively (Iain Lane)
15:30 <rafaeldtinoco> yep
15:30 <rafaeldtinoco> its the exception to solve the gnome-shell case
15:30 <Laney> The core split is basically the expansion of the desktop-common platform seed
15:30 <Laney> sorry, I got highlighted :-)
15:30 <rafaeldtinoco> that was the idea =)
15:30 <rafaeldtinoco> and thanks for the packegeset scripts updates
15:30 <ddstreet> #action rafaeldtinoco to handle "Applying packageset exceptions transitively" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001501.html)
15:30 * meetingology rafaeldtinoco to handle "Applying packageset exceptions transitively" (https://lists.ubuntu.com/archives/devel-permissions/2020-May/001501.html)
15:30 <rafaeldtinoco> ill get into it this week
15:30 <Laney> right, ok
15:31 <ddstreet> ah oops, i forgot to change topic
15:31 <ddstreet> #topic AOB
15:31 <Laney> I think it's risky updating thoes sets manually, because then the next time you go to run the script things will drop out 'mysteriously'
15:31 <rafaeldtinoco> Laney: ill mark all requests in the last months
15:31 <rafaeldtinoco> and verify one by one
15:31 <Laney> it should at least be paired with adding exceptions
15:31 <rafaeldtinoco> Laney: yep
15:32 <Laney> well, actually, you'd expect that normally just re-running the script would get new seeded stuff
15:32 <Laney> ok, i'll stop talking now
15:32 <Laney> :p
15:32 <rafaeldtinoco> Laney: can I ping you
15:32 <rafaeldtinoco> after I sort out your changes ?
15:32 <rafaeldtinoco> #)
15:33 <ddstreet> ok any other business to discuss?
15:33 <ddstreet> or did i miss anything?
15:33 <ddstreet> i think we're done then, in 5...
15:33 <ddstreet> 4
15:33 <rafaeldtinoco> i think youve missed
15:33 <rafaeldtinoco> a few topic changes
15:33 <rafaeldtinoco> #)
15:33 <ddstreet> lol yes i did :)
15:34 <rafaeldtinoco> like select chair for next meeting
15:34 <ddstreet> ah ok
15:34 <ddstreet> #topic Chair and Time for Next Meeting
15:34 <rafaeldtinoco> ill be the next chair, then robie
15:34 <ddstreet> next mtg is Monday 2020-06-15 19:00 UTC
15:34 <rafaeldtinoco> perhaps dan can go to the end of the line
15:34 <sil2100> I think I also haven't chaired for a while
15:34 <ddstreet> sounds good, i'll move myself down
15:35 <sil2100> Probably missed those meetings on which I was to chair
15:35 <ddstreet> ok anythign else i missed?
15:35 <sil2100> So if anyone feels like they'd like a break, feel free to select me as the chair
15:35 <rafaeldtinoco> thats ok
15:35 <rafaeldtinoco> next meeting I have so many items
15:35 <rafaeldtinoco> being the chair will make things quicker
15:35 <rafaeldtinoco> #)
15:35 <rafaeldtinoco> ddstreet: thanks for being the chair today
15:35 <rafaeldtinoco> nothing else
15:35 <sil2100> ;)
15:36 <sil2100> Nothing here
15:36 <ddstreet> np, ok ending in 3...
15:36 <ddstreet> 2
15:36 <ddstreet> 1
15:36 <ddstreet> #endmeeting