15:09 <ddstreet> #startmeeting
15:09 <meetingology> Meeting started Mon Apr  6 15:09:21 2020 UTC.  The chair is ddstreet. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:09 <meetingology> 
15:09 <meetingology> Available commands: action commands idea info link nick
15:09 <ddstreet> #topic Review of previous action items
15:10 <ddstreet> tsimonq2 to better document what we expect applicants to know (carried over)
15:10 <teward> simon isn't here so we'll have to carry over his action item.
15:10 <ddstreet> ddstreet to define an initial list of 'flavor teams'
15:11 <ddstreet> I sent an email to the list, as far as i can tell the short summary is there is a list of all flavor teams in my email, so we can set the expiry for those teams
15:11 <ddstreet> but also, two of the flavors do not have teams
15:11 <ddstreet> so, i think we also need to create teams for those 2 flavors, ubuntu-mate and ubuntustudio
15:12 <teward> ubuntu studio has a dev team
15:12 <teward> it's just not part of the packageset
15:12 <teward> (I'm on the dev team for Studio :P)
15:12 <ddstreet> ok then probably the packageset should be changed over to use the dev team, instead of just rosco2
15:12 <ddstreet> right?
15:12 <teward> ddstreet: add an action item RE: that team to me to follow up with Erich Eickmeyer (flavor lead) RE: a 'core' team for them with upload rights
15:13 <teward> the dev team includes quite a few people I would not want to give direct upload rights to
15:13 <teward> (i'll act as liaison since I"m actually on their team helping with upload sponsors and NEW stuff)
15:13 * Eickmeyer butts-in
15:13 <Eickmeyer> We technically *do* have a core team of which I'm the owner.
15:13 <Eickmeyer> I know that doesn't include upload rights
15:13 <teward> Eickmeyer: given YOU do not even have upload rights to the studio packageset yet because you haven't applied, we need to discuss this outside of the DMB meeting
15:14 <Eickmeyer> teward: ack
15:14 <ddstreet> #action teward follow up with Erich Eickmeyer (flavor lead) RE: a 'core' team for them with upload rights
15:14 * meetingology teward follow up with Erich Eickmeyer (flavor lead) RE: a 'core' team for them with upload rights
15:14 <teward> my two cents.
15:14 <teward> ('cause it's a larger discussioN)
15:14 <teward> ('cause it's a larger discussion)
15:14 <ddstreet> ok that's for ubuntustudio, what about for ubuntu-mate?
15:15 <ddstreet> someone should follow up on changing it to use a team for packageset owner instead of just flexiondotorg
15:15 <ddstreet> teward you want to take that one as well?
15:15 <teward> I don't ahve any direct ties to the MATE team but i'll take the action item
15:16 <ddstreet> ack thanks
15:16 <ddstreet> #action teward follow up on packageset owning team for ubuntu-mate
15:16 * meetingology teward follow up on packageset owning team for ubuntu-mate
15:16 <ddstreet> ok and just so i don't forget we're carrying over simon's item
15:17 <ddstreet> #action tsimonq2 to better document what we expect applicants to know (carried over)
15:17 * meetingology tsimonq2 to better document what we expect applicants to know (carried over)
15:17 <teward> #meetingtopic DMB Meeting
15:17 <teward> (we forgot to set the topic heh)
15:17 <ddstreet> thanks
15:18 <ddstreet> ok to finish up this action item, someone needs to set expiry time on the existing identified flavor teams, unless anyone else wants that i can take it
15:18 <ddstreet> #action ddstreet set expiry time on identified flavor teams
15:18 * meetingology ddstreet set expiry time on identified flavor teams
15:19 <ddstreet> also, if anyone disagrees with the list i sent, feel free to comment, of course
15:19 <teward> i haven't had time to review it yet ddstreet
15:19 <teward> so at least for the next few days don't kick expiry into gear yet if possible
15:19 <teward> i want to review it ;0
15:19 <teward> ;) *
15:19 <ddstreet> ack, i'll wait until next week to do that
15:19 <ddstreet> ok, on with the carried over items
15:20 <teward> (out of order)
15:20 <teward> teward to handle request "Requesting upload rights for ltsp"
15:20 <teward> Completed, and rights granted per PPU mechanisms
15:20 <teward> teward to handle request "Adding lubuntu-update-notifier to the Lubuntu package set"
15:20 <teward> Carry it over, still figuring out the packageset stuff
15:20 <teward> unless you know how to do it (I haven't found docs on it)
15:20 <teward> BUt i will ultimately ACK that into the packageset as it's only an Lubuntu package
15:21 <ddstreet> i do not, i'm happy to let you carry it over :)
15:21 <teward> yep
15:21 <ddstreet> #action teward to handle request "Adding lubuntu-update-notifier to the Lubuntu package set"
15:21 * meetingology teward to handle request "Adding lubuntu-update-notifier to the Lubuntu package set"
15:21 <ddstreet> rafaeldtinoco to handle request "Expired MOTU membership"
15:21 <ddstreet> rafaeldtinoco is not around, so we can carry this over also
15:21 <ddstreet> #action rafaeldtinoco to handle request "Expired MOTU membership" (carried over)
15:21 * meetingology rafaeldtinoco to handle request "Expired MOTU membership" (carried over)
15:22 <rafaeldtinoco> yes pls
15:22 <rafaeldtinoco> sorry, i'll do this week
15:22 <ddstreet> ah hi o/
15:22 <ddstreet> ack thanks
15:22 <ddstreet> slashd to handle request "Please add new printing-related packages to my upload rights into main"
15:22 <teward> rafaeldtinoco: if you don't get time let me know, and I'll give it a review/handle (I literally am bored off my butt with work from home heh)
15:22 <rafaeldtinoco> teward: alright. tku, will try to have it done but will let u kow
15:23 <teward> yep
15:23 <teward> NOW onto slashd :)
15:23 <ddstreet> slashd any update for printing pkgs item?
15:23 <slashd> ddstreet: not yet, will do my best to look at it this week.
15:23 <slashd> been a bit crazy lately for me
15:24 <ddstreet> ack, thanks
15:24 <ddstreet> #action slashd to handle request "Please add new printing-related packages to my upload rights into main" (carried over)
15:24 * meetingology slashd to handle request "Please add new printing-related packages to my upload rights into main" (carried over)
15:24 <ddstreet> ddstreet to write up a proposal for upload access expiry following some period of disuse
15:24 <ddstreet> i have not got to this
15:24 <ddstreet> #action ddstreet to write up a proposal for upload access expiry following some period of disuse (carried over)
15:24 * meetingology ddstreet to write up a proposal for upload access expiry following some period of disuse (carried over)
15:24 <ddstreet> ok i think that's all the carried over items
15:25 <teward> yep
15:25 <ddstreet> The PPU application is set for next meeting, so skipping over that
15:25 <teward> yep, we have no MOTU, SRU Dev, or Core Dev applications
15:25 <teward> just a few mailing list items
15:25 <ddstreet> #topic Outstanding mailing list requests to assign
15:25 <ddstreet> Consider dissolution of packagesets for defunct flavor: edubuntu (teward)
15:26 <ddstreet> https://lists.ubuntu.com/archives/devel-permissions/2020-March/001466.html
15:26 <teward> For those who haven't reviewed my email on the mailing list yet I can summarize:
15:26 <teward> Basically, in regards to the LTSP request, it brought up a point that Edubuntu is dead - and as a result the packageset has no need to exist
15:26 <teward> my proposal is to remove the packageset and thsoe who need direct upload to those packages can continue to apply via PPU processes
15:26 <teward> such dissolution of the packageset will, in my opinion, require quorum vote
15:27 <ddstreet> my only question re: that is there appears to be 1 memeber who would then lose existing upload rights
15:27 <ddstreet> should we make them re-apply to get upload rights back?
15:28 <ddstreet> or create a personal packageset for them?
15:28 <ddstreet> specifically,    - Alkis Georgopoulos (alkisg)
15:28 <rbasak> Can we invite that person to join the discussion?
15:28 <ddstreet> and the edbuntu packageset is https://people.canonical.com/~ubuntu-archive/packagesets/focal/edubuntu
15:28 <rbasak> Ask them what they'd like.
15:29 <teward> it looks like stgraber owuld be affected as well as alkisg, unless stgraber has core and i'm blind at reading their memberships
15:29 <rafaeldtinoco> question, we would have to approve to this person ppu for all those pkgs then ?
15:29 <rbasak> stgraber is a core dev
15:29 <teward> then i am blind :)
15:29 <rbasak> So no impact to him
15:29 <teward> rafaeldtinoco: it'd probably make sense to make a packageset for that user - a personal packageset for alkisg
15:29 <teward> I'm not opposed to that
15:29 <rafaeldtinoco> thats why I ask, to make sure we are on the same page
15:29 <teward> but because of the dead edubuntu flavor, edubuntu-dev still has uploads.
15:30 <rbasak> If we did that, it'd be individual PPU, not a personal packageset.
15:30 <teward> mmm, we would have to do it a PPU then.  I think we'll have to loop in alkisg, but I'm hesitant to keep defunct flavors' packagesets around
15:30 <teward> just my two cents
15:30 <rbasak> I suggest we propose it to alkisg
15:30 <rafaeldtinoco> +1
15:30 <rbasak> Before making any decision
15:30 <teward> +1
15:31 <ddstreet> +1
15:31 <ddstreet> anyone want to take that action item?
15:31 <teward> so then action item is to reach out to aklisg and ask if they're willing to make a PPU application for all the packages
15:31 <teward> *raises hand*
15:31 <teward> ... if you want to keep assigning things to me that is :p
15:31 <rbasak> No even a PPU application
15:31 <rbasak> I don't think an application is necessary
15:31 <rafaeldtinoco> just the change to happen
15:31 <rbasak> We should just ask if a transfer to PPU would be acceptable as a way forward
15:31 <rbasak> We can figure out how we want to achieve that later.
15:32 <rbasak> (I'm in favour of JFDI with no application)
15:32 <rafaeldtinoco> sgtm
15:32 <teward> agreed, so i'll take the action item of proposing to them and then JFDI if that's OK'd
15:32 <ddstreet> #action teward discuss edbuntu conversion to ppu with aklisg
15:32 * meetingology teward discuss edbuntu conversion to ppu with aklisg
15:32 <ddstreet> thanks!
15:32 <rbasak> One consequence is that things that might have previously qualified to just-be-added to the edubuntu packageset will now require individual PPU applications.
15:32 <rbasak> I think that would be fine though - just pointing it out.
15:33 <teward> rbasak: my opinion is that the Edubuntu Package Set is a legacy piece
15:33 <rbasak> Agreed
15:33 <teward> leftover from the defunct flavor
15:33 <teward> as such, NOTHING gets added to Edubuntu going forward
15:33 <teward> but we're free to remove from or dissolve the packageset
15:34 <teward> which is why I gave them PPU via DM on their ML request.
15:34 <teward> that's my opinion regarding defunct packagesets anyways
15:35 <ddstreet> ok so should we vote on edbuntu dissolution now, or wait until after teward talks to aklisg?
15:35 <rbasak> after teward talks to alkisg please
15:35 <teward> ddstreet: carry that over, we want to talk to alkisg
15:35 <rafaeldtinoco> yep
15:35 <ddstreet> ack, so let's move to the next email request
15:35 <ddstreet> Please add ukui packages to the ubuntukylin package set (handsome_feng)
15:35 <ddstreet> i think this, and the next one, are trivial items that any indivudla dmb member can handle
15:36 <ddstreet> just adding packages to packageset
15:36 <rbasak> Yes, but
15:36 <rbasak> If it's an automatically generated packageset, then that makes it complicated
15:36 <ddstreet> ah right since it's flavor pkgset
15:36 <rbasak> If you just add it to the packageset in Launchpad, that will revert the next time the automation is run
15:37 <ddstreet> so in this case, the actual action is to run the script tooling to update the packageset from the seeds
15:37 <ddstreet> right?
15:37 <rbasak> I'm not sure all flavor packagesets are generated by the script
15:37 <rbasak> ddstreet: yeah, roughly
15:37 <ddstreet> ok i guess we should take an item to check the tooling, and run it
15:37 <rbasak> Hopefully the script will agree with the request, and then it can just happen
15:37 <rbasak> Otherwise the script logic and/or exception lists might need adjusting
15:38 <ddstreet> any volunteers for that?
15:38 <rafaeldtinoco> i can give it a try
15:38 <ddstreet> thanks!
15:39 <ddstreet> #action rafaeldtinoco look at flavor packageset tooling re: update of ubuntukylin packageset, run tooling to update packageset
15:39 * meetingology rafaeldtinoco look at flavor packageset tooling re: update of ubuntukylin packageset, run tooling to update packageset
15:39 <ddstreet> request to add jsunit to the mozilla packageset (olivier.tilloy)
15:39 <ddstreet> this isn't a flavor packageset (mozilla) so i think this should just be a manual addition to the packageset
15:40 <ddstreet> any volunteers?
15:40 <teward> i can handle it
15:41 <ddstreet> don't overload yourself :)
15:41 <teward> yes i know i'm volunteering for everything but if anyone else wants it feel free to take it
15:41 <teward> ddstreet: put into perspective:
15:41 <teward> 90% of the day i'm sitting on my butt bingewatching TV and checking email and work chat for tasks
15:41 <teward> so i am not overloaded - i'm DYING for stuff to keep me entertained :)
15:41 <ddstreet> ah well that makes sense :)
15:41 <teward> so if anyone else wants it take it, otherwise assign it to me
15:42 <ddstreet> looks like it's yours ;)
15:42 <ddstreet> #action teward request to add jsunit to the mozilla packageset (olivier.tilloy)
15:42 * meetingology teward request to add jsunit to the mozilla packageset (olivier.tilloy)
15:42 <teward> aso i've already binged Stargate SG-1 from Season 1 to final episode of Season 10 already with WFH - which gives you an idea of exactly HOW BUSY I am not :p
15:42 <ddstreet> lol, sg-1 is a good one to watch
15:43 <ddstreet> ok last item i think
15:43 <ddstreet> #topic Select a chair for the next meeting (following alphabetical order of first names)
15:43 * RikMills loans teward Atlantis Bluerays
15:43 <rbasak> It'll be Simon again I guess?
15:44 <teward> RikMills: joke's on you, I have 4k streaming of it via Amazon Prime :)
15:44 <rbasak> And ddstreet can move himself to the end.
15:44 <RikMills> teward: ditto
15:44 <ddstreet> ack sounds good, i'll move myself in the list but otherwise leave as is
15:44 <teward> rbasak: i'd say we need to remove Simon from the chairs list for now
15:44 <teward> i can't even raise him on texts at the moment
15:44 <teward> and that's no easy feat
15:44 * rbasak doesn't mind
15:44 <rbasak> (who is chair)
15:44 <ddstreet> ack, will do that too
15:44 <rbasak> Just do something, and call it done please :)
15:44 <teward> yep
15:44 <ddstreet> ok AOB?
15:45 <ddstreet> 10...
15:45 <ddstreet> 5
15:45 <ddstreet> 4
15:45 <ddstreet> 3
15:45 <teward> yep
15:45 <ddstreet> you do have othe rbusiness?
15:45 <teward> but nothing that needs discussion - thanks to everyone on the DMB for being alive since the recent election
15:45 <teward> it's great we can get quorum and discussions regularly again :)
15:45 <ddstreet> agreed!
15:45 <teward> (so nothing crucial just something to point out)
15:46 <ddstreet> ok 2, 1, done
15:46 <ddstreet> #endmeeting