15:03 <juliank> #startmeeting Weekly Ubuntu Foundations team
15:03 <meetingology> Meeting started Thu Aug 15 15:03:02 2019 UTC.  The chair is juliank. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:03 <meetingology> 
15:03 <meetingology> Available commands: action commands idea info link nick
15:03 <juliank> #topic Lightning rounds
15:03 <juliank> echo $(shuf -e vorlon bdmurray xnox tdaitx doko sil2100 rbalint infinity cyphermox mwhudson juliank waveform)
15:03 <juliank> bdmurray tdaitx vorlon mwhudson doko infinity xnox sil2100 juliank rbalint waveform cyphermox
15:04 <bdmurray> finished conversion of daisy to python-cassandra (not retracer code though)
15:04 <bdmurray> submitted MP and RT regarding updating daisy in production (x2)
15:04 <bdmurray> discovered that daisy wasn't really updated in production / got it done again
15:04 <bdmurray> research into daisy w/ python-cassandra causing OOM kills
15:04 <bdmurray> reverted daisy to previous version without python-cassandra
15:04 <bdmurray> resolved issue with Error Tracker daily user count cronjob
15:04 <bdmurray> review of u-r-u MP regarding calculating snap size requirements
15:04 <bdmurray> fixed a Traceback when writing to CouldNotBucket in cassandra
15:04 <bdmurray> triage of ubuntu-bug failing LP: #1814611
15:04 <ubottu> Launchpad bug 1814611 in apport (Ubuntu Eoan) "turning off "Send error reports to Canonical" prevents using ubuntu-bug" [High,Triaged] https://launchpad.net/bugs/1814611
15:04 <bdmurray> review of MP regarding sru-report re: block-proposed tag
15:04 <bdmurray> something of a short week as I was out yesterday
15:04 <bdmurray> ✔ done
15:05 <bdmurray> no tdaitx
15:05 <bdmurray> vorlon: ?
15:05 <vorlon> oh noes
15:05 <vorlon> ok
15:05 <vorlon> * discussions around secureboot on ARM for a customer
15:06 <vorlon> * proposed-migration
15:06 <vorlon> * includes kicking off the mysql8 transition and trying to address long-stuck packages
15:06 <vorlon> * reviewing an ubuntu-image request from sil2100
15:06 <vorlon> * NEW reviews in SRU
15:06 <vorlon> (done)
15:07 <doko> no mwhudson ...
15:07 <doko> * back from vacations
15:07 <doko> * catch up with things
15:07 <doko> (done)
15:07 <juliank> No infinity
15:07 <juliank> xnox:
15:08 <xnox> * uc20:
15:08 <xnox> consoleconf & core20 now works
15:08 <xnox> * s390x stuff:
15:08 <xnox> bug #1837016
15:08 <ubottu> bug 1837016 in Ubuntu on IBM z Systems "[19.10 FEAT] Enhanced CPU-MF hardware counters - libpfm part" [High,Fix released] https://launchpad.net/bugs/1837016
15:08 <xnox> bug #1836532
15:08 <ubottu> bug 1836532 in Ubuntu on IBM z Systems "[19.10 FEAT] Upgrade libdfp 1.0.14" [High,Fix released] https://launchpad.net/bugs/1836532
15:08 <xnox> bug #1839123
15:08 <ubottu> bug 1839123 in Ubuntu on IBM z Systems "[19.10 FEAT] gzip compression improvements addl. patch required" [High,Fix released] https://launchpad.net/bugs/1839123
15:08 <xnox> bug #1835048
15:08 <ubottu> bug 1835048 in Ubuntu on IBM z Systems "[19.10 FEAT] openCryptoki ica token: add SHA*-RSA_PKCS_PSS mechanisms" [High,Fix released] https://launchpad.net/bugs/1835048
15:08 <xnox> * atlas progressing on z14 optimizied builds
15:08 <xnox> done
15:08 <xnox> next
15:09 <juliank> sil2100 is out
15:09 <juliank> It's my turn
15:09 <juliank> .. some weird clicking later ..
15:09 <juliank> * uploaded gpgme1.0 to bionic to fix FTBFS there (LP: #1813581)
15:09 <ubottu> Launchpad bug 1813581 in gpgme1.0 (Ubuntu Bionic) "gpgme1.0 ftbfs in 18.04 LTS" [High,Fix committed] https://launchpad.net/bugs/1813581
15:09 <juliank> * otherwise, it's been kind of an *apt* week.
15:09 <juliank> * released apt 1.8.3, (fake-ish)-synced to disco, 1.8.3~deb10u1 for Debian stable (LP: #1838771 amongst others)
15:09 <ubottu> Launchpad bug 1838771 in apt (Ubuntu Disco) "http:Fix Host header in proxied https connections" [Medium,In progress] https://launchpad.net/bugs/1838771
15:09 <juliank> * fixed a segmentation fault introduced in apt 1.9.2 (https://salsa.debian.org/apt-team/apt/merge_requests/73, LP: #1839714)
15:09 <ubottu> Launchpad bug 1839714 in apt (Ubuntu) "Segmentation fault when running apt update using libapt-pkg5.90_1.9.2" [High,Fix committed] https://launchpad.net/bugs/1839714
15:09 <juliank> * wondering why dpkg SRU was released on disco and xenial but not bionic (that's not a sane order ;))
15:09 <juliank> * learned more about AppStream and what the needs are on a package management daemon side
15:09 <juliank> * started preparing to run black on python-apt code
15:09 <juliank> also as a special announcement: APT PATTERNS (for packages) ARE HERE! (https://salsa.debian.org/apt-team/apt/merge_requests/74)
15:09 <juliank> * Purge config files: apt purge ?config-files
15:09 <juliank> * Remove autoremovable packages: apt remove ?garbage
15:09 <juliank> * Install packages with weird queries: apt install ?or(?name(^apt$),?and(?true,?false))
15:09 <juliank> * Show all upgradable packages: apt-cache show ?upgradable
15:09 <juliank> * Caveats: It's not working for search and inside preferences files so far
15:10 <juliank> * https://people.debian.org/~jak/apt-search-terms.html contains more info (but is badly rendered; it's apt-patterns(5) manpage).
15:10 <juliank> * Patterns for versions coming at a later point, but trying to get them in before feature freeze
15:10 <juliank> * Will be writing a blog post about that stuff, it's super exciting.
15:10 <juliank> (done)
15:10 <juliank> rbalint:
15:10 <rbalint> * tried to migrate a 243-rc1 then got it dropped from eoan-proposed and rebuilt rev deps that needed that
15:10 <rbalint> * now preparing 241 for eoan and continuing fixing up 243 for eoan+1
15:10 <rbalint> * partner work
15:10 <rbalint> (done)
15:10 <waveform> * Pi 4 boot:
15:10 <waveform> * Got u-boot working reliably across pi versions but only with conditional sections (separate u-boot for 2, 3, and 4); still no fb or kbd for u-boot on pi4 though (lacking drivers)
15:10 <waveform> * Tidying up mkknlimg usage by pi for bug #1805668 (appears mkknlimg is no longer required; have removed it apparently successfully from the experimental u-boot package)
15:10 <waveform> * Got a kernel working with both pi3 and pi4 \o/ (still stripping out irrelevant patches)
15:10 <waveform> * Kernel appears fully functional on the 3, but not fully on 4 (ethernet and framebuffer working, but neither USB2 nor USB3 - lacking some config)
15:10 <ubottu> bug 1805668 in linux-firmware-raspi2 (Ubuntu) "Building armhf and arm64 Raspberry Pi 3 images" [Undecided,New] https://launchpad.net/bugs/1805668
15:10 <waveform> * With a bit more work should be possible to have a single classic distribution that works on all (supported) pi platforms
15:10 <waveform> * Upgrade path for older versions is under consideration
15:10 <waveform> (done)
15:10 <cyphermox> I was out Friday, Monday and Tuesday.
15:11 <cyphermox> visited wineries, looked at Legos and stuff
15:11 <cyphermox> preparing netplan release
15:11 <cyphermox> (done)
15:12 <juliank> I guess no questions on status?
15:12 <juliank> #topic Release incoming bugs (eoan)
15:12 <juliank> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-ee-incoming-bug-tasks.html#foundations-bugs
15:13 <bdmurray> bug 1840122
15:13 <ubottu> bug 1840122 in linux (Ubuntu) "System fails to reboot from live session or ubiquity-dm - squashfs_read_data failed to read block" [High,Confirmed] https://launchpad.net/bugs/1840122
15:15 <xnox> bdmurray:  so, we had those squashfs error on subiquity iso during disco release.
15:15 <xnox> bdmurray:  the "fails to reboot" i wonder if it's again "waiting for someone to press enter"
15:15 <vorlon> finalrd?
15:16 <xnox> because the squashfs_read_data hides the messages.
15:16 <vorlon> are we doing finalrd yet?
15:16 <xnox> hmmmm
15:17 <xnox> i remember writting a finalrd hook, but i can't remember if i shipped it or not
15:17 <vorlon> I'm sure you didn't
15:17 <vorlon> something something late in cycle
15:18 <vorlon> so do we want to commit to this?
15:21 <xnox> apw:  remember squashfs errors during disco sprint on subiquity image? now happening on regular desktop image too as reproduced by jibel......
15:21 <xnox> apw:  did we ever look into squashfs, as in are we building them wrong? is media bad? or kernel too strict?
15:21 <juliank> #topic Release incoming bugs (bionic)
15:21 <juliank> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-bb-incoming-bug-tasks.html#foundations-bugs
15:22 <apw> xnox, i remember vaguly, do we have an example of a thing which is bad ?
15:23 <vorlon> [ACTION] xnox and apw to get to the bottom of LP: #1840122 and report back
15:23 * meetingology xnox and apw to get to the bottom of LP: #1840122 and report back
15:23 <ubottu> Launchpad bug 1840122 in linux (Ubuntu) "System fails to reboot from live session or ubiquity-dm - squashfs_read_data failed to read block" [High,Confirmed] https://launchpad.net/bugs/1840122
15:23 * apw fades into the backgroun
15:24 <gaughen> d
15:26 <apw> *a spooky voice says* "its there bug faded out"
15:26 <juliank> that's what I said!
15:29 <vorlon> the only bug there is a 'low' systemd bug that appears to be in someone else's hands, not for us
15:29 <vorlon> move on?
15:29 <juliank> ok!
15:29 <juliank> ?
15:30 <xnox> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1837700
15:30 <ubottu> Launchpad bug 1837700 in OEM Priority Project "Dell system takes a long time to connect network with external dock" [Critical,In progress]
15:30 <xnox> Need fix landing in bionic before 31st of August.
15:34 <xnox> ddstreet:  can we chat about systemd SRU bugs? they don't quite make sense to me, and I'm not sure if things were tested on non-dell systems, and like upgrades from xenial with ifupdown.
15:34 <xnox> juliank:  NEXT
15:34 <juliank> #topic Team proposed-migration report
15:34 <juliank> #link http://people.canonical.com/~ubuntu-archive/proposed-migration/update_excuses_by_team.html#foundations-bugs
15:35 <cyphermox> I'm already looking at pyyaml (since last week)
15:35 <rbalint> prometheus-blackbox-exporter can't be installed and to fix it it needs breaking a build cycle
15:35 <rbalint> i'm already on it
15:35 <ddstreet> xnox sure anytime
15:36 <juliank> cyphermox: hang on, I have a card for that
15:36 <cyphermox> juliank: ok, well it's /mostly/ rerunning the tests with the right trigers
15:37 <rbalint> can i just badtest prometheus-blackbox-exporter for a little to migrate debconf?
15:38 <gaughen> are we talking btrfs?
15:38 <vorlon> btrfs-progs: xnox has already got an mp to curtin for this
15:38 <vorlon> so that's in progress
15:38 <gaughen> cool
15:38 <juliank> what's broken there? it says candidate
15:38 <seb128> vorlon, xnox, apw, commenting a bit later, but that reboot issue is what is making daily ISO testing fail in UTAH and daily-proposed desktop not moving to current (so would be nice to get to the bottom of it)
15:38 <gaughen> then the debconf one
15:38 <vorlon> rbalint: if prometheus-blackbox-exporter can't be installed, is that an autopkgtest failure that we should ignore?
15:38 <gaughen> rbalint has debconf
15:38 <xnox> seb128:  ah, interesting! thanks.
15:40 <vorlon> prometheus-blackbox-exporter badtest added
15:40 <vorlon> golang-defaults, I've previously flagged to mwhudson's attention
15:40 <gaughen> vorlon, I'll put on his plate
15:40 <vorlon> juliank: you know to look in update_output.txt for things that are lingering in 'candidate'?
15:40 <juliank> vorlon: no
15:41 <vorlon> juliank: 'candidate' only means that this package meets all the policies (built, tests) for it to be considered for migration.  It can still block, if migrating it would make other packages uninstallable
15:41 <vorlon> and that information is in update_output.txt
15:42 <juliank> skipped: btrfs-progs (9, 33, 80)
15:42 <juliank> got: 41+0: a-16:a-7:a-7:i-5:p-3:s-3
15:42 <juliank> * amd64: curtin, subiquity, subiquity-tools
15:42 <juliank> that's super readable
15:42 <vorlon> ;)
15:42 <juliank> Can't we have britney output that to the html
15:42 <vorlon> no
15:42 <vorlon> it's a completely second pass
15:42 <juliank> ugh
15:42 <juliank> not a good ux :D
15:42 <vorlon> nope
15:42 <vorlon> but it's what exists today
15:43 <cyphermox> I had started discussing that with upstream
15:43 <cyphermox> (ie. outputting some json or whatnot that could then be used)
15:43 <vorlon> also that file is basically log output of a process that may run multiple times
15:43 <cyphermox> yeah :/
15:43 <juliank> anyway...
15:43 <cyphermox> and outputting it is performance-sensitive
15:43 <vorlon> anyway, something better would be nice, but is non-trivial :)
15:43 <vorlon> yes
15:44 <juliank> let's continue with libvpx?
15:44 <vorlon> libvpx is a library transition; seb128 was looking at it the other day
15:44 <cyphermox> I kinda half know what I'm getting into there, but I'm volunteering to help seb128 with it if necessary
15:44 <seb128> I didn't get far and I'm off tomorrow so if someone wants to look as well please do
15:44 <vorlon> ffmpeg had a failing autopkgtest on armhf; xpra fails on ppc64el; and it's entangled with mysql via mythtv (which might be transiently removable)
15:45 <cyphermox> we can still move it forward a bit
15:45 <seb128> ffmpeg got updated to a new version at the same time as the libvpx update, we would try the previous version on armhf to see if that one works
15:46 <gaughen> thanks cyphermox
15:46 <seb128> I wanted to do that today but didn't get to it
15:46 <juliank> python-tz caused pandas to regress
15:47 <vorlon> juliank: python2-only regression?
15:47 <vorlon> do we resolve that by dropping python2 from pandas? :)
15:47 <juliank> unittests            FAIL non-zero exit status 137
15:47 <juliank> unittests3           PASS
15:47 <juliank> I mean looks like it
15:48 <vorlon> there are a few revdeps that would need unwinding, but it's tractable and probably a better use of time than fixing the python2-specific ppc64el pandas test failure
15:49 <juliank> ../../../usr/lib/python2.7/dist-packages/pandas/tests/series/test_analytics.py::TestSeriesAnalytics::test_isin Killed
15:49 <xnox> http://autopkgtest.ubuntu.com/packages/p/pandas/eoan/amd64 -> triggered by pytest => fails in both py2 and py3
15:49 <xnox> because of newer pytest
15:50 <xnox> https://pandas-docs.github.io/pandas-docs-travis/whatsnew/v0.25.0.html
15:51 <vorlon> a volunteer to drop python2 support for pandas and its revdeps?
15:51 <gaughen> do it vorlon
15:51 <vorlon> ok
15:51 <vorlon> I'll take it
15:53 <gaughen> aptdaemon
15:53 <juliank> So
15:53 <juliank> this was passing once
15:53 <juliank> it normally does not
15:53 <juliank> there is some weird hang on arm64 most of the time
15:53 <vorlon> once upon a time once, or exactly once once?
15:53 <vorlon> so it's flaky and we should badtest it?
15:54 <juliank> and it's only regressing now because it suddenly passed
15:54 <juliank> yeah
15:54 <rbalint> juliank, i'm adding a badtest
15:55 <xnox> http://autopkgtest.ubuntu.com/packages/m/mysql-connector-c++ good url
15:57 <rbalint> hints for today https://code.launchpad.net/~rbalint/britney/autopkgtest-eoan-hints/+merge/371356
16:01 <juliank> let's skip the rest of the list, it's getting long
16:01 <juliank> #topic Chair selection for next meeting
16:01 <cyphermox> I volunteer
16:01 <juliank> acknowledged!
16:01 <juliank> #topic AOB
16:02 <juliank> any other business?
16:02 <vorlon> rbalint: merged; were you going to add mysql-connector-c++ hints also?
16:03 <rbalint> vorlon, i pushed that as well a few secs ago :-)
16:03 <vorlon> ok
16:03 <rbalint> i'm rebasing
16:03 <rbalint> a sec
16:03 <vorlon> rbalint: you forgot the word 'force-badtest' at the start of that hint ;)
16:04 <rbalint> ahh
16:04 <vorlon> juliank: no other business
16:04 <juliank> #endmeeting