19:01 <rbasak> #startmeeting DMB
19:01 <meetingology> Meeting started Mon Jun 17 19:01:29 2019 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:01 <meetingology> 
19:01 <meetingology> Available commands: action commands idea info link nick
19:01 <sil2100> rbasak: thanks!
19:01 <slashd> rbasak, thanks
19:01 <cyphermox> rbasak: thanks.
19:01 <rbasak> #topic Review of previous action items
19:01 <rbasak> tsimonq2 to better document what we expect applicants to know (carried over)
19:01 <rbasak> slashd to follow up on the APAC Ubuntu community coverage (carried over)
19:02 <rbasak> Check if slashd announced acheronuk's successful MOTU application everywhere where needed (carried over) (done)
19:02 <rbasak> sil2100 to add fossfreedom_ to the ubuntu-budgie packageset (done)
19:02 <rbasak> sil2100 to send announcements of fossfreedom's successful application (done)
19:02 <rbasak> Ah, three of those are done.
19:02 <rbasak> tsimonq2:, slashd: any updates on the remaining two please?
19:02 <slashd> I would add the uncomplete vote of ddstreet
19:02 <slashd> acheronuk, AFAIK it's done, i'll double check been a while
19:02 <slashd> APAC still waiting for my contact to ping me to find a good time
19:03 <rbasak> #action slashd to follow up on the APAC Ubuntu community coverage (carried over)
19:03 * meetingology slashd to follow up on the APAC Ubuntu community coverage (carried over)
19:03 <rbasak> Sounds like tsimonq2 wasn't sure he could make it, so I'll carry over his too.
19:03 <sil2100> +1
19:03 <rbasak> #action tsimonq2 to better document what we expect applicants to know (carried over)
19:03 * meetingology tsimonq2 to better document what we expect applicants to know (carried over)
19:04 <rbasak> slashd: as we have quorum, perhaps we can vote on ddstreet here directly, as the email thread is already at the votes stage?
19:04 <slashd> rbasak, sound good to me
19:04 <rbasak> #topic Follow up on the ubuntustudio packageset upload permissions for Rosco2
19:04 <rbasak> What needed doing here?
19:05 <slashd> just to vote, I think we passed the question period on the ML thread
19:05 <cyphermox> shouldn't we follow up on the thread?
19:06 <slashd> sorry thought you were taking about ddstreet ^^
19:06 <rbasak> cyphermox: we've been failing on following up on the thread, and we are quorate today. I think we should just vote.
19:06 <rbasak> The email thread is already past the questions stage.
19:06 <sil2100> rbasak: hm, I don't think anything needs doing here?
19:06 <sil2100> rbasak: (I mean the Rosco2 thing)
19:06 <rbasak> sil2100: I'm not sure. I was just trying to figure out when that item got added.
19:06 <cyphermox> fait enough
19:07 <rbasak> sil2100: looks like it was you: https://wiki.ubuntu.com/DeveloperMembershipBoard/Agenda?action=diff&rev1=753&rev2=754 :)
19:07 <sil2100> rbasak: uh oh!
19:07 <slashd> rbasak, for acheronuk I confirmed I have done everything ( I just double-checked)
19:07 <rbasak> I propose that we drop it, but that we email him to be sure we aren't dropping something.
19:07 <sil2100> rbasak: I think it's all done and we missed listing it on previous meetings because I made it a separate section instead of an action item ;p
19:08 <rbasak> slashd: acheronuk> thanks!
19:08 <sil2100> rbasak: sorry about that
19:08 <rbasak> sil2100: Rosco2> do you want to check with him or are you happy it's all done?
19:08 <sil2100> rbasak: I'll check with him just to be sure ;)
19:08 <rbasak> Thank you!
19:08 <rbasak> #action sil2100 to check with Rosco2 that ubuntustudio packageset upload permission changes are all complete
19:08 * meetingology sil2100 to check with Rosco2 that ubuntustudio packageset upload permission changes are all complete
19:09 <rbasak> #topic Ubuntu Core Developer Applications
19:09 <rbasak> #subtopic ddstreet
19:09 <rbasak> I propose to do this one first, because we weren't quorate last time, so FIFO.
19:09 <cyphermox> yup
19:09 <rbasak> Is there any further discussion needed before I start the vote?
19:09 <rbasak> (eg. points of order)
19:10 <rbasak> #vote Approve ddstreet's core dev application
19:10 <meetingology> Please vote on: Approve ddstreet's core dev application
19:10 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:10 <slashd> +1 for me as previously stated in the ML thread
19:10 <meetingology> +1 for me as previously stated in the ML thread received from slashd
19:16 <teward> err:stalled?
19:17 <teward> (sorry making sure IRC didn't die on me here...)
19:17 <cyphermox> no, not stalled.
19:18 <cyphermox> +1
19:18 <meetingology> +1 received from cyphermox
19:18 <teward> cyphermox: ack.  looks like my ZNC lagged fierce and everything was literally dead then flooded back :)
19:22 <sil2100> +1 there are a few places where Dan could get more experience and a few places where improvement is needed (more coordination, agreement), but I'm confident that he'll be able to improve in these areas with the help of other ubuntu engineers
19:22 <meetingology> +1 there are a few places where Dan could get more experience and a few places where improvement is needed (more coordination, agreement), but I'm confident that he'll be able to improve in these areas with the help of other ubuntu engineers received from sil2100
19:23 <rbasak> So, my rationale first, since it's a bit long.
19:24 <rbasak> Given previous (including recent) communications I've seen between ddstreet and other Ubuntu developers, my sole reservation is that he doesn't always seem to be on the same page as others wrt. consensus. What I don't want to see are uploads for anything other core devs consider contentious without discussion first.
19:24 <rbasak> I've seen some things I like on this recently though. I get the impression he is taking this feedback on board.
19:25 <rbasak> So I am erring on giving him the benefit of the doubt, but just ask that he keep this in mind before every upload (please don't upload if others have raised doubts, or would raise doubts if asked, without a conclusive discussion)
19:25 <rbasak> +1
19:25 <meetingology> +1 received from rbasak
19:25 <rbasak> #endvote
19:25 <meetingology> Voting ended on: Approve ddstreet's core dev application
19:25 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:25 <meetingology> Motion carried
19:26 <rbasak> Congrats ddstreet!
19:26 <sil2100> \o/
19:26 <sil2100> ddstreet: congrats!
19:26 <slashd> congrat \o/ ddstreet
19:26 <rbasak> Can someone volunteer to 1) do the ACL changes; and 2) announce, please?
19:27 <slashd> rbasak, will do
19:27 <sil2100> slashd: you want to take the action item of adding your team-mate to the team? ;)
19:27 <slashd> yep ^
19:27 <rbasak> slashd: thanks!
19:27 <rbasak> slashd: reminder: https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application
19:27 <rbasak> #action slashd to make ACL changes for ddstreet's successful core dev application
19:27 * meetingology slashd to make ACL changes for ddstreet's successful core dev application
19:27 <rbasak> #action slashd to announce ddstreet's successful core dev application
19:27 * meetingology slashd to announce ddstreet's successful core dev application
19:28 * rbasak fumbles with the agenda
19:28 <rbasak> #subtopic teward
19:28 <teward> o/
19:28 <rbasak> teward: hello! Please could you introduce yourself, and then we'll see if anyone has questions.
19:29 <rbasak> teward: and thank you for waiting!
19:30 <teward> My name is Thomas Ward, I've been using Ubuntu since 2009, and been working heavy with nginx support with the support of the Ubuntu Server Team since 2014.  I've had PPU rights for that since 2014 as well.  I've been around for a while, many of you have interacted with me before, and look forward to continuing to contribute more to Ubuntu!  CoreDev will allow me to bypass many of the sponsorship hurdles I've hit for some of my more 'drive by'
19:30 <teward> bug fixes I've done in recent times across the archive, and I thank you all for considering my application!
19:30 <teward> bleh longmessage is long.
19:30 <teward> If anyone has any questions, please feel free to ask :)
19:30 <rbasak> Questions for teward please?
19:31 <rbasak> I have none - note that I have endorsed his application, and I have been in regular communication with him for years.
19:31 <sil2100> teward: I have a question, one of my 'regular ones' ;)
19:31 <teward> And I should point out that even with CoreDev, I always look for a second set of eyes on anything that's not straightforward :)
19:31 <teward> sil2100: go ahead :)
19:32 <teward> s/I always look/I will always look/
19:32 <sil2100> teward: in your Ubuntu work so far, did you work with update_excuses and update_output for packages that you had sponsored?
19:32 <sil2100> *have had sponsored
19:32 <sil2100> (English is hard)
19:34 <teward> sil2100: yes, it is hard.  I have worked with update_excuses a lot, yes, it's my primary go-to when looking for autopkgtest output.
19:34 <teward> I haven't looked on a regular basis on update_output but do look there as well.  It's a littel harder to read so I always have to take extra time when reading through update_output
19:35 <teward> update_excuses HAS, however, helped me to catch a few broken autopkgtests unrelated to things I"ve had sponsored up (or uploaded myself such as nginx) and then work through fixing it.  Some autopkgtest failures looked to be errant failures due to cloud infra problems that Canonical IS had to look into though
19:35 <sil2100> teward: let's say you have a package blocked in -proposed, then what info could update_output give you that won't be visible in output_excuses?
19:35 <teward> sil2100: to clarify, s/output_excuses/update_excluses/ ?
19:35 <teward> before I answer :)
19:36 <teward> update_excuses*
19:36 * teward kicks his keyboard
19:36 <sil2100> Argh
19:36 <sil2100> I think my head is overheated already
19:36 <sil2100> Yeah, I meant update_excuses instead of output_excuses
19:36 <sil2100> ;)
19:38 <teward> 'tis what I thought but I want to clarify before answering ;)
19:39 <teward> sil2100: from my knowledge, update_output can provide more details on installability.  Namely, if a package is released to the release pocket, it can help to ID whether other packages are now uninstallable, as well as the number of problems introduced by a package being released.  Take for example the current ZNC item in the current update_output.txt.  There's no `got` line there, but a `got` line there could help indicate the number of
19:39 <teward> uninstallable packages or problems introduced with a package being released
19:39 <teward> Further on a per arch basis, it can help to show specific packages that now are breakable and cannot be installed by a package being uploaded
19:40 <teward> Currently for ZNC there's some problems, but notably for s390x znc-backlog can't install
19:41 <teward> Generally speaking though the update_output will help to show what else might break when introducing a package into the target release pocket for a package
19:41 <teward> which is primarily the main reason I've used it for
19:41 <teward> (there's still some bits of this output mind you I don't immediately remember what it reflects, however I regularly inquire on such confusion on the output.)
19:42 <teward> update_excuses does show cases such as autopkgtest breakages though
19:43 <teward> which isn't reflected in update_output
19:43 <sil2100> teward: thanks, that's what I wanted to hear
19:43 <rbasak> Any other questions for teward?
19:43 <teward> (whereas update_output provides more detailed data than the update_excuses shows on installability and package breakages)
19:43 <teward> sil2100: :)
19:43 <teward> sil2100: as for your overheated head... here's a glass of water :)
19:46 <rbasak> #vote Approve teward's core dev application
19:46 <meetingology> Please vote on: Approve teward's core dev application
19:46 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:46 <sil2100> teward: ok, another question, this time regarding your application! I guess I only see one endorsement (or maybe two, because Seth's comment seems like an endorsement)
19:46 <rbasak> Oh, sorry.
19:47 <rbasak> Hold on the vote and let's answer sil2100's question first.
19:47 <sarnold> my comment is indeed meant as an endorsement, but as I don't have core-dev myself, it felt more appropriate to just leave a comment
19:47 <sil2100> teward: there's no hard requirement on the number, but we usually expect around 3 to get a good idea of how a person is 'seen' by other developers
19:48 <sil2100> teward: is there any reason your application didn't get any additional written endorsements? ;)
19:48 <teward> sil2100: part of that would be that I had reached out to other developers who HAD sponsored my stuff in the past but got no reply back in emails, and in other cases a couple of people had said they would and didn't get around to it by the time I filed the application.
19:49 <rbasak> Consider my endorsement a _strong_ one, please :)
19:49 <teward> note that the lack of written endorsements is less an inaction of trying to get them, but more inaction/delays with those I had reached out to
19:49 <rbasak> I forgot to mention it in my endorsement, but there's also the thread in ubuntu-devel@ on backports which is relevant I think.
19:49 <sil2100> ;)
19:49 <teward> most of my latest sponsored items have been people just getting to it in the queues or me prodding heavily
19:49 <sil2100> teward: ACK
19:49 <sil2100> Ok, I think I'm ready to vote
19:50 <rbasak> OK.
19:50 <rbasak> Let's vote!
19:50 <rbasak> The vote is already active in meetingology from above, so please go ahead.
19:50 <rbasak> +1
19:50 <meetingology> +1 received from rbasak
19:50 <cyphermox> +1
19:50 <meetingology> +1 received from cyphermox
19:51 <sil2100> +1 but please moar uploads
19:51 <meetingology> +1 but please moar uploads received from sil2100
19:52 <slashd> +1 I wish I could see more recent activity, but base on teward history, proven skills and rbasak strong opinion about you, I'll feel confident.
19:52 <meetingology> +1 I wish I could see more recent activity, but base on teward history, proven skills and rbasak strong opinion about you, I'll feel confident. received from slashd
19:52 <sil2100> Uploads aren't most important, but uploads is the reason one wants to get core-dev!
19:52 <teward> I can guarantee there will be more uploads :)
19:52 <sil2100> s/is/are
19:52 <sil2100> And we had one vote from tsimonq2 in case he wouldn't be able to make it
19:53 <rbasak> Ah yes, I forgot.
19:53 <rbasak> tsimonq2 also voted +1
19:53 <rbasak> #endvote
19:53 <meetingology> Voting ended on: Approve teward's core dev application
19:53 <meetingology> Votes for:4 Votes against:0 Abstentions:0
19:53 <meetingology> Motion carried
19:53 <rbasak> teward: congrats!
19:53 <slashd> congrats teward \o/
19:53 <teward> thank you!  :)
19:53 <rbasak> Can someone volunteer to do teward's announcement and ACL changes please?
19:53 <teward> and thank you again for taking the time to consider my application!  :D
19:54 <sil2100> rbasak: let me take that
19:54 <Eickmeyer> \o/
19:54 <rbasak> #action sil2100 to make ACL changes for teward's successful core dev application
19:54 * meetingology sil2100 to make ACL changes for teward's successful core dev application
19:54 <rbasak> #action sil2100 to announce teward's successful core dev application
19:54 * meetingology sil2100 to announce teward's successful core dev application
19:54 <rbasak> Thanks!
19:55 <rbasak> #topic Outstanding mailing list requests to assign
19:55 <rbasak> I don't see any
19:56 <rbasak> #topic Any other business
19:56 <rbasak> Please raise any other topics now.
19:57 <sil2100> None from me, I guess
19:57 <rbasak> #endmeeting