15:14 <sil2100> #startmeeting Developer Membership Board
15:14 <meetingology> Meeting started Mon Apr  8 15:14:42 2019 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:14 <meetingology> 
15:14 <meetingology> Available commands: action commands idea info link nick
15:14 <sil2100> (I'll chair I guess)
15:15 <sil2100> #topic Review of previous action items
15:15 <sil2100> tsimonq2 to better document what we expect applicants to know (carried over)
15:15 <sil2100> I suppose this is still ongoing, right?
15:15 <tsimonq2> Sorry, punt.
15:15 <tsimonq2> Yeah.
15:15 <sil2100> Let's carry it over then
15:15 <sil2100> slashd to follow up on the APAC Ubuntu community coverage (carried over) <- slashd is not with us today so let's carry this over as well
15:15 <sil2100> #action tsimonq2 to better document what we expect applicants to know (carried over)
15:15 * meetingology tsimonq2 to better document what we expect applicants to know (carried over)
15:16 <sil2100> #action slashd to follow up on the APAC Ubuntu community coverage (carried over)
15:16 * meetingology slashd to follow up on the APAC Ubuntu community coverage (carried over)
15:16 <sil2100> tsimonq2, jbicha and micahg to vote on "give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future" <- this is done as votes happened via e-mail
15:16 <sil2100> slashd to add acheronuk to MOTU <- I suppose this was done? /me checks
15:17 <acheronuk> sil2100: someone did!
15:17 <sil2100> Yes, it's done I see o/
15:17 <sil2100> slashd to announce acheronuk's successful MOTU application <- I think this was done as well, but not sure if Eric did send it to all the required lists
15:17 <sil2100> So let's carry it over for now
15:18 <acheronuk> there was an email
15:18 <acheronuk> might have been cyphermox
15:18 <sil2100> #action Check if slashd announced acheronuk's successful MOTU application everywhere where needed (carried over)
15:18 * meetingology Check if slashd announced acheronuk's successful MOTU application everywhere where needed (carried over)
15:18 <sil2100> #topic Package Set/Per Package Uploader Applications
15:18 <sil2100> #subtopic fossfreedom
15:18 <sil2100> fossfreedom_: hello o/
15:18 <fossfreedom_> hi!
15:19 <sil2100> fossfreedom_: I guess we all know you already, but from the formal POV, could you introduce yourself? ;)
15:19 <sil2100> #link https://wiki.ubuntu.com/fossfreedom/UbuntuBudgiePackageSetApplication
15:19 <fossfreedom_> My name is David Mohammed, I am the project lead of UB and I am today asking for consideration of packageset permissions for our project
15:20 <sil2100> fossfreedom_: you currently have PPU rights to the main budgie packages, correct?
15:20 <fossfreedom_> (btw thanks for refreshing the packageset list)
15:20 <fossfreedom_> Yes - correct - I've listed those in the application also
15:21 <sil2100> #link http://people.canonical.com/~ubuntu-archive/packagesets/disco/personal-fossfreedom
15:21 <sil2100> cyphermox, tsimonq2, rbasak: any questions?
15:21 <sil2100> (this is the list of current package upload permissions ^)
15:22 <rbasak> No questions from me
15:22 <tsimonq2> None from me either.
15:23 <sil2100> cyphermox: ?
15:23 <cyphermox> no
15:24 <sil2100> Excellent
15:25 <sil2100> #vote Granting upload permissions to the ubuntu-budgie packageset to fossfreedom_
15:25 <meetingology> Please vote on: Granting upload permissions to the ubuntu-budgie packageset to fossfreedom_
15:25 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:25 <rbasak> +1
15:25 <meetingology> +1 received from rbasak
15:25 <sil2100> +1 (I have seen many uploads and SRUs from fossfreedom_ and I was always happy with them)
15:25 <meetingology> +1 (I have seen many uploads and SRUs from fossfreedom_ and I was always happy with them) received from sil2100
15:26 <cyphermox> +1
15:26 <meetingology> +1 received from cyphermox
15:27 <tsimonq2> +1
15:27 <meetingology> +1 received from tsimonq2
15:27 <sil2100> #endvote
15:27 <meetingology> Voting ended on: Granting upload permissions to the ubuntu-budgie packageset to fossfreedom_
15:27 <meetingology> Votes for:4 Votes against:0 Abstentions:0
15:27 <meetingology> Motion carried
15:27 <sil2100> fossfreedom_: congratulations o/
15:27 <tsimonq2> Congrats!
15:27 <cyphermox> fossfreedom_: congrats
15:27 <fossfreedom_> many thanks all - on behalf of our project ... much appreciation
15:28 <sil2100> Does anyone remember what in this case should happen to the PPU permissions we have set up for fossfreedom_ in the past?
15:28 <sil2100> Should we just leave it?
15:28 <rbasak> Is the package a strict superset of personal-fossfreedom?
15:29 <sil2100> rbasak: I see at least one package missing in ubuntu-budgie packageset in comparison to the personal-fossfreedom one
15:29 <sil2100> But maybe it's not needed anymore (since not seeded?)
15:29 <sil2100> budgie-welcome
15:29 <fossfreedom_> which one?
15:29 <rbasak> I wasn't around when personal-fossfreedom was created. IMHO that wasn't the intention of personal packagesets, so maybe it'd be nice to clean it up.
15:29 <sil2100> fossfreedom_: ^ is that still a thing?
15:29 <cyphermox> well, he does have upload rights for these pacakges in debian
15:29 <sil2100> Same for rhythmbox-plugin-alternative-toolbar
15:30 <sil2100> Ah, ok
15:30 <cyphermox> so a distinct list is relevant
15:30 <fossfreedom_> ah - that's now a snap - but yeah - for installers if they install budgie-welcome deb they are invited to install the deb
15:30 <rbasak> If cleaning up, then we could switch to direct PPU for those.
15:30 <fossfreedom_> snap
15:30 <rbasak> And remove personal-fossfreedom.
15:30 <rbasak> That shouldn't result in any functional difference to his upload permission
15:31 <sil2100> Does anyone volunteer for adding fossfreedom_ to the ubuntu-budgie packageset and (as a separate task) clean up the personal-fossfreedom set?
15:31 <cyphermox> well, it wouldn't, but sicne it's already there, there is no harm really
15:31 <sil2100> (by clean up I mean, remove it and switch to direct PPU)
15:31 <rbasak> I'm happy to take it but it won't be today, which isn't good.
15:31 <sil2100> I don't mind either way I guess
15:31 <cyphermox> the difference is that with a personal packageset we can actually extend the list ourselves instead of asking the TB
15:31 <rbasak> (for him)
15:31 <cyphermox> (given that we can do that by email, etc)
15:31 <cyphermox> it's consistent with delegation
15:32 <rbasak> cyphermox: yes, but it wasn't originally intended to use that mechanism instead of PPU for everyone
15:32 <cyphermox> rbasak: tbh, the "intended" is unclear
15:32 <rbasak> I guess we could, but AIUI we haven't actually taken a decision to do so
15:32 <cyphermox> it's certainly easier for us to do things that way
15:32 <rbasak> cyphermox: https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Personal_packagesets_and_glob_expansions
15:32 <cyphermox> I think it was mostly left to whomever requested it from the TB
15:33 <cyphermox> sounds consistent
15:33 <rbasak> It was only for special cases.
15:33 <cyphermox> ie. a list of packages you get PPU for via Debian Dev could be considered a list that changes often
15:34 <rbasak> If we want to do it for all PPUs, then fine, but I'd prefer to see us be consistent in how we use the mechanisms.
15:34 <cyphermox> I mean, I don't care, but it really does seem easier if it was personal lists
15:34 <cyphermox> it would 1) make it easier for us to extend the PPUs when people request more, and 2) make it easier to audit since the packagesets are already extracted and listed on a webpage
15:34 <cyphermox> rbasak: +1 on consistency
15:35 <cyphermox> I prefer the personal- lists.
15:35 <rbasak> cyphermox: would you like to drive getting the DMB to agree to switch entirly to using the personal- lists?
15:35 <cyphermox> sure
15:35 <cyphermox> I'll put it on the agenda for next meeting
15:35 <rbasak> Assuming my wording is exactly what you want?
15:36 <rbasak> Sounds good, thanks.
15:36 <cyphermox> sounds about right
15:36 <sil2100> Ok, in that case I'll add fossfreedom_ to the packageset, and the rest we resolve next meeting
15:36 <rbasak> I think I'm roughly on the fence, FWIW.
15:36 <cyphermox> ok
15:36 <rbasak> sil2100: +1
15:37 <sil2100> #action sil2100 to add fossfreedom_ to the ubuntu-budgie packageset
15:37 * meetingology sil2100 to add fossfreedom_ to the ubuntu-budgie packageset
15:37 <cyphermox> I'm slightly on the side of personal-, because it's consistent with delegating to us giving the rights, whereas right now we need to ask the TB to run various commands
15:37 <rbasak> cyphermox: up to you, but maybe an advance mailing list thread would be helpful on this one.
15:37 <cyphermox> it could be just "edit-acl add <whatever to create a new list>"
15:37 <cyphermox> rbasak: yeah
15:37 <sil2100> #topic AOB
15:37 <sil2100> Anything else?
15:38 <rbasak> I'm interested in what Launchpad devs think.
15:38 <rbasak> (on that topic, not AOB)
15:38 <sil2100> ;)
15:39 <tsimonq2> Rik told me that his announcements were already sorted.
15:39 <tsimonq2> https://lists.ubuntu.com/archives/ubuntu-devel/2019-March/040618.html
15:40 <tsimonq2> Otherwise, nothing else from me.
15:40 <sil2100> Excellent
15:40 <sil2100> Ok, let's end the meeting for today o/
15:40 <sil2100> #endmeeting