19:01 <rbasak> #startmeeting DMB
19:01 <meetingology> Meeting started Mon Mar 25 19:01:13 2019 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:01 <meetingology> 
19:01 <meetingology> Available commands: action commands idea info link nick
19:01 <rbasak> #topic Review of previous action items
19:02 <rbasak> cyphermox to deal with PPU rights for Rosco2 and Eickmeyer
19:02 <rbasak> sil2100 to send out announcements for Rosco2 and Eickmeyer
19:02 <rbasak> cyphermox to fix the packageset-report script
19:02 <rbasak> tsimonq2 to better document what we expect applicants to know (carried over)
19:02 <rbasak> slashd to follow up on the APAC Ubuntu community coverage
19:02 <rbasak> Follow up on the ubuntustudio packageset upload permissions for Rosco2
19:02 <cyphermox> my PPU actions are done
19:02 <rbasak> Thanks!
19:02 <sil2100> cyphermox: \o/
19:02 <sil2100> Announcements were sent as well
19:03 <cyphermox> the packageset-report script is changed, too; though I haven't really had much of a feedback on it
19:03 <rbasak> I had a glance and it seemed reasonable
19:03 <sil2100> cyphermox: I didn't see the code changes yet, yes, but the packageset changes you sent were ok
19:04 <slashd> o/ no update on the APAC, still figure it out stuff with my APAC contact who wants to eventually apply for contrib devel
19:04 <cyphermox> then let's consider this done?
19:04 <rbasak> tsimonq2: sends his apologies
19:04 <rbasak> So the first three are done then.
19:04 <rbasak> 4 is to carry over
19:04 <rbasak> #action tsimonq2 to better document what we expect applicants to know (carried over)
19:04 * meetingology tsimonq2 to better document what we expect applicants to know (carried over)
19:05 <rbasak> 5 is to carry over
19:05 <sil2100> o/
19:05 <rbasak> #action slashd to follow up on the APAC Ubuntu community coverage
19:05 * meetingology slashd to follow up on the APAC Ubuntu community coverage
19:05 <rbasak> Who owned 6?
19:05 <sil2100> No one, this was more like a whole-team toppic
19:06 <sil2100> i.e. us voting on Rosco2's packageset upload permissions
19:06 <rbasak> Oh, I see.
19:06 <rbasak> Where are we with that?
19:07 <sil2100> So, I guess that's something we should discuss now
19:07 <sil2100> Do we want to re-start the vote? Did anyone change their minds after our recent discussions and packageset changes?
19:08 <rbasak> I have synced with cyphermox and I think we now understand each others position better
19:10 <sil2100> I guess that in overall, for clarity, I would propose re-starting the vote for granting Rosco2 PPU rights to the ubuntustudio packageset
19:10 <rbasak> I'm quite happy to give Rosco2 upload access to things that affect Ubuntu Studio but not other flavours, as a step towards what I hope would eventually be MOTU.
19:10 <sil2100> Since we had far too many votes open last time for that that didn't resolve the issue
19:10 <cyphermox> can we please use the right nomenclature though?
19:10 <rbasak> However we have some trouble with how that squares with the packageset
19:10 <cyphermox> ie. if it's PPU, it's PPU, if it's packageset, it's packageset
19:10 <sil2100> cyphermox: understood
19:10 <rbasak> Nevertheless I believe that would satisfy the TB requirement.
19:10 <cyphermox> mixing an matching makes it really hard to understand
19:11 <cyphermox> rbasak: AFAIK right now the only overlap is xfce* packages
19:11 <cyphermox> it can be trivially fixed
19:12 <sil2100> That's basically what I meant, anyway, do we need Rosco2 around for questions? I assumed we all know what we need to know, just that we need to come to a conclusion
19:12 <Rosco2> o/
19:13 <sil2100> Rosco2: thanks for being around o/
19:14 <rbasak> cyphermox: that would bring us back to approving the packageset including all future changes though, versus approving a specific set or narrow definition.
19:14 <cyphermox> sorry, I don't understand what you mean by that
19:14 <sil2100> Well, I guess we'd be voting to grant upload rights to the packageset, whatever contents it has now or in the future
19:15 <sil2100> Packagesets change, sometimes even quite dynamically, and that's normal
19:15 <cyphermox> that's undeed what we should do
19:15 <cyphermox> (I think)
19:15 <cyphermox> I mean, I can remove the overlap now, I don't think we need to block on whether that's done or not just now
19:16 <cyphermox> (we just need to decide)
19:16 <rbasak> Sure
19:16 <cyphermox> my opinion is: there are other packagesets in the same boat, we shouldn't special case; but I'm not against it
19:16 <rbasak> But my point was that I felt that approving only the "narrow" set was appropriate right now.
19:17 <cyphermox> ack
19:17 <cyphermox> by narrow you mean without xfce?
19:17 <sil2100> Should we vote? Since I'm sure Rosco2 is dying from all the suspense ;)
19:17 <Eickmeyer> ^so am I.
19:17 <cyphermox> sil2100: what is your opinion? xfce in or out?
19:18 <cyphermox> slashd: ^
19:18 <rbasak> By narrow I mean "stuff seeded by the flavour but not any other flavor" which right now means without xfce, AIUI, but may not be this in the future, so it's not the same thing.
19:18 <Rosco2> If it makes a difference - I promise not to touch xfce packages without consulting the xubuntu guys
19:18 <cyphermox> rbasak: well, we can only deal with what is currently real, can't address what isn't a problem right now
19:19 <sil2100> cyphermox: I don't have a strong opinion, although seeing how big the ubuntustudio packageset will be big anyway, due to the nature of the project
19:19 <sil2100> That being said, I would really prefer not to block on that, as cyphermox mentioned
19:20 <slashd> cyphermox, I'm mixed feeling, can't really say 'yes' or 'no' on with or without xfce
19:20 <rbasak> cyphermox: the point of a packageset approval is to deal with future changes also.
19:21 <cyphermox> rbasak: sure, but we can only action the right now
19:21 <rbasak> cyphermox: since I'm specifically reluctant about the defined future changes, PPU for a larger set would be more appropriate IMHO.
19:21 <rbasak> Say for example PPU to the current contents of the packageset less xfce
19:21 <cyphermox> there are two separate decisions: is the ubuntustudio packageset what it should be;  and are we ready to give upload rights for what the packageset should be
19:21 <rbasak> If that is implemented technically by packageset approval, then that's fine by me.
19:21 <sil2100> I would really not want that
19:22 <sil2100> eh, ok, I see we still don't have a solid decision here among the team
19:22 <rbasak> No :-(
19:22 <sil2100> My rationale for just voting on the 'packageset' upload rights is: question - should Rosco2, as the maintainer of Ubuntu Studio, have upload rights to the ubuntustudio 'packageset'
19:22 <cyphermox> I feel it's unfair to special-case ubuntustudio; it should be handled (right now) as all the other packagesets. That is, everything that is on the seeds/image is in the packageset.
19:23 <cyphermox> sil2100: +1
19:23 <sil2100> My answer is: yes, just like the maintainers of Xubuntu have access to the xubuntu packageset, mate to mate etc.
19:23 <rbasak> cyphermox: I'm not special casing ubuntustudioi though
19:23 <cyphermox> if we think packagesets aren't what they should; it's a separate action / voting / whatever to address that
19:23 <cyphermox> rbasak: no, if you want to do a special PPU you're not, but I feel that's extra work for very little benefit
19:23 <sil2100> cyphermox: agreed
19:24 <rbasak> cyphermox: sure, so pragmatically let's save the work and give him the packageset ACL.
19:24 <sil2100> Regardless of whether the current ubuntustudio packageset is correct or not in our terms, this doesn't change the fact that Ubuntu Studio should not be treated differently from other flavors
19:25 <sil2100> If it's not, we need to keep working on fixing it, but it's neither Rosco2's or anyone else's from Ubuntu Studio's fault
19:25 <sil2100> *If it's not correct
19:25 <cyphermox> rbasak: that was my point yes
19:25 <cyphermox> aye
19:26 <cyphermox> are we ready to vote on rosco2's application then?
19:26 <rbasak> cyphermox: right, but the motion would be different.
19:26 <rbasak> I propose that we "give Rosco2 upload rights that are the current set of packages in the ubuntustudio packageset less xfce"
19:26 <sil2100> I would not want that
19:27 <cyphermox> neither do I
19:27 <sil2100> I just want a vote: "give Rosco2 upload rights to the ubuntustudio packageset"
19:27 <rbasak> I think your proposal is to "give Rosco2 upload rights equivalent to the existing definition of ubuntustudio that may change in the future according to that definition"
19:27 <cyphermox> rbasak: I think we really are in full understanding now; just absolutely disagreeing ;)
19:27 <sil2100> rbasak: I want to give him the same upload rights as any other flavor maintainers
19:27 <rbasak> OK. Well we can vote if you like.
19:27 <rbasak> Though a couple of members have sent apologies
19:27 <rbasak> So we might struggle.
19:27 <cyphermox> yeah, that's really quite unfortunately
19:27 <sil2100> But they have sent their votes
19:27 <cyphermox> *unfortunate
19:28 <sil2100> Ah, they actually did not, crap
19:29 <cyphermox> jbicha did
19:29 <sil2100> Anyway, I'd propose starting the vote
19:30 <slashd> sil2100, so voting to give same upload rights as any other flavor maintainers as you said ?
19:30 <rbasak> Oh I forgot I'm chair
19:30 <rbasak> Sorry
19:30 <sil2100> slashd: yes, basically giving him upload rigths to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future
19:31 <rbasak> #vote give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future
19:31 <meetingology> Please vote on: give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future
19:31 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:31 <rbasak> -1 for reasons already stated
19:31 <meetingology> -1 for reasons already stated received from rbasak
19:31 <cyphermox> +1
19:31 <meetingology> +1 received from cyphermox
19:31 <sil2100> +1
19:31 <meetingology> +1 received from sil2100
19:32 <slashd> +1
19:32 <meetingology> +1 received from slashd
19:32 <rbasak> That's everyone here I think?
19:32 <sil2100> Let's see if tsimonq2 can vote remotely maybe?
19:32 <rbasak> The motion cannot then pass right now but it can go to email if absent members can vote offline.
19:33 <Rosco2> Thanks all
19:33 <Eickmeyer> What was jbicha's vote?
19:33 <rbasak> Only one further +1 is required
19:34 <Rosco2> Crossing fingers and plowing on :-)
19:34 <teward> sil2100: do you need me to ping tsimonq2, who may actually be busy?  (I sent him an unrelated semi-urgent Lubuntu-infrastructure-related ping to no response a few hours ago, so...)
19:34 <sil2100> rbasak: I guess let's move on then, tsimonq2 seems to be out of terminal
19:34 <teward> (I may be able to ping him in another mechanism)
19:34 <sil2100> teward: no need, we'll just do this offline I guess, through e-mail
19:34 <teward> mmkay :)
19:34 <teward> *returns to lurking*
19:34 <cyphermox> oh; jbicha has not mentioned his stance on that vote
19:35 <sil2100> Sadly
19:35 <sil2100> I also thought he did
19:35 <cyphermox> we'll finish this by email then
19:35 <rbasak> #action tsimonq2, jbicha and micahg to vote on "give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future"
19:35 * meetingology tsimonq2, jbicha and micahg to vote on "give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future"
19:35 <rbasak> #endvote
19:35 <meetingology> Voting ended on: give Rosco2 upload rights to the ubuntustudio packageset - so to the current packageset and however it will look in the nearest future
19:35 <meetingology> Votes for:3 Votes against:1 Abstentions:0
19:35 <meetingology> Motion carried
19:35 <Eickmeyer> :'(
19:35 <teward> no it wasn't
19:35 <rbasak> (correction: one further +1 required)
19:36 <rbasak> #topic (rbasak proxying) Private request
19:36 <rbasak> One moment please, in a private channel. I think this can be resolved quickly.
19:43 <rbasak> Done
19:43 <rbasak> #topic Package Set/Per Package Uploader Applications
19:44 <rbasak> fossfreedom: o/
19:44 <rbasak> Please could you introduce your application?
19:47 <sil2100> hmmm
19:47 <sil2100> I hope we have fossfreedom here
19:47 <sil2100> In case not, to his defense: he did already introduce himself many meetings in the past
19:47 <cyphermox> yup
19:47 <rbasak> Let's move on, and we can come back later if he shows up. Unless we have some people who want to vote in his absence?
19:48 <sil2100> rbasak: let's maybe continue, we can get back to this later or postpone to the next meeting
19:48 <rbasak> acheronuk: are you here?
19:48 <acheronuk> o/
19:49 <rbasak> #info Deferred
19:49 <rbasak> #topic MOTU Applications
19:49 <rbasak> #subtopic Rik Mills (acheronuk)
19:49 <rbasak> acheronuk: o/
19:49 <rbasak> Please could you introduce your application?
19:49 <acheronuk> I'm Rik Mills, the current mainly active Kubuntu developer
19:50 <acheronuk> My application and reasons for applying can be found here: https://wiki.ubuntu.com/RikMills/Applications/MOTU#Why_am_I_applying.3F
19:50 <rbasak> Thanks!
19:50 <rbasak> Any questions for acheronuk?
19:50 * slashd reading his application page
19:54 <slashd> acheronuk, If I see it right, you had ~10 sponsored upload in the past 3-4 month, how given you MOTU today will unblock you considering you don't have a huge amount of sponsored upload lately ?
19:55 <sil2100> slashd: I suppose this was answered 'partially' in his application, I think
19:55 * sil2100 reads it up again
19:55 <cyphermox> yes
19:55 <cyphermox> specifically where his link is anchored ;)
19:55 <acheronuk> slashd: it will allow me to do more that I might have hesitated to invest time in or bother people (sponsors with). It would also allow me to assit more in transitions and autotests where direct uploads are not the permission problem
19:55 <sil2100> I guess he does mention that he wants delays to be shortened, probably regarding NEW pacakge uploads?
19:56 <acheronuk> slashd: yes, subject obviously to as much scrutiny as AAs gave before
19:57 <slashd> acheronuk, okay
19:57 <acheronuk> just I would not have to MOTU hunt. That actually has not been as much a probelm lately, but these things come and go
19:57 <rbasak> Any more questions for acheronuk?
19:58 <rbasak> #vote Grant acheronuk MOTU
19:58 <meetingology> Please vote on: Grant acheronuk MOTU
19:58 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:58 <rbasak> +1
19:58 <meetingology> +1 received from rbasak
19:58 <rbasak> I also have two proxy votes
19:59 <slashd> +1
19:59 <meetingology> +1 received from slashd
19:59 <sil2100> +1 (I have seen a lot from acheronuk and was really happy with his work so far, I think he's "good for MOTU")
19:59 <meetingology> +1 (I have seen a lot from acheronuk and was really happy with his work so far, I think he's "good for MOTU") received from sil2100
19:59 <rbasak> tsimonq2: votes +1
19:59 <rbasak> jbicha: votes +1
19:59 <rbasak> cyphermox: would you like to vote?
19:59 <cyphermox> +1
19:59 <meetingology> +1 received from cyphermox
19:59 <rbasak> Thanks!
19:59 <rbasak> I think that's everyone who's here.
20:00 <rbasak> #endvote
20:00 <meetingology> Voting ended on: Grant acheronuk MOTU
20:00 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:00 <meetingology> Motion carried
20:00 <cyphermox> sorry; I got distracted by SRUs :/
20:00 <sil2100> Darn SRUs
20:00 <cyphermox> you bet!
20:00 <rbasak> Congrtulations acheronuk!
20:00 <sil2100> acheronuk: congrats!
20:00 <cyphermox> pesky little SRUses
20:00 <acheronuk> Thank you all!
20:00 <Eickmeyer> Wooohooo acheronuk!!!
20:00 <clivejo> Congrats Rik :)
20:00 <acheronuk> clivejo: cheers
20:00 <cyphermox> acheronuk: congrats
20:00 * acheronuk pours a Jack Daniels
20:01 <rbasak> Any volunteers to sort him out according to https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_application?
20:01 <rbasak> #action rbasak to add acheronuk to MOTU
20:01 * meetingology rbasak to add acheronuk to MOTU
20:01 <rbasak> #action rbasak to announce acheronuk's successful MOTU application
20:01 * meetingology rbasak to announce acheronuk's successful MOTU application
20:02 <rbasak> Is fossfreedom around yet?
20:02 <slashd> rbasak, I'll do it if not too late for the MOTU
20:02 <rbasak> slashd: sure: do you want to take those two actions then?
20:02 <rbasak> #undo
20:02 <meetingology> Removing item from minutes: ACTION
20:02 <rbasak> #undo
20:02 <meetingology> Removing item from minutes: ACTION
20:02 <slashd> rbasak, yup
20:02 <rbasak> #action slashd to add acheronuk to MOTU
20:02 * meetingology slashd to add acheronuk to MOTU
20:03 <rbasak> #action slashd to announce acheronuk's successful MOTU application
20:03 * meetingology slashd to announce acheronuk's successful MOTU application
20:03 <rbasak> Would others prefer to vote in fossfreedom's absence or defer?
20:03 <slashd> defer
20:04 <rbasak> OK
20:04 <rbasak> #topic AOB
20:04 <rbasak> Anything?
20:05 <rbasak> #endmeeting