16:02 <vorlon> #startmeeting
16:02 <meetingology> Meeting started Thu Feb 14 16:02:35 2019 UTC.  The chair is vorlon. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology> 
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <vorlon> [TOPIC] Lightning round
16:02 <vorlon> $ echo $(shuf -e vorlon bdmurray xnox tdaitx doko sil2100 rbalint infinity cyphermox mwhudson juliank waveform)
16:03 <vorlon> rbalint sil2100 cyphermox xnox tdaitx vorlon juliank waveform mwhudson doko bdmurray infinity
16:03 <sil2100> Oh noo
16:03 <sil2100> Not ready yet
16:03 <vorlon> no rbalint today
16:04 <vorlon> sil2100 says he's not ready
16:04 <vorlon> cyphermox:
16:04 <cyphermox> guess it's my turn then
16:04 <cyphermox> - SRU verifications for trusty, xenial: shim-signed, dkms
16:04 <cyphermox> - debugging efibootmgr "block device required issues (can't reproduce) (bug LP: #1805490)
16:04 <cyphermox> - testing for cryptsetup-on-nvme issues "invalid line in crypttab" (bug LP: #1767527)
16:04 <cyphermox> - more revisions for Secure Boot/DKMS whitepaper
16:04 <ubottu> Launchpad bug 1805490 in grub2-signed (Ubuntu) "Grub2 Failed to install "efibootmgr failed to register the boot entry: Block device required."" [High,Incomplete] https://launchpad.net/bugs/1805490
16:04 <ubottu> Launchpad bug 1767527 in cryptsetup "[18.04] Installation boot failure. WARNING: invalid line in /etc/crypttab" [Undecided,In progress] https://launchpad.net/bugs/1767527
16:04 <cyphermox> - preparing netplan 0.96 release
16:04 <cyphermox> - moving packaging to gbp tree; started preparing SRUs for >=bionic
16:04 <cyphermox> - debugging NetworkManager failures w/ autopkgtests in disco
16:04 <cyphermox> - in-progress: plymouth merge
16:04 <cyphermox> (done)
16:05 <xnox> SRUS:
16:05 <xnox> bug #1790831
16:05 <xnox> bug #1800867
16:05 <xnox> bug #1813888
16:05 <xnox> bug #1806483
16:05 <xnox> bug #1815482
16:05 <ubottu> bug 1790831 in Ubuntu on IBM z Systems "lstape, lsluns: handle non-zfcp; lin_tape multiple paths" [Medium,In progress] https://launchpad.net/bugs/1790831
16:05 <ubottu> bug 1800867 in Ubuntu on IBM z Systems "[18.10 FEAT] zcrypt DD: introduce APQN tags to support deterministic driver binding - s390tools part" [High,In progress] https://launchpad.net/bugs/1800867
16:05 <xnox> bug #1815481
16:05 <ubottu> Error: Could not gather data from Launchpad for bug #1813888 (https://launchpad.net/bugs/1813888). The error has been logged
16:05 <ubottu> bug 1806483 in Ubuntu on IBM z Systems "Ubuntu 18.04.1 - OpenSSL RSA connection rate performance degradation using ibmca engine (openssl-ibmca)" [High,In progress] https://launchpad.net/bugs/1806483
16:05 <xnox> bug #1815475
16:05 <ubottu> bug 1815482 in python-imaplib2 (Ubuntu Bionic) "python-imaplib2 needs to support SNI for OpenSSL 1.1.1" [Undecided,In progress] https://launchpad.net/bugs/1815482
16:05 <xnox> bug #1815474
16:05 <ubottu> bug 1815481 in python-httplib2 (Ubuntu Bionic) "python-httplib2 needs to support SNI for OpenSSL 1.1.1" [Undecided,In progress] https://launchpad.net/bugs/1815481
16:05 <xnox> bug #1815472
16:05 <ubottu> bug 1815475 in libevent-rpc-perl (Ubuntu Bionic) "libevent-rpc-perl FTBFS in bionic, expired test certs" [Undecided,In progress] https://launchpad.net/bugs/1815475
16:05 <ubottu> bug 1815474 in bind9 (Ubuntu Bionic) "bind9 FTBFS in bionic, regression in updates" [Undecided,In progress] https://launchpad.net/bugs/1815474
16:05 <xnox> bug #1812667
16:05 <ubottu> bug 1815472 in uvloop (Ubuntu Bionic) "uvloop FTBFS in bionic, regression in updates" [Undecided,In progress] https://launchpad.net/bugs/1815472
16:05 <xnox> bug #1815439
16:05 <ubottu> bug 1812667 in isync (Ubuntu Cosmic) "Can't verify some ssl certificates (e.g. imap.gmail.com)" [Undecided,Fix committed] https://launchpad.net/bugs/1812667
16:05 <xnox> Disco:
16:05 <ubottu> bug 1815439 in python-boto (Ubuntu Cosmic) "python-boto needs to support SNI for OpenSSL 1.1.1" [Undecided,Fix committed] https://launchpad.net/bugs/1815439
16:05 <xnox> btrfs-progs https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=920886
16:05 <ubottu> Debian bug 920886 in btrfs-progs "btrfs-progs: btrfs send failed to determine mount point for snapshots stored in /" [Important,Fixed]
16:05 <xnox> bug #1784643
16:05 <ubottu> bug 1784643 in Ubuntu on IBM z Systems "[19.04 FEAT] scsi: zfcp: add port speed capabilities (lib-zfcp-hbaapi)" [Medium,Fix released] https://launchpad.net/bugs/1784643
16:05 <xnox> bug #1815484
16:05 <ubottu> bug 1815484 in Ubuntu on IBM z Systems "[19.04 FEAT] Upgrade cryptsetup 2.1.0" [High,Triaged] https://launchpad.net/bugs/1815484
16:05 <xnox> systemd fixups for new cryptsetup
16:05 <xnox> fixup FTBFS libemf with a cludge
16:05 <xnox> fixing PATH in the initramfs-tools bug #1814355
16:05 <ubottu> bug 1814355 in snapd (Ubuntu) "snapd remove /usr/local/bin from the PATH for all systemd unit (bionic SRU regression)" [High,Confirmed] https://launchpad.net/bugs/1814355
16:05 <xnox> working on fatinitrd for subiquity, not good so far
16:05 * sil2100 is ready
16:05 <xnox> (and done)
16:05 <xnox> sil2100, go, i guess =)
16:06 <sil2100> o/
16:06 <sil2100> - SRU reviews and releases
16:06 <sil2100> - Kernel reviews
16:06 <sil2100> - 18.04.2:
16:06 <sil2100> * Adding the arm64+raspi3 image to the QA tracker
16:06 <sil2100> * Refreshing .2 changelog on wiki
16:06 <sil2100> * Preparing initial core18 .2 image candidates
16:06 <sil2100> * Fixing up splash for core18 raspi3 arm64, rebuilding release candidates
16:06 <sil2100> * Requesting validation or the core18 rc images
16:06 <sil2100> * Whipping people about .2 iso-testing
16:06 <sil2100> * Testing xubuntu i386, encountering strange kvm bug on my cosmic machine
16:06 <sil2100> - Filling bug for the 'wipes current if symling for new targets' for cdimage (LP: #1815448)
16:06 <sil2100> - Filling bug and proposing fix for the checksum-directory issues (LP: 1815592)
16:06 <ubottu> Launchpad bug 1815448 in Ubuntu CD Images "Auto-publishing completely new image types from pending to current can clobber existing images in current" [High,New] https://launchpad.net/bugs/1815448
16:06 <sil2100> - Writing some tests for the old-releases archival scripting
16:06 <sil2100> - Testing linux-firmware-raspi2 with the config.txt
16:06 <sil2100> - Work on core18 promotion
16:06 <sil2100> - Various discussions re: core18
16:06 <sil2100> - Shorter week due to some errands, valentines-business and travel preparation
16:06 <sil2100> (done)
16:06 <ubottu> Launchpad bug 1815592 in Ubuntu CD Images "checksum-directory does not re-use checksums from olddirs" [High,In progress] https://launchpad.net/bugs/1815592
16:07 <sil2100> tdaitx: your turn I guess!
16:09 <vorlon> tdaitx is out
16:10 <vorlon> * merged new upstream version of pam
16:10 <vorlon> * doing some remedial merges from Debian
16:10 <vorlon> * looking at TPMs
16:10 <vorlon> * was out yesterday; will be out tomorrow, and in Malta next week
16:10 <vorlon> (done)
16:10 <juliank> * apt/{unstable,disco} 1.8.0~rc3
16:10 <juliank> * apt/trusty 1.0.1ubuntu2.20 (LP: #1815187, LP: #1815129)
16:10 <ubottu> Launchpad bug 1815187 in apt (Ubuntu Trusty) "Fix crash when opening DepCache before Cache" [Undecided,Fix committed] https://launchpad.net/bugs/1815187
16:10 <juliank> * apt/disco 1.8.0~rc3ubuntu1 (testing work on LP: #1815760, LP: #1815761)
16:10 <ubottu> Launchpad bug 1815129 in apt (Ubuntu Trusty) "apt segfaults when generating cache file" [Medium,Fix committed] https://launchpad.net/bugs/1815129
16:10 <juliank> * build a demo package to demo the hooks in the previous two bugs
16:10 <ubottu> Launchpad bug 1815760 in apt (Ubuntu Disco) "Additional hooks for update" [Undecided,In progress] https://launchpad.net/bugs/1815760
16:10 <juliank> * planning takeover of python-apt distro info by distro-info (Debian Bug #922232)
16:10 <ubottu> Launchpad bug 1815761 in apt (Ubuntu Disco) "Alternative to Dpkg::Post-Invoke that runs even if dpkg did not have to be invoked" [Undecided,In progress] https://launchpad.net/bugs/1815761
16:10 <ubottu> Debian bug 922232 in src:distro-info "src:distro-info: Please take over distro info from python-apt" [Wishlist,Open] http://bugs.debian.org/922232
16:10 <juliank> * some discussions
16:10 <juliank> (done)
16:10 <xnox> vorlon, do TPMs look up to you in return?
16:11 <waveform> * Testing upgrade from beta release to current on various Pi models (2B, 3B, 3B+, CM3, CM3+)
16:11 <waveform> * Fixed flash-kernel to include db entry for CM3 and CM3+, verifying
16:11 <waveform> * Attempted (failed) to get CM3+ booting classic or core images
16:11 <waveform> * Pushed patches for building and revision detection upstream for wiringPi
16:11 <vorlon> xnox: no eyes
16:11 <waveform> * Investigated "degraded" state of initial boot on current release; kernel-modules was not Pi specific, but network-wait is (investigating further on the latter)
16:11 <waveform> * Preparing SRU for RPi.GPIO and gpiozero (bionic)
16:11 <waveform> (done)
16:12 <vorlon> doko:
16:13 <doko> - updating cross compiler packages
16:13 <doko> - updated gdb to the current trunk
16:13 <doko> - report binutils upstream issues
16:13 <doko> - openjdk-12 update
16:13 <doko> - prepare for GCC 8.3 prerelease
16:13 <doko> - finally got my openjdk jira account
16:13 <doko> - wrote up list of Malta topics
16:13 <doko> (done)
16:13 <vorlon> bdmurray is off today
16:13 <vorlon> no infinity
16:13 <vorlon> any questions?
16:15 <vorlon> [TOPIC] Bugs
16:15 <vorlon> [LINK] http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-dd-incoming-bug-tasks.html#foundations-bugs
16:16 <vorlon> well, I think LP: #1815774 needs to come across
16:16 <ubottu> Launchpad bug 1815774 in binutils (Ubuntu) "binutils 2.32 update breaks debug symbols in disco" [High,Confirmed] https://launchpad.net/bugs/1815774
16:16 <doko> the new gdb handles this
16:17 <doko> but somebody would need to look at apport's failing autopkg tests to let that one migrate
16:17 <vorlon> doko: ok, do you mind writing that on the bug?
16:18 <vorlon> LP: #1805490, I think cyphermox may have been looking at this already
16:18 <ubottu> Launchpad bug 1805490 in grub2-signed (Ubuntu) "Grub2 Failed to install "efibootmgr failed to register the boot entry: Block device required."" [High,Incomplete] https://launchpad.net/bugs/1805490
16:18 <xnox> doko, but then we need that gdb backported and installed on the retracer, or do those use chroots to do its thing?
16:18 <cyphermox> yes
16:18 <vorlon> cyphermox: should we go ahead and commit to that?
16:18 <xnox> (ie. we don't need it back on like xenial or something)
16:18 <cyphermox> I already have a card in progress for it.
16:18 <vorlon> that's different than committing :)
16:18 <cyphermox> oh, is it? :)
16:19 <cyphermox> sure, let's poke it appropriately, but it's irreproducible so far
16:19 <vorlon> (but I'll take it so we don't have to discuss it further)
16:19 <cyphermox> fortunately, I got some responsez
16:19 <doko> xnox: sorry, I don't know anything about the retracer setup
16:20 <vorlon> the retracers do use gdb from the target release, based on past bugs of this class
16:20 <vorlon> LP: #1807900
16:20 <ubottu> Launchpad bug 1807900 in update-manager (Ubuntu Bionic) "update-manager suggests to use Livepatch, which is not available" [High,Triaged] https://launchpad.net/bugs/1807900
16:21 <vorlon> this is already assigned to andyrock; I'll go ahead and target it
16:21 <vorlon> then a ubiquity bug assigned to Laney
16:22 <vorlon> LP: #1814109
16:22 <ubottu> Launchpad bug 1814109 in libarchive (Ubuntu Disco) "Nautilus corrupts 7z archive files when extracting via 'Extract here' context menu" [High,Triaged] https://launchpad.net/bugs/1814109
16:22 <vorlon> hmm did we discuss this efore?
16:22 <vorlon> before
16:22 <vorlon> right, we're waiting for upstream
16:23 <vorlon> LP: #1815201
16:23 <ubottu> Launchpad bug 1815201 in mdadm (Ubuntu) "mdadm checkraid cronjob runs at the same time" [High,Triaged] https://launchpad.net/bugs/1815201
16:23 <xnox> i think i should take that
16:23 <xnox> and move it to systemd timers
16:23 <vorlon> ok
16:24 <xnox> but do we need to backport that to pre-xenial?
16:24 <xnox> i'm not sure what the originators OS is
16:24 <xnox> vorlon, is this recent releases only? or needed everywhere?
16:25 <vorlon> there's a bug task for xenial, but three years after release it mustn't be that critical; let's focus on the devel series firsst
16:25 <vorlon> that's all the highs
16:25 <vorlon> [TOPIC] proposed-migration
16:26 <vorlon> [LINK] http://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses_by_team.html#foundations-bugs
16:26 <vorlon> was looking better for a while, now it's looking worse
16:26 <vorlon> has anyone looked at this bison/kpatch thing?  it's a reproducible failure
16:27 <xnox> vorlon, well the bug task was added by me
16:27 <vorlon> xnox: ah
16:29 <vorlon> does anyone want to claim kpatch/bison for investigation?
16:29 <cyphermox> vorlon: I could
16:29 <vorlon> [ACTION] cyphermox to investigate bison/kpatch regression
16:29 * meetingology cyphermox to investigate bison/kpatch regression
16:29 <vorlon> cyphermox: thanks
16:29 <cyphermox> in fact, I shall
16:29 <xnox> cyphermox, you may
16:29 <cyphermox> wonderful.
16:29 <xnox> delighted
16:30 <vorlon> then salt seems to have regressed multiple ways, I don't know if it's een reproduced with a release pocket baseline
16:30 <gaughen> libimagequant0 - is that rbalint?
16:30 <doko> no, that's a MIR waiting for security review
16:30 <vorlon> ah, maybe it needs a --all-proposed
16:30 <gaughen> nvrmind, sounds like it's an mir and cyphermox is on it
16:30 <vorlon> I'll look into the salt stuff
16:30 <vorlon> [ACTION] vorlon to investigate salt autopkgtest failures
16:30 * meetingology vorlon to investigate salt autopkgtest failures
16:31 <vorlon> fwupd is stalled on component-mismatches
16:32 <vorlon> there's an MIR bug for libxmlb, so in progress
16:32 <vorlon> usbutils
16:32 <vorlon> xnox: ^^
16:32 <xnox> that looks like usb.ids needs to be promoted to main.... cause split into separate source package or whatever
16:32 <cyphermox> yup, MIR reviewed already
16:33 <cyphermox> vorlon: fwiw for libxmlb I wouldn't be against pre-promoting, I think
16:33 <vorlon> cyphermox: which one?
16:33 <cyphermox> I did assign to security but it's more like "hey, there's a crapton of code, it looks good to me but OMG"
16:33 <vorlon> ok
16:33 <vorlon> I don't think it's urgent to pre-promote
16:33 <cyphermox> ack
16:34 <cyphermox> if someone else in theMIR team wants to have a look at the code too, maybe we can just mark it Fix Committed
16:34 <cyphermox> doko: ^
16:34 <doko> which one?
16:34 <vorlon> xnox: can you confirm that it is a split of the source package, and then I can promote?
16:34 <cyphermox> libxmlb
16:35 <xnox> vorlon, it is https://tracker.debian.org/news/1028104/accepted-usbids-20190117-1-source-all-into-unstable-unstable/
16:35 <vorlon> [ACTION] vorlon to get usb.ids sorted for main
16:35 * meetingology vorlon to get usb.ids sorted for main
16:37 <vorlon> python-setuptools has a bunch of non-salt autopkgtest regressions, which proably need investigation
16:38 <vorlon> any volunteers for that?
16:39 <xnox> ewww
16:40 <cyphermox> xnox: affects meson
16:44 <xnox> not me
16:44 <gaughen> juliank wants it@!
16:45 <juliank> +0.5
16:45 <vorlon> [ACTION] juliank to investigate python-setuptools autopkgtest regressions
16:45 * meetingology juliank to investigate python-setuptools autopkgtest regressions
16:45 <vorlon> last but not least, netbase/ipset
16:45 <doko> I looked at the meson issue, it's a gdc regression. don't know if there are more
16:45 <vorlon> I think doko wants netbase
16:45 <gaughen> doko, it's all about the base
16:45 <doko> vorlon: dave needs training ;p
16:46 <gaughen> waveform, ?
16:46 <xnox> hmmm
16:46 <xnox> i could look into meson, i have done bits of it before
16:47 <xnox> and systemd uses meson.....
16:47 <vorlon> [ACTION] waveform to investigate netbase/ipset with cyphermox to support
16:47 * meetingology waveform to investigate netbase/ipset with cyphermox to support
16:47 <vorlon> and done
16:47 <vorlon> [TOPIC] AOB
16:47 <vorlon> anything else?
16:48 <gaughen> yes, vorlon, bdmurray had another bug to look at
16:48 <gaughen> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1815691
16:48 <ubottu> Launchpad bug 1815691 in ubiquity (Ubuntu) "disk not detected on an Intel NUC7i5BNHXF" [Undecided,New]
16:49 <vorlon> should we target this to disco?
16:50 <gaughen> vorlon, seems like we should
16:50 <xnox> Feb  4 22:03:10 ubuntu kernel: [    9.323672] ahci 0000:00:17.0: Switch your BIOS from RAID to AHCI mode to use them.
16:51 <vorlon> ok taking
16:51 <vorlon> anything else else?
16:52 <gaughen> no
16:52 <vorlon> #endmeeting