19:02 <tsimonq2> #startmeeting Ubuntu Developer Membership Board
19:02 <meetingology> Meeting started Mon Jan 28 19:02:59 2019 UTC.  The chair is tsimonq2. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:02 <meetingology> 
19:02 <meetingology> Available commands: action commands idea info link nick
19:03 <blackboxsw> \0
19:03 <slashd> I'll chair the next one
19:03 <tsimonq2> #topic Review of previous action items
19:03 <tsimonq2> #subtopic cyphermox to handle the recent three packageset requests
19:03 <cyphermox> *not* all done, sorry.
19:03 <tsimonq2> Alright, we'll carry the agenda item.
19:03 <cyphermox> some of this is dependent on seed changes that the requesters should do beforehand, I need to get back to them
19:04 <cyphermox> (and making sense of all the changes, there's a fair amount)
19:04 <tsimonq2> Sure, thanks.
19:04 <tsimonq2> #topic Package Set/Per Package Uploader Applications
19:04 <tsimonq2> #subtopic Ryan Harper application for PPU
19:05 <tsimonq2> rharper: Hello!
19:05 <rharper> tsimonq2: Hi!
19:05 <tsimonq2> Could you introduce yourself?
19:06 <rharper> sure,  I'm Ryan Harper;  I work for Canonical, on the Ubuntu Server team, since Oct 2013;  I've been using Ubuntu since oh, say, Breezy
19:06 <tsimonq2> Cool :)
19:06 <tsimonq2> For reference: https://wiki.ubuntu.com/RyanHarper/DeveloperApplicationPPU
19:06 <tsimonq2> Does anyone have any questions for rharper?
19:07 <rharper> cd installs to make my ThinkPad actually work well.  I've been in Open Source for about 20 years or so;  I've lots of experience with kernel, virtualization, servers, embedded systems, and at Canonical mostly focused on storage, networking, and cloud-init as well
19:07 <jbicha> o/
19:09 <rbasak> I guess we should ask the usual questions then?
19:09 <slashd> rharper, I didn't look in lp do you have any upload right atm ?
19:09 <rharper> slashd: no, I do not have any upload rights at this time
19:09 <rharper> PPAs don't count, I think for your question
19:10 <slashd> rharper, right was talking about the ubuntu archive
19:10 <rharper> yes, no upload rights to the archive
19:11 <slashd> rharper, where would you look if a package you have uploaded get stuck in -proposed to find the reason why it is stuck ?
19:11 <tsimonq2> rharper: Let's say either of these two packages are stuck in the -proposed pocket of the development release. What would you look at to see why that is the case?
19:11 <tsimonq2> slashd: Jinx.
19:11 <tsimonq2> (It's the same question.)
19:11 <slashd> tsimonq2, lol
19:12 <sarnold> lol
19:12 <rharper> I would look in the queue for the various releases, (upload queue)
19:12 <slashd> but let's say the package has been approve and build in -proposed (the package at this point is no longer in the upload queue)
19:12 <slashd> but didn't get release in -updates after a while
19:13 <slashd> where would you look to see what's going on with that package and see why it is not release yet
19:14 <rharper> for SRUs, I track a release in a bug which has links to the various bugs that all need verified before it can be released
19:15 <rharper> This page tracks which packages have pending srus; http://people.canonical.com/~ubuntu-archive/pending-sru.html
19:15 <slashd> rharper, yep that's the answer I was looking for tks
19:16 <rharper> ok, for our projects, cloud-init/curtin we have an exception which has us track all of the bugs our upload will fix, and run verification on all of those; so we're the ones doing most of the testing
19:17 <rbasak> rharper: what about for the development release?
19:17 <rharper> rbasak: well, SRU's aren't for the development release;
19:18 <rbasak> No, I mean non-SRUs
19:18 <rbasak> When you upload to the development release.
19:18 <rbasak> Say for example you upload a new cloud-init to Disco, and you see something like this (but for cloud-init): https://launchpad.net/ubuntu/+source/libphp%2Dphpmailer
19:19 <jbicha> rharper: cloud-init was uploaded to disco on Saturday. Where would you check to find out why it isn't in disco yet (but only in disco-proposed)?
19:19 <rbasak> In this example you'll have just uploaded 6.0.6-0.1.
19:19 <rbasak> What would you do next?
19:21 <rharper> rbasak: for devel uploads, i'd check to see if the package failed to build, http://qa.ubuntuwire.org/ftbfs/
19:22 <rbasak> rharper: let's say it doesn't appear there. What next?
19:23 <rharper> there may be a dependency that hasn't landed yet,
19:26 <rharper> that is, something else may be holding up other packages from going into the archive;  In the absense of information, I'd likely head to #ubuntu-release and ask for some help
19:26 <tsimonq2> That could be correct, but how do you confirm that?
19:28 <cyphermox> rharper: do you know where the migration report lives?
19:28 <cyphermox> tsimonq2: rbasak: I think we would do well to be clearer with our questions so that what we're looking for isn't ambiguous
19:28 <rharper> cyphermox: no, I've not seen that URL
19:29 <cyphermox> ack
19:29 <slashd> rharper, one last question for me ... talking about devel release ... when should you stop introducing new features for let's say 'cloud-init' (for the current devel cycle) ?
19:29 <cyphermox> rharper: see https://wiki.ubuntu.com/ProposedMigration
19:30 <rharper> slashd: each ubuntu cycle has a FeatureFreeze date set by the release schedule;  ideally we'll need to have landed all of those features before that date;  otherwise we need FeatureFreeze Exceptions
19:31 <slashd> rharper, tks
19:31 <jbicha> rharper: are you familiar with the term NBS?
19:31 <rharper> cyphermox: thx
19:31 <rharper> jbicha: no, I've not seen that
19:32 <jbicha> rharper: the term comes from Debian and means "no longer built from source". See https://people.canonical.com/~ubuntu-archive/nbs.html
19:32 <jbicha> in this case, netplan.io has stopped building its nplan transitional package but cloud-init still depends on that package name
19:34 <rharper> jbicha: interesting; yes we'll need disco to use the new name in the disco archive, we'll maintain the older deps in a our per-release branches ;
19:34 <jbicha> I don't think you're going to need that page very often; it's very specific to a particular kind of archive maintenance work
19:34 <jbicha> it's not required for this application at all, I was just mentioning it as something your team can follow up on later
19:34 <cyphermox> it's also something that shows up elsewhere
19:34 <cyphermox> (in other reports)
19:35 <rharper> jbicha: indeed
19:35 <jbicha> I don't have any other questions today 😊
19:35 <blackboxsw> rharper: from my end, both cloud-init and curtin projects have a number of tools and scripts to streamline our release process. What do you feel could use more improvement to ensure quality or ease of release for the SRU verification process?
19:37 <rharper> blackboxsw: I think our biggest challenge is regression detection;  cloud-init runs in so many places, and we have to deal with upgrades and new instances; it's quite hard to ensure we've got as much coverage as possible;  We've got on our list (with partners) to enable more CI on target platforms; which will help raise confidence that releasing things won't break customers
19:38 <tsimonq2> Any other questions or are we ready to vote?
19:38 <jbicha> cloud-init is one of my favorite things made by Canonical :)
19:39 <tsimonq2> ^
19:39 <cyphermox> ready to vote.
19:39 <slashd> tsimonq2, I'm good to vote
19:40 <tsimonq2> #vote rharper PPU for cloud-init, curtin
19:40 <meetingology> Please vote on: rharper PPU for cloud-init, curtin
19:40 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:40 <jbicha> +1
19:40 <meetingology> +1 received from jbicha
19:40 <tsimonq2> +1
19:40 <meetingology> +1 received from tsimonq2
19:41 <slashd> +1
19:41 <meetingology> +1 received from slashd
19:41 <cyphermox> +1
19:41 <meetingology> +1 received from cyphermox
19:42 <tsimonq2> rbasak?
19:42 <rbasak> +0 rharper is on my team at Canonical, so my usual (personal) policy applies: I abstain unless everyone else present is unanimously +1 and my vote is required for quorum or some other procedural issue.
19:42 <meetingology> +0 rharper is on my team at Canonical, so my usual (personal) policy applies: I abstain unless everyone else present is unanimously +1 and my vote is required for quorum or some other procedural issue. received from rbasak
19:42 <tsimonq2> ah
19:42 <tsimonq2> #endvote
19:42 <meetingology> Voting ended on: rharper PPU for cloud-init, curtin
19:42 <meetingology> Votes for:4 Votes against:0 Abstentions:1
19:42 <meetingology> Motion carried
19:42 <rbasak> rharper: congratulations!
19:42 <tsimonq2> rharper: Congratulations. :)
19:42 <slashd> Congrats rharper
19:42 <blackboxsw> woot!
19:42 <rharper> \o/
19:43 <tsimonq2> Anyone want to volunteer to handle ACLs?
19:43 <slashd> tsimonq2, I'll do it
19:43 * blackboxsw is greatful for the help  rharper can now provide
19:43 <tsimonq2> Alright, cool.
19:43 <sarnold> rharper: congratulations :)
19:43 <tsimonq2> #topic AOB
19:43 <blackboxsw> *grateful
19:43 <tsimonq2> Anything else, folks?
19:43 <rharper> sarnold: thanks!
19:43 <rbasak> tsimonq2: could you assign actions for slashd please, so we can track it?
19:43 <rbasak> https://wiki.ubuntu.com/DeveloperMembershipBoard/KnowledgeBase#Actions_after_a_successful_applications
19:44 <rbasak> calls for two actions
19:44 <rbasak> slashd: and that link has instructions for you too
19:44 <slashd> rbasak, I appreciate it
19:45 <tsimonq2> rbasak: Oh, sure.
19:45 <tsimonq2> #action slashd to handle ACLs for rharper's PPU application
19:45 * meetingology slashd to handle ACLs for rharper's PPU application
19:45 <tsimonq2> #action slashd to announce rharper's successful application
19:45 * meetingology slashd to announce rharper's successful application
19:46 <tsimonq2> Alright, anything else?
19:46 <rbasak> Thanks!
19:46 <rbasak> There was a suggestion to better document what we expect applicants to know.
19:47 <tsimonq2> #action tsimonq2 to better document what we expect applicants to know
19:47 * meetingology tsimonq2 to better document what we expect applicants to know
19:47 <rbasak> Thanks :)
19:47 <tsimonq2> So we have it for the record. :)
19:47 <tsimonq2> #endmeeting