16:01 <vorlon> #startmeeting
16:01 <meetingology> Meeting started Thu Nov 15 16:01:43 2018 UTC.  The chair is vorlon. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:03 <vorlon> [TOPIC] Lightning round
16:03 <vorlon> $ echo $(shuf -e vorlon bdmurray xnox tdaitx doko sil2100 rbalint infinity cyphermox mwhudson rcj philroche Odd_Bloke juliank fginther platonical tobikoch)
16:03 <vorlon> mwhudson cyphermox sil2100 infinity platonical tdaitx juliank fginther rbalint tobikoch rcj xnox doko bdmurray philroche vorlon Odd_Bloke
16:04 <bdmurray> I think that means platonical is first
16:05 <vorlon> hah indeed
16:05 <vorlon> platonical:
16:05 <platonical> * updates to livecd-rootfs
16:05 <platonical> * cloud partner work
16:05 <platonical> done
16:05 <platonical> tdaitx
16:06 <tdaitx> * uploaded openjdk-7 with 7u201 patches to the security team
16:06 <tdaitx> * working on jtreg testcase for SRUing openjdk-8 runtime failure
16:06 <tdaitx> * preparing upload of openjdk-8 and openjdk-lts (10, Bionic) for the security team (Debian #911847, Debian #911925, Debian #913641, LP: #1800792)
16:06 <tdaitx> * keeping track of fixed packages in debian for openjdk-11 compatibility
16:06 <tdaitx> * reviewed openjdk-8 and openjdk-11 roadmap (EOL is much later compared to late-2017 and early-2018 figures)
16:06 <tdaitx> (done)
16:06 <ubottu> Debian bug 911847 in src:openjdk-8 "openjdk-8: Backport fix to JDK-8132985: crash in freetypescaler due to double free" [Normal,Open] http://bugs.debian.org/911847
16:06 <ubottu> Debian bug 911925 in openjdk-8-jdk "S8195874: Improve jar specification adherence breaks reverse depends build and runtime" [Important,Open] http://bugs.debian.org/911925
16:06 <ubottu> Debian bug 913641 in libreoffice-report-builder "libreoffice-report-builder: report builder reports fail to run after S8195874 in OpenJDK" [Grave,Open] http://bugs.debian.org/913641
16:06 <ubottu> Launchpad bug 1800792 in openjdk-8 (Ubuntu) "Update to 8u181-b13-1ubuntu0.18.04.1 breaks Maven builds" [Undecided,Confirmed] https://launchpad.net/bugs/1800792
16:06 <tdaitx> juliank: go!
16:06 <juliank> * syncs: fakeroot
16:06 <juliank> * merges: wget, packagekit, libgcrypt20, kbd
16:06 <juliank> * apt prereleases (bug 1787460, failed attempt for bug 1801338, amongst other things)
16:06 <ubottu> bug 1787460 in linux-meta-hwe (Ubuntu) "Unattended upgrades removed linux-image-generic" [Critical,Triaged] https://launchpad.net/bugs/1787460
16:06 <juliank> * still trying to figure out how to get aptitude to build in C++17, which it requires in 0.8.11 (so we don't get stuck on 0.8.10)
16:06 <ubottu> bug 1801338 in apt (Ubuntu Cosmic) "apt fails to properly handle server-side connection closure" [Undecided,Triaged] https://launchpad.net/bugs/1801338
16:06 <juliank> * networkd-dispatcher new upstream release 2.0-0ubuntu1
16:06 <juliank> (done)
16:08 <xnox> fginther, ?
16:08 <vorlon> fginther:
16:08 <platonical> hes afk atm
16:08 <vorlon> ok
16:08 <vorlon> rbalint:
16:08 <rbalint> (short and slow week due to minor injury)
16:08 <rbalint> * found and fixed LP: #1803391
16:08 <ubottu> Launchpad bug 1803391 in systemd (Ubuntu Disco) "Systemd update installation hangs in unattended-upgrades InstallOnShutdown mode" [High,New] https://launchpad.net/bugs/1803391
16:08 <rbalint> * prepared unattended-upgrade SRU for all releases starting with Xenial with a lot of regression testing and documenting the regressions
16:08 <doko> tdaitx: is there a document about the openjdk-11 compat packages?
16:09 <rbalint> * paving the way for mass bzr -> git conversion in https://code.launchpad.net/~ubuntu-core-dev/+git/bzr-git-mass-convert
16:09 <rbalint> (done)
16:09 <tobikoch> * Things related to parallelized image builds
16:09 <tobikoch> * Point-in-time fixing of snap versions in image builds
16:09 <tobikoch> * Turning mfdiff into a reusable component
16:09 <tobikoch> * Pseudo vanguarding
16:09 <tobikoch> (done)
16:09 <tobikoch> rcj:
16:09 <tobikoch> sorry, rcj is presenting in another meeting.
16:09 <tobikoch> xnox:
16:09 <xnox> * subiquity s390x - it builds, it boots, it installs but only on qemu
16:09 <xnox> * preparing systemd SRU with linear history
16:09 <xnox> * boost1.67 transition started in debian
16:09 <xnox> done
16:09 <fginther> sorry
16:10 <fginther> * Cloud partner face to face
16:10 <tdaitx> doko: I have a trello card + a personal list in keep, I'll be moving those into our openjdk doc
16:10 <doko> ta
16:10 <fginther> * Manager stuff
16:10 <fginther> (done)
16:10 <doko> - just involved in merges in transitons, currently no other stuff
16:10 <doko> - and python3.7 done
16:10 <doko> (done)
16:11 <xnox> fginther, Manager's stuff?!
16:11 <rbalint> fginther, window manager stuff :-)
16:11 <vorlon> bdmurray:
16:11 <bdmurray> worked on modifing ET charm / spec to setup telegraf config
16:11 <bdmurray> started writing test crash verifier for Error Tracker
16:11 <bdmurray> fixed daisy bug w/ staging.launchpad.net LP: #1793735
16:11 <bdmurray> submitted RT re: updating daisy code for the above
16:11 <ubottu> Launchpad bug 1793735 in Errors "create bug link uses staging.launchpad.net" [High,Fix released] https://launchpad.net/bugs/1793735
16:11 <bdmurray> special sru reviews of debootstrap, grub2
16:11 <bdmurray> package to team mapping work / nagging
16:11 <bdmurray> uploaded cosmic, bionic SRUs for LP: #1797384
16:11 <bdmurray> submitted ubuntu-archive-tools MP fixing LP: #1720249
16:11 <ubottu> Launchpad bug 1797384 in ubuntu-release-upgrader (Ubuntu Cosmic) "release upgrader has no icon in gnome-shell dock" [High,In progress] https://launchpad.net/bugs/1797384
16:11 <ubottu> Launchpad bug 1720249 in ubuntu-archive-tools "sru-report: Color code Incomplete bugs differently" [Undecided,In progress] https://launchpad.net/bugs/1720249
16:11 <bdmurray> resolved update-notifier autopkgtest failures
16:11 <bdmurray> modified bugbot to handle ROS ppa upgrade failures
16:11 <bdmurray> performed SRU verification of grub bug LP: #1788727
16:11 <ubottu> Launchpad bug 1788727 in grub2 (Ubuntu Bionic) "upgrade crashing due to unsigned kernels" [High,Fix committed] https://launchpad.net/bugs/1788727
16:11 <bdmurray> ✔ done
16:12 <bdmurray> philroche:
16:12 <philroche> * F2F meetings with partners
16:13 <philroche> * Cloud image build system changes
16:13 <philroche> * Cloud image build system vanguard
16:13 <philroche> (done)
16:13 <bdmurray> vorlon:
16:13 <vorlon> * short week, was off Monday for US holiday
16:13 <vorlon> * subiquity on z planning
16:13 <vorlon> * disco proposed-migration transitions
16:13 <vorlon> * lots of kernel SRU processing while others are at Plumbers
16:13 <vorlon> * off next Thu/Fri (Thanksgiving)
16:13 <vorlon> (done)
16:13 <vorlon> Odd_Bloke:
16:14 <Odd_Bloke> * Cloud image vanguard
16:15 <Odd_Bloke> * Sorting out some issues with new CPC Jenkins slaves
16:15 <Odd_Bloke> (done)
16:15 <vorlon> any questions over status?
16:17 <vorlon> [TOPIC] Bugs
16:17 <vorlon> bdmurray:
16:17 <bdmurray> no news here
16:18 <vorlon> ok
16:18 <vorlon> [TOPIC] AOB
16:18 <vorlon> anything else this week?
16:18 <bdmurray> I also am out Thu Fri of next week
16:18 <gaughen> vorlon, have we sorted out the plan for systemd and u-u, xnox and rbalint?
16:18 <rbalint> is there anyone switching over to https://code.launchpad.net/~rbalint/+git/livecd-rootfs
16:19 <xnox> gaughen, i believe we have sorted the systemd patch to upload. not involved in the u-u plan of sru, etc.
16:19 <gaughen> rbalint, why would anyone switch to that?
16:19 <gaughen> xnox, do we need to expedite it?
16:19 <rbalint> gaughen, i mean to the content, not to the url
16:20 <vorlon> gaughen: I saw rbalint say he had a patch that works, so I didn't see the need to dig any deeper
16:20 <rbalint> so it would be  git+ssh://git.launchpad.net/livecd-rootfs
16:20 <gaughen> cpc-help ^^
16:25 <vorlon> fwiw we do have a variety of open MPs against several of the branches: https://code.launchpad.net/~ubuntu-core-dev/livecd-rootfs/trunk/+activereviews https://code.launchpad.net/~ubuntu-core-dev/livecd-rootfs/bionic-proposed/+activereviews https://code.launchpad.net/~ubuntu-core-dev/livecd-rootfs/xenial-proposed/+activereviews
16:25 <vorlon> (16, 3, 1)
16:29 <vorlon> so per backchannel discussion :), it sounds like we are targetting Dec 12 for this bzr->git conversion
16:29 <vorlon> in order to give us time to quiesce the queue of outstanding MPs
16:29 <vorlon> [ACTION] rbalint to send mail informing everyone of the livecd-rootfs conversion timeline
16:29 * meetingology rbalint to send mail informing everyone of the livecd-rootfs conversion timeline
16:30 <rbalint> (we may pick several other repos to convert on 12th)
16:31 <fginther> tobikoch, ^ bzr->git for livecd-rootfs. we should work to get as much merged as possible (not that you aren't already working toward this :) )
16:32 <tobikoch> fginther: ack
16:32 <vorlon> ok, anything else?
16:33 <gaughen> not from me
16:33 <vorlon> #endmeeting