13:00 <cyphermox> #startmeeting Weekly Main Inclusion Requests status
13:00 <meetingology> Meeting started Tue Sep 25 13:00:03 2018 UTC. The chair is cyphermox. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
13:00 <meetingology>
13:00 <meetingology> Available commands: action commands idea info link nick
13:00 <cyphermox> anybody absolutely wants to chair?
13:00 <didrocks> seems you started :)
13:01 <didrocks> I'm fine with not chairing :p
13:01 <cyphermox> ack
13:01 <cyphermox> well, let's carry on
13:01 <cyphermox> #topic New MIRs
13:01 <doko> hi
13:01 <cyphermox> I'm playing it by ear, bear with me
13:01 <cpaelzer> new since X?
13:02 <cyphermox> new since the last I noticed
13:02 <cyphermox> sorting the bugs by bug number?
13:02 <didrocks> fine with me
13:02 <cyphermox> there's pmdk
13:02 <cpaelzer> I updated pmdk
13:02 <cyphermox> LP: #1790856
13:02 <ubottu> Launchpad bug 1790856 in pmdk (Ubuntu) "[MIR] pmdk" [Undecided,New] https://launchpad.net/bugs/1790856
13:02 <cyphermox> ok
13:02 <cpaelzer> this is now on the security team
13:03 <cyphermox> cpaelzer: wasn't it server team?
13:03 <cpaelzer> it is ours
13:03 <cyphermox> ok
13:03 <cpaelzer> but all former concerns were eliminated
13:03 <cyphermox> alright
13:03 <cpaelzer> next step, security
13:03 <cyphermox> kk
13:03 <jdstrand> it is in our prioritized list
13:03 <cyphermox> LP: #1786489 rygel
13:03 <ubottu> Launchpad bug 1786489 in rygel (Ubuntu) "[MIR] rygel" [Undecided,New] https://launchpad.net/bugs/1786489
13:03 <didrocks> the whole dlna stack was assigned to me last week
13:03 <cyphermox> this is desktop, I thought it had been reviewed before
13:04 <cpaelzer> Important to know this also drags in gupnp-dlna (MIR bug #1785649) and gupnp-av (MIR bug #1785629)
13:04 <ubottu> bug 1785649 in gupnp-dlna (Ubuntu) "[MIR] gupnp-dlna" [Undecided,New] https://launchpad.net/bugs/1785649
13:04 <didrocks> material for 19.04 at this stage
13:04 <ubottu> bug 1785629 in gupnp-av (Ubuntu) "[MIR] gupnp-av" [Undecided,New] https://launchpad.net/bugs/1785629
13:04 <didrocks> yep, those 3 ;)
13:04 <cyphermox> yup
13:04 <cyphermox> oh, actually
13:04 <cyphermox> well, didrocks, best of luck with all that ;)
13:04 <cyphermox> cpaelzer: we shouldn't review MIRs we filed ourselves...
13:04 <didrocks> cyphermox: thanks, I'll need it :p TBH, I don't plan having a look before 3 weeks, once we are near release
13:05 <cyphermox> you're marked as the reporter for the pmdk bug
13:05 <cpaelzer> cpaelzer: that is why I had doko make the update after I summarized the state
13:05 <didrocks> unsure how we can mark those so that they don't came back in our meeting until $DELAY
13:05 <cpaelzer> cyphermox: ^^
13:05 <cyphermox> cpaelzer: ack.
13:05 <cyphermox> didrocks: we can think of something in a bit ;)
13:05 <didrocks> yep ;)
13:05 <cyphermox> ok, next
13:06 <cyphermox> LP: #1786201 MIR for intel-ipsec-mb
13:06 <ubottu> Launchpad bug 1786201 in intel-ipsec-mb (Ubuntu Cosmic) "MIR for intel-ipsec-mb" [Medium,New] https://launchpad.net/bugs/1786201
13:06 <cyphermox> I can take that?
13:06 <cyphermox> oh, it's already assigned to security
13:06 <cyphermox> this isn't working as well as I thought it would
13:06 <cpaelzer> on that I acted only as the reporter, and I asked jdstrand to lower the prio
13:07 <jdstrand> it is currently in the list as possible to defer to 19.04
13:07 <jdstrand> it is high for 19.04
13:07 <cyphermox> can we say, make sure we put things in Confirmed if they're assigned / otherwise reviewed
13:07 <jdstrand> it will likely be deferred
13:07 <cyphermox> and then always just look at News for this meeting?
13:07 <cpaelzer> ack
13:08 <cyphermox> jdstrand: would that work for the security team too?
13:08 <cpaelzer> if they are on security we would mark them confirmed and assigned to security then?
13:08 <didrocks> or we filter on NEW without assignee?
13:08 <didrocks> don't have strong opinions
13:08 <cyphermox> *shrugs*
13:08 <jdstrand> we don't filter on NEW vs !NEW
13:08 <cpaelzer> did "confirmed" so far carry a special meaning for you all?
13:08 <jdstrand> so that's fine with me
13:08 <cyphermox> not really
13:09 <cyphermox> neither did Triaged
13:09 <cyphermox> no assignments I have this:
13:09 <cyphermox> https://bugs.launchpad.net/~ubuntu-mir/+subscribedbugs?field.searchtext=&search=Search&field.status%3Alist=NEW&assignee_option=none&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.status_upstream-empty-marker=1&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.ha
13:09 <cyphermox> s_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&orderby=-id&start=0
13:10 <cyphermox> ten bugs, but all slightly older
13:10 <cyphermox> actually, not even ten
13:10 <cyphermox> the percona-* one is one big chunk
13:10 <cpaelzer> cyphermox: also given your list so far you don't see "incomplete", e.g. you might miss ledmon LP: #1794219 which I invalidated today
13:10 <ubottu> Launchpad bug 1794219 in ledmon (Ubuntu) "[MIR] ledmon" [Undecided,Incomplete] https://launchpad.net/bugs/1794219
13:11 <cpaelzer> that is, until the reporter provides the required info
13:11 <cyphermox> cpaelzer: well incomplete would mean it's thrown back to the reporter to fix something?
13:11 <cyphermox> so do we need to reassign?
13:11 <cpaelzer> no it exactly is "thrown back to the reporter to fix something"
13:11 <cpaelzer> which is why I had chosen "no assignee + incomplete"
13:12 <cyphermox> yeah
13:12 <cpaelzer> just saying "such updates" will be missing in your list
13:12 <cpaelzer> if we check that weekly
13:12 <cyphermox> my question is, do we need to go through those right now?
13:12 <cyphermox> if we're just assigning new bugs
13:12 <cpaelzer> I think Team members can mention those if there was anything special but otherwise we can skip them
13:12 <cpaelzer> opinions?
13:12 <cyphermox> we can go through those right after?
13:12 <didrocks> cyphermox: +1
13:13 <cyphermox> first new assigns, then go through incompletes see if there's something we missed?
13:13 <doko> sounds good
13:13 <cyphermox> I'm happy to take percona-*
13:13 <didrocks> and then, if people wants to ask questions on in progress MIRs or are blocked on anything, we can tackle them
13:13 <cyphermox> yep
13:13 <cyphermox> ok, LP: ##1742711 MIR: vulkan(-loader)
13:14 <cyphermox> oops
13:14 <cyphermox> LP: #1742711 MIR: vulkan(-loader)
13:14 <ubottu> Launchpad bug 1742711 in vulkan (Ubuntu) "MIR: vulkan(-loader)" [Undecided,New] https://launchpad.net/bugs/1742711
13:14 <cyphermox> who wants?
13:14 <cyphermox> looks desktopy
13:14 <didrocks> yep, can add
13:15 <cyphermox> I don't think the desktop team has signed up for that at all yet
13:15 <cpaelzer> FYI: the old "All open unclaimed MIR bugs" on https://wiki.ubuntu.com/MIRTeam was broken anyway, I replaced it with cyphermox new link above
13:15 <cyphermox> LP: #1605337 [MIR] virtualbox
13:15 <ubottu> Launchpad bug 1605337 in virtualbox (Ubuntu) "[MIR] virtualbox" [Undecided,Incomplete] https://launchpad.net/bugs/1605337
13:15 <cyphermox> my filter is not perfect
13:15 <cyphermox> carrying on ;)
13:16 <cyphermox> LP: #1274247 [MIR] Glusterfs
13:16 <ubottu> Launchpad bug 1274247 in tgt (Ubuntu) "[MIR] Glusterfs" [Undecided,Triaged] https://launchpad.net/bugs/1274247
13:16 <cpaelzer> it is much better than the old broken link leading to a LP-oops
13:16 <cyphermox> I'm not sure why all the other tasks are on that bug for glusterfs
13:16 <cpaelzer> I think I do
13:17 <cyphermox> ok, it was NAKed, and nobody signed up
13:17 <cyphermox> (to maintain)
13:17 <cpaelzer> yep
13:17 <cyphermox> looks like this is probably just a triage to do
13:17 <cpaelzer> the tasks are packages that would drop Delta
13:17 <cyphermox> cpaelzer: you want to do the triage?
13:17 <cpaelzer> I will, but that essentially is setting all to Won't Fix
13:17 <cyphermox> yup
13:18 <cyphermox> next; LP: #1108935 [MIR] websockify, spice-html5
13:18 <ubottu> Launchpad bug 1108935 in websockify (Ubuntu) "[MIR] websockify, spice-html5" [High,New] https://launchpad.net/bugs/1108935
13:18 <didrocks> security review a year ago, no answer since then
13:18 <didrocks> I would set it as incomplete, thoughts?
13:19 <cyphermox> agreed
13:19 <didrocks> (done)
13:19 <cyphermox> otoh it was an ACK
13:19 <didrocks> yeah, but with some changes
13:19 <cpaelzer> well it was opened and driven by chuck
13:19 <cyphermox> jamespage: is that something you guys want to have a look at?
13:19 <cpaelzer> jamespage: do you have any insight what became of this?
13:19 <cpaelzer> it did not end up on our side of the team split afaik
13:20 * jamespage looks again
13:20 <jamespage> no its an ubuntu-openstack team thing
13:20 <cpaelzer> Quote "Rationale: Dependency for nova console access"
13:20 <cyphermox> if it's still required, what next steps are, how to schedule the engineering time to do the changes
13:20 <jamespage> I see some work in websockify based on the security team review
13:21 <cyphermox> let's reassign to the openstack team, with a note?
13:21 <jamespage> yes - done
13:21 <cyphermox> ah, cool, thanks!
13:22 <jamespage> np
13:23 <cyphermox> and finally, LP: #821883 [MIR] argyll
13:23 <ubottu> Launchpad bug 821883 in argyll (Ubuntu) "[MIR] argyll" [High,New] https://launchpad.net/bugs/821883
13:23 <cyphermox> looks like another one with changes requested
13:23 <cyphermox> didrocks: doko: you both commented on previously, do you recall what the state is?
13:24 <didrocks> cyphermox: not really, I commented on it in 2011 ;)
13:24 <didrocks> sounds like doko requested 2 changes, one is done
13:24 <cyphermox> afaik the exotic build system isn't great, but we don't require MIRs for build-deps anymore
13:24 <doko> three years ...
13:25 <didrocks> 3 < 7 ;)
13:25 <cyphermox> I'll reassign to Till and ask if this is still required
13:25 <didrocks> yep
13:25 <doko> yeah, better before looking again
13:26 <cpaelzer> FYI the linked blueprint is tagged as done
13:26 <cpaelzer> maybe there was a different way to get this done after all
13:26 <didrocks> we have ICC color profile support for a while in ubuntu
13:26 <didrocks> which is why I wonder why Till still reverted it to NEW
13:27 <cyphermox> *shrugs*
13:27 <cyphermox> looks like I skipped over one
13:27 <cyphermox> LP: #1770146 [MIR] libayatana-appindicator
13:27 <ubottu> Launchpad bug 1770146 in libayatana-appindicator (Ubuntu) "[MIR] libayatana-appindicator" [High,New] https://launchpad.net/bugs/1770146
13:27 <didrocks> seriously?
13:27 * didrocks looks
13:28 <cyphermox> ah, doko commented
13:28 <didrocks> nack for desktop team to maintain it anyway: https://bugs.launchpad.net/ubuntu/+source/libayatana-appindicator/+bug/1770146/comments/11
13:28 <ubottu> Launchpad bug 1770146 in libayatana-appindicator (Ubuntu) "[MIR] libayatana-appindicator" [High,New]
13:28 <cyphermox> ah I see
13:29 <cyphermox> it would replace appindicator, and it looks like maybe there are changes to some revdeps
13:30 <didrocks> and we are not interested in appindicator anymore as based on GNOME which doesn't support this
13:30 <cpaelzer> still "incomplete - unless an owning team is found" right?
13:30 <didrocks> right
13:30 <cyphermox> yeah, I'm updating
13:32 <cyphermox> #topic Incomplete bugs / questions
13:33 <cyphermox> https://bugs.launchpad.net/ubuntu/?field.searchtext=&orderby=-importance&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=ubuntu-mir&field.structural_subscriber=&field.component-empty-marker=1&field.tag=&field.tags_combinator=ANY&field.status_upstream-empty-marker=1
13:33 <cyphermox> &field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_no_package.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
13:33 <cyphermox> another URL of doom
13:34 <cyphermox> any questions on open MIR bugs, or stuff that need to be shared?
13:34 <cpaelzer> maybe the last list should be ordered by last updated
13:35 <cpaelzer> On "imcomplete bugs" - as I said I marked LP: #1794219 incomplete today waiting for the reporter - being the least experienced here let me know if this was wrong
13:35 <ubottu> Launchpad bug 1794219 in ledmon (Ubuntu) "[MIR] ledmon" [Undecided,Incomplete] https://launchpad.net/bugs/1794219
13:36 <cyphermox> no, looks good
13:36 <cyphermox> afaik foundations would own it (that's what I recall from discussions last week), but I'll ask to confirm that
13:37 <doko> cyphermox: could you move these URLs into the MIRTeam wiki?
13:37 <cyphermox> also, to keep the list short, we should try to see if there are bugs there that can be set Won't Fix for real
13:37 <cyphermox> doko: yup
13:37 <cyphermox> tbh it's filters I set up just now from the LP forms
13:38 <cyphermox> maybe I'll try to get something to generate such a report
13:38 <cpaelzer> still useful in the wiki to use the same every week
13:38 <cyphermox> yup
13:39 <cyphermox> does anybody feel the need to go over each of the incompletes? I don't really ;)
13:39 <didrocks> not really (and in parallel weekly desktop meeting right now)
13:39 <cpaelzer> +1 on filtering the incomplete list, best done by whoever was involved back then
13:39 <didrocks> yep
13:39 <cpaelzer> I will kill a few server items there
13:39 <cyphermox> ack
13:39 <cyphermox> cool, moving on...
13:39 <cyphermox> #topic Any other business?
13:40 <cyphermox> anything else MIR Team related that isn't the open MIRs?
13:41 <cyphermox> oh, fwiw I'll record the commands and write a short script for running the meetings ;)
13:41 <cyphermox> so it's more copy-paste next time
13:41 <didrocks> \o/
13:41 <cpaelzer> yay
13:41 <cyphermox> #action cyphermox to add bug list URLs to wiki
13:41 * meetingology cyphermox to add bug list URLs to wiki
13:42 <cyphermox> cool, then let's call this one done
13:42 <cyphermox> jamespage: you were hanging out here, anything you wanted to ask about, concerns, etc?
13:42 <jamespage> not today
13:43 <cyphermox> alright
13:43 <cyphermox> thanks all!
13:43 <cyphermox> #endmeeting