19:07 <sil2100> #startmeeting DMB
19:07 <meetingology> Meeting started Mon Mar 26 19:07:39 2018 UTC. The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:07 <meetingology>
19:07 <meetingology> Available commands: action commands idea info link nick
19:07 <sil2100> #topic Review of previous action items
19:08 <sil2100> sil2100 to add tsimonq2 to ubuntu-qt5-dev and send announcements (done) <- as marked, that has been done
19:08 <sil2100> Did we have anything else?
19:08 <tsimonq2> Cool. ;)
19:09 <sil2100> I guess not, let's move on in that case
19:09 <sil2100> #topic Ubuntu Core Developer Applications
19:09 <sil2100> #subtopic slashd
19:09 <sil2100> https://wiki.ubuntu.com/slashd/coredev
19:09 <sil2100> slashd: o/ Please introduce yourself
19:10 <slashd> My name is Eric, I was the first to join the new "SRU Developer" group created last year. This group can only upload in stable release, regardless of component (main, universe, etc). Since then I have sponsored various packages in stable release and worked closely with other experienced Ubuntu developer from different areas. Over the year as a sponsor, I have deal with different scenarios (various packages upload, MIR, ...) which I think
19:10 <slashd> would convince you to welcome me in the "Core Developer" group.
19:12 <sil2100> Ok, time for questions
19:13 <sil2100> slashd: in the meantime a quick question from me: after which stage it is generally inappropriate to upload packages with visible string changes?
19:14 <slashd> sil2100, when you talked about stage are you referring to schedule freeze stage ?
19:14 <sil2100> Yes
19:15 <sil2100> After which 'freeze'
19:15 <slashd> sil2100, UserInterfaceFreeze
19:15 <slashd> https://wiki.ubuntu.com/UserInterfaceFreeze
19:15 <sil2100> Good
19:16 <micahg> slashd: have you worked on any merges from Debian to Ubuntu and/or library transitions?
19:17 <slashd> micahg, I haven't done merges/library transitions as of today, but I did other stuffs such as participating in the +1maintainance, patch pilots, and dealt with 2 MIRs
19:21 <sil2100> slashd: could you tell me what's the current status of LP: #1700827 ? What fixes did you submit upstream from the ones that do_ko outlined during review?
19:21 <ubottu> Launchpad bug 1700827 in pcp (Ubuntu) "[MIR] pcp package" [Medium,Incomplete] https://launchpad.net/bugs/1700827
19:23 <slashd> sil2100, I did work with upstream (red hat) at changing the dpkg-source format from native(3.0) to quilt(3.0) as it is a requirement to have a patch system, I also worked on a FTBFS situation where the package was missing some dependencies
19:24 <sarnold> I'd like to suggest the pcp MIR counts outsized here :) this required a lot more work on slashd's part than usual MIR requestors
19:24 <slashd> sil2100, I closely worked with security team and MIR approval team
19:27 <sil2100> Yeah, I know it was a very difficult one, just wanted to get an overview on how much work was required from slashd
19:27 <rbasak> sarnold: is that an endorsement? :)
19:27 <sil2100> slashd: thanks
19:27 <sarnold> rbasak: yes! yes it is. :)
19:27 <rbasak> slashd: let's say that today you received a customer request to add a package to Bionic in time for 18.04 (I know this isn't your area in Canonical but let's pretend). From an Ubuntu development perspective, which groups of Ubuntu developers will need to review the proposed package and for what?
19:27 <slashd> sil2100, there was other stuff I don't remember on top of my head, but yeah it was a long standing MIR
19:28 <slashd> rbasak, a package that not exist in the archive ? or that is part of universe for instance /
19:28 <slashd> ?
19:28 <rbasak> A package that does not exist in the archive.
19:29 <slashd> I would tend to contact the archive admin first
19:29 <sarnold> sil2100: upstream pcp folks were doing their own debian packaging; it worked, but wasn't up to the usual quality of packaging. slashd put in the time and effort to bring it up to standard and contribute it back upstream
19:29 <rbasak> Assume that it is unsuitable for Debian for some reason (so we can focus on the Ubuntu bit)
19:29 <slashd> and security as well to ACK it
19:30 <slashd> Based on my experience with MIR, I would say that security will probably be one of the first group to evaluate the package and see if this can be ACK or NACK
19:30 <sarnold> sil2100: I wanted radical enough changes to pcp to address the fact that much of the code was written to norms 20 years ago, and slashd helped organize conversations with upstream developers to move it along, prioritize the changes, etc.
19:31 <jbicha> sarnold: (the pcp work is interesting because his name doesn't show up in the debian/changelog or in the upload log)
19:31 <rbasak> slashd: what if the goal for the package is universe and doesn't need to go into main (again, let's pretend :)
19:32 <rbasak> Actually, maybe I'm going into too much detail here.
19:32 <rbasak> Never mind.
19:32 <rbasak> I'll ask this instead: is there anything else special you need for this proposed upload?
19:32 <slashd> rbasak, sorry I don't know the answer, but I would say that I would ping someone more experimented and ask guidance if that happen one day
19:33 <rbasak> Anything release schedule related you can think of?
19:34 <slashd> rbasak, well it needs to be before the Feature freeze
19:34 <slashd> is that what you mean
19:34 <slashd> ?
19:34 <rbasak> Yes :)
19:34 <slashd> ok
19:35 <rbasak> I think I'll have a question or two more, but while I figure them out, does anyone else have questions?
19:36 <jbicha> slashd: I see that most of your uploads are as SRUs. Do you expect you'll be doing more work on the development release of Ubuntu now?
19:37 <slashd> jbicha, yeah I did a lot of SRU for my team (being the only uploader), and of course not having the devel upload right, prevent me to help them more, so yeah you can expect me to participate more in the devlopement release as a sponsor, but also as a developer.
19:37 <slashd> Note that I'm already doing a lot of gatekeeping job
19:37 <jbicha> ok, thanks
19:37 <slashd> reviewing bionic debdiff from my colleague before it goes into coredev hands
19:38 <slashd> so there is a lot of action I do behind the scene for making thing smoother for everyone
19:39 <rbasak> For the record: I've worked with slashd quite a bit.
19:40 <rbasak> And in proposing the Ubuntu SRU developers team, one downside was that it still blocks slashd's team on uploading fixes to the development release in advance of an SRU. slashd still currently needs to get sponsorship for that AIUI.
19:40 <sil2100> Indeed
19:40 <rbasak> My view was that the SRU developers team was worth it by unblocking SRU uploads even if it didn't help directly with development release fixes that sometimes must precede them.
19:41 <rbasak> AIUI slashd could do with core dev so that he can do these, and currently no other team will do.
19:41 <slashd> SRU developer was and still is really useful. We have a new member since a couple of months now (ddstreet)
19:42 <sil2100> Any other questions?
19:42 <rbasak> slashd's application lays out his current experience nicely for us I think (thanks) but I thought I'd make this rationale clear as well.
19:43 * rbasak is still thinking, but go ahead and start the vote if everyone else is ready
19:44 <sil2100> bdmurray: no questions?
19:44 <rbasak> slashd: I guess one more. What's a seed? A very short summary is fine.
19:44 <bdmurray> sil2100: no, thanks for checking
19:44 <slashd> rbasak, it's a list of package part of the distribution (boot, desktop, , ...)
19:45 <slashd> classification for package by topics/areas
19:45 <rbasak> slashd: OK. Can you give me an example of a reason an Ubuntu developer might change one?
19:46 <sil2100> (I actually just wanted to check if bdmurray is alive)
19:46 <slashd> rbasak, demotion of a package from main to universe ?
19:46 <rbasak> OK, great. Thanks :)
19:46 <rbasak> No more questions from me.
19:47 <bdmurray> sil2100: I'm not that old
19:48 <sil2100> Is everyone ready to vote?
19:48 * rbasak is ready to vote
19:49 <sil2100> micahg, jbicha: ?
19:49 <jbicha> yes, let's vote :)
19:50 <micahg> ok
19:50 <sil2100> #vote Grant slashd Ubuntu Core Developer
19:50 <meetingology> Please vote on: Grant slashd Ubuntu Core Developer
19:50 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:51 <jbicha> +1
19:51 <meetingology> +1 received from jbicha
19:52 <micahg> +0 great technically, but no specific experience with some common dev release activities, I wish there was a way to grant rights for SRU style uploads to the dev release
19:52 <meetingology> +0 great technically, but no specific experience with some common dev release activities, I wish there was a way to grant rights for SRU style uploads to the dev release received from micahg
19:54 <bdmurray> +1 I've concerns similar to micahg but think this would help their workflow and believe slashd will assk for help when he needs it.
19:54 <meetingology> +1 I've concerns similar to micahg but think this would help their workflow and believe slashd will assk for help when he needs it. received from bdmurray
19:55 <rbasak> I have a personal rule that I prefer not to vote when I endorse a candidate. In this case I think I'd have endorsed slashd after having chatted to him about the details of his application, but I deliberately didn't do that earlier in this meeting so that I could feel happier voting directly. Based on my personal experience working with slashd, I think that he does well in being cautious in areas he
19:55 <rbasak> is unfamiliar, finds the right people from whom to get advice, and takes on board appropriate advice. I think he's demonstrated that he knows enough about Ubuntu development process that he knows how to ask the right questions. So even though he doesn't have as much knowledge in some areas as I would like, his general approach gives me the confidence that he'll make a good core dev. This combined
19:55 <rbasak> with his need to upload to the development release makes me a narrow +1.
19:55 <rbasak> +1
19:55 <meetingology> +1 received from rbasak
20:01 <jbicha> apologies for the delay…
20:02 <sil2100> One moment
20:05 <sil2100> +1 (normally since I endorsed I wouldn't vote, but as things are right now Eric's application would still pass even with the absent members voting negative - so, done!)
20:05 <meetingology> +1 (normally since I endorsed I wouldn't vote, but as things are right now Eric's application would still pass even with the absent members voting negative - so, done!) received from sil2100
20:05 <sil2100> #endvote
20:05 <meetingology> Voting ended on: Grant slashd Ubuntu Core Developer
20:05 <meetingology> Votes for:4 Votes against:0 Abstentions:1
20:05 <meetingology> Motion carried
20:05 <sil2100> slashd: congratulations!
20:05 <slashd> thanks everyone for your vote and comment, I appreciate it
20:05 <slashd> and my taking good note of your advice
20:06 <sil2100> Who wants to add and announce our new core-developer?
20:06 <jbicha> I can take care of that today
20:07 <sil2100> jbicha: thanks!
20:08 <sil2100> #action jbicha to add slashd to core-dev and announce his successful application
20:08 * meetingology jbicha to add slashd to core-dev and announce his successful application
20:08 <sil2100> #topic AOB
20:08 <sil2100> Anything else?
20:08 <sil2100> I guess we're already pass our meeting time
20:08 <sil2100> So let's finish
20:08 <sil2100> #endmeeting