15:05 <sil2100> #startmeeting DMB
15:05 <meetingology> Meeting started Mon Mar 12 15:05:19 2018 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:05 <meetingology> 
15:05 <meetingology> Available commands: action commands idea info link nick
15:05 <sil2100> #topic Review of previous action items
15:05 <bdmurray> There was that one about mapreri which was done.
15:06 <sil2100> Ok
15:06 <sil2100> I don't think we had anything else from the previous meeting?
15:06 <sil2100> I didn't see anything
15:06 <sil2100> (I cleaned up the agenda already)
15:07 <sil2100> So, we basically don't have anything really on our agenda, there's the still-standing application of Simon for Qt uploaders
15:07 <sil2100> Do we want to handle it today, or should we continue through e-mail?
15:07 <sil2100> If by e-mail, I would say we should start asking questions and move on to voting this week
15:08 <sil2100> Not sure if tsimonq2 is even around to answer our questions here (if we decide to do it of course)
15:08 <bdmurray> He's updated his wiki page correct?
15:08 <rbasak> Yes - I can see what he has been sponsored for clearly now.
15:09 <sil2100> Yes, that is my understanding
15:09 <rbasak> If he's here, I'm happy to proceed in this meeting.
15:09 <tsimonq2> Barely. ;)
15:09 <tsimonq2> Ask questions if you have them but reception isn't good here.
15:10 <sil2100> #topic Package Set/Per Package Uploader Applications
15:10 <sil2100> #subtopic Qt Uploaders for tsimonq2
15:11 <sil2100> The application, as a reminider: https://wiki.ubuntu.com/tsimonq2/Applications/Qt5Uploader
15:11 <sil2100> Questions?
15:14 <rbasak> I have none. I'm ready to vote.
15:14 <bdmurray> I'm still looking at the updated app.
15:14 * sil2100 needs to go AFK for 5 mins
15:18 <tsimonq2> I need to go without a phone for ~ an hour starting in ~ 5 mins. Then it's my lunch hour, so I can answer questions over IRC if there any at that time.
15:19 <sil2100> Back
15:21 <bdmurray> I'm ready
15:21 <cyphermox> ready to vote as well
15:21 <sil2100> Ok
15:21 <sil2100> micahg: you good to vote as well?
15:22 <micahg> sure
15:22 <tsimonq2> Ahh, just when I need to go AFK. Sorry :(
15:22 <tsimonq2> ttfn
15:22 <sil2100> #vote Grant Qt Uploader PPU access to tsimonq2
15:22 <meetingology> Please vote on: Grant Qt Uploader PPU access to tsimonq2
15:22 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
15:23 <rbasak> +1
15:23 <meetingology> +1 received from rbasak
15:23 <rbasak> (now that I understand the application :-)
15:23 <sil2100> +1 (I have seen some of the work of Simon's on Qt transitions through Bileto and was happy with what was going on)
15:23 <meetingology> +1 (I have seen some of the work of Simon's on Qt transitions through Bileto and was happy with what was going on) received from sil2100
15:24 <bdmurray> +1
15:24 <meetingology> +1 received from bdmurray
15:24 <micahg> +1
15:24 <meetingology> +1 received from micahg
15:25 <cyphermox> +1
15:25 <meetingology> +1 received from cyphermox
15:25 <sil2100> #endvote
15:25 <meetingology> Voting ended on: Grant Qt Uploader PPU access to tsimonq2
15:25 <meetingology> Votes for:5 Votes against:0 Abstentions:0
15:25 <meetingology> Motion carried
15:25 <cyphermox> tsimonq2: congrats
15:25 <sil2100> tsimonq2: congratulations!
15:25 <sil2100> Making someone click a button in Bileto seems like not a big deal, but that also doesn't mean someone shouldn't get upload rights for the packages he/she is working on
15:26 <sil2100> I'll add tsimonq2 to the right team in that case
15:27 <sil2100> #action sil2100 to add tsimonq2 to the Ubuntu Qt5 Uploaders team
15:27 * meetingology sil2100 to add tsimonq2 to the Ubuntu Qt5 Uploaders team
15:27 <sil2100> #topic AOB
15:27 <rbasak> I see an email to devel-permission@ from darkxst.
15:27 <rbasak> I think cyphermox was going to look into that?
15:27 <rbasak> I don't see any other ML activity needing action; that's the only one.
15:28 <sil2100> cyphermox: are you working on that?
15:28 * sil2100 can't seem to find that e-mail
15:28 <jbicha> the desktop-extra seed is poorly defined. I wonder if we should just encourage darkxst to apply for MOTU?
15:28 <rbasak> Date: Sun, 4 Mar 2018 10:59:36 +1100
15:28 <rbasak> Subject: Loosing upload rights to some GNOME components
15:29 <jbicha> http://people.canonical.com/~ubuntu-archive/packagesets/bionic/desktop-extra
15:29 <micahg> shouldn't desktop-extra seed the packages in SUPPORTED that they want to maintain?
15:30 <jbicha> we could try using the supported seed in ubuntu-gnome-meta and then kill desktop-extra
15:31 <cyphermox> rbasak: there is extra work needed, as mentioned by jbicha
15:31 <micahg> well, IIRC, desktop-extra was to give upload rights to ubuntu-desktop folks so they could also upload universe GNOME packages, if we wanted to extend ubuntu-gnome rights to them (or already are?) then there would be no need for the duplicate
15:32 <jbicha> it looks like ubuntu-desktop is already a member of ubuntu-gnome
15:32 <cyphermox> I think it will require a bit more investigation to figure out exactly what the best way to fix this is
15:33 <cyphermox> especially given that tasksel needs a task to deal with too if you're indeed supposed to be able to install vanilla separately.
15:34 <rbasak> Does darkxst know the reason for the delay?
15:35 <jbicha> I chatted with him then. His list isn't complete and there was the desktop-extra question
15:35 <jbicha> let's follow up on the list then?
15:35 <rbasak> Please
15:38 <jbicha> ok, I'm replying there. End of meeting?
15:39 <sil2100> What about the budgie packageset?
15:40 <sil2100> Did that get solved?
15:40 <jbicha> sil2100: yes: http://people.canonical.com/~ubuntu-archive/packagesets/bionic/ubuntu-budgie
15:41 <sil2100> Excellent! I missed that completely
15:41 <sil2100> Should we reach out to fossfreedom to move him to the packageset uploaders?
15:42 <rbasak> Have we voted to make him an uploader of the packageset specifically?
15:42 <jbicha> sil2100: we said before that we'd need to have a separate vote for that :(
15:42 <cyphermox> that's the process
15:42 <rbasak> IIRC some board members had doubts about the whole packageset, but were OK with a subset.
15:42 <jbicha> micahg: sorry, I was looking at the wrong page. ubuntu-desktop doesn't have upload rights for ubuntugnome but I don't object to that happening
15:43 <rbasak> Unless I'm thinking of some other case.
15:43 <rbasak> But if so, then it's exactly what we wanted, rather than an unfortunate consequence of the process.
15:43 <sil2100> Separate vote is fine
15:44 <cyphermox> well, it's only an issue in the process because this is specifically a packageset made from a seed
15:44 <cyphermox> so there's some variation in what might be in the seed, leading to someone applying having more generic upload rights than if it was a packageset for just some tighly-defined set of packages
15:45 <cyphermox> ie. budgie is not "qt5 only", it's anything that is needed for budgie minus what's in some other seeds such that it lands in core.
15:46 <sil2100> I would have to compare the packageset and what PPU rights were actually given
15:46 <cyphermox> maybe we can be nice to fossfreedom and start voting on an hypothetical application against the packageset as it is now?
15:46 <cyphermox> (on the ML I mean)
15:47 <sil2100> I wouldn't mind, seems a bit informal but sounds ok
15:47 <sil2100> cyphermox: would you maybe send out an e-mail to the ML about this?
15:47 <cyphermox> well, if we're to think it's not ready yet, then we can tell him what we expect.
15:48 <sil2100> Ok, let's maybe finish the meeting
15:48 <rbasak> Does anyone have a link to his original application handy? I'd like to see the original endorsements etc.
15:48 * sil2100 needs to AFK for some minutes again
15:48 <sil2100> o/
15:48 <sil2100> (you can continue here though!)
15:48 <sil2100> #endmeeting