19:05 <rbasak> #startmeeting Developer Membership Board
19:05 <meetingology> Meeting started Mon Dec  4 19:05:11 2017 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:05 <meetingology> 
19:05 <meetingology> Available commands: action commands idea info link nick
19:05 * rbasak volunteers
19:05 <sil2100> rbasak: \o/
19:05 <rbasak> #topic Review of previous action items
19:05 <rbasak> jbicha to send out announcement email (done)
19:05 <rbasak> rbasak to handle ACL for osomon's chromium-browser upload rights (done)
19:05 <rbasak> #info All previous action items complete
19:06 <rbasak> #topic Package Set/Per Package Uploader Applications
19:06 <rbasak> #subtopic handsome_feng for some Kylin/UKUI related PPU
19:06 <rbasak> handsome_feng: hello! Could you start by introducing yourself please?
19:06 <handsome_feng> Sure, hello,everyone, I'm handsome_feng, I've been an member of ubuntu kylin for more than 3 years, my main duties these days are the maintenance of UKUI and other kylin packages, my PPU application is at https://wiki.ubuntu.com/handsome_feng/DeveloperApplication-PPU, and sorry for my poor english,  I may reply you a bit slowly. Thanks! :)
19:07 <rbasak> #link https://wiki.ubuntu.com/handsome_feng/DeveloperApplication-PPU
19:08 <rbasak> Questions for handsome_feng?
19:09 <micahg_work> handsome_feng, I noticed that https://launchpad.net/ubuntu/+source/ukui-screensaver/1.0.3-0ubuntu1 was prepared before UI freeze and uploaded afterwards, can you explain how Ubuntu Kylin treats UI freeze and if this was an exception?
19:09 <jbicha> happyaron: I'm curious whether you're present for the application
19:09 <happyaron> yes I'm here
19:10 <jbicha> thanks
19:12 <handsome_feng> micahg_work: Yes, I understand the UI freeze: https://wiki.ubuntu.com/UserInterfaceFreeze, and this is aan exception, since I didn't find a sponner before the UI freeze. And I'm sorry for that. I will prepared the packages more early!
19:13 <bdmurray> handsome_feng: Have you uploaded any stable release updates?
19:14 <handsome_feng> bdmurray: No, I understand the SRU prosess: https://wiki.ubuntu.com/StableReleaseUpdates, and because the formar version of ubuntu kylin only add some packages on Ubuntu such as youker-assistant, indicator-china-weather and so on, It didn't need an SRU.
19:14 <jbicha> handsome_feng: where do you find sponsors?
19:17 <handsome_feng> jbicha: I usually email to happyaron, and if not , I will fill a bug with the tag and subscribe the sponner team
19:18 * rbasak has a couple of questions if the others are done
19:18 <jbicha> handsome_feng: ok, I encourage you to go ahead and file the bug right away especially when getting close to Ubuntu release deadlines
19:18 <jbicha> someone else may sponsor it from the queue before Aron gets around to it
19:19 <jbicha> handsome_feng: do you know anything about becoming a Debian Maintainer? is that something you intend to apply for?
19:20 <handsome_feng> jbicha: I have read the https://www.debian.org/doc/manuals/maint-guide/, and yes, I want to be that. :)
19:21 <handsome_feng> I want to apply the upload right for ukui packages
19:21 <jbicha> thanks, I understand. I think Aron can help you later with the process to become a Debian Maintainer
19:22 <handsome_feng> jbicha: Thanks, and I will try to learn more.
19:24 <rbasak> handsome_feng: I believe that if I install ukui-screensaver, that will also install ubuntukylin-default-settings because ukui-screensaver depends on ukui-session-manager. Is this correct?
19:25 <handsome_feng> yes
19:25 <rbasak> Since ubuntukylin-default-settings changes the default Firefox search engine, I find this result surprising. I wouldn't expect to install a screensaver package and have my search engine change as a consequence.
19:26 <rbasak> Do you have any opinion on this?
19:27 <handsome_feng> Our parter request this, and I think we can delete this, or make it suguessed.
19:28 <handsome_feng> Sorry for that
19:28 <rbasak> Don't worry, I don't expect the packages to be bug free.
19:29 <rbasak> I'm asking because I'd like to understand your own understanding of the packages for which you're requesting PPU.
19:29 <rbasak> If you wanted to fix this, how would you change the dependencies?
19:31 <handsome_feng> move the ubuntukylin-default-settings from depends to suggest, or just delete it
19:31 <rbasak> OK, thank you. That answers my first question.
19:32 <rbasak> BTW, the reason I came across this was https://askubuntu.com/questions/970219/123-sogou-com-trojan-horse-in-ukui-screensaver/970220#970220
19:33 <rbasak> My second question: can you give me an example of something you may need to check and fix after you make an upload?
19:33 <handsome_feng> rbasak, I will answer that, There is an other way.
19:36 <handsome_feng> verify that the package builds fine in -proposed, test out of -proposed and monitor autopkgtest runs
19:36 <rbasak> OK thank you
19:36 <rbasak> I don't have any more questions.
19:37 <rbasak> Any further questions from anyone else?
19:37 <bdmurray> Not from me
19:37 <cyphermox> No questions
19:38 <rbasak> sil2100, jbicha: any further questions?
19:38 <sil2100> I'm good
19:39 <jbicha> just a moment…
19:40 <flexiondotorg> Evening.
19:40 <cyphermox> actually
19:40 <flexiondotorg> UKUI is base on MATE. I worked with handsome_feng when UKUI was originally uploaded.
19:40 <cyphermox> handsome_feng: you're not asking for kylin-greeter?
19:41 <handsome_feng> Yes, I think this time I already apply too much
19:41 <flexiondotorg> He understands the relationship between the compoents well and I'd be happy to see him have upload rights for UKUI so they aren't beholden to seeking sponsorship.
19:42 <rbasak> Thanks flexiondotorg! That's helpful
19:42 <handsome_feng> flexiondotorg: Thanks !
19:42 <flexiondotorg> Thanks to jbicha for letting me know this discussion was taking place :-)
19:43 <rbasak> jbicha, cyphermox: anything further?
19:43 <cyphermox> nope
19:43 <jbicha> can I have a few more minutes? I'm still thinking and looking into uploads
19:43 <jbicha> sorry for the delay
19:43 <rbasak> OK
19:48 <jbicha> rbasak: ok, I'm ready now
19:48 <JackYu> Hi,  everyone, I'm Jack Yu from Ubuntu Kylin team. I'd like to support he have uploads rights for UKUI:).
19:49 <rbasak> jbicha: ready to vote? Or ask a question? :)
19:49 <jbicha> rbasak: I'm done asking questions :)
19:49 <rbasak> JackYu: thanks
19:49 <rbasak> OK
19:49 <rbasak> #vote Grant handsome_feng PPU to ukui-menu, ukui-indicators, ukui-control-center, ukui-session-manager, ukui-screensaver, peony, ukui-desktop-environment
19:49 <meetingology> Please vote on: Grant handsome_feng PPU to ukui-menu, ukui-indicators, ukui-control-center, ukui-session-manager, ukui-screensaver, peony, ukui-desktop-environment
19:49 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:51 <jbicha> I hate voting no, but I would like to see you do some SRUs first and it doesn't look to me like the need for sponsorship is holding Ubuntu Kylin back much yet
19:52 <jbicha> I encourage you to use other sponsors besides Aron, especially for the SRUs to have more variety
19:52 <handsome_feng> Thank jbicha, I will.
19:53 <jbicha> -1 please re-apply after doing some SRUs
19:53 <meetingology> -1 please re-apply after doing some SRUs received from jbicha
19:54 <cyphermox> +1
19:54 <meetingology> +1 received from cyphermox
19:54 <sil2100> +1, I would like to see some more SRUs as well, but currently I see no blockers in knowledge or skill
19:54 <meetingology> +1, I would like to see some more SRUs as well, but currently I see no blockers in knowledge or skill received from sil2100
19:55 <bdmurray> +1 as SRUs would get reviewed by the SRU team anyway
19:55 <meetingology> +1 as SRUs would get reviewed by the SRU team anyway received from bdmurray
19:55 <rbasak> +1 I consider happyaron's endorsement to be the key decider, given he has been handsome_feng's primary sponsor.
19:55 <meetingology> +1 I consider happyaron's endorsement to be the key decider, given he has been handsome_feng's primary sponsor. received from rbasak
19:55 <rbasak> I believe micahg had to step away.
19:56 <rbasak> That's everyone I think?
19:56 <rbasak> #endvote
19:56 <meetingology> Voting ended on: Grant handsome_feng PPU to ukui-menu, ukui-indicators, ukui-control-center, ukui-session-manager, ukui-screensaver, peony, ukui-desktop-environment
19:56 <meetingology> Votes for:4 Votes against:1 Abstentions:0
19:56 <meetingology> Motion carried
19:56 <rbasak> handsome_feng: congratulations!
19:56 <rbasak> And thank you for your continued contributions, of course.
19:56 <happyaron> congrats handsome_feng
19:56 <jbicha> handsome_feng: thank you and keep up the good work!
19:57 <JackYu> thanks, every one!
19:57 <handsome_feng> Thank you all \o/
19:57 <ypwong> handsome_feng, congrats
19:57 <rbasak> Any volunteers to follow the successful application checklist?
19:57 <maclin> thanks, every one!
19:58 <rbasak> #action rbasak to arrange handsome_feng's PPU changes
19:58 * meetingology rbasak to arrange handsome_feng's PPU changes
19:58 <rbasak> #action rbasak to announce handsome_feng successful application
19:58 * meetingology rbasak to announce handsome_feng successful application
19:58 <rbasak> #info handsome_feng's application was successful
19:58 <rbasak> #topic Outstanding mailing list requests to assign
19:59 <rbasak> "Please add new MATE applications to my MATE package set"
19:59 <rbasak> flexiondotorg: is this still outstanding?
20:00 <rbasak> Let's move on for now
20:00 <rbasak> #info Carried forward
20:01 <rbasak> #topic Any other business
20:01 <rbasak> #subtopic Regenerate packagesets and create one for Ubuntu Budgie
20:01 <rbasak> Regeneration would cover the MATE request I think?
20:01 <jbicha> cyphermox: ^
20:03 <cyphermox> blocked on TB creating the Budgie packageset; otherwise I'd need to move some more code around in the packageset generation
20:03 <cyphermox> we might as well really do it right once.
20:04 <rbasak> OK, thanks.
20:04 <rbasak> Does that cover flexiondotorg's request also?
20:04 <jbicha> cyphermox: I guess we might as well make a Kylin packageset too at the same time?
20:04 <rbasak> It already is one; I checked.
20:05 <jbicha> oh I see http://people.canonical.com/~ubuntu-archive/packagesets/bionic/ubuntukylin
20:07 <cyphermox> rbasak: it will cover flexiondotorg's request too
20:25 <sil2100> Are we done?
20:25 <sil2100> I guess we need to do endmeeting :)
20:26 <rbasak> Sorry!
20:26 <rbasak> Let's end the meeting
20:26 <rbasak> Assuming there are no objections to 18 December for the next meeting.
20:26 <rbasak> If there are objections, please raise it on the list.
20:26 <rbasak> #endmeeting