19:08 <sil2100> #startmeeting DMB
19:08 <meetingology> Meeting started Mon Sep 11 19:08:10 2017 UTC.  The chair is sil2100. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
19:08 <meetingology> 
19:08 <meetingology> Available commands: action commands idea info link nick
19:08 <sil2100> #topic Review of previous action items
19:08 <sil2100> I guess all the action items are done
19:08 <sil2100> Since the vote finished, we'd just need to announce the results + contact the TB
19:08 <bdmurray> Should we talk about the vote now or during AOB?
19:08 <sil2100> But that's a separate task
19:09 <sil2100> Let's talk afterwards, since application handling I'd prefer prioritized
19:09 <bdmurray> Okay.
19:09 <sil2100> #topic SRU Developer applications
19:10 <sil2100> #subtopic Dan Streetman
19:10 <sil2100> ddstreet: o/ Could you introduce yourself?
19:10 <ddstreet> hello o/
19:10 <sil2100> https://wiki.ubuntu.com/ddstreet/UbuntuSRUDeveloperApplication <- application link
19:10 <ddstreet> hi, i'm dan streetman, as indicated, and applying for the 'SRU developer' role
19:10 <ddstreet> sil2100 thanks, that's my application link
19:11 <ddstreet> i work closely with slashd, who is currently the only other SRU devel
19:11 <ddstreet> any questions for me?
19:12 <bdmurray> Look at the sponsorship miner I don't see very many SRU uploads. Maybe 8 is that right?
19:12 <ddstreet> yes, not too many, around 8 is probably right
19:13 <ddstreet> i have spent a lot of time working on kernel patches also
19:13 <ddstreet> and my last upload, for pylint, was artful only, no SRU
19:13 <bdmurray> That's interesting but I'm not certain its relevant to an SRU application.
19:14 <ddstreet> no, kernel and devel uploads are not relevant
19:14 <sil2100> ddstreet: a 'technical' question from my side - when submitting an SRU application, what info would you include in the Regression Potential field?
19:15 <sil2100> What is the purpose of this field?
19:15 <ddstreet> i would include any possible side-effects of the change
19:16 <ddstreet> e.g. what area of the code does this change touch, and if that code area breaks, what would that look like?
19:18 <sil2100> Thanks
19:19 <ddstreet> an example of what i've put in regression potential before, from my last vlan sru: "Any modifications to ifupdown or the scripts it uses may cause wider problems with network configuration. Specifically, this could cause problems when using vlan interfaces, as it forces every vlan's raw device interface to be fully ifup'ed before the vlan interface can finish its ifup."
19:19 <bdmurray> What prompted applying for SRU uploads today? Is not having access blocking your work even though your last SRU was in June?
19:19 <sil2100> ddstreet: a more theoretical question - what do you think, does the lack of upload rights block your work? Will you do more uploads when having the permissions?
19:20 <ddstreet> bdmurray mainly my application is so i can help move along sru applications into the queue to be reviewed
19:20 <ddstreet> i.e., speed up sru's that are needed
19:21 <ddstreet> sil2100 yes i will likely do more uploads, but probably i'll be uploading other's work
19:21 <bdmurray> ddstreet: so it'd allow you to sponsor other SRUs?
19:21 <ddstreet> yes
19:21 <ddstreet> i do not think i will personally create more patches that i apply for sru's for, but i do think i will review and upload other people's sru's
19:21 <ddstreet> obviously more than i do now, since i can't do that now ;-)
19:22 <ddstreet> and of course, it will help me when i do have a sru to upload
19:22 <ddstreet> personally-authored sru, that is
19:23 <bdmurray> That's different than what *I'd* expected this application or other SRU developer applications to look like.
19:23 <ddstreet> bdmurray what do you expect is the intention of people applying for SRU devel?
19:23 <bdmurray> I'd expected applicants to uploading their own work not sponsoring stuff for others.
19:23 <ddstreet> is that what you expect of core devs?
19:23 <micahg> one of the for granting rights is significant and sustained uploads/contributions except in cases where that doesn't make sense (PPU for a mature package that needs very infrequent updates)
19:23 <ddstreet> mainly upload their own patches?
19:24 <micahg> *one of the criteria
19:24 <bdmurray> ddstreet: How would you evaluate whether or not an upload is SRU ready?
19:25 <ddstreet> bdmurray there's 2 parts to that: 1) technical change to whatever codebase it is, and 2) sru metadata like changelog format, version number, etc
19:26 <ddstreet> for #1, the change depends on the package, and i would review the patch(es) and existing code to see how the code works, what the author is changing, if it makes sense and is done correctly, and mostly if it's upstream
19:26 <ddstreet> if it's not accepted in the upstream code, that's a big red flag for deinal
19:26 <ddstreet> assuming it's upstream, make sure it's in the devel release first
19:26 <ddstreet> if upstream accepted it, and it's in devel, and the code looks good, then check #2
19:27 <ddstreet> which involves making sure the changelog has no trailing whitespace, line length is right, includes LP: #NNN, right changelog text, author name/email
19:27 <ddstreet> check the patch e.g. patch -p1, quilt import/push/refresh, builds ok, autpkgtest
19:28 <ddstreet> version number is correct based on current version
19:29 <ddstreet> rather a lot of meta-data checks (i've thought about adding a tool to ubuntu-dev-tools to automate some of that, like scripts/checkpatch.pl for the kernel)
19:30 <ddstreet> any other q's for me?
19:31 <sil2100> Any questions? Or should we proceed to voting?
19:31 <bdmurray> I'm ready to vote.
19:31 <sil2100> BenC? micahg?
19:32 <micahg> ready
19:32 <sil2100> I guess we're good then
19:32 <sil2100> #vote Grant ddstreet SRU Developer
19:32 <meetingology> Please vote on: Grant ddstreet SRU Developer
19:32 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
19:34 <bdmurray> -1 I'd like to see more involvement in the SRU process before granting you upload rights.
19:34 <meetingology> -1 I'd like to see more involvement in the SRU process before granting you upload rights. received from bdmurray
19:34 <micahg> +0 , while the quality of work is good so far, it's a bit sporadic, also, I applaud your desire to sponsor uploads, but I don't feel that in and of itself is a reason to grant upload rights, I look forward to seeing you back soon with more SRUs completed when we can hopefully grant you SRU upload permissions
19:34 <meetingology> +0 , while the quality of work is good so far, it's a bit sporadic, also, I applaud your desire to sponsor uploads, but I don't feel that in and of itself is a reason to grant upload rights, I look forward to seeing you back soon with more SRUs completed when we can hopefully grant you SRU upload permissions received from micahg
19:34 <bdmurray> Perhaps one way to do that is looking at some things in the SRU queue and then getting an SRU team member endorsement.
19:36 <sil2100> +0, all good skill-wise but I also think it's a bit too soon, certainly a passing vote after a short while of more uploads + endorsements
19:36 <meetingology> +0, all good skill-wise but I also think it's a bit too soon, certainly a passing vote after a short while of more uploads + endorsements received from sil2100
19:36 <ddstreet> bdmurray micahg sil2100 sounds good, i'm happy to reapply after adding some more sponsored sru uploads...you guys don't mind me bugging you to sponsor my uploads right? ;-)
19:37 <sil2100> ddstreet: not at all! It would be a pleasure - I'd say keep up on uploading through sponsors and we'd gladly review you again in a month or so
19:37 <sil2100> Or whenever you're ready
19:37 <ddstreet> awesome.  thnx all
19:38 <sil2100> ddstreet: thanks!
19:38 <sil2100> #topic PPU Applications
19:38 <sil2100> #subtopic David Mohammed (fossfreedom)
19:38 <sil2100> fossfreedom: o/
19:39 <fossfreedom> :)
19:39 <sil2100> fossfreedom: could you introduce yourself? Since some of us might not know you yet!
19:39 <sil2100> https://wiki.ubuntu.com/fossfreedom/UbuntuBudgieDevApplication <- application
19:39 <fossfreedom> hi - my name is david mohammed - I am the project lead of ubuntu budgie
19:39 <fossfreedom> I am applying for PPU for the packages listed in my application
19:40 <fossfreedom> my work crosses both debian and ubuntu
19:40 <fossfreedom> the packages I have either created myself and maintain
19:40 <fossfreedom> or the package I have a direct interest due to Ubuntu Budgie
19:41 <sil2100> Sorry for the interruption, but I just got reminded that we need to close the previous vote
19:41 <sil2100> #endvote
19:41 <meetingology> Voting ended on: Grant ddstreet SRU Developer
19:41 <meetingology> Votes for:0 Votes against:1 Abstentions:2
19:41 <meetingology> Motion denied
19:41 <sil2100> Ok, please continue ;p
19:41 <fossfreedom> ok - sorry - any Q's for me?
19:42 <sil2100> I've sponsored some packages for you already and I remember not having any issues as to their contents, which is good
19:42 <bdmurray> I only see one endorsement on your application, is there a reason for this?
19:43 <jbicha> bdmurray: I see 4
19:43 <sil2100> bdmurray: yeah, there's 4
19:44 <jbicha> I strongly endorse his application. I haven't updated my endorsement since his last application in December
19:45 <jbicha> I think LocutusOfBorg's endorsement might be old too?
19:45 <bdmurray> Sorry I thought the rest were comments.
19:46 <micahg> right ,just one new endorsement since December
19:47 <sil2100> Well, it's all good
19:48 <sil2100> fossfreedom: tell me, when would be the usual cut-off 'date' after which you cannot upload NEW packages (by new I mean not-existing in the Ubuntu archive yet)?
19:49 <fossfreedom> freeze date - little late this cycle - just past in late august
19:49 <fossfreedom> idea would be to work with debian preferably
19:49 <sil2100> Which freeze that would be?
19:49 <fossfreedom> but definitely a couple of months before hand
19:50 <sil2100> Since there's a lot of different freezes in the archive ;)
19:50 <fossfreedom> debian freeze
19:50 <fossfreedom> the auto sync with debian to ubuntu
19:52 <sil2100> And what would you do if Ubuntu is in Feature Freeze already and need such a brand new package released to Ubuntu?
19:52 <fossfreedom> feature freeze is tied to debian freeze this cycle
19:52 <sil2100> By need I mean, suddenly really need it for good reasons
19:52 <fossfreedom> question very hard if it is really needed first of all
19:52 <fossfreedom> usually not
19:52 <fossfreedom> but if necessary FFE - feature freeze exception
19:52 <sil2100> But let's assume it's really needed, can you still get it in?
19:52 <sil2100> Yeah
19:54 <sil2100> BenC, bdmurray, micahg: any questions?
19:55 <bdmurray> Not from me.
19:55 <micahg> fossfreedom: I seem to recall Budgie was mainly going through Debian and there were mostly syncs happening, did something change?
19:56 <fossfreedom> in terms of budgie-desktop - upstream pull a rabbit out of their hat.  It came late this cycle
19:56 <fossfreedom> debian also had lots of issues with the new queue
19:56 <fossfreedom> so the sync would not occur before debian freeze
19:57 <micahg> is Ubuntu the upstream for the budgie packages??
19:57 <micahg> the ones not in Debian I mean
19:57 <fossfreedom> upstream - budgie-desktop github.com/budgie-desktop/budgie-desktop
19:57 <jbicha> in a way, I think Ubuntu is the upstream for the Debian packages too ;)
19:58 <micahg> right, but what about packages like budgie-welcome, budgie-desktop-environment
19:59 <fossfreedom> those two are specific to ubuntu - they are at the heart of ubuntu budgie.  They are written specifically for us and would not work with Debian
20:01 <sil2100> Any other questions?
20:01 <sil2100> I'm poking since we're again over our scheduled time here
20:02 <BenC> I’m good
20:02 <sil2100> micahg: you have any more questions?
20:03 <sil2100> I assume not in this case, let's vote
20:03 <sil2100> #vote Grant fossfreedom PPU permissions for the listed package set
20:03 <meetingology> Please vote on: Grant fossfreedom PPU permissions for the listed package set
20:03 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:04 <sil2100> Packageset list: budgie-desktop, budgie-desktop-environment, budgie-artwork, budgie-welcome, budgie-wallpapers, arc-theme, moka-icon-theme, faba-icon-theme, rhythmbox-plugin-alternative-toolbar, budgie-indicator-applet, slick-greeter and ubuntu-budgie-meta
20:04 <sil2100> (so it's in the logs)
20:04 <sil2100> +1
20:04 <meetingology> +1 received from sil2100
20:05 <bdmurray> +1
20:05 <meetingology> +1 received from bdmurray
20:07 <sil2100> BenC, micahg: ?
20:08 <BenC> +1
20:08 <meetingology> +1 received from BenC
20:08 <micahg> +1
20:08 <meetingology> +1 received from micahg
20:09 <sil2100> #endvote
20:09 <meetingology> Voting ended on: Grant fossfreedom PPU permissions for the listed package set
20:09 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:09 <meetingology> Motion carried
20:09 <sil2100> fossfreedom: congratulations!
20:10 <fossfreedom> cheers all - much appreciated!
20:10 <sil2100> Who will take care of creating the packageset etc.?
20:11 <micahg> a personal package set might be useful,, needs to be a TB member to create, but then we can maintain
20:13 <sil2100> Any volunteers to drive this? ;)
20:13 <bdmurray> I think I'll be emailing them anyway re the election so could get it setup
20:13 <sil2100> bdmurray: thanks!
20:13 <sil2100> #action bdmurray to handle the PPU role for fossfreedom
20:13 * meetingology bdmurray to handle the PPU role for fossfreedom
20:14 <sil2100> #endvote
20:14 <meetingology> No vote in progress
20:14 <sil2100> Eh, stupid copy-paste
20:14 <sil2100> #topic AOB
20:15 <sil2100> bdmurray: ok, you wanted to discuss the vote results?
20:15 <bdmurray> micahg: What did you mean by certify the election?
20:15 <micahg> vote to acknowledge the results of the election
20:15 <sil2100> The TB?
20:15 <micahg> both
20:15 <bdmurray> Why would I not vote +1?
20:15 <micahg> it's usually a formality
20:16 <sil2100> Is that always been like that?
20:16 <micahg> yeah
20:16 <bdmurray> Okay, just wondering.
20:16 <micahg> it's just a safeguard
20:16 <sil2100> So let's vote then
20:16 <bdmurray> Guess what mine is!
20:16 <sil2100> #vote Vote to acknowledge the results of the election
20:16 <meetingology> Please vote on: Vote to acknowledge the results of the election
20:16 <meetingology> Public votes can be registered by saying +1, +0 or -1 in channel, (for private voting, private message me with 'vote +1/-1/+0 #channelname)
20:16 <sil2100> +1
20:16 <meetingology> +1 received from sil2100
20:16 <micahg> +1
20:16 <meetingology> +1 received from micahg
20:16 <bdmurray> +1
20:16 <meetingology> +1 received from bdmurray
20:17 * sil2100 looks at BenC
20:17 <sil2100> *stare*
20:18 <sarnold> BenC: (some clients only highlight on the nick in the first token)
20:19 <sil2100> micahg: hmm, but how is this vote counted then?
20:19 <BenC> +1
20:19 <meetingology> +1 received from BenC
20:19 <sil2100> #endvote
20:19 <meetingology> Voting ended on: Vote to acknowledge the results of the election
20:19 <meetingology> Votes for:4 Votes against:0 Abstentions:0
20:19 <meetingology> Motion carried
20:19 <sil2100> BenC: thanks!
20:19 <BenC> Sorry, I’m doing my best to stay focused for quorum
20:20 <sil2100> micahg: since we don't actually need 4 + anyway, since there's only 5 people potentially that could vote
20:20 <sil2100> So 3 + were anyway sufficient I suppose
20:20 <sil2100> Anyway, all good
20:20 <sil2100> Now just the TB and we can officially welcome jbicha and cyphermox at the DMB
20:20 <sil2100> Ok, final thing from me
20:21 <micahg> sil2100: I think we'd still need +4 since the board is 7 members
20:21 <sil2100> BenC, micahg, bdmurray: there's an ongoing application of rbalint through e-mail
20:21 <sil2100> micahg: yeah but how can we expect 7 peolpe to vote
20:21 <micahg> right, I'll try to get to that later today
20:21 <sil2100> micahg: since we're voting for the 2 people that we're missing
20:21 <BenC> Me too
20:21 <micahg> sil2100: we can't, but I don' t think that changes quorum
20:21 <sil2100> micahg: this would be a bit absurd IMO
20:21 <sil2100> But anyway
20:22 <sil2100> Not a problem this time I guess!
20:22 <sil2100> micahg, BenC: thanks!
20:22 <micahg> IMHO it's the equivalent of 2 members on extended vacation
20:22 <bdmurray> So two actions more for me?
20:22 <bdmurray> email TB re election then announce the results?
20:22 <sil2100> #action bdmurray to contact TB regarding the election
20:22 * meetingology bdmurray to contact TB regarding the election
20:22 <sil2100> bdmurray: if you want, we can share some of those tasks
20:23 <sil2100> Want me to send out the result announcement?
20:23 <bdmurray> sil2100: Sure, I'll let you know when I hear from the TB
20:24 <LocutusO-> congrats! yes my advocacy was a little bit old, but it was still valid :)
20:24 <sil2100> #action sil2100 to send out the results announcement after the TB decision is known
20:24 * meetingology sil2100 to send out the results announcement after the TB decision is known
20:25 <sil2100> Any other business?
20:25 <sil2100> LocutusO-: ;)
20:25 <bdmurray> Nope
20:25 <sil2100> Ok, let's assume we're all good now
20:25 <sil2100> o/
20:25 <sil2100> #endmeeting