16:05 <smoser> #startmeeting ubuntu-server-team
16:05 <meetingology> Meeting started Tue Sep  5 16:05:54 2017 UTC.  The chair is smoser. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:05 <meetingology> 
16:05 <meetingology> Available commands: action commands idea info link nick
16:06 <smoser> #topic Review ACTION points from previous meeting
16:06 <smoser> looks like there were no action (per https://wiki.ubuntu.com/ServerTeam/Meeting)
16:06 <smoser> oh. wait. reading wrong
16:06 <smoser> * nacc to write a release notes entry on ipv6 netboot (carried over)
16:06 <smoser> is that right ?
16:06 <nacc> smoser: carry over
16:06 <nacc> smoser: yeah
16:06 <smoser> wow
16:06 <smoser> :)
16:07 * smoser nacc to write a release notes entry on ipv6 netboot (carried over)
16:07 <smoser> #ACTION: nacc to write a release notes entry on ipv6 netboot (carried over)
16:07 * meetingology : nacc to write a release notes entry on ipv6 netboot (carried over)
16:07 <nacc> smoser: also that one
16:07 <smoser> * nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 <cpaelzer> I keep reminding that we can almost start to think/prep artful release notes now
16:07 <smoser> #ACTION nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:07 <smoser> * rbasak to add maintainership info to mysql triage page (carried over)
16:07 <rbasak> Carry over please again
16:08 <smoser> #ACTION: rbasak to add maintainership info to mysql triage page (carried over)
16:08 * meetingology : rbasak to add maintainership info to mysql triage page (carried over)
16:08 <smoser> #topic Artful Development
16:08 <smoser> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:08 <ahasenack> final beta, sep 28th
16:09 <cpaelzer> thanks for that date ahasenack
16:09 <smoser> today is Septmber 4th, so we are post Beta 1 Freeze and FeatureFreeze.
16:09 <smoser> the final beta freeze is actually the Sep 21.
16:09 <cpaelzer> last time we asked for FFEs are there new ones that were (or are going to be) added?
16:10 <cpaelzer> I see 28th in the wiki as ahasenack does
16:10 <smoser> er... (math wrong). Sept 25. the beta on 28th
16:10 <cpaelzer> 21st is documentation string freeze
16:11 <smoser> the Final Beta Freeze is Monday the 25th . the Final Beta is Thursday the 28th.
16:11 <smoser> the link only lists thursdays, it says "(Monday)" for the freezse
16:11 <smoser> anyway... thats roughly where we are.
16:11 <smoser> bugs to fix, things to make better now.
16:11 <smoser> #subtopic Current Work
16:11 <smoser> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:11 <smoser> anyone want to coment on tasks they have ^
16:11 <smoser> ?
16:12 <cpaelzer> nothing special I'd know about atm
16:12 <smoser> #subtopic Release Bugs
16:13 <smoser> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:13 <ahasenack> that list is suspiciously short
16:14 <smoser> hm..
16:14 <smoser> possibly. probably. probably https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/1713803 should be added. i'll get that added.
16:14 <ubottu> Launchpad bug 1713803 in whereami (Ubuntu) "replacement of resolvconf with systemd needs integration" [Undecided,New]
16:14 <cpaelzer> I'm on the ntp bug in there
16:15 <smoser> ahasenack, are you volunteering to look at why that list is suspiciously short ? any thing you had in mind ?
16:15 <cpaelzer> ack smoser, yours is a big one that should be in there
16:15 <ahasenack> smoser: do you know what script generates it?
16:16 <smoser> rbasak does. it is based on tags i blieve.
16:16 <smoser> or not. as the ntp one has no tags.
16:16 <cpaelzer> bug tasks
16:16 <rbasak> It uses Artful bug tasks
16:16 <ahasenack> it has a "status tracked in artful" status
16:16 <nacc> i think it's just ~ubuntu-server bugs with artful tasks?
16:16 <cpaelzer> if a bug is open against devel, but not has a artful task it is not on there
16:16 <ahasenack> sounds like it
16:16 <smoser> there you go.
16:16 <rbasak> Which is debatable as to whether that's the correct way to track them.
16:17 <nacc> highly debatable
16:17 <rbasak> I'm not sure it is. I don't create Artful tasks.
16:17 <nacc> yeah
16:17 <rbasak> Because they don't roll forward.
16:17 <nacc> it's implicit that right now, devel tasks are artful takss
16:17 <rbasak> Well, sort of.
16:17 <nacc> *tasks
16:17 <smoser> so the useful ness of the list is suspect
16:17 <cpaelzer> I create them when I'm convinced I tackleit in that release
16:17 <smoser> do you have a better listi ?
16:17 <rbasak> smoser: correct
16:17 <cpaelzer> whic is why the ntp bug is on there
16:17 <rbasak> We can use milestones.
16:18 <smoser> or do we just stop discussing this. mile stones ... still require a task
16:18 <rbasak> But I don't think the milestone bug list would be filtered by bug subscriber.
16:18 <rbasak> Milestones can use the standard development task.
16:18 <rbasak> The necessary discussion should probably happen on ubuntu-release@
16:19 <rbasak> I've never considered it important enough to take on the big task of driving it.
16:19 <smoser> ok.
16:19 <smoser> well, i'm open to any suggestions on what should happen here.
16:19 <smoser> including "go on to next task"
16:19 <nacc> "go on to the next task"
16:19 <nacc> smoser: --^ :)
16:19 <smoser> s/task/section of meeting/
16:19 <smoser> all opposed ?
16:19 <smoser> tabled
16:20 <smoser> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd, ddstreet)
16:20 <ddstreet> no updates from slashd and me
16:20 <smoser> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:20 <cpaelzer> did percona SRU move forward?
16:20 <smoser> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:21 <smoser> ddstreet, ^ ? per cpaelzer above ?
16:21 <ddstreet> cpaelzer sorry i'm not sure, slashd just let me know there were no updates to communicate
16:21 <ddstreet> i can check briefly
16:21 <cpaelzer> ok
16:21 * smoser notes no string 'percona' in https://people.canonical.com/~ubuntu-archive/pending-sru.html
16:21 <smoser> and none at https://launchpad.net/ubuntu/xenial/+queue?queue_state=1&queue_text=percona
16:21 <cpaelzer> rbasak: did you review since last week?
16:22 <smoser> so i think the answer is 'no'
16:22 <cpaelzer> ok for nos smoser,I can check the bug on my own
16:22 <rbasak> percona is waiting an Artful FTBFS last I know.
16:22 <smoser> #topic Weekly Updates & Questions for the QA Team (powersj)
16:22 <rbasak> I haven't looked since.
16:22 <smoser> #link https://jenkins.ubuntu.com/server/
16:22 <rbasak> I believe STS are aware.
16:23 <powersj> Last week spent a lot of time trying to get the ISO tests going again. All artful smoke tests started failing after gdebi-core was moved to universe. Utah was also attempting to injecting gdebi-core preventing testing. Modified Utah to not require gdebi at all and install via dpkg + apt-get.
16:23 <rbasak> Incidentally this probably shouldn't block the SRU if it's difficult to fix for some technical reason.
16:23 <powersj> This week the tests started hanging again over the weekend asking for the keyboard information, but I am not sure what changed. Looking into that.
16:24 <powersj> questions?
16:25 <smoser> looks like none...
16:25 <smoser> moving on
16:25 <smoser> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:25 <smb> I hear we might be resolving the final issues which kept us from moving to the final 4.13 kernel version for Artful. So that should happen rather soon. Some update to flashcache which I mentioned last time: just by odd coincidence(?) after having done so, the upstream github project showed some signs of life. Though those changes did not fix later kernels yet we re-visited this and think we have a working fix for
16:25 <smb> now. But from what we heard from upstream sources we should get rid of it in 18.04 (remove from archive).
16:25 <smb> Other than that: questions?
16:25 <ddstreet> rbasak cpaelzer smoser brief follow up on percona, yes it is waiting on a FTBFS issue that STS is currently working on
16:26 <smoser> thanks ddstreet
16:26 <smoser> moving on ... no questions seen for smb.
16:26 <smoser> so
16:26 <smoser> #topic Upcoming Call For Papers
16:26 <smoser> #link https://lwn.net/Calendar/Monthly/cfp/
16:26 <smoser> #link http://www.open-zfs.org/wiki/OpenZFS_Developer_Summit
16:27 <smoser> that second link seems like it should be dropped unless we weekly just want to track openzfs
16:27 <smoser> :)
16:27 <slashd> smoser, just a quick note .... can you add in the meeting note or else, that I'll be absent for the next 2 weeks (conference and vacation). ddstreet will be my backup.
16:27 <smoser> k. thanks.
16:27 <slashd> smoser, tks
16:28 <ahasenack> smoser: +1 to drop the openzfs one
16:28 <smoser> see cfp link above... orconf and netdev2.2 are coming up.
16:28 <smoser> other than that
16:28 <smoser> #topic Ubuntu Server Team Events
16:28 <smoser> anyone have anything here ?
16:29 <smoser> #topic Open Discussion
16:29 <smoser> anything ?
16:29 <ahasenack> not from me
16:29 <cpaelzer> nope
16:29 <smoser> then closing
16:29 <smoser> #topic Announce next meeting date, time and chair
16:29 <smoser> #info Next meeting Tuesday, 2017-09-12 at 1600 UTC, chair will be ahasenack
16:29 <ahasenack> o/
16:29 <smoser> #endmeeting