16:01 <teward> #startmeeting ubuntu-server-team
16:01 <meetingology> Meeting started Tue Aug 22 16:01:11 2017 UTC.  The chair is teward. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:01 <meetingology> 
16:01 <meetingology> Available commands: action commands idea info link nick
16:01 <teward> #topic Review ACTION points from previous meeting
16:01 <teward> * nacc to write a release notes entry on ipv6 netboot (carried over)
16:02 <teward> * nacc to write a server guide entry on ipv6 netboot (carried over)
16:02 <teward> nacc: any progress on these, or should we carry these over to next meeting?
16:02 <teward> * rbasak to add maintainership info to mysql triage page (carried over)
16:02 <nacc> teward: please carry over
16:02 <teward> I think rbasak is absent, as I got put in as the chair today, so I'll carry that to next meeting.
16:02 <dpb1> carry over rbasak too
16:02 <nacc> teward: rbasak is also not attending
16:02 <teward> yep
16:03 <nacc> thanks
16:03 <teward> #action nacc to write a release notes entry on ipv6 netboot (carried over)
16:03 * meetingology nacc to write a release notes entry on ipv6 netboot (carried over)
16:03 <teward> #action nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 <teward> #action
16:03 * meetingology 
16:03 <teward> oops
16:03 <teward> #action rbasak to add maintainership info to mysql triage page (carried over)
16:03 * meetingology rbasak to add maintainership info to mysql triage page (carried over)
16:03 <teward> #topic Artful Development
16:04 <teward> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:04 <ahasenack> feature freeze this week
16:04 <cpaelzer> There is a lot of stuff currently moving in - as part of the usual flurry of uploads before Feature freeze
16:04 <ahasenack> when exactly is it on the 24th? At what time?
16:04 <teward> beat me to it for a few seconds lol
16:04 <cpaelzer> so any testing might show up new issues, please report
16:05 <teward> ahasenack: I can put an inquiry to the release team to find out, but it's probably better to treat it as "on the day" rather than assume any given specific time
16:05 <teward> at least, that's how I've treated it, trying to get things in the day before
16:05 <cpaelzer> I don't think the time matters
16:05 <cpaelzer> what I'd like to know is if we hae known FFE's already in queue
16:05 <teward> Feature Freeze is on the 24th, so try and get things in by 23rd if you need to upload and add new features.
16:05 <cpaelzer> I didn't need mine for qemu, but there might be others
16:05 <dpb1> teward: +1
16:05 <powersj> that would be a good one to use #info on
16:06 <powersj> remember to take notes with that
16:06 <cpaelzer> also the Server Team is working on several extra merges that a few might end up as FFE
16:06 <teward> powersj: working on a laptop, 1 thing at a time :P
16:06 <cpaelzer> are ther eother known FFEs already?
16:06 <dpb1> hehe
16:06 <teward> #info Feature Freeze is on the 24th, so try and get things in by 23rd if you need to upload and add new features.
16:06 <teward> #info Server Team working on several extra merges that may end up as FFEs
16:06 <teward> cpaelzer: i'm not aware of any, anyone else know of any known FFEs on the radar?
16:07 <teward> guess not, moving on.
16:07 <cpaelzer> there are a few samba-vfs things
16:07 <teward> oops :P
16:07 <cpaelzer> anyone can check https://bugs.launchpad.net/~ubuntu-release/+bugs?orderby=-date_last_updated&start=0
16:07 <cpaelzer> and look for FFe
16:07 <cpaelzer> that is what I do lacking a better list
16:07 <dpb1> #link https://bugs.launchpad.net/~ubuntu-release/+bugs?orderby=-date_last_updated&start=0
16:08 <dpb1> (anyone can put in links and infos btw)
16:08 <teward> dpb1: beating me to it by seconds xD
16:08 <dpb1> IIRC
16:08 <teward> dpb1: yep anyone can.
16:08 <teward> moving on
16:08 <teward> #subtopic Current Work
16:08 <teward> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:08 * dpb1 glares around the room at people who are asking teward to retype their stuff ;)
16:09 <teward> we've covered its and pieces on this, so unless anyone has anything to bring up here, I'll move on to the next subtopic
16:10 <teward> i'm not aware of anything else that needs discussed under current work, I'm assuming everyone's good with it so far.
16:10 <teward> #subtopic Release Bugs
16:10 <teward> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:11 <dpb1> hm
16:11 <dpb1> perf degredation of zfs clone
16:11 <teward> i was about to say heh
16:12 <dpb1> I guess I'll bring that up with stgraber
16:12 <dpb1> oh, he's here!
16:12 <teward> looking at the bug, it looks like it's fix-released in zfs-linux with Artful
16:12 <dpb1> right
16:12 <teward> but needs an lxd looksie.
16:12 <dpb1> looks like bookeeping and lxd tasks still remain, right
16:13 <dpb1> put in an action for me to follow up with stgraber about this one please
16:13 <dpb1> (I don't think I can do that)
16:13 <teward> #action dpb1 to check with stgraber for 'zfs clone' performance degredation in lxd.
16:13 * meetingology dpb1 to check with stgraber for 'zfs clone' performance degredation in lxd.
16:13 <teward> #link https://bugs.launchpad.net/ubuntu/+source/zfs-linux/+bug/1567557
16:13 <ubottu> Launchpad bug 1567557 in lxd (Ubuntu Artful) "Performance degradation of "zfs clone"" [High,Confirmed]
16:14 <teward> of the other two bugs, one is fix-committed in Artful, with a merge from Debian.
16:14 <teward> and the other one doesn't appear to be fixed yet.
16:14 <ahasenack> looks like it needs a sponsor
16:15 <ahasenack> it has debdiffs attached
16:15 <stgraber> dpb1: what's needed on our side? cking found a workaround for this issue, pushed it to artful, pushed the SRUs and has a self-contained testcase for it which doesn't need LXD itself
16:15 <ahasenack> slashd: do you need to subscribe sponsors to #1693574?
16:15 <dpb1> stgraber: not sure?  it has lxd tasks on it
16:16 <teward> ahasenack: slashd isn't here right now, we can follow up with them.
16:16 <stgraber> dpb1: ah, we can close that then, there's nothing needed on the LXD side. I think it was back from when we were trying to track this down. Should have removed it once we provided a self-contained testcase for the zfs issue.
16:17 <dpb1> stgraber: great, then I think it would be finished
16:17 <teward> stgraber: I assume then the tasks for Xenial and Zesty are similarly able to be removed?
16:19 <teward> for now, i'll move on, since I think we're aware this isn't an issue anymore
16:19 <teward> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd, ddstreet)
16:19 <teward> slashd isn't here, but had something he wanted to make note of
16:20 <teward> #info pcp MIR being worked on was NACK'd by Security Team; pcp upstream is looking at security note and seeing what they can do to satisfy requirements and needs for the security note
16:20 <teward> #link https://bugs.launchpad.net/ubuntu/+source/pcp/+bug/1700827
16:20 <ubottu> Launchpad bug 1700827 in pcp (Ubuntu) "[MIR] pcp package" [Undecided,New]
16:20 <stgraber> dpb1, teward: cleaned up the tasks
16:20 <teward> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:20 <teward> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:20 <teward> stgraber: +1, thanks!
16:21 <teward> it looks like we have a bunch of these bug tasks under us, anything in here we need to bring up other than what slashd mentioned earlier?
16:21 <teward> ddstreet: if you have anything to add?
16:22 <ddstreet> teward nothing to add from me
16:22 <teward> well I see one thing that I can close off of this list, nginx *was* updated to 1.10.2 heh.
16:23 <teward> alrighty, is there anything else to add here, from anyone?
16:23 <teward> ddstreet: thanks.
16:24 <teward> moving on.
16:24 <teward> #topic Weekly Updates & Questions for the QA Team (powersj)
16:24 <teward> #link https://jenkins.ubuntu.com/server/
16:24 <powersj> Last week revised the cloud-init kvm-backed integration tests. Played with feature flags in adding additional storage and networking devices as well. Reviewed all my open SRUs. Got jenkins instance upgraded to 100Gb of storage to avoid issues of running out of space.
16:24 <powersj> This week, spent time to review some metric reviews. Otherwise, will be spending time on cloud-init integration tests.
16:25 <teward> powersj: thanks for the update!
16:25 <teward> anyone else have anything for powersj and the QA team?
16:26 <powersj> *looks around for this team*
16:26 <teward> heh
16:26 <teward> moving on.  thanks, powersj.
16:26 <teward> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:26 <smb> Nothing really changed since last week. If there are no questions we could move ahead.
16:26 <teward> I've got no questions, any questions from anyone else?
16:27 <teward> whoops
16:27 <teward> moving on
16:27 <teward> #topic Upcoming Call For Papers
16:27 <teward> #link https://lwn.net/Calendar/Monthly/cfp/
16:27 <teward> #link http://www.open-zfs.org/wiki/OpenZFS_Developer_Summit
16:28 <teward> I'm not aware of anything specific on these calendars, though I know OpenZFS abstract and presentation proposal deadline is September 4th, if anyone has anything to add
16:28 <dpb1> nothing here
16:29 <teward> moving on.
16:29 <teward> unless anyone else has anything
16:29 <teward> #topic Ubuntu Server Team Events
16:30 <teward> i'm not aware of any major events, though I will be representing Ubuntu and the Server Team at a FOSS event here focusing on open-source systems and server work in Harrisburg, PA next week that I only heard about yesterday.
16:30 <dpb1> #info A few of the canonical-server team will be sprinting Thursday/Friday this week, FYI.
16:30 <teward> thank you to my boss here at Penn State for letting me know of that :P
16:30 <teward> thanks dpb1
16:30 <ahasenack> nice
16:30 <dpb1> teward: that sounds cool
16:31 <dpb1> teward: know what you are going to present yet?  if anything?
16:32 <teward> dpb1: not sure yet, I know I've been invited but not sure if I've been given a presentation slot yet either
16:32 <teward> i'm keeping my eyes open for that, and am more than willing to entertain ideas to add to the presentation items, if they give me a slot.
16:32 <dpb1> ok
16:32 <teward> definitely going to have talking points as I'm one of the few Ubuntu guys there.  I know nginx is a hot topic in the local LUG, they recommended I bring some expertise and knowledge on that and Ubuntu as well
16:33 <dpb1> would be interested to hear how it goes afterward :)
16:33 <teward> i'll definitely share :)
16:33 <teward> anything else on the radar that anyone's aware of?
16:33 <teward> #info teward to attend Harrisburg, PA local FOSS event focusing on open-source systems, software, and server implementations.
16:34 <teward> dpb1: thanks for the FYI on the sprinting on Thursday and Friday.
16:34 <teward> moving on.
16:34 <teward> #topic Open Discussion
16:34 <teward> Anyone got anything else for the meeting today?
16:35 <nacc> teward: nothing else here
16:35 <teward> i've got one thing to say, I'm working on automating my merging and nginx updating workflow a little, to help me along.  No ETA on that, it's still at the design stage, but it works with upstream version announcements for the most part.
16:35 <teward> i'll share when done :)
16:36 <nacc> nice
16:36 <teward> #topic Announce next meeting date, time and chair
16:36 <teward> #info Next meeting Tuesday, 2017-08-29 at 1600 UTC, chair will be rbasak
16:37 <teward> thanks for attending, everyone!
16:37 <teward> #endmeeting