16:02 <rharper> #startmeeting ubuntu-server-team
16:02 <meetingology> Meeting started Tue Jul 18 16:02:05 2017 UTC. The chair is rharper. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:02 <meetingology>
16:02 <meetingology> Available commands: action commands idea info link nick
16:02 <rharper> #topic Review ACTION points from previous meeting
16:02 <rharper> previous agenda looks the same, nacc's out this week, so I'll just carry those
16:02 <rharper> #action nacc to write a release notes entry on ipv6 netboot (carried over)
16:02 * meetingology nacc to write a release notes entry on ipv6 netboot (carried over)
16:03 <cpaelzer> yes
16:03 <rharper> #action nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 <cpaelzer> and yours likely as well?
16:03 <rharper> rbasak is not here as well, so carry
16:03 <rharper> well
16:03 <rharper> I *did* do one of them
16:03 <cpaelzer> yay++
16:03 <rharper> so, gonna mark that complete
16:03 <cpaelzer> rbasak was around
16:03 <cpaelzer> let's ping him "at home"
16:03 <rharper> k
16:04 <rharper> I'll carry it and then mark it done if the answer differs
16:04 <rharper> #action rbasak to add maintainership info to mysql triage page (carried over)
16:04 * meetingology rbasak to add maintainership info to mysql triage page (carried over)
16:04 <rharper> #done rharper to write a release notes entry on v2 yaml support in cloud-init
16:05 <rharper> on the serverguide, there wasn't much of a section on cloud-init so wasn't sure what to do about that
16:05 <rharper> so I'll carry for now
16:05 <rharper> #action rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 * meetingology rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 <rharper> ok
16:06 <rharper> rbasak: I marked your previous task as carry-over, is that accurate ?
16:07 <rharper> I'll assume so and you can correct me later if needed
16:07 <rharper> #topic Artful Development
16:07 <rharper> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:07 <rbasak> rharper: that's correct, thanks.
16:07 <rharper> rbasak: great!
16:07 <smoser> o/
16:07 <rharper> #subtopic blueprints
16:08 <rharper> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:08 <rharper> any update to current work that needs discussion ?
16:08 <cpaelzer> actually the blueprints are replaced by the non daiyl board
16:08 <cpaelzer> let me fetch the link
16:08 <ahasenack> I think just the meeting subtopic is named incorrectly
16:08 <ahasenack> the link looks correct
16:08 <cpaelzer> https://trello.com/b/8bC9VQMk/server-backlog
16:08 <rharper> I have the link, but the subtopic is from the paste
16:08 <rharper> lemme put the bp link and then switch subtopics
16:09 <cpaelzer> well we have the short and the longterm one - I think it is fair to link up both from the meeting
16:09 <rharper> #subtopic Current Work
16:09 <cpaelzer> to give the full view
16:09 <rharper> the backlog one ?
16:09 <rharper> #link https://trello.com/b/8bC9VQMk/server-backlog
16:09 <rharper> we have both, and can fix up the actions
16:09 <cpaelzer> the old blueprint split into daily and backlog - which together are a superset of the old
16:09 <rharper> #action rharper to update irc cut-n-paste links to point to trello pages
16:09 * meetingology rharper to update irc cut-n-paste links to point to trello pages
16:10 <rharper> ok, any backlog discussion needed ?
16:10 <rharper> #subtopic Release Bugs
16:10 <cpaelzer> no changes incoming atm afaik
16:10 <cpaelzer> (on the backlog)
16:10 <rharper> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:10 <rharper> cpaelzer: thanks
16:11 <rharper> anything hot here ?
16:11 <cpaelzer> one general question
16:11 <cpaelzer> slashd: who is now Mr. sosreport?
16:11 <cpaelzer> it seems you on one of the bugs found in the link above - is that the case?
16:12 <slashd> cpaelzer, well I'm taking care of it, and have monthly meeting with stokachu
16:12 <cpaelzer> ok, thanks
16:13 <cpaelzer> didn't know that stokachu is intertwinded with sosreport
16:13 <cpaelzer> on the django bug - that is in proposed - nacc can share more next week when he is available
16:13 <rharper> ok
16:13 <cpaelzer> maybe it even migrated until then
16:13 <slashd> cpaelzer, he is upstream/ubuntu, sosreport is crucial for us, so I decide to take the lead on this for our team
16:14 <cpaelzer> ok, good to know
16:14 <slashd> and work with him on this to merge package in a regular basis when needed to fix bug
16:14 <rharper> #info stokachu is upstream/ubuntu for sosreport package
16:14 <rharper> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd, ddstreet)
16:14 <slashd> Business as usual for us, here's the SRUs we are currently working on : https://pastebin.canonical.com/193745/ , other than that I have nothing special to report this week.
16:15 <rharper> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:15 <slashd> #info SRU pending for : percona-xtradb-cluster-5.5 percona-xtradb-cluster-5.6, open-iscsi, ksh, cups, nfs-utils, rsyslog
16:15 <rharper> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:15 <ahasenack> hm, rsyslog
16:16 <ahasenack> slashd: what is the rsyslog sru?
16:16 <ahasenack> time jumps
16:16 <ahasenack> ok, see it
16:16 <ahasenack> I might have another sru for it soon
16:16 <ahasenack> but can wait
16:16 <rharper> bug #1429427
16:16 <ubottu> bug 1429427 in rsyslog (Ubuntu Trusty) "Unexplainable time jumps in CRON" [Medium,In progress] https://launchpad.net/bugs/1429427
16:17 <cpaelzer> fyi from me also a nut SRU might be coming soon
16:17 <cpaelzer> but I thought "soon" since quite a while, so I don't know how soon
16:17 <slashd> ahasenack, only for trusty, so it won't block you for other releases
16:17 <rharper> #info #1429427 - (rsyslog) Unexplainable time jumps in CRON , Series to SRU : trusty, Owners : Seyeong Kim
16:17 <slashd> I can ping you when Trusty SRU is done if you want
16:17 <cpaelzer> I want Debian to move before us so we can keep a sync
16:18 <rharper> #info #1590799 - (nfs-utils) nfs-kernel-server does not start because of dependency failure, Series to SRU : yakkety, Verification : verification-done-xenial verification-needed, Owners : Rafael David Tinoco
16:18 <ahasenack> slashd: ok
16:18 <ahasenack> mine is...
16:18 <rharper> #info #1657256 - (percona-xtradb-cluster-5.5 percona-xtradb-cluster-5.6) Percona crashes when doing a a 'larger' update , Series to SRU : xenial zesty trusty yakkety, Owners : Mario Splivalo
16:18 <ahasenack> https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1675515
16:18 <ubottu> Launchpad bug 1531622 in rsyslog (Ubuntu) "duplicate for #1675515 default config still using a legacy keyword: KLogPermitNonKernelFacility" [Medium,Fix released]
16:18 <ahasenack> which leads to https://bugs.launchpad.net/ubuntu/+source/rsyslog/+bug/1703987
16:18 <rharper> #info #1668639 - (rsyslog) Add a trigger to reload rsyslog when a new configuration file is dropped in /etc/rsyslog.d, Series to SRU : xenial zesty artful trusty yakkety, Owners : Frode Nordahl
16:18 <ubottu> Launchpad bug 1703987 in rsyslog (Ubuntu) "New style permitnonkernelfacility imklog option inside module() doesn't work" [Low,Triaged]
16:19 <ahasenack> as just changing the config doesn't fix it (upstream bug)
16:19 <rharper> #info #1684039 - (open-iscsi) iBFT network configuration does not correctly populate PROTO=dhcp in /run/net-*.conf which breaks cloud-init, Series to SRU : xenial artful zesty, Owners : Trent Lloyd
16:19 <rharper> #info #1695876 - (cups) German Documentation file displays incorrect CUPS version, Series to SRU : xenial, Owners : Ivy Alexander
16:20 <rharper> #info #1697501 - (ksh) ksh segfault on job_chksave () after it receive a SIGCHLD (Signal 17) , Series to SRU : xenial zesty yakkety, Verification : verification-done-trusty verification-done-xenial verification-done-yakkety verification-done-zesty, Owners : Eric Desrochers
16:20 <rharper> ok, link dereferenced for logs and emailing
16:21 <rharper> ok, moving forward
16:21 <rharper> #topic Weekly Updates & Questions for the QA Team (powersj)
16:21 <rharper> #link https://jenkins.ubuntu.com/server/
16:21 <powersj> Last week lots of time spent on the KVM backend for cloud-init testing. This week more of the same.
16:21 <powersj> questions?
16:21 <rharper> \o/
16:21 <rharper> when/where can I try it ?
16:22 <rharper> branch, jenkins job?
16:22 <powersj> https://code.launchpad.net/~powersj/cloud-init/+git/cloud-init/+ref/cii-kvm
16:22 <powersj> there is the branch ^
16:22 <cpaelzer> powersj: x86 only for now?
16:22 <powersj> cpaelzer: yes
16:22 <cpaelzer> how much more lockup when virt tests run?
16:22 <cpaelzer> so how much workload in hours?
16:23 <powersj> heh not sure yet, I have the backend working, but I need to spend time on test cases to utilize the new features
16:23 <rharper> #link https://code.launchpad.net/~powersj/cloud-init/+git/cloud-init/+ref/cii-kvm
16:23 <cpaelzer> sure
16:23 <rharper> #info cloud-init integration testing with KVM backend in progress
16:24 <rharper> powersj: did the curtin vmtests run last night ?
16:24 * rharper hasn't looked
16:24 <powersj> rharper: ah yes all passed, except daily-t due to bcache
16:24 <rharper> my manual run on our developement system passed all tests
16:24 <teward> (i'm late again sorry)
16:24 <rharper> powersj: ok, good; that's more normal
16:25 <rharper> I think the bcache on trusty might be the TOCTOU bug I filed
16:25 <rharper> typically happens under load only
16:25 <rharper> bug #1700564
16:25 <ubottu> bug 1700564 in curtin "under heavy IO encounter TOCTOU bug with bcache removal" [Undecided,New] https://launchpad.net/bugs/1700564
16:25 <rharper> any other questions for powersj ?
16:26 <rharper> previous week there was some discussion on seed changes?
16:26 <rharper> cpaelzer: powersj any update here ?
16:26 <powersj> ah I misspoke, wasn't seed change
16:26 <rharper> ah
16:26 <rharper> ok
16:26 <powersj> sounded as if a dependency change pulled more things in, no update though
16:27 <cpaelzer> seed changes were about virt- tasks
16:27 <cpaelzer> they are done, waiting on aa to remove some packages, that is all
16:27 <rharper> ok
16:27 <cpaelzer> that is https://bugs.launchpad.net/bugs/1540323
16:27 <ubottu> Launchpad bug 1540323 in ubuntu-virt (Ubuntu) "ubuntu-virt is not generated from seeds" [Undecided,Triaged]
16:27 <rharper> #info seed changes are done, waiting on an AA to remove some packages
16:28 <rharper> cpaelzer: thanks
16:28 <rharper> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:28 <smb> Or was that about nplan and libnss-resolve not being pulled in by the same meta? That is in kind of works
16:28 <smb> or systemd-netword has to be fixed to work without libnss-resolve
16:29 <smb> Anyhow for kernel. Been distracted with other things, so only can say artful kernel is 4.11 now and intention for release is to be 4.13... Any questions?
16:29 <rharper> smb: mmm, systemd fun
16:29 <smb> a source of much fun... :-P
16:29 <rharper> "fun"
16:29 <rharper> yes, I need more of that
16:30 <rharper> smb: was there a bug for the libnss-resolve/systemd-networkd/nplan path ?
16:30 <smb> yes
16:30 <smb> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1703640
16:30 <ubottu> Launchpad bug 1703640 in systemd (Ubuntu) "nplan and libnss-resolve should be in same dependency" [Medium,Triaged]
16:30 <rharper> excellent, thanks
16:30 <rharper> any other questions for smb ?
16:31 <rharper> #topic Upcoming Call For Papers
16:31 <rharper> #link https://lwn.net/Calendar/Monthly/cfp/
16:31 <rharper> any paper submissions or new venues to discuss ?
16:32 <rharper> #topic Ubuntu Server Team Events
16:32 <cpaelzer> better late than never, on the topic before "systemd fun" FYI 234 is in proposed
16:32 <cpaelzer> and fixes one of my issues, so it is fun this time
16:32 <rharper> well, that's got to be better than 232 and 233
16:33 <rharper> no team events to announce yet
16:33 <rharper> ok
16:33 <rharper> #topic Open Discussion
16:33 <rharper> fire away
16:33 <smb> rharper, as you asked for more systemd "fun": here you go: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1703882
16:33 <ubottu> Launchpad bug 1703882 in systemd (Ubuntu) "systemd-networkd does not pick up dns-search from DHCP" [Undecided,New]
16:33 <rharper> that's no fun
16:33 <smb> though might be fixed in the new version, I have not yet looked
16:34 <rharper> I suspect AA under MAAS is going to be interesting
16:34 <smb> the interesting as in "interesting times"
16:34 <rharper> indeed
16:35 <rharper> there doesn't seem to be anything up for discussion so I'll go ahead and close
16:35 <rharper> #topic Announce next meeting date, time and chair
16:35 <rharper> chair will be powersj
16:35 <powersj> \o/
16:35 <rharper> meeting sametime a week from now, minus 35 minutes
16:35 <rharper> #endmeeting