15:59 <dpb1> #startmeeting ubuntu-server-team
15:59 <meetingology> Meeting started Tue Jun 20 15:59:52 2017 UTC. The chair is dpb1. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:59 <meetingology>
15:59 <meetingology> Available commands: action commands idea info link nick
15:59 <dpb1> who we got?
16:00 <ahasenack> o/
16:00 * dpb1 stokes fire a bit waiting for people to show
16:00 <rbasak> o/
16:00 <smb> o/
16:01 <dpb1> #topic Review ACTION points from previous meeting
16:02 <powersj> o/
16:02 <dpb1> #action rbasak to add maintainership info to mysql triage page (carried over)
16:02 * meetingology rbasak to add maintainership info to mysql triage page (carried over)
16:02 <rbasak> Carry over please
16:03 <dpb1> hm
16:03 <dpb1> to carry over do we just leave it sit?
16:03 * rbasak is adding a Trello card :-/
16:03 <dpb1> ty
16:03 <dpb1> #action nacc to write a release notes entry on ipv6 netboot (carried over)
16:03 * meetingology nacc to write a release notes entry on ipv6 netboot (carried over)
16:03 <dpb1> #action nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 * meetingology nacc to write a server guide entry on ipv6 netboot (carried over)
16:03 <dpb1> still want to do these two nacc ?
16:04 <teward> (I'm late, sorry)
16:04 <nacc> dpb1: yeah, carry them please
16:04 <cpaelzer> the embarrassment-level of having these all these release notes still around is rising :-)
16:04 <cpaelzer> hi teward
16:04 <dpb1> ok rharper your turn
16:04 <dpb1> rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:04 <dpb1> rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:04 <dpb1> these feel more done, since we have them on rtd
16:05 <rharper> carry of course
16:05 <dpb1> could we link them to the RTD pages?
16:05 <rharper> yes
16:05 <ahasenack> what's rtf?
16:05 <ahasenack> er
16:05 <ahasenack> rtd
16:05 <dpb1> readthedocs
16:05 <rharper> Read The Docs
16:05 <dpb1> #action rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 * meetingology rharper to write a server guide entry on v2 yaml support in cloud-init (carried over)
16:05 <dpb1> #action rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:05 * meetingology rharper to write a release notes entry on v2 yaml support in cloud-init (carried over)
16:05 <cpaelzer> #link http://cloudinit.readthedocs.io/en/latest/
16:05 <dpb1> #link http://cloudinit.readthedocs.io/en/latest/
16:06 <cpaelzer> thanks dpb1
16:06 <dpb1> #topic Artful Development
16:06 <dpb1> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:06 <dpb1> #subtopic Trello
16:06 <dpb1> Just wanted to let everyone know we have replaced "the blueprint" with a trello board
16:07 <dpb1> #link https://trello.com/b/U9HhWyT0/daily-ubuntu-server
16:07 <dpb1> know we talked about it last week, but just a reminder
16:07 <teward> dpb1: +1 for that - it's a lot more useful than 'the blueprint' in my opinion.
16:07 <dpb1> thx teward
16:07 <teward> (also better at-a-glance to see what's going on in what states)
16:07 <dpb1> +1
16:07 <dpb1> #subtopic Active work that may need wider communication
16:08 <dpb1> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:08 <cpaelzer> I have something I wondered on devel, actually on proposed migration in general
16:08 <dpb1> floor is yours cpaelzer
16:08 <cpaelzer> if any migration issues were overrulled by the power of an AA or such, can that be tracked afterwards anywhere?
16:08 <cpaelzer> -l
16:09 <ahasenack> what are the usual reasons?
16:09 <ahasenack> flaky tests?/
16:09 <teward> testsuite fail
16:09 <cpaelzer> yes
16:09 <teward> package dependencies not built
16:09 <teward> etc.
16:09 <ahasenack> I think for flaky tests a bug can be filed
16:09 <ahasenack> we shouldn't get used to failing tests
16:10 <teward> there's also the case where "new binary packages" exist that didn't exist before and they usually are just cashiered in.
16:10 <dpb1> cpaelzer: you mean, we have moved the trello card into done already, that kind of tracking?
16:10 <cpaelzer> no
16:10 <cpaelzer> let me explain
16:10 <cpaelzer> I had a package which is a auto-sync from Debian
16:10 <cpaelzer> and it passed into artful, so it has completed its proposed migration
16:11 <cpaelzer> I was wondering if somebody "shoved" it through as since then all related tests were failing
16:11 <teward> don't non-merge autosyncs skip proposed migration?
16:12 <cpaelzer> I have seen other auto-syncs in migration
16:12 <cpaelzer> if some skip there must be a splitter somewhere which decides
16:12 <cpaelzer> e.g. mininet 2.2.2-1 was in artful, but until then http://autopkgtest.ubuntu.com/packages/mininet/artful/amd64 had NO listing of any 2.2.2-1 test
16:12 <cpaelzer> but I don't want to pick on this case
16:12 <cpaelzer> I have found and fixed it
16:13 <cpaelzer> I wonder if I have package X in release Y - is there any way/place I can check if anything was --force ?
16:13 <dpb1> audit log
16:13 <cpaelzer> like as launchpad has a publication history if there is a "package exception history" anywhere?
16:13 <dpb1> or something like that
16:13 <cpaelzer> yeah
16:13 <ahasenack> I guess only an AA can answer
16:13 <dpb1> Might be worth a reach out to ubuntu-devel
16:14 <cpaelzer> maybe with better words, but yes
16:14 <cpaelzer> ok I'll take an action to ask
16:14 <cpaelzer> I wanted to know it, so I volunteer to ask about it
16:14 <dpb1> #action cpaelzer reach out to ubuntu-devel@/AA and find out if an audit log of package exceptions exists anywhere
16:14 * meetingology cpaelzer reach out to ubuntu-devel@/AA and find out if an audit log of package exceptions exists anywhere
16:15 <dpb1> Any other topics to bring up about artful development?
16:15 <dpb1> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd)
16:15 <slashd> Here's the list of LP bugs that SEG is currently working on : http://pastebin.ubuntu.com/24908778/
16:15 <slashd> - By any chance, if there is a SRU verification member amongst us who has some cycle, we would appreciate to have someone approving the upload listed under [SRU verification needed] ^. Otherwise, it's fine I'll ask the SRU vanguard.
16:15 <slashd> - Also note that we are currently working on a MIR process to request to uplift 'pcp' pkg from Ubuntu universe to Ubuntu main. The paper work is not ready yet, but we are working on it. I'll probably have more to say about it next week.
16:16 <slashd> #info SRU pending for : percona-xtradb-cluster-5.5, nfs-utils, autofs5, percona-xtradb-cluster-5.6 percona-xtradb-cluster-5.5, multipath-tools, isc-dhcp
16:16 <dpb1> #info SRU pending for : percona-xtradb-cluster-5.5, nfs-utils, autofs5, percona-xtradb-cluster-5.6 percona-xtradb-cluster-5.5, multipath-tools, isc-dhcp
16:17 <cpaelzer> adding - #info further SRU pending: qemu, ntp
16:17 <dpb1> rbasak: any suggestion on the SRU for slashd?
16:17 <dpb1> #info further SRU pending: qemu, ntp
16:17 <rbasak> It's an endless queue unfortunately. It's my SRU day tomorrow - I'll take a look if I get that far.
16:18 <slashd> rbasak, thanks
16:18 <dpb1> slashd: any help needed on the bug list?
16:18 <cpaelzer> slashd: I wonder - are you usually relying on SRU verification team?
16:18 <slashd> dpb1, everything is under control
16:19 <cpaelzer> usually we try to get the reporters to help, who would that be in your case
16:19 <cpaelzer> any on site partner maybe?
16:19 <slashd> cpaelzer, we are always relying on them for SRU
16:19 <cpaelzer> or are they totally out of the loop in your case?
16:19 <cpaelzer> ah ok, then it is the same
16:19 <cpaelzer> so "just" the normal SRU duty
16:19 <cpaelzer> which rbasak and his peers are fighting the queue
16:19 <cpaelzer> thanks slashd
16:20 <dpb1> thanks slashd for the summary, interesting bugs this week. :)
16:20 <dpb1> #topic Weekly Updates & Questions for the QA Team (powersj)
16:20 <dpb1> #link https://jenkins.ubuntu.com/server/
16:20 <powersj> Last week got the cloud-init tests of COPR complete and running daily. Overhauled the daily tests of cloud-init and as of last night, got the CI pipeline in place and operational. Continue to run into some issues with pylxd and lxd 2.14, so running a local patched version of pylxd until pypi can be updated. And a blog post on our sprint.
16:20 <powersj> This week get the CI pipeline announced, get the ISO tests green, and back to proposed testing.
16:20 <powersj> questions?
16:21 <dpb1> have you checked with anyone on the pylxd issue?
16:21 <dpb1> or is there a bug filed?
16:21 <powersj> yes it is a matter of getting a new version uploaded to pypi
16:21 <powersj> and yes
16:21 <dpb1> linky linky?
16:22 <powersj> https://github.com/lxc/pylxd/issues/232
16:22 <slashd> dpb1, Is it possible to add on the #topic server ddstreet as a backup in case I'm absent ?
16:22 <dpb1> #link https://github.com/lxc/pylxd/issues/232
16:22 <dpb1> #action dpb look into why this is stalled https://github.com/lxc/pylxd/issues/232
16:22 * meetingology dpb look into why this is stalled https://github.com/lxc/pylxd/issues/232
16:23 <rbasak> slashd: I suggest you just go ahead and edit
16:23 <rbasak> https://wiki.ubuntu.com/ServerTeam/Meeting
16:23 <dpb1> slashd: I'll do it
16:23 <slashd> rbasak, dpb1 I did but it seems ddstreet disapeared from the list.
16:23 <dpb1> #action dpb add on the #topic server ddstreet as a backup in case slashd is absent ?
16:23 * meetingology dpb add on the #topic server ddstreet as a backup in case slashd is absent ?
16:23 <slashd> dpb1, thanks
16:23 <dpb1> slashd: thx for bringing it up
16:24 <dpb1> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:24 * rbasak suspects someone is using something other than the agenda to paste in meetingology commands :-)
16:24 <smb> An embargoed CVE uncloaked on your port side. Many new kernels launched. Otherwise the 4.11 kernel for artful still waits in proposed for better times (not sure what keeps it as I was distracted by previous news item). Are there questions?
16:25 <cpaelzer> smb: since you love the questions ahead of time, 4.14 next LTS is that in time for 18.04 ?
16:25 <dpb1> rbasak: (aside) it's why I took the action, I want to clean up the sources of truth
16:26 <smb> cpaelzer, maybe too soon even.
16:26 <smb> cpaelzer, estimated release of 4.14 is Nov-2017
16:26 <cpaelzer> ~November/December
16:26 <cpaelzer> yeah
16:26 <cpaelzer> too bad
16:26 <cpaelzer> try to stall the current 70 day cacle :-)
16:27 <dpb1> As the kernel turns....
16:27 <smb> Those plans ever worked sooo well
16:27 <dpb1> OK.
16:27 <dpb1> thx smb
16:27 <dpb1> #topic Upcoming Call For Papers
16:27 <dpb1> #link https://lwn.net/Calendar/Monthly/cfp/
16:28 <powersj> I did submit for debconf, but haven't heard back
16:28 <dpb1> any conferences or deadlines people are aiming for?
16:28 <cpaelzer> I heard that people are going to http://event.share.org/page/share-providence-registration
16:29 <cpaelzer> but it is too late to submit own ones
16:29 <cpaelzer> I'll track feedback from there with jfh, if it seems useful I might consider that next time
16:29 <cpaelzer> I was a regular speaker there in the past which might help to get accepted
16:29 <cpaelzer> but for now just FYI
16:29 <dpb1> #link http://event.share.org/page/share-providence-registration
16:30 <dpb1> #info cpaelzer interested in investgating for useful content.
16:30 <dpb1> that will be a great line item in the meeting notes
16:30 <teward> heh
16:30 <dpb1> #topic Ubuntu Server Team Events
16:30 <cpaelzer> hehe
16:31 <teward> better than what cpaelzer is taking from an OOB discussion as a quote regarding NTP from me xD (lol)
16:31 <cpaelzer> #link http://events.share.org/Summer2017/Public/Sessions.aspx?undefinedSuperTrackId=&TrackId=&AssociationId=&DateId=&FormatId=&DurationId=&SpeakerId=&AbilityLevelId=&SessionTypeId=&SubExpoId=&Keyword=ubuntu&&SearchEvent=&View=Sessions_summary
16:31 <cpaelzer> all ubuntu covering sessions scheduled for this time
16:31 <cpaelzer> but we are at Team events, sorry - too late
16:31 <dpb1> #link http://events.share.org/Summer2017/Public/Sessions.aspx?undefinedSuperTrackId=&TrackId=&AssociationId=&DateId=&FormatId=&DurationId=&SpeakerId=&AbilityLevelId=&SessionTypeId=&SubExpoId=&Keyword=ubuntu&&SearchEvent=&View=Sessions_summary
16:31 <powersj> we need another bug squashing day, been too long
16:31 <dpb1> cpaelzer: it's ok, the meeting notes are already sunk this week, best to sink them all the way
16:32 <cpaelzer> powersj: +1 *
16:32 <dpb1> #idea new bug squashing day is needed
16:32 <cpaelzer> * = if nothing in server-next teases you please help clear the expiring backlog
16:32 <cpaelzer> more on the open discussion
16:33 <dpb1> powersj: how do we normally announce it?
16:33 * cpaelzer is waiting for dpb1 to spin the topic-wheel-of-fortune
16:33 <powersj> to mailing list
16:33 <cpaelzer> nacc: writes to the list
16:33 <cpaelzer> and we update the wiki
16:33 <cpaelzer> there is a common header on all our pages
16:33 <nacc> technically anyone can do it
16:33 <nacc> :)
16:33 <dpb1> I nominate powersj to do it
16:33 <powersj> *sigh*
16:33 <dpb1> any seconds?
16:34 <dpb1> :)
16:34 <powersj> go ahead and give me the action, I'll show the rest of you how to complete an action item
16:34 <powersj> ;)
16:34 <cpaelzer> yeah !!
16:34 <dpb1> #humblebrag
16:34 <rharper> lol
16:34 <dpb1> #action powersj schedule a bugsquashing day!
16:34 * meetingology powersj schedule a bugsquashing day!
16:34 <dpb1> exciting
16:35 <dpb1> #topic Open Discussion
16:35 <teward> just... keep yer mitts off nginx - it's gonna have some rapid-changes in the next while :P
16:35 <dpb1> teward: yay!
16:35 <teward> (I literally have an upload 'prepped' if it passes sbuild fails)
16:35 <teward> s/fails//
16:35 <cpaelzer> nice
16:35 <ahasenack> cpaelzer: you had something here?
16:35 <cpaelzer> yeah
16:35 * dpb1 notices the fire is getting low, good time for open discussion
16:35 * teward tosses more logs on the fire.
16:35 <cpaelzer> we gave some more content to
16:35 <teward> :P
16:36 <cpaelzer> #link https://wiki.ubuntu.com/ServerTeam/KnowledgeBase
16:36 <cpaelzer> There was he suggestion that the better we define that the more we can have:
16:36 <cpaelzer> 1. agreement how we actually do things - yeah
16:36 <cpaelzer> 2. give other people a chance to help us
16:36 <cpaelzer> Please anyone who can give it a review and improvment
16:36 <cpaelzer> we can then use that if we get requests to help our triaging, backlog clearing, ...
16:36 <dpb1> #link https://wiki.ubuntu.com/ServerTeam/KnowledgeBase
16:37 <cpaelzer> along that there is another change to discuss
16:37 <cpaelzer> since the Team sprint we report all expiring backlog
16:37 <dpb1> #help please review https://wiki.ubuntu.com/ServerTeam/KnowledgeBase esp. triage section
16:37 <cpaelzer> the list is so long that nobody tackles the remaining bugs
16:37 <cpaelzer> and it is discouraging being on triage schedule
16:38 <cpaelzer> rbasak: brought up (thanks!) that this is just the same again we had with triaging at all
16:38 <cpaelzer> there we made a list of all the backlog we have
16:38 <cpaelzer> and picked them one by one as we could afford to do so
16:38 <cpaelzer> in that mindset I have prepared a few things
16:38 <cpaelzer> our current backlog that we as the Team need to clear
16:38 <cpaelzer> #link https://docs.google.com/spreadsheets/d/16CTKVQUjG78xi527_68uN4kVQ2EVYo6T7pFGouVwL_k/edit?ts=57abafba#gid=734042816
16:38 <cpaelzer> not sure this is public
16:38 * dpb1 looks
16:38 <dpb1> oh goodness
16:39 <cpaelzer> that is a new tab in the same gdoc that helped to clear the old backlog
16:39 <cpaelzer> as painful as it is we need to clear that
16:39 <dpb1> I opened up view access
16:39 <cpaelzer> please each of us pick a few and get them done in the context as described on the wiki
16:39 <cpaelzer> ok dpb1
16:40 <cpaelzer> if that is ok there is another extension
16:40 <cpaelzer> #link https://github.com/powersj/ubuntu-server-triage/pull/13
16:40 <cpaelzer> that is a MP to the triaging tool we use
16:40 <dpb1> #link https://docs.google.com/spreadsheets/d/16CTKVQUjG78xi527_68uN4kVQ2EVYo6T7pFGouVwL_k/edit?ts=57abafba#gid=734042816
16:40 <dpb1> #link https://github.com/powersj/ubuntu-server-triage/pull/13
16:40 <cpaelzer> if merged, it will ensure you only see "YOUR" expiring bugs
16:40 <cpaelzer> so if today is your triage day
16:40 <cpaelzer> then you'll see all server-next expiring 60 from today
16:40 <cpaelzer> ...
16:40 <cpaelzer> but if you miss to complete your duty today it won't be punted to the next member the next day
16:41 <cpaelzer> on top the list is shorter and less discouraging
16:41 <cpaelzer> any objections to the suggested change in tooling behaviour or how we hadnle the backlog?
16:41 * dpb1 recommends next time cpaelzer adds an agenda item for this "open disucssion"
16:42 <cpaelzer> agreed
16:42 * cpaelzer begs all your pardon
16:42 <dpb1> cpaelzer: I think it's good. the wiki summarizes things well
16:43 <cpaelzer> ok, lets keep track of picking from the backlog in the daily standup and sync on that next week here
16:43 <cpaelzer> #action check progress on clearing expiration backlog (all of us)
16:43 * meetingology check progress on clearing expiration backlog (all of us)
16:43 <dpb1> hm
16:43 <cpaelzer> nice that command seems to work from me - interesting
16:43 <dpb1> can I adjust action items?
16:43 <cpaelzer> very unexpected
16:44 * dpb1 "fixes"
16:44 <ahasenack> I like your QA approach :)
16:44 <ahasenack> "this shouldn't work, let's try it"
16:44 <dpb1> #action add agenda item for next week to check on triage progress.
16:44 * meetingology add agenda item for next week to check on triage progress.
16:44 <dpb1> dpb1^^^ ugh
16:44 <dpb1> ok
16:44 <dpb1> #topic Announce next meeting date, time and chair
16:44 <cpaelzer> ahasenack: that is how you test, be mean to programs :-)
16:44 <ahasenack> +1
16:45 <dpb1> Next meeting Tuesday, 2017-06-27 at 1600 UTC, chair will be ahasenack
16:45 <ahasenack> hoy
16:45 <dpb1> #info Next meeting Tuesday, 2017-06-27 at 1600 UTC, chair will be ahasenack
16:46 <dpb1> and that's all folks, thanks for participating
16:46 <dpb1> #endmeeting