15:02 <slangasek> #startmeeting
15:02 <meetingology> Meeting started Thu May 18 15:02:47 2017 UTC.  The chair is slangasek. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:02 <meetingology> 
15:02 <meetingology> Available commands: action commands idea info link nick
15:03 <slangasek> [TOPIC] Lightning round
15:03 <slangasek> ah, I think the VPN was being unpleasant
15:04 <slangasek> $ echo $(shuf -e doko bdmurray slangasek infinity sil2100 cyphermox tdaitx xnox mwhudson rbalint)
15:04 <slangasek> rbalint slangasek cyphermox tdaitx sil2100 mwhudson xnox doko infinity bdmurray
15:04 <rbalint> set up GKE and Azure environments
15:04 <rbalint> packaged printer drivers for OKI #862726
15:04 <rbalint> created patch for ftbfs both for cvs and debhelper LP: #1691078
15:04 <ubottu> Launchpad bug 1691078 in debhelper (Ubuntu) "cvs FTBFS in artful: dpkg-deb: error: invalid compressor parameters: unknown compression strategy" [Undecided,Fix committed] https://launchpad.net/bugs/1691078
15:04 <gaughen> I'm on my way
15:04 <rbalint> Azure image preparations - in progress
15:04 <rbalint> EOF
15:04 <gaughen> to mumble
15:07 <slangasek> * slow week, sick most of the time
15:07 <slangasek> * netplan planning
15:07 <slangasek> * discussions around some new customer image requests
15:07 <slangasek> * landed branches to move more essential config (that doesn't need to be private) into the lp:ubuntu-cdimage project
15:07 <slangasek> * looking at integration of kernel livepatch in the desktop UI
15:07 <slangasek> * discussions around SecureBoot-signed kernels for customer projects
15:07 <slangasek> * a few merges
15:07 <slangasek> * a few SRUs processed
15:07 <slangasek> * work on AA/SRU tooling around ESM kernel publications
15:07 <slangasek> * upcoming:
15:07 <slangasek> * out of office next Wed for partner meetings in Seattle area
15:07 <slangasek> (done)
15:07 <slangasek> cyphermox:
15:08 <cyphermox> MIRs:
15:08 <cyphermox> - gjs, gnome-shell, gdm3, mozjs38, gnome-settings-daemon, mutter...
15:08 <cyphermox> grub/UEFI:
15:08 <cyphermox> - still fighting the grub EFI patches; almost done: fixing the last warnings/errors that cause armhf/arm64 to ftbfs.
15:08 <cyphermox> netplan:
15:08 <cyphermox> - MAC cloning support (fixing autopkgtests)
15:08 <cyphermox> spec work:
15:08 <cyphermox> - harassing slangasek to sign-off on foundations-aa-deprecate-legacy-net-tools and foundations-aa-migrating-to-netplan
15:08 <cyphermox> - tracking down feedback/sign-off from server, juju teams.
15:08 <cyphermox> also, discussing MIR team staffing
15:08 <cyphermox> upcoming: more SB, other desktop MIRs...
15:08 <cyphermox> (done)
15:09 * xnox steps away for a minute
15:09 <slangasek> tdaitx:
15:09 <tdaitx> = OpenJDK
15:09 <tdaitx> * Packaged OpenJDK 7 for Trusty, packaged again due to a regression
15:09 <tdaitx> * Packaged IcedTea 2.6.10 (waiting the build to finish in order to test it)
15:09 <tdaitx> * Checked error tracker for regressions on the new packages and was also combing for a specific java-atk-wrapper segfault, as we might need to backport/SRU the newest java-atk-wrapper to trusty
15:09 <tdaitx> = JCK
15:09 <tdaitx> * Started testing 8u131 (ongoing, hotspot and interactive tests are next)
15:09 <tdaitx> = Other
15:09 <tdaitx> * Performance review (ongoing)
15:09 <tdaitx> (done)
15:10 * xnox ?!
15:11 <xnox> bug #1690605
15:11 <xnox> bug #1686784
15:11 <xnox> sponsored bug #1576341
15:11 <xnox> progress on removals review
15:11 <ubottu> bug 1690605 in systemd (Ubuntu) "systemd-resolved: no dns resolution after upgrade to Artful" [Undecided,Fix committed] https://launchpad.net/bugs/1690605
15:11 <xnox> progress on rax onmetal image
15:11 <xnox> bug #1691100
15:11 <ubottu> bug 1686784 in systemd (Ubuntu Xenial) "no predictable names for platform (non-PCI) NICs" [Undecided,Confirmed] https://launchpad.net/bugs/1686784
15:11 <xnox> bug #1689346
15:11 <ubottu> bug 1576341 in systemd (Ubuntu) "systemd in degraded state on startup in LXD containers" [High,Fix committed] https://launchpad.net/bugs/1576341
15:11 <xnox> bug #1686784
15:11 <ubottu> bug 1691100 in cloud-init (Ubuntu) "ipv6 parsing appears to fail for netplan, with latest changes" [Undecided,New] https://launchpad.net/bugs/1691100
15:11 <ubottu> bug 1689346 in cloud-init (Ubuntu) "cloud-init and nplan do not parse and use OpenStack networking correctly with netmask" [Medium,In progress] https://launchpad.net/bugs/1689346
15:11 <xnox> bug #1690388 times two
15:11 <ubottu> bug 1690388 in cloud-init (Ubuntu) "wrong hwaddr on the vlan bond with nplan and cloud-init" [Undecided,In progress] https://launchpad.net/bugs/1690388
15:11 <xnox> bug #1690480
15:11 <ubottu> bug 1690480 in cloud-init (Ubuntu) "cloud-init / nplan - missing bond mode miimon xmit_hash_policy" [Undecided,In progress] https://launchpad.net/bugs/1690480
15:11 <xnox> bug #1682871
15:11 <ubottu> bug 1682871 in linux (Ubuntu Xenial) "attempts to rename vlans / vlans have addr_assign_type of 0 on kernel 4.4" [High,In progress] https://launchpad.net/bugs/1682871
15:11 <xnox> Installed windows10 preview sdk et.al.
15:11 <xnox> ..
15:11 <cyphermox> xnox: err, I do have miimon and xmit_hash_policy support in netplan?
15:12 <cyphermox> is that why it's a cloud-init bug instead?
15:12 <xnox> cyphermox, correct, but cloud-init was not passing those keys through to netplan at all.
15:12 <cyphermox> xnox: ah, I see
15:12 <xnox> cyphermox, and used wrong _ - between the words
15:12 <slangasek> doko: here?
15:12 <cyphermox> sure, alright
15:13 <xnox> cyphermox, honestly, netplan is fine. and the macaddress thing is optional and is the only "missing" bit i found in nplan so far.
15:13 <cyphermox> xnox: I'll upload macaddress today, probably
15:13 <cyphermox> if all goes well and autopkgtests pass
15:13 <xnox> all the bugs are in cloudinit Configdrive <-> netplan code
15:13 <xnox> #action gaughen to use actions
15:13 * meetingology gaughen to use actions
15:14 <slangasek> infinity not on channel
15:14 <slangasek> bdrung:
15:14 <slangasek> sigh
15:14 <slangasek> bdmurray:
15:14 <bdmurray> SRU queue reviews
15:14 <bdmurray> building snapport w/ whoopsie
15:14 <bdmurray> SRU of apport for zesty, yakkety, xenial, and trusty
15:14 <bdmurray> SRU of whoopsie for yakkety, xenial, and trusty
15:14 <bdmurray> talked to doko about crash autopkgtest failure - artful-proposed not on ddebs
15:15 <bdmurray> merged upstream apport into artful
15:15 <bdmurray> resolved apport autopkgtest failure on artful (fixed upstream too)
15:15 <bdmurray> submitted RT regarding requeueing of old cores in production ET
15:15 <bdmurray> wrote code to remove EoL release core files added to daisy
15:15 <bdmurray> submitted RT regarding update of staging ET
15:15 <bdmurray> SRU verification of apport and whoopsie for T, X, Y, Z
15:15 <bdmurray> upgraded desktop to Zesty
15:15 <bdmurray> added packages to gunnarhj's package set
15:15 <bdmurray> uploaded unattended-upgrades fix for LP: #1680599
15:15 <ubottu> Launchpad bug 1680599 in unattended-upgrades (Ubuntu) "unattended-upgrades crashes without writing to the log on invalid config file entries" [Medium,In progress] https://launchpad.net/bugs/1680599
15:15 <bdmurray> working on a fix for unattended-upgrades bug LP: #1649709
15:15 <ubottu> Launchpad bug 1649709 in unattended-upgrades (Ubuntu) "unatttended-upgrades 0.92ubuntu3 installs all updates but update-manager is set to only install security automatically" [Medium,In progress] https://launchpad.net/bugs/1649709
15:15 <bdmurray> submitted MP removing aufs support from u-r-u
15:15 <bdmurray> working with gdb dev regarding gdb hang
15:15 <bdmurray> ✔ done
15:16 <slangasek> any questions on status?
15:16 <slangasek> gratuitous bot test: https://launchpad.net/bugs/1649709
15:16 <ubottu> Launchpad bug 1649709 in unattended-upgrades (Ubuntu) "unatttended-upgrades 0.92ubuntu3 installs all updates but update-manager is set to only install security automatically" [Medium,In progress]
15:17 <slangasek> https://launchpad.net/bugs/1649709
15:17 <cyphermox> "<meetingology> Available commands: #accept #accepted #action #agree #agreed #chair #commands #done #endmeeting #endvote #halp #help #idea #info #link #lurk #meetingname #meetingtopic #nick #private_commands #progress #rejected #replay #restrictlogs #save #startmeeting #subtopic #topic #unchair #undo #unlurk #vote #voters #votesrequired"
15:17 <cyphermox> #idea use more of the commands, maybe?
15:17 <xnox> #subtopic investigate available commands
15:18 <cyphermox> some of these only work if you're chair
15:18 <slangasek> so no questions on status, then? :)
15:18 <cyphermox> not really
15:18 <slangasek> [TOPIC] AOB
15:18 <slangasek> anything else for today?
15:19 <cyphermox> well just a FYI maybe
15:19 <cyphermox> rbalint has prepared the libd-i merge, this would affect a few other d-i components that need rebuild
15:19 <bdmurray> slangasek: we were talking about artful-proposed and ddebs the other day and then doko noticed crash's autopkgtest failing because of that
15:19 <slangasek> oh?
15:20 <bdmurray> maybe it's artful-updates
15:20 <slangasek> right, some tests look for -updates before it's created
15:20 <bdmurray> I saw you were looking at ddeb-retriever is this fixable there?
15:20 <rbalint> cyphermox: i can prepare some more merges for the affected components instead of plain rebuilds
15:20 <slangasek> bdmurray: we could pre-create it there, yes
15:20 <cyphermox> rbalint: let's discuss this later
15:20 <rbalint> cyphermox: ok
15:21 <bdmurray> slangasek: that seems like a good idea to me
15:21 <slangasek> bdmurray: https://bugs.launchpad.net/ddeb-retriever ?
15:21 <slangasek> or, well, raise an MP :)
15:21 <cyphermox> slangasek: also, I noticed http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/ isn't quite as fully developped as usual; but I haven't really dug in to see why.
15:22 <slangasek> hrm
15:22 <bdmurray> slangasek: okay
15:22 <slangasek> cyphermox: could it be the python3 switch?
15:22 <cyphermox> maybe, but it seems like half of it run?
15:22 <slangasek> cyphermox: I'd suggest asking cjwatson or infinity about that one
15:22 <cyphermox> as I said, would need to look at other places too
15:22 <cyphermox> yeah
15:23 <cyphermox> I just happened to notice it earlier when looking up something
15:24 <slangasek> bdmurray: (maybe add a bug task on canonical-foundations so we have central tracking)
15:25 <bdmurray> slangasek: Is that a project?
15:26 <slangasek> I think we created a private project of some kind for that, yes
15:26 <bdmurray> oh, so we did
15:27 <slangasek> ok; anything else today?
15:28 <slangasek> going once...
15:30 <slangasek> #endmeeting