16:03 <cpaelzer> #startmeeting ubuntu-server-team
16:03 <meetingology> Meeting started Tue May 9 16:03:27 2017 UTC. The chair is cpaelzer. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
16:03 <meetingology>
16:03 <meetingology> Available commands: action commands idea info link nick
16:03 <cpaelzer> #topic Review ACTION points from previous meeting
16:03 <cpaelzer> There were plenty of actions, but also I know some of them resovled - so lets go one by one
16:04 * cpaelzer rbasak, powersj, cpaelzer to draft mysql triage response page like nginx has (carried over)
16:04 <rbasak> Still pending :-(
16:04 <cpaelzer> wrong
16:04 <cpaelzer> I added a description of the way we tag mysql bugs as triage if they are suitable for a central dup bug or to steal replies from.
16:04 <cpaelzer> #link https://wiki.ubuntu.com/ServerTeam/mysql
16:04 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/+source/mysql-5.7/+bugs?&field.tag=triage
16:04 <rbasak> Oh. Thanks!
16:04 <cpaelzer> That covers the most common cases and we can easily add more.
16:04 <cpaelzer> I updated the wiki for that, the remaining action would be for rbasak to update who maintains the package.
16:04 <cpaelzer> rbasak: you are doing that with Lars and more? - it would be nice if you could update this section.
16:04 <cpaelzer> The site became a bit "light" now that we actually do it via launchpad tags, but it seemed to make more sense.
16:04 <cpaelzer> rbasak: are you ok to take that remainign update as action with you?
16:04 <dpb1> cpaelzer++
16:04 <cpaelzer> only your part rbasak :-)
16:04 <rbasak> My todo entry for that is below the fold now :-/
16:04 <cpaelzer> honestly I just wasn't sure I'd get the oracle role in this right, so I'd ask you to take that
16:04 <rbasak> Sure
16:05 <cpaelzer> everything else will be in the tags unless we want another solution
16:05 <cpaelzer> and the wiki plinks
16:05 <cpaelzer> #action: rbasak to add maintainership info to mysql triage page
16:05 * meetingology : rbasak to add maintainership info to mysql triage page
16:05 <rbasak> ack
16:05 * cpaelzer nacc to write a release notes entry on ipv6 netboot
16:05 * cpaelzer nacc to write a server guide entry on ipv6 netboot
16:06 <nacc> cpaelzer: both continue
16:06 <cpaelzer> I see useful new content
16:06 <cpaelzer> ok, continuing
16:06 <cpaelzer> #action nacc to write a release notes entry on ipv6 netboot
16:06 * meetingology nacc to write a release notes entry on ipv6 netboot
16:06 <cpaelzer> #action nacc to write a server guide entry on ipv6 netboot
16:06 * meetingology nacc to write a server guide entry on ipv6 netboot
16:06 <cpaelzer> the next pair is for rharper on cloud-init
16:06 * cpaelzer rharper to write a server guide entry on v2 yaml support in cloud-init
16:06 * cpaelzer rharper to write a release notes entry on v2 yaml support in cloud-init
16:06 * rharper hangs head
16:06 <cpaelzer> continue?
16:06 <rharper> well, we did publish the docs
16:07 <rharper> but I've not referred to them in the guides
16:07 * rharper fetches link
16:07 <cpaelzer> nore the release notes?
16:07 <rharper> http://cloudinit.readthedocs.io/en/latest/topics/network-config.html
16:07 <smoser> \o/
16:07 <rharper> cpaelzer: correct, we should link to that in guide and notes
16:07 <rharper> s/we/rharper
16:07 <rharper> so, yes, carry
16:07 <cpaelzer> yeah, I'll continue your action then and info on this
16:07 <dpb1> that looks like technical content
16:07 <rharper> ack
16:08 <rharper> dpb1: yeah, did that before we were told to
16:08 <dpb1> rharper++
16:08 <cpaelzer> #info mysql triaging now assisted by most common bugs being tagged, see links for details
16:08 <rharper> sweet, I was hoping for a gold star
16:08 <dpb1> gold stars for all!
16:08 <cpaelzer> #info ipv6 info available for cloud-init
16:08 <cpaelzer> #link http://cloudinit.readthedocs.io/en/latest/topics/network-config.html
16:08 <cpaelzer> #action: rharper to write a server guide entry on v2 yaml support in cloud-init
16:08 * meetingology : rharper to write a server guide entry on v2 yaml support in cloud-init
16:08 <cpaelzer> #action rharper to write a release notes entry on v2 yaml support in cloud-init
16:08 * meetingology rharper to write a release notes entry on v2 yaml support in cloud-init
16:09 <cpaelzer> the last action was ACTION: teward to add release notes blurb for nginx (1.10.x -> 1.12.x)
16:09 <cpaelzer> I synced with him as he can not attend
16:09 <cpaelzer> pasting from that now
16:09 <cpaelzer> <teward> cpaelzer: well i won't be able to be at the meeting tomorrow [...] make a note on the action item for me re: nginx release notes to push it to the next meeting for a status checkin
16:09 <cpaelzer> <teward> i've got the bulletpoints on a notepad document, i've not gotten much further
16:09 <cpaelzer> teward: thanks for keeping us updated, notes in the meeting and keeping the action for now
16:09 <cpaelzer> #action teward to add release notes blurb for nginx (1.10.x -> 1.12.x)
16:09 * meetingology teward to add release notes blurb for nginx (1.10.x -> 1.12.x)
16:09 <cpaelzer> that gets us to current dev
16:09 <cpaelzer> #topic Artful Development
16:09 <cpaelzer> #link https://wiki.ubuntu.com/ArtfulAardvark/ReleaseSchedule
16:10 <cpaelzer> #subtopic blueprints
16:10 <cpaelzer> #link https://blueprints.launchpad.net/ubuntu/+spec/servercloud-aa-server-core
16:10 <cpaelzer> I saw nacc and myself check a few of the merges already
16:10 <cpaelzer> more to come the next weeks for sure
16:10 <nacc> lvm2 just went through as well
16:10 <cpaelzer> thanks nacc
16:10 <cpaelzer> your pace on this makes me proud and wishing there wouldn't be that much libvirt/qemu things up in the air atm
16:11 <cpaelzer> nacc for merge president
16:11 <dpb1> nacc++
16:11 <cpaelzer> #info merges going well so far and which is good given how early in the cycle we still are
16:11 <cpaelzer> #subtopic Release Bugs
16:11 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-aa-tracking-bug-tasks.html#ubuntu-server
16:11 <cpaelzer> I've mostly seen 17.04 issues recently which is natural after the release and people using it now
16:11 <nacc> i think my m.u.c list is pretty short now, so i can pick up others next week
16:12 <nacc> yep
16:12 <cpaelzer> anyone seen 17.10 things that are worth to share?
16:12 <ahasenack> would this be the place to bring up that samba bug I've worked on?
16:12 <cpaelzer> SRU comes later
16:12 <ahasenack> it's for artful first
16:12 <cpaelzer> and if you miss it there there is open discussion as a catch all
16:12 <cpaelzer> then pelase shoot
16:13 <cpaelzer> this isn't so strict on where
16:13 <ahasenack> I have this mp: https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767
16:13 <cpaelzer> as long as people provide good input
16:13 <ahasenack> and I outline 3 options at the bottom
16:13 <nacc> ahasenack: yeah i need to take a look at it
16:13 <nacc> ahasenack: as i did the last bit of samba
16:13 <nacc> but if you want to own samba! please do )
16:13 <nacc> :)
16:13 <cpaelzer> oO
16:13 <ahasenack> let me just paste the 3 options here quickly (3 lines)
16:13 <ahasenack> a) upload to artful, exercise there, and do the same for the zesty SRU
16:13 <ahasenack> b) upload to artful, but for the zesty SRU, remove the fix-1584485.patch until we are happy artful's samba is fine.
16:13 <ahasenack> c) remove patch from artful and zesty until patch author can chime in
16:14 <ahasenack> current status is that pam_winbind is broken on zesty+
16:14 <nacc> ahasenack: this is the static linking thing, right?
16:14 <ahasenack> yes
16:14 <cpaelzer> ahasenack: could you ontline in one sentence what the original patch was for?
16:14 <cpaelzer> so everybody knows without reading through all of the bug
16:15 <ahasenack> static linking some samba libs into pam_winbind and nss_winbind so that on package upgrades we didn't get into a situation where the running processes would dlopen new/old libraries and crash
16:15 <cpaelzer> #link https://code.launchpad.net/~ahasenack/ubuntu/+source/samba/+git/samba/+merge/323767
16:15 <nacc> ahasenack: i would prefer a), i think, it matches what i'd expect we'd do (fix dev release and then SRU fix back)
16:15 <ahasenack> nacc: ok, that's what the MP is doing
16:15 <nacc> ahasenack: ack, i will try and get feedback to you today
16:15 <cpaelzer> #info discussion on how to preceed on an issue with sambas libraries (regression-update)
16:16 <ahasenack> thanks, my concern is leaving zesty with a broken pam_winbind for too long
16:16 <ahasenack> since this was a regression
16:16 <ahasenack> s/since/specially/
16:17 <cpaelzer> ahasenack: once you encounter a stall on the process with a) you can emergency fix it in zesty
16:17 <ahasenack> I wouldn't call it a stall just yet, but thanks :)
16:18 <cpaelzer> ok thanks ahasenack for working on this, anything else before I leave current development release?
16:18 <ahasenack> not from me
16:18 <nacc> php transition is done, we're at 7.1 now
16:18 <nacc> php7.0 has been removed
16:18 <nacc> tomcat8 transition may have to wait for a bit, as upstreams are not yet compatbile
16:19 <cpaelzer> upstreams not compatible means you can't start pushing in the new one while the old one is around?
16:19 <cpaelzer> is upstream working on this - so we know this will resolve?
16:20 <cpaelzer> #info php7.1 transition complete in artful release
16:20 <cpaelzer> nacc: ^^ ?
16:21 <cpaelzer> do we expect this to resolve upstream and pull then?
16:21 <nacc> cpaelzer: yeah there is a bug open and just waiting on upstream to change their code
16:21 <cpaelzer> ok, great
16:21 <cpaelzer> #topic Server & Cloud Bugs & SRU/Pending Uploads (slashd)
16:21 <nacc> cpaelzer: if we migrate tomcat8 to 8.5, dogtag-pki and tomcatjss will immediately break again
16:21 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-z-tracking-bug-tasks.html#ubuntu-server
16:21 <cpaelzer> #link http://reqorts.qa.ubuntu.com/reports/rls-mgr/rls-x-tracking-bug-tasks.html#ubuntu-server
16:21 <cpaelzer> I know slashd is on a sprint, so we give him a 60 sec timeout to appear ...
16:22 <cpaelzer> #info tomcat8->8.5 transition stalled by upstream issue (versions are not compatible)
16:22 <cpaelzer> <timeout>
16:22 <cpaelzer> #topic Weekly Updates & Questions for the QA Team (powersj)
16:22 <cpaelzer> #link https://jenkins.ubuntu.com/server/
16:22 <cpaelzer> powersj is out atm
16:23 <cpaelzer> from his info mail an info
16:23 <cpaelzer> #info All Artful server ISO tests are now running
16:23 <cpaelzer> #topic Weekly Updates & Questions for the Kernel Team (smb, sforshee)
16:24 <cpaelzer> I pinged smb when the meeting started and he was around today, but didn't join yet
16:24 <cpaelzer> there might be a kernel breaking somewhere else
16:24 <ahasenack> :)
16:24 <cpaelzer> and it is too early to start our #1 question being "what will the next kernel version be"
16:24 <cpaelzer> anyone else soemthing for the kernel section of the log?
16:25 <cpaelzer> going on ...
16:25 <cpaelzer> #topic Upcoming Call For Papers
16:25 <cpaelzer> #link https://lwn.net/Calendar/Monthly/cfp/
16:25 <cpaelzer> Linux Plumbers Conference Deadline is closing in
16:26 <cpaelzer> nothing else on my personal radar that touches us
16:26 <cpaelzer> #topic Ubuntu Server Team Events
16:27 <cpaelzer> there will be a mini-sprint the rest of the week to make some of our libvirt delta upstreamable to debian/libvirt-upstrem
16:27 <cpaelzer> to ease maintenance later on and let everyone benefit
16:27 <nacc> nice
16:27 <cpaelzer> any sem-public events out there that people might care?
16:27 <cpaelzer> semi
16:27 <cpaelzer> ok, that is a no
16:27 <cpaelzer> #topic Open Discussion
16:27 <cpaelzer> I have something here
16:28 <cpaelzer> this is a wall of text, sorry, but there was already so much progress
16:28 <cpaelzer> #info Discussion on updating the serverguide as a "bug fix"
16:28 <cpaelzer> #link https://lists.ubuntu.com/archives/ubuntu-doc/2017-May/020429.html
16:28 <cpaelzer> There is a mail thread about the discussion I kicked off, but the TL;DR is nicely in a quote of Doug Smythies
16:28 <cpaelzer> "Procedure: For the 16.04 Ubuntu Serverguide, just tell me when you want an update publication done and I'll do it, after say about a 2 week string freeze and translation catch up window**. For the 14.04 Serverguide, it would have to be an important update, as typically, and only speaking for myself, I don't bother with the older LTS versions."
16:28 <cpaelzer> I also saw andreas already started with a doc MP
16:28 <cpaelzer> #link https://code.launchpad.net/~ahasenack/serverguide/use-sasl-external-for-config-changes-973981/+merge/323786
16:28 <cpaelzer> And a few minutes ago I saw the MP was merged
16:28 <cpaelzer> so perfect case to encourage everyone
16:29 <cpaelzer> we felt that those won't be updated, but the feeling was wrong
16:29 <cpaelzer> So for the issue we had other than fixing in the package if we can, for the guide update add a bug task and provide a branch.
16:29 <cpaelzer> Starter info for the guide is here:
16:29 <cpaelzer> #link https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/UbuntuServerGuide
16:29 <cpaelzer> #link https://wiki.ubuntu.com/DocumentationTeam/SystemDocumentation/BuildingDocumentation
16:29 <cpaelzer> #info feel more free before to do serverguide changes when applicable as a "bug fix".
16:29 <cpaelzer> Any further thing to add?
16:30 <cpaelzer> giving a few extra sec as this was a lot of text ...
16:30 <ahasenack> :)
16:30 <cpaelzer> Also on the thread, we were asked to also provide some doc contribution to kernel uninstall handling
16:30 <cpaelzer> #link https://bugs.launchpad.net/serverguide/+bug/1031091
16:30 <ubottu> Launchpad bug 1031091 in Ubuntu Server Guide trunk "Serverguide Automatic Updates contains inconsistencies and / or errors" [High,Triaged]
16:30 <cpaelzer> #link https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1647790
16:31 <cpaelzer> Would anyone be willing to action himself to take a look at these as well?
16:31 <ubottu> Launchpad bug 1647790 in debian-installer (Ubuntu) "Choosing "No automatic updates" has no effect" [Undecided,Confirmed]
16:31 <dpb1> I'd like to look
16:31 <cpaelzer> great
16:32 <cpaelzer> #action: dpb to look into a few open issues around automatic updates that were pointed out by the doc team
16:32 * meetingology : dpb to look into a few open issues around automatic updates that were pointed out by the doc team
16:32 <cpaelzer> anything else before I close?
16:32 <cpaelzer> nacc: you'll be the next chair - is next week ok for you?
16:32 <cpaelzer> #topic Announce next meeting date, time and chair
16:32 <nacc> cpaelzer: yep
16:33 <cpaelzer> #info next week meeting at the same day/time, charing will be nacc
16:33 <cpaelzer> #link https://wiki.ubuntu.com/ServerTeam/Meeting
16:33 <cpaelzer> #endmeeting