15:11 <rbasak> #startmeeting DMB
15:11 <meetingology> Meeting started Mon May  8 15:11:31 2017 UTC.  The chair is rbasak. Information about MeetBot at http://wiki.ubuntu.com/meetingology.
15:11 <meetingology> 
15:11 <meetingology> Available commands: action commands idea info link nick
15:11 <rbasak> Might as well be me rather than me waiting around.
15:11 <rbasak> #topic Review of previous action items
15:11 <rbasak> rbasak to sort Aron's request (carried-over)
15:12 <rbasak> I was looking at this earlier, and would like a second opinion. But I'll move on for now.
15:12 <rbasak> #topic Applications
15:12 <rbasak> #info There are no applications on today's agenda.
15:12 <rbasak> #topic Outstanding mailing list requests to assign
15:13 <rbasak> One from Gunnar about GNOME Help packages. Is someone availalble to take that please?
15:14 <rbasak> I see no other outstanding requests.
15:14 <rbasak> Any volunteers?
15:14 <bdmurray> rbasak: that's just adding packages?
15:15 <bdmurray> If so give it to me.
15:15 <rbasak> I think so.
15:15 <bdmurray> Well either way, I'll do it.
15:15 <rbasak> It might the description of personal-gunnarhj changing too.
15:15 <rbasak> Thanks!
15:15 <rbasak> #action bdmurray to handle GunnarHj's GNOME Help packages PPU request
15:15 * meetingology bdmurray to handle GunnarHj's GNOME Help packages PPU request
15:15 <jbicha> happyaron also requested his packageset be updated
15:16 <rbasak> Yeah, see above - I'll discuss that next.
15:16 <rbasak> #topic Any other business
15:17 <rbasak> I'm not sure on what basis to handle happyaron's request. Do I just verify that he's listed in the Debian Uploaders field?
15:17 <rbasak> As network-manager seems like quite a step up from some packages in universe from an Ubuntu perspective.
15:18 <rbasak> The others seem straightforward to me, with dkms perhaps in the middle.
15:18 <rbasak> For reference: https://lists.ubuntu.com/archives/devel-permissions/2017-April/001100.html
15:18 <bdmurray> Do we know what his original application was like?
15:19 <rbasak> I think it might be before my time. I'll see if I can find it.
15:21 <rbasak> I can only find https://wiki.ubuntu.com/AronXu/DeveloperApplication, which was presumably unsuccessful. Or was that converted to PPU maybe?
15:22 <jbicha> hi, I hope I'm not interrupting but happyaron has been one of the main maintainers of NM in Ubuntu:
15:22 <jbicha> https://git.launchpad.net/network-manager/log/
15:22 <jbicha> https://git.launchpad.net/~network-manager/network-manager/+git/ubuntu-applet/log/
15:22 <bdmurray> I think because network-manager is seeded it requires some further discussion.
15:24 <rbasak> https://irclogs.ubuntu.com/2013/09/09/%23ubuntu-meeting.html is relevant.
15:25 <rbasak> That's Aron's core dev application (unsuccessful) and it looks like the ubuntukylin packageset was created instead.
15:25 <bdmurray> https://wiki.ubuntu.com/UbuntuDevelopers#PerPackage
15:26 <bdmurray> That makes reference to "need to show ... previous work on the package" and "previous concern for the package ... in Ubuntu" - so I think an application needs to be more than just add these.
15:27 <rbasak> I suppose that applies to all of them?
15:27 <rbasak> Shall I reply and ask him to address that bullet point for the packages he's requesting?
15:28 <Laney> The DD process applies to happyaron. https://wiki.ubuntu.com/DeveloperMembershipBoard/ApplicationProcess
15:28 <bdmurray> Well maybe not for DDs, but I'm concerned about this in particular because of bug 1676547.
15:28 <ubottu> bug 1676547 in network-manager (Ubuntu) "No network connectivity after upgrade from 16.04 to 16.10" [Critical,In progress] https://launchpad.net/bugs/1676547
15:30 <rbasak> OK, so what should I do next?
15:33 <bdmurray> I think the guidelines for DDs are clear and we should just add it, but I personally have reservations.  So then the question is do we, the DMB, get to exercise judgement in this (DD) case.
15:34 <rbasak> The DMB set the DD guidelines, so the DMB absolutely can exercise judgement so we so choose.
15:34 <jbicha> bdmurray: is 1676547 happyaron's fault? I'm not sure how relevant that bug is here?
15:35 <rbasak> And if we do choose, then perhaps that's an indication that the DD guideline needs amending.
15:35 <jbicha> (and I apologize if I'm speaking out of turn here)
15:35 <bdmurray> jbicha: cyphermox could explain better but as I understand it the SRU of network-manager to xenial add new capabilities which were not accounted for in Yakkeyt.
15:36 <jbicha> ah ok
15:36 <bdmurray> So if you had the X SRU installed and upgraded to yakkety you'd have no network. If you didn't have the n-m SRU you'd be fine.
15:36 <rbasak> Perhaps the DD guidelines need amending to make it clear that the same original criteria must still apply to the packages being requested?
15:36 <jbicha> I think I helped sponsor those SRUs :(
15:37 <Laney> The page I linked says you can seek assurances if you think the new packages have more 'impact'.
15:38 <bdmurray> Well not many people upgrade from X to Y this late, but still even if it didn't impact many people its not a great experience.
15:39 <bdmurray> rbasak: So I think network-manager is worth some further discussion.
15:40 <rbasak> OK
15:40 <rbasak> What about the others?
15:40 <rbasak> dkms?
15:41 <rbasak> ocserv and proxychains are I think probably uncontroversial?
15:41 <bdmurray> rbasak: thinking about dkms
15:42 <bdmurray> that's also seeded so maybe it should be discussed too?
15:42 <rbasak> #agreed Aron Xu's DD-based PPU request for network-manager needs further discussion
15:42 <rbasak> OK
15:43 <sil2100> I see only one direct ubuntu upload of dkms made by him
15:43 <rbasak> #agreed Aron Xu's DD-based PPU request for dkms is similarly seeded so should probably be part of the same discussion
15:43 <rbasak> ocserv and proxychains are I think probably uncontroversial?
15:44 <bdmurray> agreed
15:44 <sil2100> +1
15:45 <rbasak> #agreed +1 for Aron Xu's DD-based PPU requests for ocserv and proxychains
15:45 <bdmurray> rbasak: although proxychains was already in his list...
15:45 <rbasak> Thanks all. I'll reply to the list.
15:45 <rbasak> Hmm. OK!
15:45 <bdmurray> rbasak: also you said ocserv and he said ocsev
15:46 <rbasak> I think he typoed it. What he said didn't seem to exist, and so I looked up his Debian maintainerships.
15:46 <bdmurray> Hmm, okay.
15:47 <rbasak> I guess that's it for Aron for this meeting today then?
15:47 <rbasak> Any other AOB?
15:47 <bdmurray> not from me
15:49 <rbasak> That'll be it then. Thanks all!
15:49 <rbasak> #endmeeting